]> git.pld-linux.org Git - packages/fontconfig.git/blob - fontconfig.spec
- converted to UTF-8
[packages/fontconfig.git] / fontconfig.spec
1 #
2 # Conditional build
3 %bcond_with     bytecode        # use bytecode hinting instead of autohinting by default
4 %bcond_without  static_libs     # don't build static library
5 #
6 Summary:        Font configuration and customization tools
7 Summary(pl.UTF-8):   Narzędzia do konfigurowania fontów
8 Summary(pt_BR.UTF-8):   Ferramentas para configuração e customização do acesso a fontes
9 Name:           fontconfig
10 Version:        2.4.2
11 Release:        1
12 Epoch:          1
13 License:        MIT
14 Group:          Libraries
15 Source0:        http://fontconfig.org/release/%{name}-%{version}.tar.gz
16 # Source0-md5:  f035852f521b54677f2b5c9e2f6d54a4
17 Patch0:         %{name}-blacklist.patch
18 Patch1:         %{name}-autohint.patch
19 URL:            http://fontconfig.org/
20 BuildRequires:  autoconf
21 BuildRequires:  automake
22 BuildRequires:  docbook-utils >= 0.6.13-3
23 BuildRequires:  docbook-dtd41-sgml
24 BuildRequires:  ed
25 BuildRequires:  expat-devel
26 BuildRequires:  freetype-devel >= 2.1.5
27 BuildRequires:  libtool
28 BuildRequires:  pkgconfig
29 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
30 Requires:       freetype >= 2.1.5
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 Fontconfig is designed to locate fonts within the system and select
35 them according to requirements specified by applications.
36
37 This package contains tools and documentation.
38
39 %description -l pl.UTF-8
40 Fontconfig jest biblioteką przeznaczoną do lokalizowania fontów w
41 systemie i wybierania ich w zależności od potrzeb aplikacji.
42
43 Paket ten zawiera programy narzędziowe i dokumentację.
44
45 %description -l pt_BR.UTF-8
46 Fontconfig é uma biblioteca para configuração e customização do acesso
47 a fontes.
48
49 Este pacote contém as ferramentas e documentação.
50
51 %package libs
52 Summary:        Font configuration and customization library
53 Summary(pl.UTF-8):   Biblioteka do konfigurowania fontów
54 Summary(pt_BR.UTF-8):   Biblioteca para configuração e customização do acesso a fontes
55 Group:          Development/Libraries
56 Requires:       freetype >= 2.1.5
57 Provides:       XFree86-fontconfig
58 Conflicts:      fontconfig <= 1:2.2.98-1
59 Obsoletes:      XFree86-fontconfig
60
61 %description libs
62 Fontconfig is designed to locate fonts within the system and select
63 them according to requirements specified by applications.
64
65 %description libs -l pl.UTF-8
66 Fontconfig jest biblioteką przeznaczoną do lokalizowania fontów w
67 systemie i wybierania ich w zależności od potrzeb aplikacji.
68
69 %description libs -l pt_BR.UTF-8
70 Fontconfig é uma biblioteca para configuração e customização do acesso
71 a fontes.
72
73 %package devel
74 Summary:        Font configuration and customization library - development files
75 Summary(pl.UTF-8):   Biblioteka do konfigurowania fontów - pliki dla programistów
76 Summary(pt_BR.UTF-8):   Biblioteca para configuração e customização do acesso a fontes - arquivos de desenvolvimento
77 Group:          Development/Libraries
78 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
79 Requires:       expat-devel
80 Requires:       freetype-devel >= 2.1.5
81 Provides:       XFree86-fontconfig-devel
82 Obsoletes:      XFree86-fontconfig-devel
83
84 %description devel
85 Fontconfig is designed to locate fonts within the system and select
86 them according to requirements specified by applications.
87
88 This package contains the header files needed to develop programs that
89 use these fontconfig.
90
91 %description devel -l pl.UTF-8
92 Fontconfig jest biblioteką przeznaczoną do lokalizowania fontów w
93 systemie i wybierania ich w zależności od potrzeb aplikacji.
94
95 Ten pakiet zawiera pliki nagłówkowe potrzebne do kompilowania
96 programów korzystających z biblioteki fontconfig.
97
98 %description devel -l pt_BR.UTF-8
99 Fontconfig é uma biblioteca para configuração e customização do acesso
100 a fontes.
101
102 Este pacote contém arquivos de desenvolvimento necessários à criação
103 de extensões baseadas na biblioteca fontconfig.
104
105 %package static
106 Summary:        Static font configuration and customization library
107 Summary(pl.UTF-8):   Statyczna biblioteka do konfigurowania fontów
108 Summary(pt_BR.UTF-8):   Biblioteca estática para configuração e customização do acesso a fontes
109 Group:          Development/Libraries
110 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
111 Provides:       XFree86-fontconfig-static
112 Obsoletes:      XFree86-fontconfig-static
113
114 %description static
115 This package contains static version of fontconfig library.
116
117 %description static -l pl.UTF-8
118 Ten pakiet zawiera statyczną wersję biblioteki fontconfig.
119
120 %description static -l pt_BR.UTF-8
121 Este pacote contém a biblioteca estática do fontconfig
122
123 %prep
124 %setup -q
125 %patch0 -p1
126 %if %{with bytecode}
127 %patch1 -p1
128 %endif
129
130 %build
131 %{__libtoolize}
132 %{__aclocal}
133 %{__autoconf}
134 %{__autoheader}
135 %{__automake}
136 %configure \
137         --disable-docs \
138         %{!?with_static_libs:--disable-static}
139 %{__make}
140
141 %install
142 rm -rf $RPM_BUILD_ROOT
143 install -d $RPM_BUILD_ROOT{%{_mandir}/man{1,3,5},/var/cache/fontconfig}
144
145 %{__make} install \
146         DESTDIR=$RPM_BUILD_ROOT
147
148 install doc/*.3 $RPM_BUILD_ROOT%{_mandir}/man3
149 install doc/*.5 $RPM_BUILD_ROOT%{_mandir}/man5
150
151 cp -f conf.d/README README.confd
152
153 %clean
154 rm -rf $RPM_BUILD_ROOT
155
156 %post
157 umask 022
158 HOME=/tmp %{_bindir}/fc-cache -f 2>/dev/null || :
159
160 %post   libs -p /sbin/ldconfig
161 %postun libs -p /sbin/ldconfig
162
163 %files
164 %defattr(644,root,root,755)
165 %doc AUTHORS COPYING ChangeLog README README.confd
166 %attr(755,root,root) %{_bindir}/fc-*
167 %{_mandir}/man1/*.1*
168 %{_mandir}/man5/*.5*
169 /var/cache/fontconfig
170
171 %files libs
172 %defattr(644,root,root,755)
173 %dir %{_sysconfdir}/fonts
174 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/fonts/fonts.conf
175 %{_sysconfdir}/fonts/fonts.dtd
176 %dir %{_sysconfdir}/fonts/conf.avail
177 %{_sysconfdir}/fonts/conf.avail/*.conf
178 %{_sysconfdir}/fonts/conf.avail/README
179 %dir %{_sysconfdir}/fonts/conf.d
180 %config(noreplace,missingok) %verify(not link md5 mtime size) %{_sysconfdir}/fonts/conf.d/*.conf
181 %attr(755,root,root) %{_libdir}/lib*.so.*.*
182
183 %files devel
184 %defattr(644,root,root,755)
185 %doc doc/fontconfig-devel/*.html
186 %attr(755,root,root) %{_libdir}/lib*.so
187 %{_libdir}/lib*.la
188 %{_includedir}/fontconfig
189 %{_pkgconfigdir}/fontconfig.pc
190 %{_mandir}/man3/*.3*
191
192 %if %{with static_libs}
193 %files static
194 %defattr(644,root,root,755)
195 %{_libdir}/lib*.a
196 %endif
This page took 0.037435 seconds and 3 git commands to generate.