]> git.pld-linux.org Git - packages/fontconfig.git/blob - fontconfig.spec
- s/date/(LC_ALL=C date)/; there can't be polish characters in fonts.conf
[packages/fontconfig.git] / fontconfig.spec
1
2 %define fcname          fcpackage
3 %define fcversion       2_0
4
5 Summary:        Font configuration and customization library
6 Summary(pl):    Biblioteka do konfigurowania fontów
7 Name:           fontconfig
8 Version:        1.0.1
9 Release:        1
10 Epoch:          1
11 License:        MIT
12 Group:          Libraries
13 Source0:        http://fontconfig.org/release/%{fcname}.%{fcversion}.tar.gz
14 URL:            http://fontconfig.org/
15 BuildRequires:  autoconf
16 BuildRequires:  automake
17 BuildRequires:  ed
18 BuildRequires:  expat-devel
19 BuildRequires:  freetype-devel
20 BuildRequires:  libtool
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 Fontconfig is designed to locate fonts within the system and select
25 them according to requirements specified by applications.
26
27 %description -l pl
28 Fontconfig jest biblioteka przeznaczon± do lokalizowania fontów w
29 systemie i wybierania ich w zale¿no¶ci od potrzeb aplikacji.
30
31 %package devel
32 Summary:        Font configuration and customization library
33 Summary(pl):    Biblioteka do konfigurowania fontów
34 Group:          Development/Libraries
35 Requires:       %{name} = %{version}
36 Requires:       freetype-devel
37
38 %description devel
39 Fontconfig is designed to locate fonts within the system and select
40 them according to requirements specified by applications.
41
42 This package contains the header files needed to develop programs that
43 use these fontconfig.
44
45 %description devel -l pl
46 Fontconfig jest biblioteka przeznaczon± do lokalizowania fontów w
47 systemie i wybierania ich w zale¿no¶ci od potrzeb aplikacji.
48
49 Ten pakiet zawiera pliki nag³ówkowe potrzebne do kompilowania
50 programów korzystaj±cych z biblioteki fontconfig.
51
52 %prep
53 %setup -q -n %{fcname}.%{fcversion}
54
55 %build
56 cd %{name}
57 %{__autoconf}
58 %configure
59 %{__make}
60
61 %install
62 rm -rf $RPM_BUILD_ROOT
63 install -d $RPM_BUILD_ROOT%{_mandir}/man1
64
65 cd %{name}
66 %{__make} install \
67         DESTDIR=$RPM_BUILD_ROOT
68
69 install fc-cache/fc-cache.man $RPM_BUILD_ROOT%{_mandir}/man1/fc-cache.3
70 install fc-list/fc-list.man $RPM_BUILD_ROOT%{_mandir}/man1/fc-list.3
71
72 %clean
73 rm -rf $RPM_BUILD_ROOT
74
75 %post   -p /sbin/ldconfig
76 %postun -p /sbin/ldconfig
77
78 %files
79 %defattr(644,root,root,755)
80 %doc %{name}/{AUTHORS,README}
81 %dir %{_sysconfdir}/fonts
82 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/fonts/fonts.conf
83 %{_sysconfdir}/fonts/fonts.dtd
84 %attr(755,root,root) %{_bindir}/fc-*
85 %attr(755,root,root) %{_libdir}/lib*.so.*.*
86 %{_mandir}/man1/*
87
88 %files devel
89 %defattr(644,root,root,755)
90 %doc %{name}/ChangeLog
91 %attr(755,root,root) %{_bindir}/fontconfig-config
92 %{_includedir}/fontconfig
93 %{_libdir}/lib*.so
94 %{_pkgconfigdir}/fontconfig.pc
This page took 0.034087 seconds and 3 git commands to generate.