]> git.pld-linux.org Git - packages/fontconfig.git/blob - fontconfig.spec
- typo; unified: -libs before -devel
[packages/fontconfig.git] / fontconfig.spec
1 #
2 # Conditional build
3 %bcond_with     bytecode        # use bytecode hinting instead of autohinting by default
4 #
5 Summary:        Font configuration and customization tools
6 Summary(pl):    Narzêdzia do konfigurowania fontów
7 Name:           fontconfig
8 Version:        2.2.98
9 Release:        2
10 Epoch:          1
11 License:        MIT
12 Group:          Libraries
13 Source0:        http://fontconfig.org/release/%{name}-%{version}.tar.gz
14 # Source0-md5:  f13af7e7dfa4e1d68aeb9dcc8d12045a
15 Patch0:         %{name}-blacklist.patch
16 Patch1:         %{name}-autohint.patch
17 Patch2:         %{name}-autohint2.patch
18 URL:            http://fontconfig.org/
19 BuildRequires:  autoconf
20 BuildRequires:  automake
21 BuildRequires:  docbook-utils >= 0.6.13-3
22 BuildRequires:  docbook-dtd41-sgml
23 BuildRequires:  ed
24 BuildRequires:  expat-devel
25 BuildRequires:  freetype-devel >= 2.1.5
26 BuildRequires:  libtool
27 Requires        %{name}-libs = %{epoch}:%{version}-%{release}
28 Requires:       freetype >= 2.1.5
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 Fontconfig is designed to locate fonts within the system and select
33 them according to requirements specified by applications.
34
35 This package contains tools and documentation.
36
37 %description -l pl
38 Fontconfig jest bibliotek± przeznaczon± do lokalizowania fontów w
39 systemie i wybierania ich w zale¿no¶ci od potrzeb aplikacji.
40
41 Paket ten zawiera programy narzêdziowe i dokumentacjê.
42
43 #%description -l pt_BR
44 #Fontconfig é uma biblioteca para configuração e customização do acesso
45 #a fontes.
46
47 %package libs
48 Summary:        Font configuration and customization library
49 Summary(pl):    Biblioteka do konfigurowania fontów
50 Summary(pt_BR): Fontconfig é uma biblioteca para configuração e customização do acesso a fontes
51 Group:          Development/Libraries
52 Requires:       freetype >= 2.1.5
53 Provides:       XFree86-fontconfig
54 Conflicts:      fontconfig <= 1:2.2.98-1
55 Obsoletes:      XFree86-fontconfig
56
57 %description libs
58 Fontconfig is designed to locate fonts within the system and select
59 them according to requirements specified by applications.
60
61 %description libs -l pl
62 Fontconfig jest bibliotek± przeznaczon± do lokalizowania fontów w
63 systemie i wybierania ich w zale¿no¶ci od potrzeb aplikacji.
64
65 %description libs -l pt_BR
66 Fontconfig é uma biblioteca para configuração e customização do acesso
67 a fontes.
68
69 %package devel
70 Summary:        Font configuration and customization library - development files
71 Summary(pl):    Biblioteka do konfigurowania fontów - pliki dla programistów
72 Summary(pt_BR): Fontconfig é uma biblioteca para configuração e customização do acesso a fontes
73 Group:          Development/Libraries
74 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
75 Requires:       expat-devel
76 Requires:       freetype-devel >= 2.1.5
77 Provides:       XFree86-fontconfig-devel
78 Obsoletes:      XFree86-fontconfig-devel
79
80 %description devel
81 Fontconfig is designed to locate fonts within the system and select
82 them according to requirements specified by applications.
83
84 This package contains the header files needed to develop programs that
85 use these fontconfig.
86
87 %description devel -l pl
88 Fontconfig jest bibliotek± przeznaczon± do lokalizowania fontów w
89 systemie i wybierania ich w zale¿no¶ci od potrzeb aplikacji.
90
91 Ten pakiet zawiera pliki nag³ówkowe potrzebne do kompilowania
92 programów korzystaj±cych z biblioteki fontconfig.
93
94 %description devel -l pt_BR
95 Fontconfig é uma biblioteca para configuração e customização do acesso
96 a fontes.
97
98 %package static
99 Summary:        Static font configuration and customization library
100 Summary(pl):    Statyczna biblioteka do konfigurowania fontów
101 Group:          Development/Libraries
102 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
103 Provides:       XFree86-fontconfig-static
104 Obsoletes:      XFree86-fontconfig-static
105
106 %description static
107 This package contains static version of fontconfig library.
108
109 %description static -l pl
110 Ten pakiet zawiera statyczn± wersjê biblioteki fontconfig.
111
112 %prep
113 %setup -q
114 %patch0 -p1
115 %if %{with bytecode}
116 %patch1 -p1
117 %else
118 %patch2 -p1
119 %endif
120
121 %build
122 %{__libtoolize}
123 %{__aclocal}
124 %{__autoconf}
125 %{__autoheader}
126 %{__automake}
127 %configure \
128         --disable-docs
129 %{__make}
130
131 %install
132 rm -rf $RPM_BUILD_ROOT
133 install -d $RPM_BUILD_ROOT%{_mandir}/man{1,3,5}
134
135 %{__make} install \
136         DESTDIR=$RPM_BUILD_ROOT
137
138 install doc/*.3 $RPM_BUILD_ROOT%{_mandir}/man3
139 install doc/*.5 $RPM_BUILD_ROOT%{_mandir}/man5
140
141 %clean
142 rm -rf $RPM_BUILD_ROOT
143
144 %post
145 /sbin/ldconfig
146 HOME=/root %{_bindir}/fc-cache -f 2>/dev/null
147
148 %postun -p /sbin/ldconfig
149
150 %files
151 %defattr(644,root,root,755)
152 %doc AUTHORS COPYING ChangeLog README
153 %attr(755,root,root) %{_bindir}/fc-*
154 %{_mandir}/man1/*.1*
155 %{_mandir}/man5/*.5*
156
157 %files libs
158 %defattr(644,root,root,755)
159 %dir %{_sysconfdir}/fonts
160 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/fonts/fonts.conf
161 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/fonts/local.conf
162 %{_sysconfdir}/fonts/fonts.dtd
163 %attr(755,root,root) %{_libdir}/lib*.so.*.*
164
165 %files devel
166 %defattr(644,root,root,755)
167 %doc doc/fontconfig-devel/*.html
168 %attr(755,root,root) %{_libdir}/lib*.so
169 %{_libdir}/lib*.la
170 %{_includedir}/fontconfig
171 %{_pkgconfigdir}/fontconfig.pc
172 %{_mandir}/man3/*.3*
173
174 %files static
175 %defattr(644,root,root,755)
176 %{_libdir}/lib*.a
This page took 0.133449 seconds and 3 git commands to generate.