]> git.pld-linux.org Git - packages/flashrom.git/blob - flashrom.spec
- updated to 1.1, enable jaylink support
[packages/flashrom.git] / flashrom.spec
1 #
2 # Conditional build:
3 %bcond_without  ftdi    # FTDI chips
4 %bcond_without  jaylink # J-Link chips
5 #
6 Summary:        Tool Flashing your BIOS from the Unix/Linux command line
7 Summary(pl.UTF-8):      Narzędzie do aktualizacji BIOS-u z linii poleceń Uniksa/Linuksa
8 Name:           flashrom
9 Version:        1.1
10 Release:        1
11 License:        GPL v2+
12 Group:          Applications/System
13 Source0:        https://download.flashrom.org/releases/%{name}-v%{version}.tar.bz2
14 # Source0-md5:  91bab6c072e38a493bb4eb673e4fe0d6
15 URL:            https://www.flashrom.org/Flashrom
16 %{?with_ftdi:BuildRequires:     libftdi1-devel >= 1.0}
17 %{?with_jaylink:BuildRequires:  libjaylink-devel}
18 # libusb 0.1 still needed for PICKIT2_SPI dongle
19 BuildRequires:  libusb-compat-devel >= 0.1
20 BuildRequires:  libusb-devel >= 1.0
21 BuildRequires:  pciutils-devel
22 BuildRequires:  pkgconfig
23 BuildRequires:  zlib-devel
24 ExclusiveArch:  %{ix86} %{x8664} x32 mips ppc ppc64 sparc sparcv9 sparc64
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %define         _sbindir                /sbin
28
29 %description
30 flashrom is a utility for identifying, reading, writing, verifying and
31 erasing flash chips. It's often used to flash BIOS / EFI / coreboot /
32 firmware images.
33  - Supports more than 470 flash chips, 291 chipsets, 500 mainboards,
34    79 PCI devices, 17 USB devices and various parallel/serial port
35    programmers.
36  - Supports parallel, LPC, FWH and SPI flash interfaces and various
37    chip packages (DIP32, PLCC32, DIP8, SO8/SOIC8, TSOP32, TSOP40,
38   TSOP48, BGA and more)
39  - No physical access needed, root access is sufficient.
40  - No bootable floppy disk, bootable CD-ROM or other media needed.
41  - No keyboard or monitor needed. Simply reflash remotely via SSH.
42  - No instant reboot needed. Reflash your chip in a running system,
43    verify it, be happy. The new firmware will be present next time you
44    boot.
45  - Crossflashing and hotflashing is possible as long as the flash chips
46    are electrically and logically compatible (same protocol). Great for
47    recovery.
48  - Scriptability. Reflash a whole pool of identical machines at the
49    same time from the command line. It is recommended to check flashrom
50    output and error codes.
51  - Speed. flashrom is often much faster than most vendor flash tools.
52  - Portability. Supports DOS, Linux, FreeBSD (including
53    Debian/kFreeBSD), NetBSD, OpenBSD, DragonFly BSD, Solaris, Mac OS
54    X, and other Unix-like OSes, as well as GNU Hurd.
55
56 %description -l pl.UTF-8
57 flashrom to narzędzie do identyfikacji, odczytu, zapisu, weryfikacji i
58 kasowania układów flash. Jest często używany do programowania obrazów
59 BIOS-u / EFI / coreboot / firmware'u.
60  - Obsługuje ponad 470 układów flash, 291 chipsetów, 500 płyt głównych,
61    79 urządzeń PCI, 17 urządzeń USB i różne programatory podłączane
62    przez port równoległy/szeregowy.
63  - Wspiera układy flash równoległe, LPC, FWH i SPI o różnych
64    obudowach/wyprowadzeniach (DIP32, PLCC32, DIP8, SO8/SOIC8, TSOP32,
65    TSOP40, TSOP48, BGA i inne)
66  - Nie wymaga fizycznego dostępu, wystarczy dostęp do konta roota.
67  - Nie potrzebuje bootowalnej dyskietki, rozruchowego dysku CD-ROM lub
68    innych nośników.
69  - Nie jest wymagana klawiatura ani monitor. Wystarczy przeprogramować
70    zdalnie poprzez SSH.
71  - Nie ma potrzeby ponownego uruchamiania komputera. Wystarczy
72    przeprogramować układ w uruchomionym systemie, zweryfikować i być
73    szczęśliwym. Nowy firmware będzie dostępny po następnym
74    uruchomieniu.
75  - Crossflashing i hotflashing są możliwe na tyle, na ile układy flash
76    są elektrycznie i logicznie kompatybilne (ten sam protokół). Jest to
77    świetna metoda do przywracania sprzętu ze źle zaprogramowanym
78    firmwarem/BIOS-em.
79  - Pozwala na tworzenie skryptów do wielokrotnego programowania.
80    Programowanie identycznych maszyn w tym samym czasie z wiersza
81    poleceń. Zaleca się sprawdzanie komunikatów programu flashrom i
82    kodów błędów.
83  - Szybkość. flashrom jest często znacznie szybszy niż większość
84    sprzedawanych narzędzi do flashowania.
85  - Przenośność. Obsługuje systemy DOS, Linux, FreeBSD (w tym
86    Debian/kFreeBSD), Dragonfly BSD, Solaris, Mac OS X oraz inne
87    systemy operacyjne oparte na Uniksie, a także GNU Hurd.
88
89 %prep
90 %setup -q -n %{name}-v%{version}
91
92 %build
93 %{__make} \
94         CC='%{__cc}' \
95         CFLAGS="%{rpmcflags}" \
96         LDFLAGS="%{rpmldflags}" \
97         %{!?with_ftdi:CONFIG_FT2232_SPI=no} \
98         %{?with_jaylink:CONFIG_JLINK_SPI=yes}
99
100 %install
101 rm -rf $RPM_BUILD_ROOT
102 install -d $RPM_BUILD_ROOT{%{_sbindir},%{_mandir}/man8}
103 install %{name} $RPM_BUILD_ROOT%{_sbindir}
104 install %{name}.8 $RPM_BUILD_ROOT%{_mandir}/man8
105
106 %clean
107 rm -rf $RPM_BUILD_ROOT
108
109 %files
110 %defattr(644,root,root,755)
111 %doc README
112 %attr(755,root,root) %{_sbindir}/flashrom
113 %{_mandir}/man8/flashrom.8*
This page took 0.093962 seconds and 3 git commands to generate.