]> git.pld-linux.org Git - packages/flake8.git/blob - flake8.spec
automatic change: use py_build/py_install macros
[packages/flake8.git] / flake8.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 Summary:        The modular source code checker: pep8, pyflakes and co
6 Name:           flake8
7 Version:        2.2.5
8 Release:        2
9 License:        MIT
10 Group:          Development/Tools
11 Source0:        https://pypi.python.org/packages/source/f/flake8/%{name}-%{version}.tar.gz
12 # Source0-md5:  6dea927949b94c9d9495ab24bcdf9cf0
13 URL:            https://pypi.python.org/pypi/flake8
14 BuildRequires:  python3-distribute
15 BuildRequires:  python3-modules
16 BuildRequires:  rpm-pythonprov
17 %if %{with tests}
18 BuildRequires:  python3-mccabe >= 0.2.1
19 BuildRequires:  python3-nose
20 BuildRequires:  python3-pep8 >= 1.5.7
21 BuildRequires:  python3-pyflakes >= 0.8.1
22 %endif
23 Requires:       python3-modules
24 BuildArch:      noarch
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 The modular source code checker. It is a wrapper around these tools:
29 - PyFlakes
30 - pep8
31 - Ned Batchelder's McCabe script
32
33 %prep
34 %setup -q
35
36 %build
37 %py3_build %{?with_tests:test}
38
39 %install
40 rm -rf $RPM_BUILD_ROOT
41 %py3_install
42
43 %clean
44 rm -rf $RPM_BUILD_ROOT
45
46 %files
47 %defattr(644,root,root,755)
48 %doc CHANGES.rst CONTRIBUTORS.txt README.rst
49 %attr(755,root,root) %{_bindir}/flake8
50 %{py3_sitescriptdir}/%{name}
51 %{py3_sitescriptdir}/%{name}-%{version}-py*.egg-info
This page took 0.02976 seconds and 4 git commands to generate.