]> git.pld-linux.org Git - packages/flac.git/blob - flac.spec
- workaround for broken build process (which fails on AMD64)
[packages/flac.git] / flac.spec
1 # maybe TODO: split (c++, ogg?)
2 #
3 # Conditional build:
4 %bcond_without  xmms    # don't build XMMS plugin
5 #
6 Summary:        Free Lossless Audio Codec
7 Summary(pl):    Free Lossless Audio Codec - Darmowy Bezstratny Kodek Audio
8 Name:           flac
9 Version:        1.1.0
10 Release:        4
11 License:        GPL/LGPL
12 Group:          Libraries
13 Source0:        http://dl.sourceforge.net/flac/%{name}-%{version}.tar.gz
14 # Source0-md5:  19b456a27b5fcf502c76cc33f33e1490
15 Patch0:         %{name}-lt.patch
16 Patch1:         %{name}-am18.patch
17 Patch2:         %{name}-link.patch
18 Patch3:         %{name}-without_xmms.patch
19 URL:            http://flac.sourceforge.net/
20 BuildRequires:  autoconf
21 BuildRequires:  automake
22 %{?with_xmms:BuildRequires:     id3lib-devel >= 3.8.0}
23 BuildRequires:  libogg-devel >= 1:1.0
24 BuildRequires:  libstdc++-devel
25 BuildRequires:  libtool >= 2:1.4d-3
26 %{?with_xmms:BuildRequires:     rpmbuild(macros) >= 1.125}
27 %{?with_xmms:BuildRequires:     xmms-devel >= 0.9.5.1}
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 FLAC is an Open Source lossless audio codec developed by Josh Coalson.
32
33 %description -l pl
34 FLAC jest bezstratnym kodekiem audio z otwartymi ¼ród³ami, rozwijanym
35 przez Josha Coalsona.
36
37 %package devel
38 Summary:        FLAC - development files
39 Summary(pl):    FLAC - pliki nag³ówkowe
40 Group:          Development/Libraries
41 Requires:       %{name} = %{version}
42
43 %description devel
44 The package contains the development header files for FLAC libraries.
45
46 %description devel -l pl
47 Ten pakiet zawiera pliki nag³ówkowe bibliotek FLAC.
48
49 %package static
50 Summary:        FLAC - static libraries
51 Summary(pl):    FLAC - biblioteki statyczne
52 Group:          Development/Libraries
53 Requires:       %{name}-devel = %{version}
54
55 %description static
56 The package contains FLAC static libraries.
57
58 %description static -l pl
59 Ten pakiet zawiera biblioteki statyczne FLAC.
60
61 %package -n xmms-input-flac
62 Summary:        Free Lossless Audio Codec - XMMS plugin
63 Summary(pl):    Wtyczka FLAC dla XMMS
64 License:        GPL/LGPL
65 Group:          Libraries
66 Requires:       %{name} = %{version}
67 Requires:       xmms
68
69 %description -n xmms-input-flac
70 FLAC input plugin for XMMS.
71
72 %description -n xmms-input-flac -l pl
73 Wtyczka dla XMMS umo¿liwiaj±ca odtwarzanie plików w formacie FLAC.
74
75 %prep
76 %setup -q
77 %patch0 -p1
78 %patch1 -p1
79 %patch2 -p1
80 %{!?with_xmms:%patch3 -p1}
81
82 %build
83 %{__libtoolize}
84 %{__aclocal}
85 %{__autoconf}
86 %{__automake}
87
88 # during make static libraries are linked into dynamic libraries
89 # objects in static libraries are compiled without -fPIC and such
90 # objects cannot be linked into dynamic libraries on some platforms
91 # e.g. AMD64. Workaround - -fPIC passed to every compilation
92 %configure \
93         CFLAGS="-fPIC %{rpmcflags}"
94 %{__make}
95
96 %install
97 rm -rf $RPM_BUILD_ROOT
98
99 %{__make} install \
100         DESTDIR=$RPM_BUILD_ROOT
101
102 # no makefiles in doc dirs
103 rm -f doc/html/{Makefile*,images/Makefile*,ru/Makefile*}
104
105 %clean
106 rm -rf $RPM_BUILD_ROOT
107
108 %post   -p /sbin/ldconfig
109 %postun -p /sbin/ldconfig
110
111 %files
112 %defattr(644,root,root,755)
113 %doc AUTHORS README doc/html/{*.html,images}
114 %lang(ru) %doc doc/html/ru
115 %attr(755,root,root) %{_bindir}/*
116 %attr(755,root,root) %{_libdir}/lib*.so.*.*
117 %{_mandir}/man1/*
118
119 %files devel
120 %defattr(644,root,root,755)
121 %attr(755,root,root) %{_libdir}/lib*.so
122 %{_libdir}/lib*.la
123 %{_includedir}/*
124 %{_aclocaldir}/*
125
126 %files static
127 %defattr(644,root,root,755)
128 %{_libdir}/lib*.a
129
130 %if %{with xmms}
131 %files -n xmms-input-flac
132 %defattr(644,root,root,755)
133 %attr(755,root,root) %{xmms_input_plugindir}/*.so
134 %{xmms_input_plugindir}/*.la
135 %endif
This page took 0.068607 seconds and 4 git commands to generate.