]> git.pld-linux.org Git - packages/flac.git/blob - flac.spec
up to 1.4.3
[packages/flac.git] / flac.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # static library
4
5 Summary:        Free Lossless Audio Codec
6 Summary(pl.UTF-8):      Free Lossless Audio Codec - Wolnodostępny bezstratny kodek audio
7 Name:           flac
8 Version:        1.4.3
9 Release:        1
10 License:        BSD (libFLAC/libFLAC++), GPL v2+ (programs and plugins)
11 Group:          Libraries
12 Source0:        https://downloads.xiph.org/releases/flac/%{name}-%{version}.tar.xz
13 # Source0-md5:  7cab20b46e0bc859234bf5ba7da81625
14 URL:            https://xiph.org/flac/
15 BuildRequires:  autoconf >= 2.60
16 BuildRequires:  automake >= 1:1.11
17 BuildRequires:  doxygen
18 # for AM_ICONV
19 BuildRequires:  gettext-tools
20 BuildRequires:  libogg-devel >= 2:1.0
21 BuildRequires:  libstdc++-devel
22 BuildRequires:  libtool >= 2:2
23 BuildRequires:  tar >= 1:1.22
24 BuildRequires:  xz
25 # flac 1.4.2 dropped xmms plugin; for now we build plugin in xmms-input-flac.spec from flac 1.4.1 sources.
26 # Uncomment this Obsoletes in case xmms-input-flac.spec doesn't build any longer:
27 #Obsoletes:     xmms-input-flac < 1.4.2
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 FLAC is an Open Source lossless audio codec developed by Josh Coalson.
32
33 %description -l pl.UTF-8
34 FLAC jest bezstratnym kodekiem audio z otwartymi źródłami, rozwijanym
35 przez Josha Coalsona.
36
37 %package devel
38 Summary:        FLAC - development files
39 Summary(pl.UTF-8):      FLAC - pliki nagłówkowe
40 License:        BSD
41 Group:          Development/Libraries
42 Requires:       %{name} = %{version}-%{release}
43 Requires:       libogg-devel >= 2:1.0
44
45 %description devel
46 The package contains the development header files for FLAC libraries.
47
48 %description devel -l pl.UTF-8
49 Ten pakiet zawiera pliki nagłówkowe bibliotek FLAC.
50
51 %package static
52 Summary:        FLAC - static libraries
53 Summary(pl.UTF-8):      FLAC - biblioteki statyczne
54 License:        BSD
55 Group:          Development/Libraries
56 Requires:       %{name}-devel = %{version}-%{release}
57
58 %description static
59 The package contains FLAC static libraries.
60
61 %description static -l pl.UTF-8
62 Ten pakiet zawiera biblioteki statyczne FLAC.
63
64 %package c++
65 Summary:        FLAC++ - C++ API for FLAC codec
66 Summary(pl.UTF-8):      FLAC++ - API C++ do kodeka FLAC
67 Group:          Libraries
68 Requires:       %{name} = %{version}-%{release}
69
70 %description c++
71 FLAC++ - C++ API for FLAC codec.
72
73 %description c++ -l pl.UTF-8
74 FLAC++ - API C++ do kodeka FLAC.
75
76 %package c++-devel
77 Summary:        Header files for FLAC++ library
78 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki FLAC++
79 Group:          Development/Libraries
80 Requires:       %{name}-c++ = %{version}-%{release}
81 Requires:       %{name}-devel = %{version}-%{release}
82 Requires:       libstdc++-devel
83
84 %description c++-devel
85 Header files for FLAC++ library.
86
87 %description c++-devel -l pl.UTF-8
88 Pliki nagłówkowe biblioteki FLAC++.
89
90 %package c++-static
91 Summary:        Static FLAC++ library
92 Summary(pl.UTF-8):      Statyczna biblioteka FLAC++
93 Group:          Development/Libraries
94 Requires:       %{name}-c++-devel = %{version}-%{release}
95
96 %description c++-static
97 Static FLAC++ library.
98
99 %description c++-static -l pl.UTF-8
100 Statyczna biblioteka FLAC++.
101
102 %prep
103 %setup -q
104
105 %{__rm} m4/ogg.m4
106
107 %build
108 %{__libtoolize}
109 %{__aclocal} -I m4
110 %{__autoconf}
111 %{__autoheader}
112 %{__automake}
113 %configure \
114         --disable-silent-rules \
115         %{?with_static_libs:--enable-static}
116
117 %{__make}
118
119 %install
120 rm -rf $RPM_BUILD_ROOT
121
122 %{__make} install \
123         DESTDIR=$RPM_BUILD_ROOT
124
125 # packaged as %doc in -devel
126 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}
127
128 %clean
129 rm -rf $RPM_BUILD_ROOT
130
131 %post   -p /sbin/ldconfig
132 %postun -p /sbin/ldconfig
133
134 %post   c++ -p /sbin/ldconfig
135 %postun c++ -p /sbin/ldconfig
136
137 %files
138 %defattr(644,root,root,755)
139 %doc AUTHORS CHANGELOG.md COPYING.Xiph README.md
140 %attr(755,root,root) %{_bindir}/flac
141 %attr(755,root,root) %{_bindir}/metaflac
142 %attr(755,root,root) %{_libdir}/libFLAC.so.*.*.*
143 %attr(755,root,root) %ghost %{_libdir}/libFLAC.so.12
144 %{_mandir}/man1/flac.1*
145 %{_mandir}/man1/metaflac.1*
146
147 %files devel
148 %defattr(644,root,root,755)
149 %doc doc/api/*.{html,png} doc/images/logo*.{gif,svg}
150 %attr(755,root,root) %{_libdir}/libFLAC.so
151 %{_libdir}/libFLAC.la
152 %{_includedir}/FLAC
153 %{_pkgconfigdir}/flac.pc
154 %{_aclocaldir}/libFLAC.m4
155
156 %if %{with static_libs}
157 %files static
158 %defattr(644,root,root,755)
159 %{_libdir}/libFLAC.a
160 %endif
161
162 %files c++
163 %defattr(644,root,root,755)
164 %attr(755,root,root) %{_libdir}/libFLAC++.so.*.*.*
165 %attr(755,root,root) %ghost %{_libdir}/libFLAC++.so.10
166
167 %files c++-devel
168 %defattr(644,root,root,755)
169 %attr(755,root,root) %{_libdir}/libFLAC++.so
170 %{_libdir}/libFLAC++.la
171 %{_includedir}/FLAC++
172 %{_pkgconfigdir}/flac++.pc
173 %{_aclocaldir}/libFLAC++.m4
174
175 %if %{with static_libs}
176 %files c++-static
177 %defattr(644,root,root,755)
178 %{_libdir}/libFLAC++.a
179 %endif
This page took 0.11958 seconds and 4 git commands to generate.