]> git.pld-linux.org Git - packages/flac.git/blob - flac.spec
- updated to 1.1.4
[packages/flac.git] / flac.spec
1 # TODO: separate c++
2 #
3 # Conditional build:
4 %bcond_without  static_libs     # don't build static library
5 %bcond_without  xmms            # don't build XMMS plugin
6 #
7 Summary:        Free Lossless Audio Codec
8 Summary(pl.UTF-8):      Free Lossless Audio Codec - Wolnodostępny bezstratny kodek audio
9 Name:           flac
10 Version:        1.1.4
11 Release:        1
12 License:        BSD (libFLAC/libFLAC++), GPL (programs and plugins)
13 Group:          Libraries
14 Source0:        http://dl.sourceforge.net/flac/%{name}-%{version}.tar.gz
15 # Source0-md5:  3958cbd5b6ed8c14966792538e44223b
16 Patch0:         %{name}-without_xmms.patch
17 URL:            http://flac.sourceforge.net/
18 BuildRequires:  autoconf
19 BuildRequires:  automake >= 1:1.7
20 # for AM_ICONV
21 BuildRequires:  gettext-devel
22 BuildRequires:  libogg-devel >= 2:1.0
23 BuildRequires:  libstdc++-devel
24 BuildRequires:  libtool >= 2:1.4d-3
25 %{?with_xmms:BuildRequires:     rpmbuild(macros) >= 1.125}
26 %{?with_xmms:BuildRequires:     xmms-devel >= 0.9.5.1}
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 FLAC is an Open Source lossless audio codec developed by Josh Coalson.
31
32 %description -l pl.UTF-8
33 FLAC jest bezstratnym kodekiem audio z otwartymi źródłami, rozwijanym
34 przez Josha Coalsona.
35
36 %package devel
37 Summary:        FLAC - development files
38 Summary(pl.UTF-8):      FLAC - pliki nagłówkowe
39 License:        BSD
40 Group:          Development/Libraries
41 Requires:       %{name} = %{version}-%{release}
42 Requires:       libogg-devel >= 2:1.0
43 # for -c++ only
44 #Requires:      libstdc++-devel
45
46 %description devel
47 The package contains the development header files for FLAC libraries.
48
49 %description devel -l pl.UTF-8
50 Ten pakiet zawiera pliki nagłówkowe bibliotek FLAC.
51
52 %package static
53 Summary:        FLAC - static libraries
54 Summary(pl.UTF-8):      FLAC - biblioteki statyczne
55 License:        BSD
56 Group:          Development/Libraries
57 Requires:       %{name}-devel = %{version}-%{release}
58
59 %description static
60 The package contains FLAC static libraries.
61
62 %description static -l pl.UTF-8
63 Ten pakiet zawiera biblioteki statyczne FLAC.
64
65 %package -n xmms-input-flac
66 Summary:        Free Lossless Audio Codec - XMMS plugin
67 Summary(pl.UTF-8):      Wtyczka FLAC dla XMMS
68 License:        GPL v2+
69 Group:          Libraries
70 Requires:       %{name} = %{version}-%{release}
71 Requires:       xmms
72
73 %description -n xmms-input-flac
74 FLAC input plugin for XMMS.
75
76 %description -n xmms-input-flac -l pl.UTF-8
77 Wtyczka dla XMMS umożliwiająca odtwarzanie plików w formacie FLAC.
78
79 %prep
80 %setup -q
81 %{!?with_xmms:%patch0 -p1}
82
83 %build
84 %{__libtoolize}
85 %{__aclocal}
86 %{__autoconf}
87 %{__autoheader}
88 %{__automake}
89 %configure \
90         %{!?with_static_libs:--disable-static}
91
92 %{__make}
93
94 %install
95 rm -rf $RPM_BUILD_ROOT
96
97 %{__make} install \
98         DESTDIR=$RPM_BUILD_ROOT
99
100 # no makefiles in doc dirs
101 rm -f doc/html/{Makefile*,images/Makefile*,ru/Makefile*}
102 rm -f $RPM_BUILD_ROOT%{xmms_input_plugindir}/*.la
103
104 %clean
105 rm -rf $RPM_BUILD_ROOT
106
107 %post   -p /sbin/ldconfig
108 %postun -p /sbin/ldconfig
109
110 %files
111 %defattr(644,root,root,755)
112 %doc AUTHORS COPYING.Xiph README doc/html/{*.html,images}
113 %lang(ru) %doc doc/html/ru
114 %attr(755,root,root) %{_bindir}/flac
115 %attr(755,root,root) %{_bindir}/metaflac
116 %attr(755,root,root) %{_libdir}/libFLAC.so.*.*.*
117 %attr(755,root,root) %{_libdir}/libFLAC++.so.*.*.*
118 %{_mandir}/man1/flac.1*
119 %{_mandir}/man1/metaflac.1*
120
121 %files devel
122 %defattr(644,root,root,755)
123 %attr(755,root,root) %{_libdir}/libFLAC.so
124 %attr(755,root,root) %{_libdir}/libFLAC++.so
125 %{_libdir}/libFLAC.la
126 %{_libdir}/libFLAC++.la
127 %{_includedir}/FLAC
128 %{_includedir}/FLAC++
129 %{_pkgconfigdir}/flac.pc
130 %{_pkgconfigdir}/flac++.pc
131 %{_aclocaldir}/libFLAC.m4
132 %{_aclocaldir}/libFLAC++.m4
133
134 %if %{with static_libs}
135 %files static
136 %defattr(644,root,root,755)
137 %{_libdir}/libFLAC.a
138 %{_libdir}/libFLAC++.a
139 %endif
140
141 %if %{with xmms}
142 %files -n xmms-input-flac
143 %defattr(644,root,root,755)
144 %attr(755,root,root) %{xmms_input_plugindir}/libxmms-flac.so
145 %endif
This page took 0.111422 seconds and 4 git commands to generate.