]> git.pld-linux.org Git - packages/flac.git/blob - flac.spec
up to 1.4.3
[packages/flac.git] / flac.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static library
4 %bcond_without  xmms            # don't build XMMS plugin
5 %bcond_with     sse2            # SSE2 instructions
6
7 %ifarch %{x8664} x32 pentium4
8 %define with_sse2       1
9 %endif
10 Summary:        Free Lossless Audio Codec
11 Summary(pl.UTF-8):      Free Lossless Audio Codec - Wolnodostępny bezstratny kodek audio
12 Name:           flac
13 Version:        1.3.2
14 Release:        1
15 License:        BSD (libFLAC/libFLAC++), GPL v2+ (programs and plugins)
16 Group:          Libraries
17 Source0:        http://downloads.xiph.org/releases/flac/%{name}-%{version}.tar.xz
18 # Source0-md5:  454f1bfa3f93cc708098d7890d0499bd
19 URL:            http://xiph.org/flac/
20 BuildRequires:  autoconf >= 2.60
21 BuildRequires:  automake >= 1:1.11
22 # for AM_ICONV
23 BuildRequires:  gettext-tools
24 BuildRequires:  libogg-devel >= 2:1.0
25 BuildRequires:  libstdc++-devel
26 BuildRequires:  libtool >= 2:2
27 %{?with_xmms:BuildRequires:     rpmbuild(macros) >= 1.125}
28 BuildRequires:  tar >= 1:1.22
29 %{?with_xmms:BuildRequires:     xmms-devel >= 0.9.5.1}
30 BuildRequires:  xz
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 FLAC is an Open Source lossless audio codec developed by Josh Coalson.
35
36 %description -l pl.UTF-8
37 FLAC jest bezstratnym kodekiem audio z otwartymi źródłami, rozwijanym
38 przez Josha Coalsona.
39
40 %package devel
41 Summary:        FLAC - development files
42 Summary(pl.UTF-8):      FLAC - pliki nagłówkowe
43 License:        BSD
44 Group:          Development/Libraries
45 Requires:       %{name} = %{version}-%{release}
46 Requires:       libogg-devel >= 2:1.0
47
48 %description devel
49 The package contains the development header files for FLAC libraries.
50
51 %description devel -l pl.UTF-8
52 Ten pakiet zawiera pliki nagłówkowe bibliotek FLAC.
53
54 %package static
55 Summary:        FLAC - static libraries
56 Summary(pl.UTF-8):      FLAC - biblioteki statyczne
57 License:        BSD
58 Group:          Development/Libraries
59 Requires:       %{name}-devel = %{version}-%{release}
60
61 %description static
62 The package contains FLAC static libraries.
63
64 %description static -l pl.UTF-8
65 Ten pakiet zawiera biblioteki statyczne FLAC.
66
67 %package c++
68 Summary:        FLAC++ - C++ API for FLAC codec
69 Summary(pl.UTF-8):      FLAC++ - API C++ do kodeka FLAC
70 Group:          Libraries
71 Requires:       %{name} = %{version}-%{release}
72
73 %description c++
74 FLAC++ - C++ API for FLAC codec.
75
76 %description c++ -l pl.UTF-8
77 FLAC++ - API C++ do kodeka FLAC.
78
79 %package c++-devel
80 Summary:        Header files for FLAC++ library
81 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki FLAC++
82 Group:          Development/Libraries
83 Requires:       %{name}-c++ = %{version}-%{release}
84 Requires:       %{name}-devel = %{version}-%{release}
85 Requires:       libstdc++-devel
86
87 %description c++-devel
88 Header files for FLAC++ library.
89
90 %description c++-devel -l pl.UTF-8
91 Pliki nagłówkowe biblioteki FLAC++.
92
93 %package c++-static
94 Summary:        Static FLAC++ library
95 Summary(pl.UTF-8):      Statyczna biblioteka FLAC++
96 Group:          Development/Libraries
97 Requires:       %{name}-c++-devel = %{version}-%{release}
98
99 %description c++-static
100 Static FLAC++ library.
101
102 %description c++-static -l pl.UTF-8
103 Statyczna biblioteka FLAC++.
104
105 %package -n xmms-input-flac
106 Summary:        Free Lossless Audio Codec - XMMS plugin
107 Summary(pl.UTF-8):      Wtyczka FLAC dla XMMS
108 License:        GPL v2+
109 Group:          Libraries
110 Requires:       %{name} = %{version}-%{release}
111 Requires:       xmms >= 0.9.5.1
112
113 %description -n xmms-input-flac
114 FLAC input plugin for XMMS.
115
116 %description -n xmms-input-flac -l pl.UTF-8
117 Wtyczka dla XMMS umożliwiająca odtwarzanie plików w formacie FLAC.
118
119 %prep
120 %setup -q
121
122 %{__rm} m4/ogg.m4
123
124 %build
125 %{__libtoolize}
126 %{__aclocal} -I m4
127 %{__autoconf}
128 %{__autoheader}
129 %{__automake}
130 %configure \
131         --disable-silent-rules \
132         %{!?with_sse2:--disable-sse} \
133         %{?with_static_libs:--enable-static} \
134         %{!?with_xmms:--disable-xmms-plugin}
135
136 %{__make}
137
138 rm -rf doc-html
139 cp -a doc/html doc-html
140 # no makefiles in doc dirs
141 find doc-html -name 'Makefile*' | xargs %{__rm}
142
143 %install
144 rm -rf $RPM_BUILD_ROOT
145 %{__make} install \
146         DESTDIR=$RPM_BUILD_ROOT
147
148 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
149
150 %if %{with xmms}
151 %{__rm} $RPM_BUILD_ROOT%{xmms_input_plugindir}/*.la
152 %if %{with static_libs}
153 %{__rm} $RPM_BUILD_ROOT%{xmms_input_plugindir}/*.a
154 %endif
155 %endif
156
157 %clean
158 rm -rf $RPM_BUILD_ROOT
159
160 %post   -p /sbin/ldconfig
161 %postun -p /sbin/ldconfig
162
163 %post   c++ -p /sbin/ldconfig
164 %postun c++ -p /sbin/ldconfig
165
166 %files
167 %defattr(644,root,root,755)
168 %doc AUTHORS COPYING.Xiph README
169 %attr(755,root,root) %{_bindir}/flac
170 %attr(755,root,root) %{_bindir}/metaflac
171 %attr(755,root,root) %{_libdir}/libFLAC.so.*.*.*
172 %attr(755,root,root) %ghost %{_libdir}/libFLAC.so.8
173 %{_mandir}/man1/flac.1*
174 %{_mandir}/man1/metaflac.1*
175
176 %files devel
177 %defattr(644,root,root,755)
178 %doc doc-html/{*.html,images}
179 %attr(755,root,root) %{_libdir}/libFLAC.so
180 %{_libdir}/libFLAC.la
181 %{_includedir}/FLAC
182 %{_pkgconfigdir}/flac.pc
183 %{_aclocaldir}/libFLAC.m4
184
185 %if %{with static_libs}
186 %files static
187 %defattr(644,root,root,755)
188 %{_libdir}/libFLAC.a
189 %endif
190
191 %files c++
192 %defattr(644,root,root,755)
193 %attr(755,root,root) %{_libdir}/libFLAC++.so.*.*.*
194 %attr(755,root,root) %ghost %{_libdir}/libFLAC++.so.6
195
196 %files c++-devel
197 %defattr(644,root,root,755)
198 %attr(755,root,root) %{_libdir}/libFLAC++.so
199 %{_libdir}/libFLAC++.la
200 %{_includedir}/FLAC++
201 %{_pkgconfigdir}/flac++.pc
202 %{_aclocaldir}/libFLAC++.m4
203
204 %if %{with static_libs}
205 %files c++-static
206 %defattr(644,root,root,755)
207 %{_libdir}/libFLAC++.a
208 %endif
209
210 %if %{with xmms}
211 %files -n xmms-input-flac
212 %defattr(644,root,root,755)
213 %attr(755,root,root) %{xmms_input_plugindir}/libxmms-flac.so
214 %endif
This page took 0.091057 seconds and 3 git commands to generate.