]> git.pld-linux.org Git - packages/fish.git/blob - fish.spec
- up to 2.2.0
[packages/fish.git] / fish.spec
1 Summary:        fish - A friendly interactive shell
2 Summary(pl.UTF-8):      fish - przyjazna interaktywna powłoka
3 Name:           fish
4 Version:        2.2.0
5 Release:        1
6 License:        GPL v2
7 Group:          Applications/Shells
8 Source0:        http://fishshell.com/files/%{version}/%{name}-%{version}.tar.gz
9 # Source0-md5:  f6c3d940148593ff6648adb07986cbcb
10 URL:            http://fishshell.com/
11 BuildRequires:  autoconf >= 2.60
12 BuildRequires:  doxygen
13 BuildRequires:  gettext-tools
14 BuildRequires:  ncurses-devel
15 Suggests:       python
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %description
19 fish is a shell geared towards interactive use. Its features are
20 focused on user friendlieness and discoverability. The language syntax
21 is simple but incompatible with other shell languages.
22
23 %description -l pl.UTF-8
24 fish jest powłoką nastawioną na interaktywne używanie. Jego cechą jest
25 przyjazne nastawienie dla użytkownika. Składnia języka jest prosta ale
26 nie jest zgodna z innymi językami powłoki.
27
28 %prep
29 %setup -q
30
31 %build
32 %{__aclocal}
33 %{__autoconf}
34 %{__autoheader}
35 %configure
36
37 %{__make}
38
39 %install
40 rm -rf $RPM_BUILD_ROOT
41 %{__make} install \
42         DESTDIR=$RPM_BUILD_ROOT
43
44 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}
45
46 %find_lang %{name}
47
48 %clean
49 rm -rf $RPM_BUILD_ROOT
50
51 %post
52 umask 022
53 if [ ! -f /etc/shells ]; then
54         echo "%{_bindir}/fish" >> /etc/shells
55 else
56         grep -q '^%{_bindir}/fish$' /etc/shells || echo "%{_bindir}/fish" >> /etc/shells
57 fi
58
59 %preun
60 if [ "$1" = "0" ]; then
61         umask 022
62         grep -v '^%{_bindir}/fish$' /etc/shells > /etc/shells.new
63         mv -f /etc/shells.new /etc/shells
64 fi
65
66 %files -f %{name}.lang
67 %defattr(644,root,root,755)
68 %doc README.md user_doc/html/*.{html,css,png}
69 %attr(755,root,root) %{_bindir}/fish*
70 %attr(755,root,root) %{_bindir}/mimedb
71 %dir %{_datadir}/%{name}
72 %{_datadir}/%{name}/config.fish
73 %dir %{_datadir}/%{name}/completions
74 %{_datadir}/%{name}/completions/..fish
75 %{_datadir}/%{name}/completions/*.fish
76 %dir %{_datadir}/%{name}/functions
77 %{_datadir}/%{name}/functions/*.fish
78 %{_datadir}/%{name}/man
79 %dir %{_datadir}/%{name}/tools
80 %attr(755,root,root) %{_datadir}/%{name}/tools/create_manpage_completions.py
81 %{_datadir}/%{name}/tools/deroff.py
82 %dir %{_datadir}/%{name}/tools/web_config
83 %{_datadir}/%{name}/tools/web_config/delete.png
84 %{_datadir}/%{name}/tools/web_config/fishconfig.css
85 %{_datadir}/%{name}/tools/web_config/index.html
86 %{_datadir}/%{name}/tools/web_config/js
87 %{_datadir}/%{name}/tools/web_config/partials
88 %{_datadir}/%{name}/tools/web_config/sample_prompts
89 %attr(755,root,root) %{_datadir}/%{name}/tools/web_config/webconfig.py
90 %dir %{_sysconfdir}/fish
91 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/fish/config.fish
92 %{_mandir}/man1/fish*.1*
93 %{_mandir}/man1/mimedb.1*
This page took 0.481073 seconds and 3 git commands to generate.