]> git.pld-linux.org Git - packages/findutils.git/blob - findutils.spec
- updated info patch (remaining parts are PLD-specific, as described in devel-hints-*)
[packages/findutils.git] / findutils.spec
1 #
2 # Conditional build:
3 %bcond_without  selinux         # build without SELinux support
4 #
5 Summary:        GNU Find Utilities (find, xargs)
6 Summary(de.UTF-8):      GNU-Suchprogramme (find, xargs)
7 Summary(es.UTF-8):      Utilitarios de búsqueda de la GNU
8 Summary(fr.UTF-8):      Utilitaires de recherche de GNU (find, xargs)
9 Summary(pl.UTF-8):      Narzędzia GNU do odnajdywania plików (find, xargs)
10 Summary(pt_BR.UTF-8):   Utilitários de procura da GNU
11 Summary(tr.UTF-8):      GNU dosya arama araçları
12 Name:           findutils
13 Version:        4.6.0
14 Release:        1
15 Epoch:          1
16 License:        GPL v3+
17 Group:          Applications/File
18 # development versions at ftp://alpha.gnu.org/gnu/findutils/
19 Source0:        http://ftp.gnu.org/gnu/findutils/%{name}-%{version}.tar.gz
20 # Source0-md5:  9936aa8009438ce185bea2694a997fc1
21 #Source1:       http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
22 Source1:        %{name}-non-english-man-pages.tar.bz2
23 # Source1-md5:  e76388b0c3218eec3557d05ccd6d6515
24
25 Patch1:         %{name}-man-selinux.patch
26 Patch2:         %{name}-info.patch
27 # http://translationproject.org/latest/findutils/pl.po
28 Patch3:         %{name}-pl.po-update.patch
29 URL:            http://www.gnu.org/software/findutils/
30 BuildRequires:  autoconf >= 2.59
31 BuildRequires:  automake
32 BuildRequires:  gettext-tools >= 0.14.5
33 %{?with_selinux:BuildRequires:  libselinux-devel}
34 BuildRequires:  texinfo
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %description
38 The findutils package contains programs which will help you locate
39 files on your system. The find utility searches through a hierarchy of
40 directories looking for files which match a certain set of criteria
41 (such as a filename pattern). The locate utility searches a database
42 (create by updatedb) to quickly find a file matching a given pattern.
43 The xargs utility builds and executes command lines from standard
44 input arguments (usually lists of file names generated by the find
45 command).
46
47 %description -l de.UTF-8
48 Das findutils-Paket enthält Programme, die dabei helfen, Dateien auf
49 Ihrem System zu finden. Das Find-Utility durchsucht die
50 Verzeichnishierarchie nach Dateien, die zu bestimmten Kriterien (z.B.
51 Dateiname) passen. Das locate-Utility durchsucht eine Datenbank
52 (erzeugt durch updatedb), um die Dateien schneller finden zu können.
53 xargs konstruiert Kommandozeilen von der Standardeingabe (z.B.
54 Dateilisten, die von find erzeugt werden), und führt sie aus.
55
56 %description -l es.UTF-8
57 Este paquete contiene programas para ayúdalo a localizar archivos en
58 tu sistema. El programa find puede pesquisar, a través de una
59 jerarquía de directorios, buscando por archivos que obedezcan a un
60 cierto conjunto de criterios (como nombre de archivo modelo).
61
62 %description -l fr.UTF-8
63 Ce package contient des programmes pour vous aider à localiser des
64 fichiers sur votre système. Le programme find peut rechercher à
65 travers une hiérarchie de répertoires des fichiers conformes à
66 certains critères (comme un type de nom).
67
68 %description -l pl.UTF-8
69 W pakiecie znajdują się narzędzia pozwalające na poszukiwanie
70 określonych plików. Program find służy do poszukiwania w drzewie
71 katalogów plików o określonych parametrach, jak nazwa, uprawnienia,
72 typ czy data ostatniej modyfikacji.
73
74 %description -l pt_BR.UTF-8
75 Esse pacote contém programas para ajudá-lo a localizar arquivos em seu
76 sistema. O programa find pode procurar através de uma hierarquia de
77 diretórios procurando por arquivos que obedeçam um certo conjunto de
78 critérios (como nome de arquivo modelo).
79
80 %description -l tr.UTF-8
81 Bu pakette yer alan yazılımlar sisteminizde yer alan dosyaları
82 bulabilmeniz için hazırlanmışlardır. find programı ile belirli
83 özellikleri olan bir yazılımı bir dizin hiyerarşisi altında
84 arayabilirsiniz.
85
86 %prep
87 %setup -q
88
89 # patch1 is applied in install stage
90 %patch2 -p1
91 %patch3 -p1
92
93 %{__rm} po/stamp-po
94
95 %build
96 %{__aclocal} -I gl/m4 -I m4
97 %{__autoconf}
98 %{__autoheader}
99 %{__automake}
100 %configure \
101         %{__with_without selinux}
102
103 %{__make}
104
105 %install
106 rm -rf $RPM_BUILD_ROOT
107
108 %{__make} install \
109         DESTDIR=$RPM_BUILD_ROOT
110
111 bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
112 %{?with_selinux:patch -p0 -d $RPM_BUILD_ROOT%{_mandir} < %{PATCH1}}
113
114 # xargs is wanted in /bin
115 install -d $RPM_BUILD_ROOT/bin
116 mv $RPM_BUILD_ROOT%{_bindir}/xargs $RPM_BUILD_ROOT/bin
117
118 # useless in binary package
119 %{__rm} $RPM_BUILD_ROOT%{_infodir}/find-maint.info*
120
121 # unpackaged locate
122 %{__rm} $RPM_BUILD_ROOT%{_bindir}/{locate,updatedb} \
123         $RPM_BUILD_ROOT%{_libdir}/{bigram,code,frcode} \
124         $RPM_BUILD_ROOT%{_mandir}/{,*/}man?/{locate.1,updatedb.1,locatedb.5}*
125
126 rm -f $RPM_BUILD_ROOT{%{_infodir}/dir,%{_mandir}/README.findutils-non-english-man-pages}
127
128 %find_lang %{name}
129
130 %clean
131 rm -rf $RPM_BUILD_ROOT
132
133 %post   -p /sbin/postshell
134 -/usr/sbin/fix-info-dir -c %{_infodir}
135
136 %postun -p /sbin/postshell
137 -/usr/sbin/fix-info-dir -c %{_infodir}
138
139 %files -f %{name}.lang
140 %defattr(644,root,root,755)
141 %doc NEWS README TODO ChangeLog
142 %attr(755,root,root) %{_bindir}/find
143 %attr(755,root,root) /bin/xargs
144 %{_mandir}/man1/find.1*
145 %{_mandir}/man1/xargs.1*
146 %lang(de) %{_mandir}/de/man1/[fx]*
147 %lang(es) %{_mandir}/es/man1/[fx]*
148 %lang(fi) %{_mandir}/fi/man1/[fx]*
149 %lang(fr) %{_mandir}/fr/man1/[fx]*
150 %lang(hu) %{_mandir}/hu/man1/[fx]*
151 %lang(it) %{_mandir}/it/man1/[fx]*
152 %lang(ja) %{_mandir}/ja/man1/[fx]*
153 %lang(nl) %{_mandir}/nl/man1/[fx]*
154 %lang(pl) %{_mandir}/pl/man1/[fx]*
155 %lang(zh_CN) %{_mandir}/zh_CN/man1/[fx]*
156 %{_infodir}/find.info*
This page took 0.07512 seconds and 3 git commands to generate.