]> git.pld-linux.org Git - packages/findutils.git/blob - findutils.spec
- updated for 4.2.11
[packages/findutils.git] / findutils.spec
1 #
2 # Conditional build:
3 %bcond_without  selinux         # build without SELinux support
4 #
5 Summary:        GNU Find Utilities (find, xargs)
6 Summary(de):    GNU-Suchprogramme (find, xargs)
7 Summary(es):    Utilitarios de búsqueda de la GNU
8 Summary(fr):    Utilitaires de recherche de GNU (find, xargs)
9 Summary(pl):    Narzêdzia GNU do odnajdywania plików (find, xargs)
10 Summary(pt_BR): Utilitários de procura da GNU
11 Summary(tr):    GNU dosya arama araçlarý
12 Name:           findutils
13 Version:        4.2.8
14 Release:        1
15 Epoch:          1
16 License:        GPL
17 Group:          Applications/File
18 Source0:        ftp://alpha.gnu.org/gnu/findutils/%{name}-%{version}.tar.gz
19 # Source0-md5:  3c276abe786d83c2f962912377b1e3b1
20 #Source1:       http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
21 Source1:        %{name}-non-english-man-pages.tar.bz2
22 # Source1-md5:  e76388b0c3218eec3557d05ccd6d6515
23 Patch0:         %{name}-info.patch
24 Patch1:         %{name}-mktemp.patch
25 Patch2:         %{name}-pl.po-update.patch
26 Patch3:         %{name}-selinux.patch
27 Patch4:         %{name}-man-selinux.patch
28 URL:            http://www.gnu.org/software/findutils/
29 BuildRequires:  autoconf
30 BuildRequires:  automake
31 BuildRequires:  gettext-devel
32 %{?with_selinux:BuildRequires:  libselinux-devel}
33 BuildRequires:  texinfo
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %description
37 The findutils package contains programs which will help you locate
38 files on your system. The find utility searches through a hierarchy of
39 directories looking for files which match a certain set of criteria
40 (such as a filename pattern). The locate utility searches a database
41 (create by updatedb) to quickly find a file matching a given pattern.
42 The xargs utility builds and executes command lines from standard
43 input arguments (usually lists of file names generated by the find
44 command).
45
46 %description -l de
47 Das findutils-Paket enthält Programme, die dabei helfen, Dateien auf
48 Ihrem System zu finden. Das Find-Utility durchsucht die
49 Verzeichnishierarchie nach Dateien, die zu bestimmten Kriterien (z.B.
50 Dateiname) passen. Das locate-Utility durchsucht eine Datenbank
51 (erzeugt durch updatedb), um die Dateien schneller finden zu können.
52 xargs konstruiert Kommandozeilen von der Standardeingabe (z.B.
53 Dateilisten, die von find erzeugt werden), und führt sie aus.
54
55 %description -l es
56 Este paquete contiene programas para ayúdalo a localizar archivos en
57 tu sistema. El programa find puede pesquisar, a través de una
58 jerarquía de directorios, buscando por archivos que obedezcan a un
59 cierto conjunto de criterios (como nombre de archivo modelo).
60
61 %description -l fr
62 Ce package contient des programmes pour vous aider à localiser des
63 fichiers sur votre système. Le programme find peut rechercher à
64 travers une hiérarchie de répertoires des fichiers conformes à
65 certains critères (comme un type de nom).
66
67 %description -l pl
68 W pakiecie znajduj± siê narzêdzia pozwalaj±ce na poszukiwanie
69 okre¶lonych plików. Program find s³u¿y do poszukiwania w drzewie
70 katalogów plików o okre¶lonych parametrach, jak nazwa, uprawnienia,
71 typ czy data ostatniej modyfikacji.
72
73 %description -l pt_BR
74 Esse pacote contém programas para ajudá-lo a localizar arquivos em seu
75 sistema. O programa find pode procurar através de uma hierarquia de
76 diretórios procurando por arquivos que obedeçam um certo conjunto de
77 critérios (como nome de arquivo modelo).
78
79 %description -l tr
80 Bu pakette yer alan yazýlýmlar sisteminizde yer alan dosyalarý
81 bulabilmeniz için hazýrlanmýþlardýr. find programý ile belirli
82 özellikleri olan bir yazýlýmý bir dizin hiyerarþisi altýnda
83 arayabilirsiniz.
84
85 %prep
86 %setup -q
87 %patch0 -p1
88 %patch1 -p1
89 %patch2 -p1
90 %{?with_selinux:%patch3 -p1}
91 # patch4 is applied in install stage
92
93 %{__perl} -pi -e 's/_jy_FIND LIBOBJS_NORMALIZE/_jy_FINDLIBOBJS_NORMALIZE/' m4/findlib.m4
94
95 %build
96 %{__aclocal} -I gnulib/m4 -I m4
97 %{__autoconf}
98 %{__autoheader}
99 %{__automake}
100 %configure
101
102 %{__make}
103
104 %install
105 rm -rf $RPM_BUILD_ROOT
106
107 %{__make} install \
108         DESTDIR=$RPM_BUILD_ROOT
109
110 bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
111 %{?with_selinux:patch -p0 -d $RPM_BUILD_ROOT%{_mandir} < %{PATCH4}}
112
113 # xargs is wanted in /bin
114 install -d $RPM_BUILD_ROOT/bin
115 mv $RPM_BUILD_ROOT%{_bindir}/xargs $RPM_BUILD_ROOT/bin
116
117 # unpackaged locate
118 rm -f $RPM_BUILD_ROOT%{_bindir}/{locate,updatedb} \
119         $RPM_BUILD_ROOT%{_libdir}/{bigram,code,frcode} \
120         $RPM_BUILD_ROOT%{_mandir}/{,*/}man?/{locate.1,updatedb.1,locatedb.5}*
121
122 %find_lang %{name}
123
124 %clean
125 rm -rf $RPM_BUILD_ROOT
126
127 %post
128 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
129
130 %postun
131 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
132
133 %files -f %{name}.lang
134 %defattr(644,root,root,755)
135 %doc NEWS README TODO ChangeLog
136 %attr(755,root,root) %{_bindir}/find
137 %attr(755,root,root) /bin/xargs
138
139 %{_mandir}/man1/[fx]*
140 %lang(de) %{_mandir}/de/man1/[fx]*
141 %lang(es) %{_mandir}/es/man1/[fx]*
142 %lang(fi) %{_mandir}/fi/man1/[fx]*
143 %lang(fr) %{_mandir}/fr/man1/[fx]*
144 %lang(hu) %{_mandir}/hu/man1/[fx]*
145 %lang(it) %{_mandir}/it/man1/[fx]*
146 %lang(ja) %{_mandir}/ja/man1/[fx]*
147 %lang(nl) %{_mandir}/nl/man1/[fx]*
148 %lang(pl) %{_mandir}/pl/man1/[fx]*
149 %lang(zh_CN) %{_mandir}/zh_CN/man1/[fx]*
150 %{_infodir}/find.info*
This page took 0.062003 seconds and 3 git commands to generate.