]> git.pld-linux.org Git - packages/fife.git/blob - fife.spec
- release 4 (by relup.sh)
[packages/fife.git] / fife.spec
1 #
2 # TODO:
3 #       - package apidocs
4 #
5 %bcond_without  static_libs     # don't build static libraries
6 #
7 Summary:        Flexible Isometric Free Engine
8 Name:           fife
9 Version:        0.3.3r3
10 Release:        4
11 License:        LGPL v2
12 Group:          Libraries
13 Source0:        http://downloads.sourceforge.net/fife/%{name}_%{version}.tar.gz
14 # Source0-md5:  ee39612009e124263dc79d1f0fa7ca7c
15 Patch0:         %{name}-extra_libs.patch
16 URL:            http://fifengine.net/
17 BuildRequires:  OpenAL-devel
18 BuildRequires:  SDL-devel
19 BuildRequires:  SDL_image-devel
20 BuildRequires:  SDL_ttf-devel
21 BuildRequires:  boost-devel
22 BuildRequires:  guichan-devel
23 #BuildRequires: guichan_opengl-devel
24 #BuildRequires: guichan_sdl-devel
25 BuildRequires:  libpng-devel
26 BuildRequires:  libvorbis-devel
27 BuildRequires:  python-devel >= 2.7
28 BuildRequires:  scons
29 BuildRequires:  swig-python
30 BuildRequires:  tinyxml-devel
31 BuildRequires:  xorg-lib-libXcursor-devel
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 FIFE is a cross platform 2D game creation framework written in C++
36 with Python bindings. It's designed to be flexible enough to support a
37 wide variety of 2D game types but specializes in 2D isometric type
38 views.
39
40 %package devel
41 Summary:        Header files for %{name} library
42 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki %{name}
43 Group:          Development/Libraries
44 Requires:       %{name} = %{version}-%{release}
45
46 %description devel
47 Header files for %{name} library.
48
49 %description devel -l pl.UTF-8
50 Pliki nagłówkowe biblioteki %{name}.
51
52 %package static
53 Summary:        Static %{name} library
54 Summary(pl.UTF-8):      Statyczna biblioteka %{name}
55 Group:          Development/Libraries
56 Requires:       %{name}-devel = %{version}-%{release}
57
58 %description static
59 Static %{name} library.
60
61 %description static -l pl.UTF-8
62 Statyczna biblioteka %{name}.
63
64 %package -n python-%{name}
65 Summary:        Flexible Isometric Free Engine Python Module
66 Group:          Development/Languages/Python
67 Requires:       %{name} = %{version}-%{release}
68 Requires:       python-modules
69
70 %description -n python-%{name}
71 FIFE is a cross platform 2D game creation framework written in C++
72 with Python bindings. It's designed to be flexible enough to support a
73 wide variety of 2D game types but specializes in 2D isometric type
74 views.
75
76 %package apidocs
77 Summary:        %{name} API documentation
78 Summary(pl.UTF-8):      Dokumentacja API biblioteki %{name}
79 Group:          Documentation
80
81 %description apidocs
82 API and internal documentation for %{name} library.
83
84 %description apidocs -l pl.UTF-8
85 Dokumentacja API biblioteki %{name}.
86
87 %prep
88 %setup -qn %{name}_%{version}
89 %patch0 -p1
90
91 %build
92 %scons -j1 fife-shared fife-python \
93         %{?with_static_libs:fife-static} \
94         --lib-dir=%{_libdir} \
95         --prefix=%{_prefix} \
96         --python-prefix=%{py_sitedir}
97
98 %install
99 rm -rf $RPM_BUILD_ROOT
100
101 %scons -j1 install-shared install-python install-dev \
102         %{?with_static_libs:install-static} \
103         --lib-dir=%{_libdir} \
104         --prefix=%{_prefix} \
105         --python-prefix=%{py_sitedir} \
106         --install-sandbox=$RPM_BUILD_ROOT
107
108 SAVED_PWD=$PWD
109 cd $RPM_BUILD_ROOT%{_libdir}
110 ln -s lib%{name}.so.0.?.? lib%{name}.so.0
111 ln -s lib%{name}.so.0.?.? lib%{name}.so
112 cd $SAVED_PWD
113
114 %clean
115 rm -rf $RPM_BUILD_ROOT
116
117 %post   -p /sbin/ldconfig
118 %postun -p /sbin/ldconfig
119
120 %files
121 %defattr(644,root,root,755)
122 %doc AUTHORS CHANGES README
123 %attr(755,root,root) %{_libdir}/lib%{name}.so.*.*.*
124 %attr(755,root,root) %ghost %{_libdir}/lib%{name}.so.0
125
126 %files devel
127 %defattr(644,root,root,755)
128 %attr(755,root,root) %{_libdir}/lib%{name}.so
129 %{_includedir}/%{name}
130
131 %files -n python-%{name}
132 %defattr(644,root,root,755)
133 %dir %{py_sitedir}/%{name}
134 %attr(755,root,root) %{py_sitedir}/%{name}/*.so
135 %{py_sitedir}/%{name}/*.py*
136 %{py_sitedir}/%{name}/extensions
137
138 %if %{with static_libs}
139 %files static
140 %defattr(644,root,root,755)
141 %{_libdir}/lib%{name}.a
142 %endif
143
144 %if %{with apidocs}
145 %files apidocs
146 %defattr(644,root,root,755)
147 %doc apidocs/*
148 %endif
This page took 0.08122 seconds and 3 git commands to generate.