]> git.pld-linux.org Git - packages/ffmpeg.git/commitdiff
- added fdk_aac option (nonfree); libilbc needs different ilbc library variant
authorJakub Bogusz <qboosh@pld-linux.org>
Sat, 6 Oct 2012 10:58:02 +0000 (12:58 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Sat, 6 Oct 2012 10:58:02 +0000 (12:58 +0200)
ffmpeg.spec

index aa9a4060339d204f7a833de998493c6c36a08bbf..d8581f586e8e35aa00348d38b67631bb20e236d1 100644 (file)
@@ -1,4 +1,4 @@
-# TODO: libilbc, libfdk-aac, flite
+# TODO: libilbc (requires webrtc.org version), flite (some additional voices required)
 #
 # How to deal with ffmpeg/opencv checken-egg problem:
 #      1. make-request -r --without opencv ffmpeg.spec
@@ -9,10 +9,12 @@
 # Conditional build:
 %bcond_with    nonfree         # non free options of package (currently: faac)
 %bcond_with    aacplus         # AAC+ encoding via libaacplus (requires nonfree)
+%bcond_with    fdk_aac         # AAC encoding via libfdk_aac (requires nonfree)
 %bcond_without autoreqdep      # don't care about package name deps generated by rpm
 %bcond_without caca            # textual display using libcaca
 %bcond_with    flite           # flite voice synthesis support [ffmpeg expects more voices]
 %bcond_without frei0r          # build without frei0r video filtering
+%bcond_with    ilbc            # iLBC de/encoding via libilbc
 %bcond_without openal          # build without OpenAL 1.1 capture support
 %bcond_without opencv          # build without opencv video filtering
 %bcond_without pulseaudio      # build without PulseAudio input support
@@ -47,6 +49,7 @@ BuildRequires:        alsa-lib-devel
 BuildRequires: bzip2-devel
 BuildRequires: celt-devel >= 0.11.0
 %{?with_nonfree:BuildRequires: faac-devel}
+%{?with_fdk_aac:BuildRequires: fdk-aac-devel}
 %{?with_flite:BuildRequires:   flite-devel}
 BuildRequires: fontconfig-devel
 BuildRequires: freetype-devel
@@ -67,6 +70,7 @@ BuildRequires:        libcdio-devel
 BuildRequires: libdc1394-devel >= 2
 BuildRequires: libgsm-devel
 BuildRequires: libiec61883-devel
+%{?with_ilbc:BuildRequires:    libilbc-devel}
 BuildRequires: libmodplug-devel
 BuildRequires: libnut-devel
 BuildRequires: libraw1394-devel >= 2
@@ -173,6 +177,7 @@ Requires:   alsa-lib-devel
 Requires:      bzip2-devel
 Requires:      celt-devel >= 0.11.0
 %{?with_nonfree:Requires:      faac-devel}
+%{?with_fdk_aac:Requires:      fdk-aac-devel}
 Requires:      fontconfig-devel
 Requires:      freetype-devel
 Requires:      jack-audio-connection-kit-devel
@@ -186,6 +191,7 @@ Requires:   libcdio-devel
 Requires:      libdc1394-devel >= 2
 Requires:      libgsm-devel
 Requires:      libiec61883-devel
+%{?with_ilbc:Requires: libilbc-devel}
 Requires:      libmodplug-devel
 Requires:      libnut-devel
 Requires:      libraw1394-devel >= 2
@@ -353,10 +359,12 @@ EOF
        --enable-libcelt \
        --enable-libcdio \
        --enable-libdc1394 \
+       %{?with_fdk_aac:--enable-libfdk-aac} \
        %{?with_flite:--enable-libflite} \
        --enable-libfreetype \
        --enable-libgsm \
        --enable-libiec61883 \
+       %{?with_ilbc:--enable-libilbc} \
        --enable-libmodplug \
        --enable-libmp3lame \
        --enable-libnut \
This page took 0.100647 seconds and 4 git commands to generate.