]> git.pld-linux.org Git - packages/festival.git/blob - festival.spec
- update config.* (for athlon)
[packages/festival.git] / festival.spec
1 Summary:        The Festival speech sythesis system
2 Summary(pl):    System syntezy mowy Festival
3 Name:           festival
4 Version:        1.4.2
5 Release:        4
6 License:        GPL
7 Group:          Applications/Sound
8 Source0:        http://www.cstr.ed.ac.uk/download/festival/%{version}/%{name}-%{version}-release.tar.gz
9 Source1:        http://www.cstr.ed.ac.uk/download/festival/%{version}/festvox_us1.tar.gz
10 Source2:        http://www.cstr.ed.ac.uk/download/festival/%{version}/festvox_us2.tar.gz
11 Source3:        http://www.cstr.ed.ac.uk/download/festival/%{version}/festvox_us3.tar.gz
12 Source4:        http://www.cstr.ed.ac.uk/download/festival/%{version}/festvox_en1.tar.gz
13 Patch0:         %{name}-config.patch
14 URL:            http://www.cstr.ed.ac.uk/projects/festival/
15 BuildRequires:  speech_tools-devel
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %ifarch alpha
19 %define         fostype alpha_Linux
20 %else
21 %define         fostype unknown_Linux
22 %endif
23
24 %description
25 Festival offers a general framework for building speech synthesis
26 systems as well as including examples of various modules. As a whole
27 it offers full text to speech through a number APIs: from shell level,
28 though a Scheme command interpreter, as a C++ library, from Java, and
29 an Emacs interface. Festival is multi-lingual, though English is the
30 most advanced.
31
32 %description -l pl
33 Festival jest platform± przeznaczon± do budowania systemów syntezy
34 mowy oraz do ³atwego testowania ró¿nych modu³ów sk³adaj±cych siê na
35 syntezator mowy. Mo¿na te¿ u¿ywaæ programu jako maszynki czytaj±cej
36 pliki tekstowe. Festival jest wielojêzyczny, lecz jêzyk angielski jest
37 najbardziej zaawansowany.
38
39 %package devel
40 Summary:        Festival developement enviroment
41 Summary(pl):    Festival - ¶rodowidko rozwojowe
42 Group:          Applications/Sound
43
44 %description devel
45 Festival developement enviroment.
46
47 %description devel -l pl
48 Festival - ¶rodowisko rozwojowe.
49
50 %package voices-english-mbrola-us
51 Summary:        Festival's files for voices us1, us2, us3
52 Summary(pl):    Pliki Festival do g³osów us1, us2, us3
53 Group:          Applications/Sound
54 Requires:       mbrola
55
56 %description voices-english-mbrola-us
57 Files needed to use us1, us2, us3 voices from mbrola packages.
58
59 %description voices-english-mbrola-us -l pl
60 Pliki potrzebne do u¿ycia g³osów us1, us2, us3 z pakietu mbrola.
61
62 %package voices-english-mbrola-en
63 Summary:        Festival's files for voice en1
64 Summary(pl):    Pliki Festival do g³osu en1
65 Group:          Applications/Sound
66 Requires:       mbrola
67
68 %description voices-english-mbrola-en
69 Files needed to use en1 voice from mbrola packages.
70
71 %description voices-english-mbrola-en -l pl
72 Pliki potrzebne do u¿ycia g³osu en1 z pakietu mbrola.
73
74 %prep
75 %setup -q -n %{name} -b1 -b2 -b3 -b4
76 %patch0 -p1
77
78 %build
79 cp -f /usr/share/automake/config.* .
80 %configure2_13
81 %{__make} \
82         CC="%{__cc}" \
83         CXX="%{__cxx}" \
84         OPTIMISE_CCFLAGS="%{rpmcflags}" \
85         OPTIMISE_CXXFLAGS="%{rpmcflags}" \
86         OPTIMISE_LINK="%{rpmldflags}" \
87         REQUIRED_LIBDEPS=
88 # REQUIRED_LIBDPES is workaround not to need static speech_tools libraries
89
90 %install
91 rm -rf $RPM_BUILD_ROOT
92 install -d $RPM_BUILD_ROOT{%{_bindir},%{_datadir}/%{name}/lib/{voices/english,dicts},%{_libdir},%{_includedir}/%{name},%{_mandir}/man1}
93
94 # bin
95 install bin/festival_server* bin/text2wave $RPM_BUILD_ROOT%{_bindir}
96 install src/main/festival{,_client} $RPM_BUILD_ROOT%{_bindir}
97
98 # devel
99 install src/lib/libFestival.a $RPM_BUILD_ROOT%{_libdir}
100 install src/include/*.h $RPM_BUILD_ROOT%{_includedir}/%{name}
101
102 # data
103 cp -r lib config examples $RPM_BUILD_ROOT%{_datadir}/%{name}
104 find $RPM_BUILD_ROOT%{_datadir}/%{name} -name Makefile -exec rm \{\} \;
105
106 install doc/festival{,_client}.1 $RPM_BUILD_ROOT%{_mandir}/man1
107
108 %clean
109 rm -rf $RPM_BUILD_ROOT
110
111 %files
112 %defattr(644,root,root,755)
113 %doc ACKNOWLEDGMENTS COPYING NEWS README
114 %{_mandir}/man1/*
115 %attr(755,root,root) %{_bindir}/*
116 %dir %{_datadir}/%{name}
117 %dir %{_datadir}/%{name}/lib
118 %dir %{_datadir}/%{name}/lib/dicts
119 %dir %{_datadir}/%{name}/lib/voices
120 %dir %{_datadir}/%{name}/lib/voices/english
121 %dir %{_datadir}/%{name}/lib/etc
122 %dir %{_datadir}/%{name}/lib/etc/%{fostype}
123 %attr(755,root,root) %{_datadir}/%{name}/lib/etc/%{fostype}/audsp
124 %{_datadir}/%{name}/lib/etc/email_filter
125 %{_datadir}/%{name}/lib/*.scm
126 %{_datadir}/%{name}/lib/Sable.v0_2.dtd
127 %{_datadir}/%{name}/lib/festival.el
128 %{_datadir}/%{name}/lib/sable-latin.ent
129 %{_datadir}/%{name}/lib/scfg_wsj_wp20.gram
130 %{_datadir}/%{name}/lib/sec.*.ngrambin
131 %{_datadir}/%{name}/lib/speech.properties
132 %{_datadir}/%{name}/examples
133
134 %files devel
135 %defattr(644,root,root,755)
136 %{_includedir}/%{name}
137 %{_libdir}/*
138 %{_datadir}/%{name}/config
139
140 %files voices-english-mbrola-us
141 %defattr(644,root,root,755)
142 %{_datadir}/%{name}/lib/voices/english/us1_mbrola
143 %{_datadir}/%{name}/lib/voices/english/us2_mbrola
144 %{_datadir}/%{name}/lib/voices/english/us3_mbrola
145
146 %files voices-english-mbrola-en
147 %defattr(644,root,root,755)
148 %{_datadir}/%{name}/lib/voices/english/en1_mbrola
This page took 0.144229 seconds and 4 git commands to generate.