]> git.pld-linux.org Git - packages/festival.git/blob - festival.spec
- release 7
[packages/festival.git] / festival.spec
1 # TODO: kill ELF binary from %{_datadir}, see files
2 Summary:        The Festival speech sythesis system
3 Summary(pl.UTF-8):      System syntezy mowy Festival
4 Name:           festival
5 Version:        1.4.4
6 %define         rel     7
7 %define         _snap   20030803
8 Release:        0.%{_snap}.%{rel}
9 License:        BSD-like (except for festival.el, which is on GPL)
10 Group:          Applications/Sound
11 #Source0:       http://www.cstr.ed.ac.uk/download/festival/%{version}/%{name}-%{version}-release.tar.gz
12 Source0:        http://www.festvox.org/packed/festival/latest/festival-%{version}-current%{_snap}.tar.gz
13 # Source0-md5:  ffaa7533b3f50791aabfbf1cee09ca85
14 Source1:        http://www.cstr.ed.ac.uk/download/festival/%{version}/festvox_us1.tar.gz
15 # Source1-md5:  d0c3e727003e715a65daf01003101813
16 Source2:        http://www.cstr.ed.ac.uk/download/festival/%{version}/festvox_us2.tar.gz
17 # Source2-md5:  fbcc8baacbff3aa2aaaf5a93701bb5e0
18 Source3:        http://www.cstr.ed.ac.uk/download/festival/%{version}/festvox_us3.tar.gz
19 # Source3-md5:  06dbfe2edaab6ffa31deeaf522e0c33e
20 Source4:        http://www.cstr.ed.ac.uk/download/festival/%{version}/festvox_en1.tar.gz
21 # Source4-md5:  66e3bc07751d7e31826185649c5ada5a
22 Patch0:         %{name}-config.patch
23 Patch1:         %{name}-asterisk.patch
24 Patch2:         %{name}-gcc4.patch
25 URL:            http://www.cstr.ed.ac.uk/projects/festival/
26 BuildRequires:  automake
27 BuildRequires:  speech_tools-devel
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %ifarch alpha
31 %define         fostype alpha_Linux
32 %else
33 %define         fostype unknown_Linux
34 %endif
35
36 %description
37 Festival offers a general framework for building speech synthesis
38 systems as well as including examples of various modules. As a whole
39 it offers full text to speech through a number APIs: from shell level,
40 though a Scheme command interpreter, as a C++ library, from Java, and
41 an Emacs interface. Festival is multi-lingual, though English is the
42 most advanced.
43
44 %description -l pl.UTF-8
45 Festival jest platformą przeznaczoną do budowania systemów syntezy
46 mowy oraz do łatwego testowania różnych modułów składających się na
47 syntezator mowy. Można też używać programu jako maszynki czytającej
48 pliki tekstowe. Festival jest wielojęzyczny, lecz język angielski jest
49 najbardziej zaawansowany.
50
51 %package devel
52 Summary:        Festival developement environment
53 Summary(pl.UTF-8):      Festival - środowidko rozwojowe
54 Group:          Applications/Sound
55
56 %description devel
57 Festival developement environment.
58
59 %description devel -l pl.UTF-8
60 Festival - środowisko rozwojowe.
61
62 %package voices-english-mbrola-us
63 Summary:        Festival's files for voices us1, us2, us3
64 Summary(pl.UTF-8):      Pliki Festival do głosów us1, us2, us3
65 Group:          Applications/Sound
66 Requires:       mbrola
67
68 %description voices-english-mbrola-us
69 Files needed to use us1, us2, us3 voices from mbrola packages.
70
71 %description voices-english-mbrola-us -l pl.UTF-8
72 Pliki potrzebne do użycia głosów us1, us2, us3 z pakietu mbrola.
73
74 %package voices-english-mbrola-en
75 Summary:        Festival's files for voice en1
76 Summary(pl.UTF-8):      Pliki Festival do głosu en1
77 Group:          Applications/Sound
78 Requires:       mbrola
79
80 %description voices-english-mbrola-en
81 Files needed to use en1 voice from mbrola packages.
82
83 %description voices-english-mbrola-en -l pl.UTF-8
84 Pliki potrzebne do użycia głosu en1 z pakietu mbrola.
85
86 %prep
87 %setup -q -n %{name} -b1 -b2 -b3 -b4
88 %patch0 -p1
89 %patch1 -p1
90 %patch2 -p1
91
92 %build
93 cp -f /usr/share/automake/config.* .
94 %{__perl} -pi -e 's,^EST=.*,EST=%{_libdir}/speech_tools,' config/config.in
95 %configure2_13
96 %{__make} \
97         CC="%{__cc}" \
98         CXX="%{__cxx}" \
99         ECHO_N='printf "%%s"' \
100         OPTIMISE_CCFLAGS="%{rpmcflags}" \
101         OPTIMISE_CXXFLAGS="%{rpmcflags}" \
102         OPTIMISE_LINK="%{rpmldflags}" \
103         REQUIRED_LIBDEPS= 
104 # REQUIRED_LIBDPES is workaround not to need static speech_tools libraries
105
106 %install
107 rm -rf $RPM_BUILD_ROOT
108 install -d $RPM_BUILD_ROOT{%{_bindir},%{_datadir}/%{name}/lib/{voices/english,dicts},%{_libdir},%{_includedir}/%{name},%{_mandir}/man1}
109
110 # bin
111 install bin/festival_server* bin/text2wave $RPM_BUILD_ROOT%{_bindir}
112 install src/main/festival{,_client} $RPM_BUILD_ROOT%{_bindir}
113
114 # devel
115 install src/lib/libFestival.a $RPM_BUILD_ROOT%{_libdir}
116 install src/include/*.h $RPM_BUILD_ROOT%{_includedir}/%{name}
117
118 # data
119 cp -r lib config examples $RPM_BUILD_ROOT%{_datadir}/%{name}
120 find $RPM_BUILD_ROOT%{_datadir}/%{name} -name Makefile -exec rm \{\} \;
121
122 install doc/festival{,_client}.1 $RPM_BUILD_ROOT%{_mandir}/man1
123
124 %clean
125 rm -rf $RPM_BUILD_ROOT
126
127 %files
128 %defattr(644,root,root,755)
129 %doc ACKNOWLEDGMENTS COPYING NEWS README
130 %{_mandir}/man1/*
131 %attr(755,root,root) %{_bindir}/*
132 %dir %{_datadir}/%{name}
133 %dir %{_datadir}/%{name}/lib
134 %dir %{_datadir}/%{name}/lib/dicts
135 %dir %{_datadir}/%{name}/lib/voices
136 %dir %{_datadir}/%{name}/lib/voices/english
137 %dir %{_datadir}/%{name}/lib/etc
138 %dir %{_datadir}/%{name}/lib/etc/%{fostype}
139 # XXX: ELF binary, fix it!
140 %attr(755,root,root) %{_datadir}/%{name}/lib/etc/%{fostype}/audsp
141 %{_datadir}/%{name}/lib/etc/email_filter
142 %{_datadir}/%{name}/lib/*.scm
143 %{_datadir}/%{name}/lib/Sable.v0_2.dtd
144 %{_datadir}/%{name}/lib/festival.el
145 %{_datadir}/%{name}/lib/sable-latin.ent
146 %{_datadir}/%{name}/lib/scfg_wsj_wp20.gram
147 %{_datadir}/%{name}/lib/sec.*.ngrambin
148 %{_datadir}/%{name}/lib/speech.properties
149 %{_datadir}/%{name}/examples
150
151 %files devel
152 %defattr(644,root,root,755)
153 %{_includedir}/%{name}
154 %{_libdir}/libFestival.a
155 %dir %{_datadir}/%{name}
156 %{_datadir}/%{name}/config
157
158 # no mbrola on amd64
159 %ifarch %{ix86} ppc alpha sparc
160 %files voices-english-mbrola-us
161 %defattr(644,root,root,755)
162 %{_datadir}/%{name}/lib/voices/english/us1_mbrola
163 %{_datadir}/%{name}/lib/voices/english/us2_mbrola
164 %{_datadir}/%{name}/lib/voices/english/us3_mbrola
165
166 %files voices-english-mbrola-en
167 %defattr(644,root,root,755)
168 %{_datadir}/%{name}/lib/voices/english/en1_mbrola
169 %endif
This page took 0.168421 seconds and 3 git commands to generate.