]> git.pld-linux.org Git - packages/festival.git/blob - festival.spec
- gcc 4.1 fixes
[packages/festival.git] / festival.spec
1 # TODO: kill ELF binary from %{_datadir}, see files
2 Summary:        The Festival speech sythesis system
3 Summary(pl):    System syntezy mowy Festival
4 Name:           festival
5 Version:        1.4.4
6 %define         _snap   20030803
7 Release:        0.%{_snap}.3
8 License:        BSD-like (except for festival.el, which is on GPL)
9 Group:          Applications/Sound
10 #Source0:       http://www.cstr.ed.ac.uk/download/festival/%{version}/%{name}-%{version}-release.tar.gz
11 Source0:        http://www.festvox.org/packed/festival/latest/festival-%{version}-current%{_snap}.tar.gz
12 # Source0-md5:  ffaa7533b3f50791aabfbf1cee09ca85
13 Source1:        http://www.cstr.ed.ac.uk/download/festival/%{version}/festvox_us1.tar.gz
14 # Source1-md5:  d0c3e727003e715a65daf01003101813
15 Source2:        http://www.cstr.ed.ac.uk/download/festival/%{version}/festvox_us2.tar.gz
16 # Source2-md5:  fbcc8baacbff3aa2aaaf5a93701bb5e0
17 Source3:        http://www.cstr.ed.ac.uk/download/festival/%{version}/festvox_us3.tar.gz
18 # Source3-md5:  06dbfe2edaab6ffa31deeaf522e0c33e
19 Source4:        http://www.cstr.ed.ac.uk/download/festival/%{version}/festvox_en1.tar.gz
20 # Source4-md5:  66e3bc07751d7e31826185649c5ada5a
21 Patch0:         %{name}-config.patch
22 Patch1:         %{name}-asterisk.patch
23 Patch2:         %{name}-gcc4.patch
24 URL:            http://www.cstr.ed.ac.uk/projects/festival/
25 BuildRequires:  automake
26 BuildRequires:  speech_tools-devel
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %ifarch alpha
30 %define         fostype alpha_Linux
31 %else
32 %define         fostype unknown_Linux
33 %endif
34
35 %description
36 Festival offers a general framework for building speech synthesis
37 systems as well as including examples of various modules. As a whole
38 it offers full text to speech through a number APIs: from shell level,
39 though a Scheme command interpreter, as a C++ library, from Java, and
40 an Emacs interface. Festival is multi-lingual, though English is the
41 most advanced.
42
43 %description -l pl
44 Festival jest platform± przeznaczon± do budowania systemów syntezy
45 mowy oraz do ³atwego testowania ró¿nych modu³ów sk³adaj±cych siê na
46 syntezator mowy. Mo¿na te¿ u¿ywaæ programu jako maszynki czytaj±cej
47 pliki tekstowe. Festival jest wielojêzyczny, lecz jêzyk angielski jest
48 najbardziej zaawansowany.
49
50 %package devel
51 Summary:        Festival developement enviroment
52 Summary(pl):    Festival - ¶rodowidko rozwojowe
53 Group:          Applications/Sound
54
55 %description devel
56 Festival developement enviroment.
57
58 %description devel -l pl
59 Festival - ¶rodowisko rozwojowe.
60
61 %package voices-english-mbrola-us
62 Summary:        Festival's files for voices us1, us2, us3
63 Summary(pl):    Pliki Festival do g³osów us1, us2, us3
64 Group:          Applications/Sound
65 Requires:       mbrola
66
67 %description voices-english-mbrola-us
68 Files needed to use us1, us2, us3 voices from mbrola packages.
69
70 %description voices-english-mbrola-us -l pl
71 Pliki potrzebne do u¿ycia g³osów us1, us2, us3 z pakietu mbrola.
72
73 %package voices-english-mbrola-en
74 Summary:        Festival's files for voice en1
75 Summary(pl):    Pliki Festival do g³osu en1
76 Group:          Applications/Sound
77 Requires:       mbrola
78
79 %description voices-english-mbrola-en
80 Files needed to use en1 voice from mbrola packages.
81
82 %description voices-english-mbrola-en -l pl
83 Pliki potrzebne do u¿ycia g³osu en1 z pakietu mbrola.
84
85 %prep
86 %setup -q -n %{name} -b1 -b2 -b3 -b4
87 %patch0 -p1
88 %patch1 -p1
89 %patch2 -p1
90
91 %build
92 cp -f /usr/share/automake/config.* .
93 %{__perl} -pi -e 's,^EST=.*,EST=%{_libdir}/speech_tools,' config/config.in
94 %configure2_13
95 %{__make} \
96         CC="%{__cc}" \
97         CXX="%{__cxx}" \
98         ECHO_N='printf "%%s"' \
99         OPTIMISE_CCFLAGS="%{rpmcflags}" \
100         OPTIMISE_CXXFLAGS="%{rpmcflags}" \
101         OPTIMISE_LINK="%{rpmldflags}" \
102         REQUIRED_LIBDEPS= 
103 # REQUIRED_LIBDPES is workaround not to need static speech_tools libraries
104
105 %install
106 rm -rf $RPM_BUILD_ROOT
107 install -d $RPM_BUILD_ROOT{%{_bindir},%{_datadir}/%{name}/lib/{voices/english,dicts},%{_libdir},%{_includedir}/%{name},%{_mandir}/man1}
108
109 # bin
110 install bin/festival_server* bin/text2wave $RPM_BUILD_ROOT%{_bindir}
111 install src/main/festival{,_client} $RPM_BUILD_ROOT%{_bindir}
112
113 # devel
114 install src/lib/libFestival.a $RPM_BUILD_ROOT%{_libdir}
115 install src/include/*.h $RPM_BUILD_ROOT%{_includedir}/%{name}
116
117 # data
118 cp -r lib config examples $RPM_BUILD_ROOT%{_datadir}/%{name}
119 find $RPM_BUILD_ROOT%{_datadir}/%{name} -name Makefile -exec rm \{\} \;
120
121 install doc/festival{,_client}.1 $RPM_BUILD_ROOT%{_mandir}/man1
122
123 %clean
124 rm -rf $RPM_BUILD_ROOT
125
126 %files
127 %defattr(644,root,root,755)
128 %doc ACKNOWLEDGMENTS COPYING NEWS README
129 %{_mandir}/man1/*
130 %attr(755,root,root) %{_bindir}/*
131 %dir %{_datadir}/%{name}
132 %dir %{_datadir}/%{name}/lib
133 %dir %{_datadir}/%{name}/lib/dicts
134 %dir %{_datadir}/%{name}/lib/voices
135 %dir %{_datadir}/%{name}/lib/voices/english
136 %dir %{_datadir}/%{name}/lib/etc
137 %dir %{_datadir}/%{name}/lib/etc/%{fostype}
138 # XXX: ELF binary, fix it!
139 %attr(755,root,root) %{_datadir}/%{name}/lib/etc/%{fostype}/audsp
140 %{_datadir}/%{name}/lib/etc/email_filter
141 %{_datadir}/%{name}/lib/*.scm
142 %{_datadir}/%{name}/lib/Sable.v0_2.dtd
143 %{_datadir}/%{name}/lib/festival.el
144 %{_datadir}/%{name}/lib/sable-latin.ent
145 %{_datadir}/%{name}/lib/scfg_wsj_wp20.gram
146 %{_datadir}/%{name}/lib/sec.*.ngrambin
147 %{_datadir}/%{name}/lib/speech.properties
148 %{_datadir}/%{name}/examples
149
150 %files devel
151 %defattr(644,root,root,755)
152 %{_includedir}/%{name}
153 %{_libdir}/libFestival.a
154 %{_datadir}/%{name}/config
155
156 # no mbrola on amd64
157 %ifarch %{ix86} ppc alpha sparc
158 %files voices-english-mbrola-us
159 %defattr(644,root,root,755)
160 %{_datadir}/%{name}/lib/voices/english/us1_mbrola
161 %{_datadir}/%{name}/lib/voices/english/us2_mbrola
162 %{_datadir}/%{name}/lib/voices/english/us3_mbrola
163
164 %files voices-english-mbrola-en
165 %defattr(644,root,root,755)
166 %{_datadir}/%{name}/lib/voices/english/en1_mbrola
167 %endif
This page took 0.223042 seconds and 3 git commands to generate.