]> git.pld-linux.org Git - packages/fbida.git/blob - fbida.spec
- added fbida-libpng-1.4.patch (png_set_expand_gray_1_2_4_to_8 instead of
[packages/fbida.git] / fbida.spec
1 # TODO:
2 # - package thumbnail.cgi (in %{_libdir}/cgi-bin?)
3 #
4 # Conditional build:
5 %bcond_without  curl    # without URL support
6 %bcond_without  exif    # without EXIF tags support
7 %bcond_without  gif     # without GIF images support
8 %bcond_without  lirc    # without LIRC control support
9 %bcond_without  motif   # don't build (Motif-based) ida
10 %bcond_without  pcd     # without PCD images support
11 %bcond_without  png     # without PNG images support
12 %bcond_without  sane    # without SANE scanning support (in ida)
13 %bcond_without  tiff    # without TIFF images support
14 #
15 %if !%{with motif}
16 # SANE used only in ida
17 %undefine       with_sane
18 %endif
19 Summary:        fbida - a few applications for viewing and editing images
20 Summary(pl.UTF-8):      fbida - kilka aplikacji do oglądania i edycji obrazków
21 Name:           fbida
22 Version:        2.07
23 Release:        2
24 License:        GPL
25 Group:          Applications/Graphics
26 Source0:        http://dl.bytesex.org/releases/fbida/%{name}-%{version}.tar.gz
27 # Source0-md5:  3e05910fb7c1d9b2bd3e272d96db069c
28 Patch0:         %{name}-config-noforce.patch
29 Patch1:         %{name}-desktop.patch
30 Patch2:         %{name}-libpng-1.4.patch
31 URL:            http://linux.bytesex.org/fbida/
32 %{?with_curl:BuildRequires:     curl-devel}
33 BuildRequires:  fontconfig-devel
34 BuildRequires:  freetype-devel >= 2.0.0
35 # -Wno-pointer-sign
36 BuildRequires:  gcc >= 5:4.0
37 %{?with_gif:BuildRequires:      giflib-devel}
38 BuildRequires:  libexif-devel >= 1:0.6.9
39 BuildRequires:  libjpeg-devel
40 %{?with_pcd:BuildRequires:      libpcd-devel >= 1:1.0.1}
41 %{?with_png:BuildRequires:      libpng-devel}
42 %{?with_lirc:BuildRequires:     lirc-devel}
43 %{?with_tiff:BuildRequires:     libtiff-devel}
44 # acc. to README lesstif is not sufficient
45 %{?with_motif:BuildRequires:    openmotif-devel >= 2.0}
46 BuildRequires:  pkgconfig
47 %{?with_sane:BuildRequires:     sane-backends-devel}
48 BuildRequires:  perl-base
49 BuildRequires:  xorg-lib-libXpm-devel
50 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
51
52 %define         _appdefsdir     /usr/share/X11/app-defaults
53
54 %description
55 The fbida project contains a few applications for viewing and editing
56 images, with the main focus being photos. The applications are:
57 - fbi - image viewer for the Linux framebuffer console
58 - fbgs - wrapper script for viewing PS/PDF files using fbi
59 - ida - Motif-based application for viewing images
60 - exiftran - command-line tool to do lossless transformations of JPEG
61   images
62 - thumbnail.cgi - small and fast CGI program to extract EXIF
63   thumbnails from JPEG images and send them to the web browser
64
65 %description -l pl.UTF-8
66 Projekt fbida zawiera kilka aplikacji do oglądania i edycji obrazków,
67 głównie przeznaczonych dla zdjęć. Te aplikacje to:
68 - fbi - przeglądarka dla linuksowej konsoli z framebufferem
69 - fbgs - skrypt do oglądania plików PS/PDF przy użyciu fbi
70 - ida - oparta na Motifie aplikacja do oglądania obrazków
71 - exiftran - działające z linii poleceń narzędzie do wykonywania
72   bezstratnych przekształceń obrazków JPEG
73 - thumbnail.cgi - mały i szybki program CGI do wyciągania miniaturek
74   EXIF z obrazków JPEG i wysyłania ich do przeglądarki WWW
75
76 %package -n fbi
77 Summary:        Linux FrameBuffer Imageviewer
78 Summary(pl.UTF-8):      Przeglądarka obrazków dla linuksowego framebuffera
79 Group:          Applications/Graphics
80 Requires:       mktemp >= 1.3
81
82 %description -n fbi
83 This is a image viewer for linux framebuffer devices. It supports
84 PhotoCD, JPEG and PPM directly. GIF, TIFF and PNG are handled with the
85 netpbm tools, for anything else convert from the ImageMagick package
86 is used as external converter.
87
88 This package contains also additional utilities:
89 - fbgs - wrapper script for viewing PS/PDF files using fbi
90 - exiftran - command-line tool to do lossless transformations of JPEG
91   images
92
93 %description -n fbi -l pl.UTF-8
94 To jest przeglądarka obrazków korzystająca z framebuffera. Obsługuje
95 bezpośrednio PhotoCD, JPEG i PPM; GIF, TIFF i PNG poprzez narzędzia z
96 pakietu netpbm-progs; inne obrazki poprzez program convert z pakietu
97 ImageMagick.
98
99 Ten pakiet zawiera także dodatkowe narzędzia:
100 - fbgs - skrypt do oglądania plików PS/PDF przy użyciu fbi
101 - exiftran - działające z linii poleceń narzędzie do wykonywania
102   bezstratnych przekształceń obrazków JPEG
103
104 %package -n ida
105 Summary:        Small and fast image viewer, Motif-based
106 Summary(pl.UTF-8):      Mała, szybka przeglądarka obrazków oparta na Motifie
107 Group:          X11/Applications/Graphics
108
109 %description -n ida
110 Ida is a small and fast image viewer, Motif-based. For people who
111 don't want the KDE/GNOME overhead. Some basic editing functions are
112 available too.
113
114 %description -n ida -l pl.UTF-8
115 Ida to mała i szybka przeglądarka obrazków oparta na Motifie.
116 Przeznaczona jest dla ludzi, którzy nie chcą narzutu KDE/GNOME.
117 Dostępne jest też trochę podstawowych funkcji edycyjnych.
118
119 %prep
120 %setup -q
121 %patch0 -p1
122 %patch1 -p1
123 %patch2 -p1
124
125 %build
126 CFLAGS="%{rpmcflags}" \
127 %{__make} \
128         CC="%{__cc}" \
129         verbose=yes \
130         %{!?with_pcd:HAVE_LIBPCD=no} \
131         %{!?with_gif:HAVE_LIBUNGIF=no} \
132         %{!?with_png:HAVE_LIBPNG=no} \
133         %{!?with_tiff:HAVE_LIBTIFF=no} \
134         %{!?with_sane:HAVE_LIBSANE=no} \
135         %{!?with_curl:HAVE_LIBCURL=no} \
136         %{!?with_lirc:HAVE_LIBLIRC=no} \
137         %{!?with_motif:HAVE_MOTIF=no}
138
139 %install
140 rm -rf $RPM_BUILD_ROOT
141
142 %{__make} install \
143         DESTDIR=$RPM_BUILD_ROOT \
144         prefix=%{_prefix} \
145         INSTALL_BINARY=install \
146         %{!?with_pcd:HAVE_LIBPCD=no} \
147         %{!?with_gif:HAVE_LIBUNGIF=no} \
148         %{!?with_png:HAVE_LIBPNG=no} \
149         %{!?with_tiff:HAVE_LIBTIFF=no} \
150         %{!?with_sane:HAVE_LIBSANE=no} \
151         %{!?with_curl:HAVE_LIBCURL=no} \
152         %{!?with_lirc:HAVE_LIBLIRC=no} \
153         %{!?with_motif:HAVE_MOTIF=no}
154
155 %if %{with motif}
156 install -D desktop/ida.desktop $RPM_BUILD_ROOT%{_desktopdir}/ida.desktop
157 %endif
158
159 %clean
160 rm -rf $RPM_BUILD_ROOT
161
162 %files -n fbi
163 %defattr(644,root,root,755)
164 %attr(755,root,root) %{_bindir}/exiftran
165 %attr(755,root,root) %{_bindir}/fbgs
166 %attr(755,root,root) %{_bindir}/fbi
167 %{_mandir}/man1/exiftran.1*
168 %{_mandir}/man1/fbgs.1*
169 %{_mandir}/man1/fbi.1*
170
171 %if %{with motif}
172 %files -n ida
173 %defattr(644,root,root,755)
174 %doc README TODO
175 %attr(755,root,root) %{_bindir}/ida
176 %{_mandir}/man1/ida.1*
177 %{_appdefsdir}/Ida
178 %{_desktopdir}/ida.desktop
179 %endif
This page took 0.215712 seconds and 4 git commands to generate.