]> git.pld-linux.org Git - packages/fbida.git/blob - fbida.spec
- unified cairogl bcond name
[packages/fbida.git] / fbida.spec
1 # TODO:
2 # - package thumbnail.cgi (in %{_libdir}/cgi-bin?)
3 #
4 # Conditional build:
5 %bcond_without  curl            # without URL support
6 %bcond_without  exif            # without EXIF tags support
7 %bcond_without  gif             # without GIF images support
8 %bcond_without  lirc            # without LIRC control support
9 %bcond_without  motif           # don't build (Motif-based) ida
10 %bcond_without  pcd             # without PCD images support
11 %bcond_without  png             # without PNG images support
12 %bcond_without  sane            # without SANE scanning support (in ida)
13 %bcond_without  tiff            # without TIFF images support
14 %bcond_without  webp            # without WebP images support
15 %bcond_with     cairo_gl        # with Cairo-GL support (fbpdf program)
16
17 %if %{without motif}
18 # SANE used only in ida
19 %undefine       with_sane
20 %endif
21 Summary:        fbida - a few applications for viewing and editing images
22 Summary(pl.UTF-8):      fbida - kilka aplikacji do oglądania i edycji obrazków
23 Name:           fbida
24 Version:        2.13
25 Release:        1
26 License:        GPL
27 Group:          Applications/Graphics
28 Source0:        https://www.kraxel.org/releases/fbida/%{name}-%{version}.tar.gz
29 # Source0-md5:  de4268242e93eb95e220e14e441c1c50
30 Patch0:         %{name}-config-noforce.patch
31 Patch1:         %{name}-desktop.patch
32 Patch2:         format-security.patch
33 Patch3:         no-cairo-gl.patch
34 URL:            https://www.kraxel.org/blog/linux/fbida/
35 BuildRequires:  ImageMagick-devel
36 BuildRequires:  Mesa-libgbm-devel
37 BuildRequires:  cairo-devel
38 %{?with_curl:BuildRequires:     curl-devel}
39 BuildRequires:  fontconfig-devel
40 BuildRequires:  freetype-devel >= 2.0.0
41 # -Wno-pointer-sign
42 BuildRequires:  gcc >= 5:4.0
43 %{?with_gif:BuildRequires:      giflib-devel}
44 BuildRequires:  libdrm-devel
45 BuildRequires:  libepoxy-devel
46 BuildRequires:  libexif-devel >= 1:0.6.9
47 BuildRequires:  libjpeg-devel
48 %{?with_pcd:BuildRequires:      libpcd-devel >= 1:1.0.1}
49 %{?with_png:BuildRequires:      libpng-devel}
50 %{?with_tiff:BuildRequires:     libtiff-devel}
51 %{?with_webp:BuildRequires:     libwebp-devel}
52 %{?with_lirc:BuildRequires:     lirc-devel}
53 # acc. to README lesstif is not sufficient
54 %{?with_motif:BuildRequires:    motif-devel >= 2.0}
55 BuildRequires:  perl-base
56 BuildRequires:  pkgconfig
57 %{?with_cairo_gl:BuildRequires: pkgconfig(cairo-gl)}
58 BuildRequires:  poppler-glib-devel
59 %{?with_sane:BuildRequires:     sane-backends-devel}
60 BuildRequires:  util-linux
61 BuildRequires:  which
62 BuildRequires:  xorg-lib-libXpm-devel
63 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
64
65 %define         _appdefsdir     /usr/share/X11/app-defaults
66
67 %description
68 The fbida project contains a few applications for viewing and editing
69 images, with the main focus being photos. The applications are:
70 - fbi - image viewer for the Linux framebuffer console
71 - fbgs - wrapper script for viewing PS/PDF files using fbi
72 - ida - Motif-based application for viewing images
73 - exiftran - command-line tool to do lossless transformations of JPEG
74   images
75 - thumbnail.cgi - small and fast CGI program to extract EXIF
76   thumbnails from JPEG images and send them to the web browser
77
78 %description -l pl.UTF-8
79 Projekt fbida zawiera kilka aplikacji do oglądania i edycji obrazków,
80 głównie przeznaczonych dla zdjęć. Te aplikacje to:
81 - fbi - przeglądarka dla linuksowej konsoli z framebufferem
82 - fbgs - skrypt do oglądania plików PS/PDF przy użyciu fbi
83 - ida - oparta na Motifie aplikacja do oglądania obrazków
84 - exiftran - działające z linii poleceń narzędzie do wykonywania
85   bezstratnych przekształceń obrazków JPEG
86 - thumbnail.cgi - mały i szybki program CGI do wyciągania miniaturek
87   EXIF z obrazków JPEG i wysyłania ich do przeglądarki WWW
88
89 %package -n fbi
90 Summary:        Linux FrameBuffer Imageviewer
91 Summary(pl.UTF-8):      Przeglądarka obrazków dla linuksowego framebuffera
92 Group:          Applications/Graphics
93 Requires:       mktemp >= 1.3
94
95 %description -n fbi
96 This is a image viewer for linux framebuffer devices. It supports
97 PhotoCD, JPEG and PPM directly. GIF, TIFF and PNG are handled with the
98 netpbm tools, for anything else convert from the ImageMagick package
99 is used as external converter.
100
101 This package contains also additional utilities:
102 - fbgs - wrapper script for viewing PS/PDF files using fbi
103 - exiftran - command-line tool to do lossless transformations of JPEG
104   images
105
106 %description -n fbi -l pl.UTF-8
107 To jest przeglądarka obrazków korzystająca z framebuffera. Obsługuje
108 bezpośrednio PhotoCD, JPEG i PPM; GIF, TIFF i PNG poprzez narzędzia z
109 pakietu netpbm-progs; inne obrazki poprzez program convert z pakietu
110 ImageMagick.
111
112 Ten pakiet zawiera także dodatkowe narzędzia:
113 - fbgs - skrypt do oglądania plików PS/PDF przy użyciu fbi
114 - exiftran - działające z linii poleceń narzędzie do wykonywania
115   bezstratnych przekształceń obrazków JPEG
116
117 %package -n fbpdf
118 Summary:        Linux FrameBuffer PDF viewer
119 Summary(pl.UTF-8):      Przeglądarka plików PDF dla linuksowego framebuffera
120 Group:          Applications/Graphics
121
122 %description -n fbpdf
123 Linux FrameBuffer PDF viewer.
124
125 %description -n fbpdf -l pl.UTF-8
126 Przeglądarka plików PDF dla linuksowego framebuffera.
127
128 %package -n ida
129 Summary:        Small and fast image viewer, Motif-based
130 Summary(pl.UTF-8):      Mała, szybka przeglądarka obrazków oparta na Motifie
131 Group:          X11/Applications/Graphics
132
133 %description -n ida
134 Ida is a small and fast image viewer, Motif-based. For people who
135 don't want the KDE/GNOME overhead. Some basic editing functions are
136 available too.
137
138 %description -n ida -l pl.UTF-8
139 Ida to mała i szybka przeglądarka obrazków oparta na Motifie.
140 Przeznaczona jest dla ludzi, którzy nie chcą narzutu KDE/GNOME.
141 Dostępne jest też trochę podstawowych funkcji edycyjnych.
142
143 %prep
144 %setup -q
145 %patch0 -p1
146 %patch1 -p1
147 %patch2 -p1
148 %patch3 -p1
149
150 %build
151 CFLAGS="%{rpmcflags}" \
152 %{__make} \
153         CC="%{__cc}" \
154         verbose=yes \
155         %{!?with_pcd:HAVE_LIBPCD=no} \
156         %{!?with_gif:HAVE_LIBGIF=no} \
157         %{!?with_png:HAVE_LIBPNG=no} \
158         %{!?with_tiff:HAVE_LIBTIFF=no} \
159         %{!?with_webp:HAVE_LIBWEBP=no} \
160         %{!?with_sane:HAVE_LIBSANE=no} \
161         %{!?with_curl:HAVE_LIBCURL=no} \
162         %{!?with_lirc:HAVE_LIBLIRC=no} \
163         %{!?with_motif:HAVE_MOTIF=no}
164
165 %install
166 rm -rf $RPM_BUILD_ROOT
167
168 %{__make} install \
169         DESTDIR=$RPM_BUILD_ROOT \
170         prefix=%{_prefix} \
171         INSTALL_BINARY=install \
172         %{!?with_pcd:HAVE_LIBPCD=no} \
173         %{!?with_gif:HAVE_LIBGIF=no} \
174         %{!?with_png:HAVE_LIBPNG=no} \
175         %{!?with_tiff:HAVE_LIBTIFF=no} \
176         %{!?with_webp:HAVE_LIBWEBP=no} \
177         %{!?with_sane:HAVE_LIBSANE=no} \
178         %{!?with_curl:HAVE_LIBCURL=no} \
179         %{!?with_lirc:HAVE_LIBLIRC=no} \
180         %{!?with_motif:HAVE_MOTIF=no}
181
182 %if %{with motif}
183 install -D desktop/ida.desktop $RPM_BUILD_ROOT%{_desktopdir}/ida.desktop
184 %endif
185
186 %clean
187 rm -rf $RPM_BUILD_ROOT
188
189 %files -n fbi
190 %defattr(644,root,root,755)
191 %attr(755,root,root) %{_bindir}/exiftran
192 %attr(755,root,root) %{_bindir}/fbgs
193 %attr(755,root,root) %{_bindir}/fbi
194 %{_mandir}/man1/exiftran.1*
195 %{_mandir}/man1/fbgs.1*
196 %{_mandir}/man1/fbi.1*
197
198 %if %{with cairo_gl}
199 %files -n fbpdf
200 %defattr(644,root,root,755)
201 %attr(755,root,root) %{_bindir}/fbpdf
202 %endif
203
204 %if %{with motif}
205 %files -n ida
206 %defattr(644,root,root,755)
207 %doc README TODO
208 %attr(755,root,root) %{_bindir}/ida
209 %{_mandir}/man1/ida.1*
210 %{_appdefsdir}/Ida
211 %{_desktopdir}/ida.desktop
212 %endif
This page took 0.071803 seconds and 3 git commands to generate.