]> git.pld-linux.org Git - packages/fbida.git/blob - fbida.spec
- don't use %{without ...}, it may not work after inverting bcond
[packages/fbida.git] / fbida.spec
1 # TODO:
2 # - package thumbnail.cgi (in %{_libdir}/cgi-bin?)
3 #
4 # Conditional build:
5 %bcond_without  curl    # without URL support
6 %bcond_without  exif    # without EXIF tags support
7 %bcond_without  gif     # without GIF images support
8 %bcond_without  lirc    # without LIRC control support
9 %bcond_without  motif   # don't build (Motif-based) ida
10 %bcond_without  pcd     # without PCD images support
11 %bcond_without  png     # without PNG images support
12 %bcond_without  sane    # without SANE scanning support (in ida)
13 %bcond_without  tiff    # without TIFF images support
14 #
15 %if !%{with motif}
16 # SANE used only in ida
17 %undefine       with_sane
18 %endif
19 Summary:        fbida - a few applications for viewing and editing images
20 Summary(pl):    fbida - kilka aplikacji do ogl±dania i edycji obrazków
21 Name:           fbida
22 Version:        2.06
23 Release:        1
24 License:        GPL
25 Group:          Applications/Graphics
26 Source0:        http://dl.bytesex.org/releases/fbida/%{name}-%{version}.tar.gz
27 # Source0-md5:  1f78e9a83fb546660a024a4bc0580ace
28 Patch0:         %{name}-config-noforce.patch
29 Patch1:         %{name}-desktop.patch
30 URL:            http://linux.bytesex.org/fbida/
31 %{?with_curl:BuildRequires:     curl-devel}
32 BuildRequires:  fontconfig-devel
33 BuildRequires:  freetype-devel >= 2.0.0
34 # -Wno-pointer-sign
35 BuildRequires:  gcc >= 5:4.0
36 %{?with_gif:BuildRequires:      giflib-devel}
37 BuildRequires:  libexif-devel >= 1:0.6.9
38 BuildRequires:  libjpeg-devel
39 %{?with_pcd:BuildRequires:      libpcd-devel >= 1:1.0.1}
40 %{?with_png:BuildRequires:      libpng-devel}
41 %{?with_lirc:BuildRequires:     lirc-devel}
42 %{?with_tiff:BuildRequires:     libtiff-devel}
43 # acc. to README lesstif is not sufficient
44 %{?with_motif:BuildRequires:    openmotif-devel >= 2.0}
45 BuildRequires:  pkgconfig
46 %{?with_sane:BuildRequires:     sane-backends-devel}
47 BuildRequires:  perl-base
48 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
49
50 %define         _appdefsdir     /usr/X11R6/lib/X11/app-defaults
51
52 %description
53 The fbida project contains a few applications for viewing and editing
54 images, with the main focus being photos. The applications are:
55 - fbi - image viewer for the Linux framebuffer console
56 - fbgs - wrapper script for viewing PS/PDF files using fbi
57 - ida - Motif-based application for viewing images
58 - exiftran - command-line tool to do lossless transformations of JPEG
59   images
60 - thumbnail.cgi - small and fast CGI program to extract EXIF
61   thumbnails from JPEG images and send them to the web browser
62
63 %description -l pl
64 Projekt fbida zawiera kilka aplikacji do ogl±dania i edycji obrazków,
65 g³ównie przeznaczonych dla zdjêæ. Te aplikacje to:
66 - fbi - przegl±darka dla linuksowej konsoli z framebufferem
67 - fbgs - skrypt do ogl±dania plików PS/PDF przy u¿yciu fbi
68 - ida - oparta na Motifie aplikacja do ogl±dania obrazków
69 - exiftran - dzia³aj±ce z linii poleceñ narzêdzie do wykonywania
70   bezstratnych przekszta³ceñ obrazków JPEG
71 - thumbnail.cgi - ma³y i szybki program CGI do wyci±gania miniaturek
72   EXIF z obrazków JPEG i wysy³ania ich do przegl±darki WWW
73
74 %package -n fbi
75 Summary:        Linux FrameBuffer Imageviewer
76 Summary(pl):    Przegl±darka obrazków dla linuksowego framebuffera
77 Group:          Applications/Graphics
78 Requires:       mktemp >= 1.3
79
80 %description -n fbi
81 This is a image viewer for linux framebuffer devices. It supports
82 PhotoCD, JPEG and PPM directly. GIF, TIFF and PNG are handled with the
83 netpbm tools, for anything else convert from the ImageMagick package
84 is used as external converter.
85
86 This package contains also additional utilities:
87 - fbgs - wrapper script for viewing PS/PDF files using fbi
88 - exiftran - command-line tool to do lossless transformations of JPEG
89   images
90
91 %description -n fbi -l pl
92 To jest przegl±darka obrazków korzystaj±ca z framebuffera. Obs³uguje
93 bezpo¶rednio PhotoCD, JPEG i PPM; GIF, TIFF i PNG poprzez narzêdzia z
94 pakietu netpbm-progs; inne obrazki poprzez program convert z pakietu
95 ImageMagick.
96
97 Ten pakiet zawiera tak¿e dodatkowe narzêdzia:
98 - fbgs - skrypt do ogl±dania plików PS/PDF przy u¿yciu fbi
99 - exiftran - dzia³aj±ce z linii poleceñ narzêdzie do wykonywania
100   bezstratnych przekszta³ceñ obrazków JPEG
101
102 %package -n ida
103 Summary:        Small and fast image viewer, Motif-based
104 Summary(pl):    Ma³a, szybka przegl±darka obrazków oparta na Motifie
105 Group:          X11/Applications/Graphics
106
107 %description -n ida
108 Ida is a small and fast image viewer, Motif-based. For people who
109 don't want the KDE/GNOME overhead. Some basic editing functions are
110 available too.
111
112 %description -n ida -l pl
113 Ida to ma³a i szybka przegl±darka obrazków oparta na Motifie.
114 Przeznaczona jest dla ludzi, którzy nie chc± narzutu KDE/GNOME.
115 Dostêpne jest te¿ trochê podstawowych funkcji edycyjnych.
116
117 %prep
118 %setup -q
119 %patch0 -p1
120 %patch1 -p1
121
122 %build
123 CFLAGS="%{rpmcflags}" \
124 %{__make} \
125         CC="%{__cc}" \
126         verbose=yes \
127         %{!?with_pcd:HAVE_LIBPCD=no} \
128         %{!?with_gif:HAVE_LIBUNGIF=no} \
129         %{!?with_png:HAVE_LIBPNG=no} \
130         %{!?with_tiff:HAVE_LIBTIFF=no} \
131         %{!?with_sane:HAVE_LIBSANE=no} \
132         %{!?with_curl:HAVE_LIBCURL=no} \
133         %{!?with_lirc:HAVE_LIBLIRC=no} \
134         %{!?with_motif:HAVE_MOTIF=no}
135
136 %install
137 rm -rf $RPM_BUILD_ROOT
138
139 %{__make} install \
140         DESTDIR=$RPM_BUILD_ROOT \
141         prefix=%{_prefix} \
142         INSTALL_BINARY=install \
143         %{!?with_pcd:HAVE_LIBPCD=no} \
144         %{!?with_gif:HAVE_LIBUNGIF=no} \
145         %{!?with_png:HAVE_LIBPNG=no} \
146         %{!?with_tiff:HAVE_LIBTIFF=no} \
147         %{!?with_sane:HAVE_LIBSANE=no} \
148         %{!?with_curl:HAVE_LIBCURL=no} \
149         %{!?with_lirc:HAVE_LIBLIRC=no} \
150         %{!?with_motif:HAVE_MOTIF=no}
151
152 %if %{with motif}
153 install -D desktop/ida.desktop $RPM_BUILD_ROOT%{_desktopdir}/ida.desktop
154 %endif
155
156 %clean
157 rm -rf $RPM_BUILD_ROOT
158
159 %files -n fbi
160 %defattr(644,root,root,755)
161 %attr(755,root,root) %{_bindir}/exiftran
162 %attr(755,root,root) %{_bindir}/fbgs
163 %attr(755,root,root) %{_bindir}/fbi
164 %{_mandir}/man1/exiftran.1*
165 %{_mandir}/man1/fbgs.1*
166 %{_mandir}/man1/fbi.1*
167
168 %if %{with motif}
169 %files -n ida
170 %defattr(644,root,root,755)
171 %doc README TODO
172 %attr(755,root,root) %{_bindir}/ida
173 %{_mandir}/man1/ida.1*
174 %{_appdefsdir}/Ida
175 %{_desktopdir}/ida.desktop
176 %endif
This page took 0.066887 seconds and 3 git commands to generate.