]> git.pld-linux.org Git - packages/fbida.git/blob - fbida.spec
- updated to 2.03
[packages/fbida.git] / fbida.spec
1 #
2 # TODO: package thumbnail.cgi (in %{_libdir}/cgi-bin?)
3 #
4 # Conditional build:
5 %bcond_without  curl    # without URL support
6 %bcond_without  exif    # without EXIF tags support
7 %bcond_without  gif     # without GIF images support
8 %bcond_without  lirc    # without LIRC control support
9 %bcond_without  motif   # don't build (Motif-based) ida
10 %bcond_without  pcd     # without PCD images support
11 %bcond_without  png     # without PNG images support
12 %bcond_without  sane    # without SANE scanning support (in ida)
13 %bcond_without  tiff    # without TIFF images support
14 #
15 %if %{without motif}
16 # SANE used only in ida
17 %undefine       with_sane
18 %endif
19 Summary:        fbida - a few applications for viewing and editing images
20 Summary(pl):    fbida - kilka aplikacji do ogl±dania i edycji obrazków
21 Name:           fbida
22 Version:        2.03
23 Release:        1
24 License:        GPL
25 Group:          Applications/Graphics
26 Source0:        http://dl.bytesex.org/releases/fbida/%{name}-%{version}.tar.gz
27 # Source0-md5:  8fd76661686a38a7bcd251b7aadc73eb
28 Patch0:         %{name}-fbgs.patch
29 Patch1:         %{name}-config-noforce.patch
30 Patch2:         %{name}-desktop.patch
31 URL:            http://linux.bytesex.org/fbida/
32 %{?with_curl:BuildRequires:     curl-devel}
33 BuildRequires:  fontconfig-devel
34 BuildRequires:  freetype-devel >= 2.0.0
35 BuildRequires:  libexif-devel >= 1:0.6.9
36 BuildRequires:  libjpeg-devel
37 %{?with_pcd:BuildRequires:      libpcd-devel >= 1:1.0.1}
38 %{?with_png:BuildRequires:      libpng-devel}
39 %{?with_lirc:BuildRequires:     lirc-devel}
40 %{?with_tiff:BuildRequires:     libtiff-devel}
41 %{?with_gif:BuildRequires:      libungif-devel}
42 # acc. to README lesstif is not sufficient
43 %{?with_motif:BuildRequires:    openmotif-devel >= 2.0}
44 BuildRequires:  pkgconfig
45 %{?with_sane:BuildRequires:     sane-backends-devel}
46 BuildRequires:  perl-base
47 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
48
49 %define         _appdefsdir     /usr/X11R6/lib/X11/app-defaults
50
51 %description
52 The fbida project contains a few applications for viewing and editing
53 images, with the main focus being photos. The applications are:
54 - fbi - image viewer for the Linux framebuffer console
55 - fbgs - wrapper script for viewing PS/PDF files using fbi
56 - ida - Motif-based application for viewing images
57 - exiftran - command-line tool to do lossless transformations of JPEG
58   images
59 - thumbnail.cgi - small and fast CGI program to extract EXIF
60   thumbnails from JPEG images and send them to the web browser
61
62 %description -l pl
63 Projekt fbida zawiera kilka aplikacji do ogl±dania i edycji obrazków,
64 g³ównie przeznaczonych dla zdjêæ. Te aplikacje to:
65 - fbi - przegl±darka dla linuksowej konsoli z framebufferem
66 - fbgs - skrypt do ogl±dania plików PS/PDF przy u¿yciu fbi
67 - ida - oparta na Motifie aplikacja do ogl±dania obrazków
68 - exiftran - dzia³aj±ce z linii poleceñ narzêdzie do wykonywania
69   bezstratnych przekszta³ceñ obrazków JPEG
70 - thumbnail.cgi - ma³y i szybki program CGI do wyci±gania miniaturek
71   EXIF z obrazków JPEG i wysy³ania ich do przegl±darki WWW
72
73 %package -n fbi
74 Summary:        Linux FrameBuffer Imageviewer
75 Summary(pl):    Przegl±darka obrazków dla linuksowego framebuffera
76 Group:          Applications/Graphics
77
78 %description -n fbi
79 This is a image viewer for linux framebuffer devices. It supports
80 PhotoCD, JPEG and PPM directly. GIF, TIFF and PNG are handled with the
81 netpbm tools, for anything else convert from the ImageMagick package
82 is used as external converter.
83
84 This package contains also additional utilities:
85 - fbgs - wrapper script for viewing PS/PDF files using fbi
86 - exiftran - command-line tool to do lossless transformations of JPEG
87   images
88
89 %description -n fbi -l pl
90 To jest przegl±darka obrazków korzystaj±ca z framebuffera. Obs³uguje
91 bezpo¶rednio PhotoCD, JPEG i PPM; GIF, TIFF i PNG poprzez narzêdzia z
92 pakietu netpbm-progs; inne obrazki poprzez program convert z pakietu
93 ImageMagick.
94
95 Ten pakiet zawiera tak¿e dodatkowe narzêdzia:
96 - fbgs - skrypt do ogl±dania plików PS/PDF przy u¿yciu fbi
97 - exiftran - dzia³aj±ce z linii poleceñ narzêdzie do wykonywania
98   bezstratnych przekszta³ceñ obrazków JPEG
99
100 %package -n ida
101 Summary:        Small and fast image viewer, Motif-based
102 Summary(pl):    Ma³a, szybka przegl±darka obrazków oparta na Motifie
103 Group:          X11/Applications/Graphics
104
105 %description -n ida
106 Ida is a small and fast image viewer, Motif-based. For people who
107 don't want the KDE/GNOME overhead. Some basic editing functions are
108 available too.
109
110 %description -n ida -l pl
111 Ida to ma³a i szybka przegl±darka obrazków oparta na Motifie.
112 Przeznaczona jest dla ludzi, którzy nie chc± narzutu KDE/GNOME.
113 Dostêpne jest te¿ trochê podstawowych funkcji edycyjnych.
114
115 %prep
116 %setup -q
117 %patch0 -p1
118 %patch1 -p1
119 %patch2 -p1
120
121 %build
122 CFLAGS="%{rpmcflags}" \
123 %{__make} \
124         CC="%{__cc}" \
125         verbose=yes \
126         %{!?with_pcd:HAVE_LIBPCD=no} \
127         %{!?with_gif:HAVE_LIBUNGIF=no} \
128         %{!?with_png:HAVE_LIBPNG=no} \
129         %{!?with_tiff:HAVE_LIBTIFF=no} \
130         %{!?with_sane:HAVE_LIBSANE=no} \
131         %{!?with_curl:HAVE_LIBCURL=no} \
132         %{!?with_lirc:HAVE_LIBLIRC=no} \
133         %{!?with_motif:HAVE_MOTIF=no}
134
135 %install
136 rm -rf $RPM_BUILD_ROOT
137
138 %{__make} install \
139         DESTDIR=$RPM_BUILD_ROOT \
140         prefix=%{_prefix} \
141         INSTALL_BINARY=install \
142         %{!?with_pcd:HAVE_LIBPCD=no} \
143         %{!?with_gif:HAVE_LIBUNGIF=no} \
144         %{!?with_png:HAVE_LIBPNG=no} \
145         %{!?with_tiff:HAVE_LIBTIFF=no} \
146         %{!?with_sane:HAVE_LIBSANE=no} \
147         %{!?with_curl:HAVE_LIBCURL=no} \
148         %{!?with_lirc:HAVE_LIBLIRC=no} \
149         %{!?with_motif:HAVE_MOTIF=no}
150
151 %if %{with motif}
152 install -D desktop/ida.desktop $RPM_BUILD_ROOT%{_desktopdir}/ida.desktop
153 %endif
154
155 %clean
156 rm -rf $RPM_BUILD_ROOT
157
158 %files -n fbi
159 %defattr(644,root,root,755)
160 %attr(755,root,root) %{_bindir}/exiftran
161 %attr(755,root,root) %{_bindir}/fbgs
162 %attr(755,root,root) %{_bindir}/fbi
163 %{_mandir}/man1/exiftran.1*
164 %{_mandir}/man1/fbgs.1*
165 %{_mandir}/man1/fbi.1*
166
167 %if %{with motif}
168 %files -n ida
169 %defattr(644,root,root,755)
170 %doc README TODO
171 %attr(755,root,root) %{_bindir}/ida
172 %{_mandir}/man1/ida.1*
173 %{_appdefsdir}/Ida
174 %{_desktopdir}/ida.desktop
175 %endif
This page took 0.069156 seconds and 3 git commands to generate.