]> git.pld-linux.org Git - packages/fbida.git/blob - fbida.spec
- release 4
[packages/fbida.git] / fbida.spec
1 # TODO:
2 # - package thumbnail.cgi (in %{_libdir}/cgi-bin?)
3 #
4 # Conditional build:
5 %bcond_without  curl    # without URL support
6 %bcond_without  exif    # without EXIF tags support
7 %bcond_without  gif     # without GIF images support
8 %bcond_without  lirc    # without LIRC control support
9 %bcond_without  motif   # don't build (Motif-based) ida
10 %bcond_without  pcd     # without PCD images support
11 %bcond_without  png     # without PNG images support
12 %bcond_without  sane    # without SANE scanning support (in ida)
13 %bcond_without  tiff    # without TIFF images support
14 %bcond_without  webp    # without WebP images support
15 #
16 %if !%{with motif}
17 # SANE used only in ida
18 %undefine       with_sane
19 %endif
20 Summary:        fbida - a few applications for viewing and editing images
21 Summary(pl.UTF-8):      fbida - kilka aplikacji do oglądania i edycji obrazków
22 Name:           fbida
23 Version:        2.08
24 Release:        4
25 License:        GPL
26 Group:          Applications/Graphics
27 Source0:        http://www.kraxel.org/releases/fbida/%{name}-%{version}.tar.gz
28 # Source0-md5:  9b3693ab26a58194e36b479bffb61ed0
29 Patch0:         %{name}-config-noforce.patch
30 Patch1:         %{name}-desktop.patch
31 URL:            http://www.kraxel.org/blog/linux/fbida/
32 BuildRequires:  ImageMagick-devel
33 %{?with_curl:BuildRequires:     curl-devel}
34 BuildRequires:  fontconfig-devel
35 BuildRequires:  freetype-devel >= 2.0.0
36 # -Wno-pointer-sign
37 BuildRequires:  gcc >= 5:4.0
38 %{?with_gif:BuildRequires:      giflib-devel}
39 BuildRequires:  libexif-devel >= 1:0.6.9
40 BuildRequires:  libjpeg-devel
41 %{?with_pcd:BuildRequires:      libpcd-devel >= 1:1.0.1}
42 %{?with_png:BuildRequires:      libpng-devel}
43 %{?with_tiff:BuildRequires:     libtiff-devel}
44 %{?with_webp:BuildRequires:     libwebp-devel}
45 %{?with_lirc:BuildRequires:     lirc-devel}
46 # acc. to README lesstif is not sufficient
47 %{?with_motif:BuildRequires:    openmotif-devel >= 2.0}
48 BuildRequires:  perl-base
49 BuildRequires:  pkgconfig
50 %{?with_sane:BuildRequires:     sane-backends-devel}
51 BuildRequires:  util-linux
52 BuildRequires:  which
53 BuildRequires:  xorg-lib-libXpm-devel
54 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
55
56 %define         _appdefsdir     /usr/share/X11/app-defaults
57
58 %description
59 The fbida project contains a few applications for viewing and editing
60 images, with the main focus being photos. The applications are:
61 - fbi - image viewer for the Linux framebuffer console
62 - fbgs - wrapper script for viewing PS/PDF files using fbi
63 - ida - Motif-based application for viewing images
64 - exiftran - command-line tool to do lossless transformations of JPEG
65   images
66 - thumbnail.cgi - small and fast CGI program to extract EXIF
67   thumbnails from JPEG images and send them to the web browser
68
69 %description -l pl.UTF-8
70 Projekt fbida zawiera kilka aplikacji do oglądania i edycji obrazków,
71 głównie przeznaczonych dla zdjęć. Te aplikacje to:
72 - fbi - przeglądarka dla linuksowej konsoli z framebufferem
73 - fbgs - skrypt do oglądania plików PS/PDF przy użyciu fbi
74 - ida - oparta na Motifie aplikacja do oglądania obrazków
75 - exiftran - działające z linii poleceń narzędzie do wykonywania
76   bezstratnych przekształceń obrazków JPEG
77 - thumbnail.cgi - mały i szybki program CGI do wyciągania miniaturek
78   EXIF z obrazków JPEG i wysyłania ich do przeglądarki WWW
79
80 %package -n fbi
81 Summary:        Linux FrameBuffer Imageviewer
82 Summary(pl.UTF-8):      Przeglądarka obrazków dla linuksowego framebuffera
83 Group:          Applications/Graphics
84 Requires:       mktemp >= 1.3
85
86 %description -n fbi
87 This is a image viewer for linux framebuffer devices. It supports
88 PhotoCD, JPEG and PPM directly. GIF, TIFF and PNG are handled with the
89 netpbm tools, for anything else convert from the ImageMagick package
90 is used as external converter.
91
92 This package contains also additional utilities:
93 - fbgs - wrapper script for viewing PS/PDF files using fbi
94 - exiftran - command-line tool to do lossless transformations of JPEG
95   images
96
97 %description -n fbi -l pl.UTF-8
98 To jest przeglądarka obrazków korzystająca z framebuffera. Obsługuje
99 bezpośrednio PhotoCD, JPEG i PPM; GIF, TIFF i PNG poprzez narzędzia z
100 pakietu netpbm-progs; inne obrazki poprzez program convert z pakietu
101 ImageMagick.
102
103 Ten pakiet zawiera także dodatkowe narzędzia:
104 - fbgs - skrypt do oglądania plików PS/PDF przy użyciu fbi
105 - exiftran - działające z linii poleceń narzędzie do wykonywania
106   bezstratnych przekształceń obrazków JPEG
107
108 %package -n ida
109 Summary:        Small and fast image viewer, Motif-based
110 Summary(pl.UTF-8):      Mała, szybka przeglądarka obrazków oparta na Motifie
111 Group:          X11/Applications/Graphics
112
113 %description -n ida
114 Ida is a small and fast image viewer, Motif-based. For people who
115 don't want the KDE/GNOME overhead. Some basic editing functions are
116 available too.
117
118 %description -n ida -l pl.UTF-8
119 Ida to mała i szybka przeglądarka obrazków oparta na Motifie.
120 Przeznaczona jest dla ludzi, którzy nie chcą narzutu KDE/GNOME.
121 Dostępne jest też trochę podstawowych funkcji edycyjnych.
122
123 %prep
124 %setup -q
125 %patch0 -p1
126 %patch1 -p1
127
128 %build
129 CFLAGS="%{rpmcflags}" \
130 %{__make} \
131         CC="%{__cc}" \
132         verbose=yes \
133         %{!?with_pcd:HAVE_LIBPCD=no} \
134         %{!?with_gif:HAVE_LIBUNGIF=no} \
135         %{!?with_png:HAVE_LIBPNG=no} \
136         %{!?with_tiff:HAVE_LIBTIFF=no} \
137         %{!?with_webp:HAVE_LIBWEBP=no} \
138         %{!?with_sane:HAVE_LIBSANE=no} \
139         %{!?with_curl:HAVE_LIBCURL=no} \
140         %{!?with_lirc:HAVE_LIBLIRC=no} \
141         %{!?with_motif:HAVE_MOTIF=no}
142
143 %install
144 rm -rf $RPM_BUILD_ROOT
145
146 %{__make} install \
147         DESTDIR=$RPM_BUILD_ROOT \
148         prefix=%{_prefix} \
149         INSTALL_BINARY=install \
150         %{!?with_pcd:HAVE_LIBPCD=no} \
151         %{!?with_gif:HAVE_LIBUNGIF=no} \
152         %{!?with_png:HAVE_LIBPNG=no} \
153         %{!?with_tiff:HAVE_LIBTIFF=no} \
154         %{!?with_webp:HAVE_LIBWEBP=no} \
155         %{!?with_sane:HAVE_LIBSANE=no} \
156         %{!?with_curl:HAVE_LIBCURL=no} \
157         %{!?with_lirc:HAVE_LIBLIRC=no} \
158         %{!?with_motif:HAVE_MOTIF=no}
159
160 %if %{with motif}
161 install -D desktop/ida.desktop $RPM_BUILD_ROOT%{_desktopdir}/ida.desktop
162 %endif
163
164 %clean
165 rm -rf $RPM_BUILD_ROOT
166
167 %files -n fbi
168 %defattr(644,root,root,755)
169 %attr(755,root,root) %{_bindir}/exiftran
170 %attr(755,root,root) %{_bindir}/fbgs
171 %attr(755,root,root) %{_bindir}/fbi
172 %{_mandir}/man1/exiftran.1*
173 %{_mandir}/man1/fbgs.1*
174 %{_mandir}/man1/fbi.1*
175
176 %if %{with motif}
177 %files -n ida
178 %defattr(644,root,root,755)
179 %doc README TODO
180 %attr(755,root,root) %{_bindir}/ida
181 %{_mandir}/man1/ida.1*
182 %{_appdefsdir}/Ida
183 %{_desktopdir}/ida.desktop
184 %endif
This page took 0.095403 seconds and 3 git commands to generate.