]> git.pld-linux.org Git - packages/farstream.git/blob - farstream.spec
Updated to 0.2.0. python-farstream is no longer provided
[packages/farstream.git] / farstream.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # do not build and package API docs
4 %bcond_without  static_libs     # don't build static libraries
5 #
6 Summary:        Audio/Video Communications Framework
7 Summary(pl.UTF-8):      Szkielet komunikacji Audio/Video
8 Name:           farstream
9 Version:        0.2.0
10 Release:        1
11 License:        LGPL v2+
12 Group:          Libraries
13 Source0:        http://freedesktop.org/software/farstream/releases/farstream/%{name}-%{version}.tar.gz
14 # Source0-md5:  efedec4a885170d350b5cc43c933f1c0
15 URL:            http://www.freedesktop.org/wiki/Software/Farstream
16 BuildRequires:  autoconf >= 2.60
17 BuildRequires:  automake
18 BuildRequires:  glib2-devel >= 1:2.32.0
19 BuildRequires:  gobject-introspection-devel >= 0.10.1
20 BuildRequires:  gstreamer-devel >= 1.0.0
21 BuildRequires:  gstreamer-plugins-base-devel >= 1.0.0
22 BuildRequires:  gtk-doc >= 1.8
23 BuildRequires:  gupnp-igd-devel >= 0.2
24 BuildRequires:  libnice-devel >= 0.1.3
25 BuildRequires:  libtool
26 BuildRequires:  pkgconfig
27 Requires:       glib2 >= 1:2.32.0
28 Requires:       gstreamer >= 1.0.0
29 Requires:       gstreamer-plugins-base >= 1.0.0
30 Requires:       libnice >= 0.1.3
31 Obsoletes:      farsight2 < 0.0.32
32 Obsoletes:      python-farsight2 < 0.0.32
33 Obsoletes:      python-farstream < 0.2.0
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %description
37 The Farstream (formerly Farsight) project is an effort to create a
38 framework to deal with all known audio/video conferencing protocols.
39 On one side it offers a generic API that makes it possible to write
40 plugins for different streaming protocols, on the other side it offers
41 an API for clients to use those plugins.
42
43 The main target clients for Farstream are Instant Messaging
44 applications. These applications should be able to use Farstream for
45 all their Audio/Video conferencing needs without having to worry about
46 any of the lower level streaming and NAT traversal issues.
47
48 %description -l pl.UTF-8
49 Projekt Farstream (dawniej Farsight) to próba stworzenia szkieletu
50 obsługującego wszystkie znane protokoły konferencji audio/video. Z
51 jednej strony oferuje ogólne API umożliwiające pisanie wtyczek dla
52 różnych protokołów strumieniowych, z drugiej strony oferuje API dla
53 klientów, pozwalającyce im używać tych wtyczek.
54
55 Głównymi klientami szkieletu Farstream mają być aplikacje
56 komunikatorów (IM). Powinny być w stanie używać Farstreama do potrzeb
57 konferencji audio/video bez konieczności obsługi niskopoziomowych
58 poziomów strumieni i omijania NAT-u.
59
60 %package devel
61 Summary:        Header files for Farstream library
62 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Farstream
63 Group:          Development/Libraries
64 Requires:       %{name} = %{version}-%{release}
65 Requires:       glib2-devel >= 1:2.32.0
66 Requires:       gstreamer-devel >= 1.0.0
67 Requires:       gstreamer-plugins-base-devel >= 1.0.0
68 Obsoletes:      farsight2-devel < 0.0.32
69
70 %description devel
71 Header files for Farstream library.
72
73 %description devel -l pl.UTF-8
74 Pliki nagłówkowe biblioteki Farstream.
75
76 %package static
77 Summary:        Static Farstream library
78 Summary(pl.UTF-8):      Statyczna biblioteka Farstream
79 Group:          Development/Libraries
80 Requires:       %{name}-devel = %{version}-%{release}
81 Obsoletes:      farsight2-static < 0.0.32
82
83 %description static
84 Static Farstream library.
85
86 %description static -l pl.UTF-8
87 Statyczna biblioteka Farstream.
88
89 %package apidocs
90 Summary:        Farstream API documentation
91 Summary(pl.UTF-8):      Dokumentacja API biblioteki Farstream
92 Group:          Documentation
93 Requires:       gtk-doc-common
94 Obsoletes:      farsight2-apidocs < 0.0.32
95
96 %description apidocs
97 API documentation for Farstream library.
98
99 %description apidocs -l pl.UTF-8
100 Dokumentacja API biblioteki Farstream.
101
102 %prep
103 %setup -q
104
105 %build
106 %{__libtoolize}
107 %{__aclocal} -I m4 -I common/m4
108 %{__autoconf}
109 %{__autoheader}
110 %{__automake}
111 %configure \
112         %{__enable_disable apidocs gtk-doc} \
113         %{__enable_disable static_libs static} \
114         --disable-silent-rules \
115         --with-html-dir=%{_gtkdocdir}
116 %{__make}
117
118 %install
119 rm -rf $RPM_BUILD_ROOT
120
121 %{__make} install \
122         DESTDIR=$RPM_BUILD_ROOT
123
124 %{__rm} $RPM_BUILD_ROOT%{_libdir}/{farstream-0.2,gstreamer-1.0}/*.{a,la}
125 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
126
127 %clean
128 rm -rf $RPM_BUILD_ROOT
129
130 %post   -p /sbin/ldconfig
131 %postun -p /sbin/ldconfig
132
133 %files
134 %defattr(644,root,root,755)
135 %doc AUTHORS ChangeLog NEWS README
136 %attr(755,root,root) %{_libdir}/libfarstream-0.2.so.*.*.*
137 %attr(755,root,root) %ghost %{_libdir}/libfarstream-0.2.so.2
138 %{_libdir}/girepository-1.0/Farstream-0.2.typelib
139 %dir %{_libdir}/farstream-0.2
140 %attr(755,root,root) %{_libdir}/farstream-0.2/libmulticast-transmitter.so
141 %attr(755,root,root) %{_libdir}/farstream-0.2/libnice-transmitter.so
142 %attr(755,root,root) %{_libdir}/farstream-0.2/librawudp-transmitter.so
143 %attr(755,root,root) %{_libdir}/farstream-0.2/libshm-transmitter.so
144 %attr(755,root,root) %{_libdir}/gstreamer-1.0/libfsmsnconference.so
145 %attr(755,root,root) %{_libdir}/gstreamer-1.0/libfsrawconference.so
146 %attr(755,root,root) %{_libdir}/gstreamer-1.0/libfsrtcpfilter.so
147 %attr(755,root,root) %{_libdir}/gstreamer-1.0/libfsrtpconference.so
148 %attr(755,root,root) %{_libdir}/gstreamer-1.0/libfsvideoanyrate.so
149 %{_datadir}/farstream
150
151 %files devel
152 %defattr(644,root,root,755)
153 %attr(755,root,root) %{_libdir}/libfarstream-0.2.so
154 %{_datadir}/gir-1.0/Farstream-0.2.gir
155 %{_includedir}/farstream-0.2
156 %{_pkgconfigdir}/farstream-0.2.pc
157
158 %if %{with static_libs}
159 %files static
160 %defattr(644,root,root,755)
161 %{_libdir}/libfarstream-0.2.a
162 %endif
163
164 %if %{with apidocs}
165 %files apidocs
166 %defattr(644,root,root,755)
167 %{_gtkdocdir}/farstream-libs-1.0
168 %{_gtkdocdir}/farstream-plugins-0.2
169 %endif
This page took 0.188678 seconds and 3 git commands to generate.