]> git.pld-linux.org Git - packages/fail2ban.git/blob - fail2ban.spec
- package ghost log file and added logrotate config
[packages/fail2ban.git] / fail2ban.spec
1 Summary:        Ban IPs that make too many password failures
2 Summary(pl.UTF-8):      Blokowanie IP powodujących zbyt dużo prób logowań z błędnym hasłem
3 Name:           fail2ban
4 Version:        0.8.11
5 Release:        2.4
6 License:        GPL
7 Group:          Daemons
8 Source0:        http://download.sourceforge.net/fail2ban/%{name}-%{version}.tar.gz
9 # Source0-md5:  2182a21c7efd885f373ffc941d11914d
10 Source1:        %{name}.init
11 Source2:        %{name}.logrotate
12 Patch0:         ipv6.patch
13 Patch1:         private-scriptdir.patch
14 URL:            http://fail2ban.sourceforge.net/
15 BuildRequires:  python-devel
16 BuildRequires:  python-modules
17 BuildRequires:  rpm-pythonprov
18 BuildRequires:  rpmbuild(macros) >= 1.671
19 Requires(post,preun):   /sbin/chkconfig
20 Requires(post,preun,postun):    systemd-units >= 38
21 Requires:       python-log4py
22 Requires:       rc-scripts
23 Requires:       systemd-units >= 38
24 BuildArch:      noarch
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 Fail2Ban scans log files like /var/log/secure and bans IP that makes
29 too many password failures. It updates firewall rules to reject the IP
30 address. These rules can be defined by the user. Fail2Ban can read
31 multiple log files including sshd or Apache web server logs.
32
33 %description -l pl.UTF-8
34 Fail2Ban skanuje pliki logów takie jak /var/log/secure i blokuje IP
35 powodujące zbyt dużo prób logowań z błędnym hasłem. Uaktualnia regułki
36 firewalla, aby odrzucić adres IP. Regułki te mogą być definiowane
37 przez użytkownika. Fail2Ban potrafi czytać wiele plików logów włącznie
38 z sshd czy plikami logów serwera WWW Apache.
39
40 %prep
41 %setup -q
42 %patch0 -p1
43 %patch1 -p1
44 rm setup.cfg
45
46 # we don't want very generic named dirs directly in py_sitescriptdir
47 sed -i -e 's|@@SCRIPTDIR@@|"%{py_sitescriptdir}/%{name}"|' fail2ban-{client,regex,server}
48
49 %build
50 %{__python} setup.py build
51
52 %install
53 rm -rf $RPM_BUILD_ROOT
54 install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,logrotate.d} \
55         $RPM_BUILD_ROOT{%{_mandir}/man1,/var/log} \
56         $RPM_BUILD_ROOT{%{systemdunitdir},%{systemdtmpfilesdir}}
57
58 %{__python} setup.py install \
59         --optimize=2 \
60         --install-lib=%{py_sitescriptdir}/%{name} \
61         --root=$RPM_BUILD_ROOT
62
63 install -p man/*.1 $RPM_BUILD_ROOT%{_mandir}/man1
64
65 install -p %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/fail2ban
66 install -p %{SOURCE2} $RPM_BUILD_ROOT/etc/logrotate.d/fail2ban
67
68 install -p files/fail2ban-tmpfiles.conf $RPM_BUILD_ROOT%{systemdtmpfilesdir}/fail2ban.conf
69 install -p files/fail2ban.service $RPM_BUILD_ROOT%{systemdunitdir}/fail2ban.service
70
71 :> $RPM_BUILD_ROOT/var/log/fail2ban.log
72
73 %py_postclean
74
75 %clean
76 rm -rf $RPM_BUILD_ROOT
77
78 %post
79 /sbin/chkconfig --add %{name}
80 %service %{name} restart
81 %systemd_post fail2ban.service
82
83 %preun
84 if [ "$1" = "0" ]; then
85         %service -q %{name} stop
86         /sbin/chkconfig --del %{name}
87 fi
88 %systemd_preun fail2ban.service
89
90 %postun
91 %systemd_reload
92
93 %triggerpostun -- fail2ban < 0.8.11-3
94 %systemd_trigger fail2ban.service
95
96 %files
97 %defattr(644,root,root,755)
98 %doc ChangeLog README.md TODO COPYING
99 %attr(754,root,root) /etc/rc.d/init.d/fail2ban
100 %attr(755,root,root) %{_bindir}/fail2ban-client
101 %attr(755,root,root) %{_bindir}/fail2ban-iptables
102 %attr(755,root,root) %{_bindir}/fail2ban-regex
103 %attr(755,root,root) %{_bindir}/fail2ban-server
104 %{systemdunitdir}/fail2ban.service
105 %{systemdtmpfilesdir}/fail2ban.conf
106 %dir /var/run/fail2ban
107 %dir %{_sysconfdir}/fail2ban
108 %dir %{_sysconfdir}/fail2ban/action.d
109 %dir %{_sysconfdir}/fail2ban/fail2ban.d
110 %dir %{_sysconfdir}/fail2ban/filter.d
111 %dir %{_sysconfdir}/fail2ban/jail.d
112 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/fail2ban/*.conf
113 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/fail2ban/*/*.conf
114 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/fail2ban
115 %{py_sitescriptdir}/%{name}
116 %{_mandir}/man1/fail2ban-client.1*
117 %{_mandir}/man1/fail2ban-regex.1*
118 %{_mandir}/man1/fail2ban-server.1*
119 %{_mandir}/man1/fail2ban.1*
120 %attr(640,root,logs) %ghost /var/log/fail2ban.log
This page took 0.097576 seconds and 3 git commands to generate.