]> git.pld-linux.org Git - packages/exiv2.git/blob - exiv2.spec
fix build on platforms without control flow protection
[packages/exiv2.git] / exiv2.spec
1 #
2 # Conditional build:
3 %bcond_with     curl            # enable webready with HTTP support via curl
4 %bcond_with     libssh          # enable webready with SSH support via libssh
5
6 Summary:        EXIF and IPTC metadata manipulation tools
7 Summary(pl.UTF-8):      Narzędzia do obróbki metadanych EXIF i IPTC
8 Name:           exiv2
9 Version:        0.27.3
10 Release:        1
11 License:        GPL v2+
12 Group:          Applications/Graphics
13 #Source0Download: https://www.exiv2.org/download.html
14 Source0:        https://www.exiv2.org/builds/%{name}-%{version}-Source.tar.gz
15 # Source0-md5:  68a59595e8617284b2e1eee528ae1f77
16 Patch0:         cmake.patch
17 Patch1:         %{name}-no-xmpsdk-install.patch
18 Patch2:         compiler_flags.patch
19 URL:            https://www.exiv2.org/
20 BuildRequires:  cmake >= 3.3.2
21 %{?with_curl:BuildRequires:     curl-devel}
22 BuildRequires:  expat-devel
23 BuildRequires:  gettext-tools
24 %{?with_libssh:BuildRequires:   libssh-devel}
25 BuildRequires:  libstdc++-devel
26 BuildRequires:  zlib-devel
27 Requires:       %{name}-libs = %{version}-%{release}
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 EXIF and IPTC metadata manipulation tools.
32
33 %description -l pl.UTF-8
34 Narzędzia do obróbki metadanych EXIF i IPTC.
35
36 %package libs
37 Summary:        EXIF and IPTC metadata manipulation library
38 Summary(pl.UTF-8):      Biblioteka do obróbki metadanych EXIF i IPTC
39 Group:          Libraries
40
41 %description libs
42 EXIF and IPTC metadata manipulation library.
43
44 %description libs -l pl.UTF-8
45 Biblioteka do obróbki metadanych EXIF i IPTC.
46
47 %package devel
48 Summary:        EXIF and IPTC metadata manipulation library development files
49 Summary(pl.UTF-8):      Pliki programistyczne biblioteki do obróbki metadanych EXIF i IPTC
50 Group:          Development/Libraries
51 Requires:       %{name}-libs = %{version}-%{release}
52 %{?with_curl:Requires:  curl-devel}
53 Requires:       expat-devel
54 %{?with_libssh:Requires:        libssh-devel}
55 Requires:       libstdc++-devel
56 Requires:       zlib-devel
57 Obsoletes:      exiv2-static
58
59 %description devel
60 EXIF and IPTC metadata manipulation library development files.
61
62 %description devel -l pl.UTF-8
63 Pliki programistyczne biblioteki do obróbki metadanych EXIF i IPTC.
64
65 %prep
66 %setup -q -n %{name}-%{version}-Source
67 %patch0 -p1
68 %patch1 -p1
69 %patch2 -p1
70
71 %build
72 install -d build
73 cd build
74 %cmake .. \
75         -DEXIV2_BUILD_SAMPLES=OFF \
76         %{?with_curl:-DEXIV2_ENABLE_CURL=ON} \
77         -DEXIV2_ENABLE_NLS=ON \
78         %{?with_libssh:-DEXIV2_ENABLE_SSH=ON} \
79         -DEXIV2_ENABLE_VIDEO=ON \
80 %if %{with curl} || %{with libssh}
81         -DEXIV2_ENABLE_WEBREADY=ON
82 %endif
83
84 %{__make}
85
86 %install
87 rm -rf $RPM_BUILD_ROOT
88
89 %{__make} -C build install \
90         DESTDIR=$RPM_BUILD_ROOT
91
92 %find_lang %{name}
93
94 %clean
95 rm -rf $RPM_BUILD_ROOT
96
97 %post   libs -p /sbin/ldconfig
98 %postun libs -p /sbin/ldconfig
99
100 %files -f %{name}.lang
101 %defattr(644,root,root,755)
102 %doc README.md doc/ChangeLog doc/cmd.txt
103 %attr(755,root,root) %{_bindir}/exiv2
104 %{_mandir}/man1/exiv2.1*
105
106 %files libs
107 %defattr(644,root,root,755)
108 %attr(755,root,root) %{_libdir}/libexiv2.so.*.*.*
109 %attr(755,root,root) %ghost %{_libdir}/libexiv2.so.27
110
111 %files devel
112 %defattr(644,root,root,755)
113 %attr(755,root,root) %{_libdir}/libexiv2.so
114 %{_includedir}/exiv2
115 %{_pkgconfigdir}/exiv2.pc
116 %{_libdir}/cmake/exiv2
This page took 0.172263 seconds and 4 git commands to generate.