]> git.pld-linux.org Git - packages/exempi.git/blob - exempi.spec
- updated to 2.6.5
[packages/exempi.git] / exempi.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # unit tests
4
5 Summary:        An XMP metadata support library
6 Summary(pl.UTF-8):      Biblioteka obsługująca metadane XMP
7 Name:           exempi
8 Version:        2.6.5
9 Release:        1
10 License:        BSD
11 Group:          Libraries
12 #Source0Download: https://libopenraw.freedesktop.org/exempi/
13 Source0:        https://libopenraw.freedesktop.org/download/%{name}-%{version}.tar.xz
14 # Source0-md5:  51fe14c2a5fa44816ba8187c6ad87d78
15 URL:            https://libopenraw.freedesktop.org/exempi/
16 BuildRequires:  automake >= 1:1.11
17 %{?with_tests:BuildRequires:    boost-devel >= 1.60.0}
18 BuildRequires:  expat-devel >= 1.95
19 BuildRequires:  libstdc++-devel >= 6:4.4
20 BuildRequires:  tar >= 1:1.22
21 BuildRequires:  xz
22 BuildRequires:  zlib-devel
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 XMP metadata parsing and IO library.
27
28 %description -l pl.UTF-8
29 Biblioteka do analizy oraz wejścia/wyjścia metadanych XMP.
30
31 %package devel
32 Summary:        Header files for exempi
33 Summary(pl.UTF-8):      Pliki nagłówkowe exempi
34 Group:          Development/Libraries
35 Requires:       %{name} = %{version}-%{release}
36 Requires:       expat-devel >= 1.95
37 Requires:       libstdc++-devel >= 6:4.4
38 Requires:       zlib-devel
39
40 %description devel
41 Header files for exempi.
42
43 %description devel -l pl.UTF-8
44 Pliki nagłówkowe exempi.
45
46 %package static
47 Summary:        Static exempi library
48 Summary(pl.UTF-8):      Statyczna biblioteka exempi
49 Group:          Development/Libraries
50 Requires:       %{name}-devel = %{version}-%{release}
51
52 %description static
53 Static exempi library.
54
55 %description static -l pl.UTF-8
56 Statyczna biblioteka exempi.
57
58 %package samples
59 Summary:        Sample exempi programs
60 Summary(pl.UTF-8):      Przykładowe programy exempi
61 Group:          Applications/Archiving
62 # doesn't require base, statically linked with exempi code
63
64 %description samples
65 Sample programs using exempi library.
66
67 %description samples -l pl.UTF-8
68 Przykładowe programy używające biblioteki exempi.
69
70 %prep
71 %setup -q
72
73 %build
74 cp -f /usr/share/automake/config.sub .
75 # configure fails on boost linking check
76 %configure \
77         --disable-silent-rules \
78         %{!?with_tests:--disable-unittest}
79 %{__make}
80
81 %if %{with tests}
82 %{__make} check
83 %endif
84
85 %install
86 rm -rf $RPM_BUILD_ROOT
87 install -d $RPM_BUILD_ROOT%{_bindir}
88
89 %{__make} install \
90         DESTDIR=$RPM_BUILD_ROOT
91
92 # obsoleted by pkg-config
93 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libexempi.la
94
95 install samples/source/{dumpmainxmp,dumpxmp,xmpcoverage,xmpfilescoverage} $RPM_BUILD_ROOT%{_bindir}
96
97 %clean
98 rm -rf $RPM_BUILD_ROOT
99
100 %post   -p /sbin/ldconfig
101 %postun -p /sbin/ldconfig
102
103 %files
104 %defattr(644,root,root,755)
105 %doc AUTHORS COPYING ChangeLog NEWS README.md TODO
106 %attr(755,root,root) %{_bindir}/exempi
107 %attr(755,root,root) %{_libdir}/libexempi.so.*.*.*
108 %attr(755,root,root) %ghost %{_libdir}/libexempi.so.8
109 %{_mandir}/man1/exempi.1*
110
111 %files devel
112 %defattr(644,root,root,755)
113 %attr(755,root,root) %{_libdir}/libexempi.so
114 %{_includedir}/exempi-2.0
115 %{_pkgconfigdir}/exempi-2.0.pc
116
117 %files static
118 %defattr(644,root,root,755)
119 %{_libdir}/libexempi.a
120
121 %files samples
122 %defattr(644,root,root,755)
123 %attr(755,root,root) %{_bindir}/dumpmainxmp
124 %attr(755,root,root) %{_bindir}/dumpxmp
125 %attr(755,root,root) %{_bindir}/xmpcoverage
126 %attr(755,root,root) %{_bindir}/xmpfilescoverage
This page took 0.06622 seconds and 4 git commands to generate.