]> git.pld-linux.org Git - packages/exact-image.git/commitdiff
- added pl, some bconds and verbose build
authorJakub Bogusz <qboosh@pld-linux.org>
Sun, 19 Oct 2014 19:35:39 +0000 (21:35 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Sun, 19 Oct 2014 19:35:39 +0000 (21:35 +0200)
exact-image.spec

index a7bce5a1d9ff91364aedce7a1c89620231880399..7a849e8f2dcb36035bdce7531a8556d4ab2012de 100644 (file)
@@ -1,4 +1,19 @@
+#
+# Conditional build:
+%bcond_without evas    # Edisplay support
+%bcond_with    gif     # GIF support
+%bcond_without lua     # Lua API
+%bcond_without perl    # Perl API
+%bcond_with    php     # PHP API
+%bcond_without python  # Python API
+
+%ifarch %{x8664}
+%undefine      with_lua
+%undefine      with_perl
+%undefine      with_python
+%endif
 Summary:       A fast, modern and generic image processing library
 Summary:       A fast, modern and generic image processing library
+Summary(pl.UTF-8):     Szybka, nowoczesna i ogólna biblioteka do przetwarzania obrazu
 Name:          exact-image
 Version:       0.8.9
 Release:       2
 Name:          exact-image
 Version:       0.8.9
 Release:       2
@@ -11,27 +26,37 @@ Patch1:             exactimage_0.8.5-1.patch
 URL:           http://www.exactcode.de/site/open_source/exactimage/
 BuildRequires: OpenEXR-devel >= 1.2.0
 BuildRequires: agg-devel >= 2.3
 URL:           http://www.exactcode.de/site/open_source/exactimage/
 BuildRequires: OpenEXR-devel >= 1.2.0
 BuildRequires: agg-devel >= 2.3
-BuildRequires: evas-devel >= 0.9.9
-#BuildRequires:        giflib4-devel
+%{?with_evas:BuildRequires:    evas-devel >= 0.9.9}
+BuildRequires: expat-devel
+# pkgconfig(freetype) >= 9.5.0
+BuildRequires: freetype-devel >= 2.1.6
+%{?with_gif:BuildRequires:     giflib4-devel}
 BuildRequires: jasper-devel
 BuildRequires: lcms-devel >= 1.10
 BuildRequires: jasper-devel
 BuildRequires: lcms-devel >= 1.10
-BuildRequires: libpng-devel >= 1.5
+BuildRequires: libjpeg-devel
+BuildRequires: libpng-devel >= 2:1.5
 BuildRequires: libstdc++-devel
 BuildRequires: libstdc++-devel
-BuildRequires: libtiff-cxx-devel
-BuildRequires: lua51-devel
-BuildRequires: perl-devel >= 5.8.0
-BuildRequires: php-devel >= 5.2.0
-BuildRequires: python-devel >= 2.5.0
-BuildRequires: ruby >= 1.8.5
-BuildRequires: swig-perl >= 1.3.32
-BuildRequires: swig-php >= 1.3.32
-BuildRequires: swig-python >= 1.3.32
+BuildRequires: libtiff-devel
+%{?with_lua:BuildRequires:     lua51-devel >= 5.1}
+BuildRequires: perl-devel >= 1:5.8.0
+%{?with_php:BuildRequires:     php-devel >= 5.2.0}
+%{?with_python:BuildRequires:  python-devel >= 1:2.5.0}
+BuildRequires: ruby-devel >= 1.8.5
+%{?with_perl:BuildRequires:    swig-perl >= 1.3.32}
+%{?with_php:BuildRequires:     swig-php >= 1.3.32}
+%{?with_python:BuildRequires:  swig-python >= 1.3.32}
 BuildRequires: xorg-lib-libX11-devel >= 1.3
 BuildRequires: xorg-lib-libX11-devel >= 1.3
+BuildRequires: zlib-devel
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
-A fast, modern and generic (template) based C++ image processing library,
-alternative to ImageMagick.
+A fast, modern and generic (template based) C++ image processing
+library, alternative to ImageMagick.
+
+%description -l pl.UTF-8
+Szybka, nowoczesna i ogólna (oparta na szablonach) biblioteka C++
+do przetwarzania obrazu, będąca alternatywą dla biblioteki
+ImageMagick.
 
 %prep
 %setup -q
 
 %prep
 %setup -q
@@ -39,20 +64,26 @@ alternative to ImageMagick.
 %patch1 -p1
 
 %build
 %patch1 -p1
 
 %build
-./configure --prefix=%{_prefix} --without-libungif --without-php \
-%ifarch %{x8664}
-       --without-lua --without-perl --without-python
-%endif
+./configure \
+       --prefix=%{_prefix} \
+       %{!?with_evas:--without-evas} \
+       %{!?with_gif:--without-libungif} \
+       %{!?with_lua:--without-lua} \
+       %{!?with_perl:--without-perl} \
+       %{!?with_php:--without-php} \
+       %{!?with_python:--without-python}
 
 %{__make} \
        CFLAGS="%{rpmcflags}" \
 
 %{__make} \
        CFLAGS="%{rpmcflags}" \
-       CXXFLAGS="%{rpmcflags}"
+       CXXFLAGS="%{rpmcflags}" \
+       Q=
 
 %install
 rm -rf $RPM_BUILD_ROOT
 
 %{__make} install \
 
 %install
 rm -rf $RPM_BUILD_ROOT
 
 %{__make} install \
-       DESTDIR=$RPM_BUILD_ROOT
+       DESTDIR=$RPM_BUILD_ROOT \
+       Q=
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -64,7 +95,7 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/e2mtiff
 %attr(755,root,root) %{_bindir}/econvert
 %attr(755,root,root) %{_bindir}/edentify
 %attr(755,root,root) %{_bindir}/e2mtiff
 %attr(755,root,root) %{_bindir}/econvert
 %attr(755,root,root) %{_bindir}/edentify
-%attr(755,root,root) %{_bindir}/edisplay
+%{?with_evas:%attr(755,root,root) %{_bindir}/edisplay}
 %attr(755,root,root) %{_bindir}/empty-page
 %attr(755,root,root) %{_bindir}/hocr2pdf
 %attr(755,root,root) %{_bindir}/optimize2bw
 %attr(755,root,root) %{_bindir}/empty-page
 %attr(755,root,root) %{_bindir}/hocr2pdf
 %attr(755,root,root) %{_bindir}/optimize2bw
This page took 0.042649 seconds and 4 git commands to generate.