]> git.pld-linux.org Git - packages/exact-image.git/blob - exact-image.spec
- added pl, some bconds and verbose build
[packages/exact-image.git] / exact-image.spec
1 #
2 # Conditional build:
3 %bcond_without  evas    # Edisplay support
4 %bcond_with     gif     # GIF support
5 %bcond_without  lua     # Lua API
6 %bcond_without  perl    # Perl API
7 %bcond_with     php     # PHP API
8 %bcond_without  python  # Python API
9
10 %ifarch %{x8664}
11 %undefine       with_lua
12 %undefine       with_perl
13 %undefine       with_python
14 %endif
15 Summary:        A fast, modern and generic image processing library
16 Summary(pl.UTF-8):      Szybka, nowoczesna i ogólna biblioteka do przetwarzania obrazu
17 Name:           exact-image
18 Version:        0.8.9
19 Release:        2
20 License:        GPL v2
21 Group:          Applications/Graphics
22 Source0:        http://dl.exactcode.de/oss/exact-image/%{name}-%{version}.tar.bz2
23 # Source0-md5:  a8694722cd7cc9aa9407950a8440f0cd
24 Patch0:         %{name}-libs.patch
25 Patch1:         exactimage_0.8.5-1.patch
26 URL:            http://www.exactcode.de/site/open_source/exactimage/
27 BuildRequires:  OpenEXR-devel >= 1.2.0
28 BuildRequires:  agg-devel >= 2.3
29 %{?with_evas:BuildRequires:     evas-devel >= 0.9.9}
30 BuildRequires:  expat-devel
31 # pkgconfig(freetype) >= 9.5.0
32 BuildRequires:  freetype-devel >= 2.1.6
33 %{?with_gif:BuildRequires:      giflib4-devel}
34 BuildRequires:  jasper-devel
35 BuildRequires:  lcms-devel >= 1.10
36 BuildRequires:  libjpeg-devel
37 BuildRequires:  libpng-devel >= 2:1.5
38 BuildRequires:  libstdc++-devel
39 BuildRequires:  libtiff-devel
40 %{?with_lua:BuildRequires:      lua51-devel >= 5.1}
41 BuildRequires:  perl-devel >= 1:5.8.0
42 %{?with_php:BuildRequires:      php-devel >= 5.2.0}
43 %{?with_python:BuildRequires:   python-devel >= 1:2.5.0}
44 BuildRequires:  ruby-devel >= 1.8.5
45 %{?with_perl:BuildRequires:     swig-perl >= 1.3.32}
46 %{?with_php:BuildRequires:      swig-php >= 1.3.32}
47 %{?with_python:BuildRequires:   swig-python >= 1.3.32}
48 BuildRequires:  xorg-lib-libX11-devel >= 1.3
49 BuildRequires:  zlib-devel
50 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
51
52 %description
53 A fast, modern and generic (template based) C++ image processing
54 library, alternative to ImageMagick.
55
56 %description -l pl.UTF-8
57 Szybka, nowoczesna i ogólna (oparta na szablonach) biblioteka C++
58 do przetwarzania obrazu, będąca alternatywą dla biblioteki
59 ImageMagick.
60
61 %prep
62 %setup -q
63 %patch0 -p1
64 %patch1 -p1
65
66 %build
67 ./configure \
68         --prefix=%{_prefix} \
69         %{!?with_evas:--without-evas} \
70         %{!?with_gif:--without-libungif} \
71         %{!?with_lua:--without-lua} \
72         %{!?with_perl:--without-perl} \
73         %{!?with_php:--without-php} \
74         %{!?with_python:--without-python}
75
76 %{__make} \
77         CFLAGS="%{rpmcflags}" \
78         CXXFLAGS="%{rpmcflags}" \
79         Q=
80
81 %install
82 rm -rf $RPM_BUILD_ROOT
83
84 %{__make} install \
85         DESTDIR=$RPM_BUILD_ROOT \
86         Q=
87
88 %clean
89 rm -rf $RPM_BUILD_ROOT
90
91 %files
92 %defattr(644,root,root,755)
93 %doc README TODO
94 %attr(755,root,root) %{_bindir}/bardecode
95 %attr(755,root,root) %{_bindir}/e2mtiff
96 %attr(755,root,root) %{_bindir}/econvert
97 %attr(755,root,root) %{_bindir}/edentify
98 %{?with_evas:%attr(755,root,root) %{_bindir}/edisplay}
99 %attr(755,root,root) %{_bindir}/empty-page
100 %attr(755,root,root) %{_bindir}/hocr2pdf
101 %attr(755,root,root) %{_bindir}/optimize2bw
This page took 0.0735 seconds and 3 git commands to generate.