]> git.pld-linux.org Git - packages/exact-image.git/blob - exact-image.spec
- added giflib patch (giflib 5+ support, covers both 5.0 and 5.1+)
[packages/exact-image.git] / exact-image.spec
1 #
2 # Conditional build:
3 %bcond_without  evas    # Edisplay support
4 %bcond_without  gif     # GIF support
5 %bcond_without  lua     # Lua API
6 %bcond_without  perl    # Perl API
7 %bcond_with     php     # PHP API
8 %bcond_without  python  # Python API
9
10 %ifarch %{x8664}
11 %undefine       with_lua
12 %undefine       with_perl
13 %undefine       with_python
14 %endif
15 Summary:        A fast, modern and generic image processing library
16 Summary(pl.UTF-8):      Szybka, nowoczesna i ogólna biblioteka do przetwarzania obrazu
17 Name:           exact-image
18 Version:        0.8.9
19 Release:        2
20 License:        GPL v2
21 Group:          Applications/Graphics
22 Source0:        http://dl.exactcode.de/oss/exact-image/%{name}-%{version}.tar.bz2
23 # Source0-md5:  a8694722cd7cc9aa9407950a8440f0cd
24 Patch0:         %{name}-libs.patch
25 Patch1:         exactimage_0.8.5-1.patch
26 Patch2:         %{name}-giflib.patch
27 URL:            http://www.exactcode.de/site/open_source/exactimage/
28 BuildRequires:  OpenEXR-devel >= 1.2.0
29 BuildRequires:  agg-devel >= 2.3
30 %{?with_evas:BuildRequires:     evas-devel >= 0.9.9}
31 BuildRequires:  expat-devel
32 # pkgconfig(freetype) >= 9.5.0
33 BuildRequires:  freetype-devel >= 2.1.6
34 %{?with_gif:BuildRequires:      giflib-devel >= 5}
35 BuildRequires:  jasper-devel
36 BuildRequires:  lcms-devel >= 1.10
37 BuildRequires:  libjpeg-devel
38 BuildRequires:  libpng-devel >= 2:1.5
39 BuildRequires:  libstdc++-devel
40 BuildRequires:  libtiff-devel
41 %{?with_lua:BuildRequires:      lua51-devel >= 5.1}
42 BuildRequires:  perl-devel >= 1:5.8.0
43 %{?with_php:BuildRequires:      php-devel >= 5.2.0}
44 %{?with_python:BuildRequires:   python-devel >= 1:2.5.0}
45 BuildRequires:  ruby-devel >= 1.8.5
46 %{?with_perl:BuildRequires:     swig-perl >= 1.3.32}
47 %{?with_php:BuildRequires:      swig-php >= 1.3.32}
48 %{?with_python:BuildRequires:   swig-python >= 1.3.32}
49 BuildRequires:  xorg-lib-libX11-devel >= 1.3
50 BuildRequires:  zlib-devel
51 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
52
53 %description
54 A fast, modern and generic (template based) C++ image processing
55 library, alternative to ImageMagick.
56
57 %description -l pl.UTF-8
58 Szybka, nowoczesna i ogólna (oparta na szablonach) biblioteka C++
59 do przetwarzania obrazu, będąca alternatywą dla biblioteki
60 ImageMagick.
61
62 %prep
63 %setup -q
64 %patch0 -p1
65 %patch1 -p1
66 %patch2 -p1
67
68 %build
69 ./configure \
70         --prefix=%{_prefix} \
71         %{!?with_evas:--without-evas} \
72         %{!?with_gif:--without-libungif} \
73         %{!?with_lua:--without-lua} \
74         %{!?with_perl:--without-perl} \
75         %{!?with_php:--without-php} \
76         %{!?with_python:--without-python}
77
78 %{__make} \
79         CFLAGS="%{rpmcflags}" \
80         CXXFLAGS="%{rpmcflags}" \
81         Q=
82
83 %install
84 rm -rf $RPM_BUILD_ROOT
85
86 %{__make} install \
87         DESTDIR=$RPM_BUILD_ROOT \
88         Q=
89
90 %clean
91 rm -rf $RPM_BUILD_ROOT
92
93 %files
94 %defattr(644,root,root,755)
95 %doc README TODO
96 %attr(755,root,root) %{_bindir}/bardecode
97 %attr(755,root,root) %{_bindir}/e2mtiff
98 %attr(755,root,root) %{_bindir}/econvert
99 %attr(755,root,root) %{_bindir}/edentify
100 %{?with_evas:%attr(755,root,root) %{_bindir}/edisplay}
101 %attr(755,root,root) %{_bindir}/empty-page
102 %attr(755,root,root) %{_bindir}/hocr2pdf
103 %attr(755,root,root) %{_bindir}/optimize2bw
This page took 0.123782 seconds and 3 git commands to generate.