]> git.pld-linux.org Git - packages/eventum.git/blob - eventum.spec
- fix scm commits causing garbage in certain commit messages
[packages/eventum.git] / eventum.spec
1 # TODO
2 # - discard bundled packages (from INSTALL):
3 #  - JpGraph 1.5.3 (last GPL version)
4 #  - dTree 2.0.5 (http://www.destroydrop.com/javascript/tree/)
5 #  - dynCalendar.js (http://www.phpguru.org/dyncalendar.html)
6 #  - overLIB 3.5.1 (http://www.bosrup.com/web/overlib/)
7 #  - A few other small javascript libraries
8 # - 64bit platforms beware? http://bugs.php.net/bug.php?id=30215 (it's actually Smarty related problem)
9 #
10 # Conditional build:
11 %bcond_without  pear    # build with system PEAR packages (or use bundled ones)
12 %bcond_with     qmail   # build the router-qmail subpackage
13 #
14 # snapshot: DATE
15 %define _snap 20060318
16
17 %define _rel    0.2
18
19 %{?with_pear:%include   /usr/lib/rpm/macros.php}
20 Summary:        Eventum Issue / Bug tracking system
21 Summary(pl):    Eventum - system ¶ledzenia spraw/b³êdów
22 Name:           eventum
23 Version:        1.7.0
24 Release:        %{?_snap:4.%{_snap}.}%{?_rc:%{_rc}.}%{_rel}
25 License:        GPL
26 Group:          Applications/WWW
27 #Source0:       http://mysql.dataphone.se/Downloads/%{name}/%{name}-%{version}.tar.gz
28 Source0:        http://downloads.mysql.com/snapshots/eventum/%{name}-nightly-%{_snap}.tar.gz
29 # Source0-md5:  a9d1c01ee5ad396729e75262bdae558c
30 Source1:        %{name}-apache.conf
31 Source2:        %{name}-mail-queue.cron
32 Source3:        %{name}-mail-download.cron
33 Source4:        %{name}-reminder.cron
34 Source5:        %{name}-monitor.cron
35 Source6:        %{name}-cvs.php
36 Source7:        %{name}-irc.php
37 Source8:        %{name}-irc.init
38 Source9:        %{name}-irc.sysconfig
39 Source10:       %{name}-config.php
40 Source11:       %{name}-router-qmail.sh
41 Source12:       %{name}-config-setup.php
42 Source13:       %{name}-upgrade.sh
43 Source14:       %{name}-router-postfix.sh
44 Patch0:         %{name}-paths.patch
45 Patch1:         %{name}-cvs-config.patch
46 Patch2:         %{name}-irc-config.patch
47 Patch3:         %{name}-PEAR.patch
48 Patch4:         http://glen.alkohol.ee/pld/%{name}-reply-subject.patch
49 Patch5:         %{name}-lf.patch
50 Patch6:         http://glen.alkohol.ee/pld/%{name}-maq-subject.patch
51 Patch7:         %{name}-bot-reconnect.patch
52 Patch8:         %{name}-perms.patch
53 Patch9:         http://glen.alkohol.ee/pld/%{name}-httpclient-clientside.patch
54 Patch10:        %{name}-cli-wr-separated.patch
55 Patch12:        %{name}-htmloptions-truncate.patch
56 Patch13:        %{name}-link_filter-updates.patch
57 Patch14:        %{name}-irc-mem.patch
58 Patch16:        %{name}-recent_activity-usability.patch
59 Patch17:        http://glen.alkohol.ee/pld/%{name}-upload-error-keep-popup.patch
60 Patch18:        http://glen.alkohol.ee/pld/%{name}-scm-parse-response.patch
61 Patch19:        %{name}-double-decode.patch
62 Patch20:        http://glen.alkohol.ee/pld/%{name}-keep-submitbutton.patch
63 Patch21:        http://glen.alkohol.ee/pld/%{name}-tt-unhide.patch
64 Patch22:        %{name}-route-mem.patch
65 Patch23:        http://glen.alkohol.ee/pld/%{name}-msgid-case.patch
66 Patch24:        http://glen.alkohol.ee/pld/%{name}-route-and-download.patch
67 Patch25:        %{name}-scm-pluscharisbad.patch
68 URL:            http://dev.mysql.com/downloads/other/eventum/
69 %{?with_pear:BuildRequires:     rpm-php-pearprov >= 4.0.2-98}
70 BuildRequires:  rpmbuild(macros) >= 1.268
71 BuildRequires:  sed >= 4.0
72 Requires:       %{name}-base = %{version}-%{release}
73 Requires:       Smarty >= 2.6.10-4
74 Requires:       php >= 3:4.2.0
75 Requires:       php-gd
76 Requires:       php-imap
77 Requires:       php-mysql
78 Requires:       php-pcre
79 Requires:       php-session
80 %if %{with pear}
81 Requires:       php-pear-Benchmark
82 Requires:       php-pear-DB
83 Requires:       php-pear-Date
84 Requires:       php-pear-HTTP_Request
85 Requires:       php-pear-Mail
86 Requires:       php-pear-Mail_Mime
87 Requires:       php-pear-Math_Stats
88 Requires:       php-pear-Net_DIME
89 Requires:       php-pear-Net_SMTP
90 Requires:       php-pear-Net_Socket
91 Requires:       php-pear-Net_URL
92 Requires:       php-pear-Net_UserAgent_Detect
93 Requires:       php-pear-PEAR-core
94 Requires:       php-pear-Text_Diff
95 Requires:       php-pear-XML_RPC
96 %endif
97 Requires(triggerpostun):        /usr/bin/php
98 Requires(triggerpostun):        sed >= 4.0
99 Requires:       apache(mod_dir)
100 Requires:       webapps
101 Requires:       webserver = apache
102 BuildArch:      noarch
103 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
104
105 %define         _noautoreq      'pear(/etc/webapps/.*)' 'pear(jpgraph_dir.php)' 'pear(.*Smarty.class.php)'
106
107 %define         _libdir         %{_prefix}/lib/%{name}
108 %define         _appdir         %{_datadir}/%{name}
109 %define         _smartyplugindir        %{_appdir}/include/smarty
110 %define         _smartydir      /usr/share/php/Smarty
111 %define         _webapps        /etc/webapps
112 %define         _webapp         %{name}
113 %define         _webappdir      %{_webapps}/%{_webapp}
114 %define         _sysconfdir     /etc/%{name}
115
116 %description
117 Eventum is a user-friendly and flexible issue tracking system that can
118 be used by a support department to track incoming technical support
119 requests, or by a software development team to quickly organize tasks
120 and bugs. Eventum is used by the MySQL AB Technical Support team, and
121 has allowed us to dramatically improve our response times.
122
123 %description -l pl
124 Eventum to przyjazny dla u¿ytkownika system ¶ledzenia spraw, który
125 mo¿e byæ u¿ywany przez dzia³ obs³ugi do ¶ledzenia przychodz±cych ¿±dañ
126 obs³ugi technicznej albo przez zespó³ tworz±cy oprogramowanie do
127 szybkiej organizacji zadañ i b³êdów. Eventum jest u¿ywany przez zespó³
128 Technical Support MySQL AB i umo¿liwi³ im znacz±co poprawiæ czasy
129 reakcji.
130
131 %package base
132 Summary:        Eventum base package
133 Summary(pl):    Podstawowy pakiet Eventum
134 Group:          Applications/WWW
135 Requires(postun):       /usr/sbin/groupdel
136 Requires(postun):       /usr/sbin/userdel
137 Requires(pre):  /bin/id
138 Requires(pre):  /usr/bin/getgid
139 Requires(pre):  /usr/sbin/groupadd
140 Requires(pre):  /usr/sbin/useradd
141 Provides:       group(eventum)
142 Provides:       user(eventum)
143
144 %description base
145 This package contains base directory structure for Eventum.
146
147 %description base -l pl
148 Ten pakiet zawiera podstawow± strukturê katalogów dla Eventum.
149
150 %package setup
151 Summary:        Eventum setup package
152 Summary(pl):    Pakiet do wstêpnej konfiguracji Eventum
153 Group:          Applications/WWW
154 Requires:       %{name} = %{version}-%{release}
155
156 %description setup
157 Install this package to configure initial Eventum installation. You
158 should uninstall this package when you're done, as it considered
159 insecure to keep the setup files in place.
160
161 %description setup -l pl
162 Ten pakiet nale¿y zainstalowaæ w celu wstêpnej konfiguracji Eventum po
163 pierwszej instalacji. Potem nale¿y go odinstalowaæ, jako ¿e
164 pozostawienie plików instalacyjnych mog³oby byæ niebezpieczne.
165
166 %package mail-queue
167 Summary:        Eventum mail queue process
168 Summary(pl):    Przetwarzanie kolejki poczty Eventum
169 Group:          Applications/WWW
170 Requires:       %{name} = %{version}-%{release}
171 Requires:       crondaemon
172
173 %description mail-queue
174 Beginning with the first release of Eventum, emails are not directly
175 sent out from the various scripts, but rather added to a mail queue
176 table that is processed by a cron job. If an email cannot be sent, it
177 will be marked as such in the mail queue log, and the cron job script
178 will re-try to send it again the next time it runs.
179
180 This package contains the cron job.
181
182 %description mail-queue -l pl
183 Od pierwszego wydania Eventum poczta nie jest wysy³ana bezpo¶rednio z
184 ró¿nych skryptów, lecz dodawana do kolejki przetwarzanej z crona.
185 Je¶li poczta nie mo¿e byæ wys³ana, bêdzie odpowiednio oznaczona w logu
186 kolejki poczty, a skrypt z crona bêdzie próbowa³ wys³aæ j± ponownie
187 nastêpnym razem.
188
189 Ten pakiet zawiera zadanie dla crona.
190
191 %package mail-download
192 Summary:        Eventum email download
193 Summary(pl):    ¦ci±ganie poczty Eventum
194 Group:          Applications/WWW
195 Requires:       %{name} = %{version}-%{release}
196 Requires:       crondaemon
197
198 %description mail-download
199 In order for Eventum's email integration feature to work, you need to
200 setup a cron job to run the script every so often.
201
202 This package contains the cron job.
203
204 %description mail-download -l pl
205 Aby integracja poczty elektronicznej w Eventum dzia³a³a, trzeba
206 ustawiæ zadanie crona, aby uruchamia³ odpowiedni skrypt wystarczaj±co
207 czêsto.
208
209 Ten pakiet zawiera zadanie dla crona.
210
211 %package reminder
212 Summary:        Eventum Reminder System
213 Summary(pl):    System przypominania dla Eventum
214 Group:          Applications/WWW
215 Requires:       %{name} = %{version}-%{release}
216 Requires:       crondaemon
217
218 %description reminder
219 The reminder system was designed with the objective as serving as a
220 safe net for issues that need attention. Depending on what
221 configuration you create, you may have several reminders (or alerts)
222 be sent out whenever an issue needs attention, for whatever parameter
223 you may deem necessary.
224
225 This package contains the cron job.
226
227 %description reminder -l pl
228 System przypominania zosta³ zaprojektowany tak, aby s³u¿y³ jako
229 bezpieczna sieæ dla spraw wymagaj±cych uwagi. W zale¿no¶ci od
230 konfiguracji mo¿na ustawiæ ró¿ne przypominajki (lub alarmy) wysy³ane
231 przy ka¿dej sprawie wymagaj±cej uwagi lub przy parametrze, który mo¿na
232 uwa¿aæ za potrzebny.
233
234 Ten pakiet zawiera zadanie dla crona.
235
236 %package monitor
237 Summary:        Eventum Heartbeat Monitor
238 Summary(pl):    Monitor ¿ycia dla Eventum
239 Group:          Applications/WWW
240 Requires:       %{name} = %{version}-%{release}
241 Requires:       crondaemon
242 Requires:       php-posix
243
244 %description monitor
245 The heartbeat monitor is a feature designed for the administrator that
246 wants to be alerted whenever a common problem in Eventum is detected,
247 like the database server not being available anymore, or maybe when
248 the recommended permissions for certain configuration files are
249 changed.
250
251 Please note that before running the heartbeat monitor, you may need to
252 customize some of the checks to be appropriate for your own system,
253 particularly the permission and file checks on
254 Monitor::checkConfiguration().
255
256 This package contains the cron job.
257
258 %description monitor -l pl
259 Monitor ¿ycia to funkcjonalno¶æ zaprojektowana dla administratora
260 chc±cego byæ alarmowanym przy ka¿dym wykryciu popularnego problemu z
261 Eventum, jak nie dzia³anie serwera bazy danych albo zmiana uprawnieñ
262 do plików konfiguracyjnych.
263
264 Nale¿y zauwa¿yæ, ¿e przed uruchomieniem tego monitora mo¿e byæ
265 konieczne dostosowanie niektórych testów do systemu, w szczególno¶ci
266 testów uprawnieñ i plików w Monitor::checkConfiguration().
267
268 Ten pakiet zawiera zadanie dla crona.
269
270 %package route-drafts
271 Summary:        Eventum Draft Routing
272 Summary(pl):    Przekazywanie szkiców dla Eventum
273 Group:          Applications/WWW
274 Requires:       %{name} = %{version}-%{release}
275 Requires:       eventum(router)
276
277 %description route-drafts
278 The draft routing feature is used to automatically associate a thread
279 of drafts into an Eventum issue. By setting up qmail (or even Postfix)
280 to deliver emails sent to a specific address (usually
281 draft-<number>@<domain>) to the above script, users are able to send
282 drafts written in their mail client to be stored in Eventum. These
283 drafts will NOT broadcasted to the notification list.
284
285 %description route-drafts -l pl
286 Przekazywanie szkiców s³u¿y do automatycznego wi±zania w±tku szkiców z
287 problemem w Eventum. Ustawiaj±c qmaila (czy nawet Postfiksa), aby
288 dostarcza³ pocztê wys³an± na podany adres (zwykle
289 draft-<liczba>@<domena>) do tego skryptu umo¿liwia siê u¿ytkownikom
290 wysy³anie szkiców napisanych w ich kliencie pocztowym do zapisania w
291 Eventum. Szkice te NIE bêd± wysy³ane na listê powiadomieñ.
292
293 %package route-emails
294 Summary:        Eventum Email Routing
295 Summary(pl):    Przekazywanie poczty dla Eventum
296 Group:          Applications/WWW
297 Requires:       %{name} = %{version}-%{release}
298 Requires:       eventum(router)
299
300 %description route-emails
301 The email routing feature is used to automatically associate a thread
302 of emails into an Eventum issue. By setting up qmail (or even postfix)
303 to deliver emails sent to a specific address (usually
304 issue-<number>@<domain>) to the above script, users are able to use
305 their email clients to reply to emails coming from Eventum, and those
306 replies will be automatically associated with the issue and
307 broadcasted to the entire notification list.
308
309 %description route-emails -l pl
310 Funkcjonalno¶æ przekazywania poczty s³u¿y do automatycznego wi±zania
311 w±tku listów ze spraw± w Eventum. Po ustawieniu qmaila (czy nawet
312 postfiksa), aby dostarcza³ listy wysy³ane na pewien adres (zwykle
313 issue-<numer>@<domena>) na powy¿szy skrypt, u¿ytkownicy bêd± mogli
314 u¿ywaæ klientów pocztowych do odpowiadania na listy przychodz±ce z
315 Eventum, a odpowiedzi te bêd± automatycznie wi±zane ze spraw± i
316 rozprowadzane do ca³ej listy og³oszeniowej.
317
318 %package route-notes
319 Summary:        Eventum Note Routing
320 Summary(pl):    Przekazywanie notatek dla Eventum
321 Group:          Applications/WWW
322 Requires:       %{name} = %{version}-%{release}
323 Requires:       eventum(router)
324
325 %description route-notes
326 The note routing feature is used to automatically associate a thread
327 of notes into an Eventum issue. By setting up qmail (or even postfix)
328 to deliver emails sent to a specific address (usually
329 note-<number>@<domain>) to the above script, users are able to use
330 their email clients to reply to internal notes coming from Eventum,
331 and those replies will be automatically associated with the issue and
332 broadcasted to the notification list staff members.
333
334 %description route-notes -l pl
335 Funkcjonalno¶æ przekazywania notatek s³u¿y do automatycznego wi±zania
336 w±tku notatek ze spraw± w Eventum. Po ustawieniu qmaila (czy nawet
337 postfiksa), aby dostarcza³ listy wysy³ane na pewien adres (zwykle
338 note-<numer>@<domena>) na powy¿szy skrypt, u¿ytkownicy bêd± mogli
339 u¿ywaæ klientów pocztowych do odpowiadania na wewnêtrzne notatki
340 pochodz±ce od Eventu, a odpowiedzi te bêd± automatycznie wi±zane ze
341 spraw± i rozprowadzane do cz³onków personelu listy og³oszeniowej.
342
343 %package router-qmail
344 Summary:        Eventum Mail Routing - qmail
345 Summary(pl):    Przekazywanie poczty Eventum - qmail
346 Group:          Applications/Mail
347 # loose dep is intentional. qmail subpackage isn't built on PLD
348 # builders and there really nothing changes.
349 Requires:       %{name} >= %{version}-%{release}
350 Requires:       qmail >= 1.03
351 Provides:       eventum(router)
352 Obsoletes:      eventum(router)
353
354 %description router-qmail
355 This package provides way of routing notes and emails back to Eventum
356 via qmail.
357
358 %description router-qmail -l pl
359 Ten pakiet udostêpnia metodê przekazywania notatek i listów do Eventum
360 przez qmaila.
361
362 %package router-postfix
363 Summary:        Eventum Mail Routing - Postfix
364 Summary(pl):    Przekazywanie poczty Eventum - Postfix
365 Group:          Applications/Mail
366 Requires:       %{name} = %{version}-%{release}
367 Requires:       postfix
368 Provides:       eventum(router)
369 Obsoletes:      eventum(router)
370
371 %description router-postfix
372 This package provides way of routing notes and emails back to Eventum
373 via Postfix.
374
375 The Postfix configuration instructions you can find from
376 <http://eventum.mysql.org/wiki/index.php/Setting_up_email_routing_with_postfix>.
377
378 %description router-postfix -l pl
379 Ten pakiet udostêpnia metodê przekazywania notatek i listów do Eventum
380 przez Postfiksa.
381
382 Opis konfiguracji Postfiksa mo¿na znale¼æ pod adresem
383 <http://eventum.mysql.org/wiki/index.php/Setting_up_email_routing_with_postfix>.
384
385 %package irc
386 Summary:        Eventum IRC Notification Bot
387 Summary(pl):    IRC-owy bot powiadamiaj±cy dla Eventum
388 Group:          Applications/WWW
389 Requires(triggerpostun):        sed >= 4.0
390 Requires:       %{name} = %{version}-%{release}
391 Requires:       php-pear-Net_SmartIRC
392 Requires:       php-sockets
393 Requires:       rc-scripts >= 0.4.0.18
394
395 %description irc
396 The IRC notification bot is a nice feature for remote teams that want
397 to handle issues and want to have a quick and easy way to get simple
398 notifications. Right now the bot notifies of the following actions:
399 - New Issues
400 - Blocked emails
401 - Issues that got their assignment list changed
402
403 NOTE: You will need to manually edit the bot.php script to set your
404 appropriate preferences, like IRC server and channel that the bot
405 should join.
406
407 %description irc -l pl
408 IRC-owy bot powiadamiaj±cy to mi³a funkcjonalno¶æ dla zdalnych
409 zespo³ów chc±cych obs³ugiwaæ sprawy i mieæ szybki i ³atwy sposób na
410 uzyskiwanie prostych powiadomieñ. Aktualnie bot powiadamia o
411 nastêpuj±cych zdarzeniach:
412 - nowych sprawach
413 - zablokowanych listach
414 - sprawach, dla których zmieni³a siê lista powi±zañ
415
416 UWAGA: w celu wprowadzenia w³asnych ustawieñ, takich jak serwer IRC i
417 kana³ u¿ywany przez bota, trzeba rêcznie zmodyfikowaæ skrypt bot.php .
418
419 %package cli
420 Summary:        Eventum command-line interface
421 Summary(pl):    Interfejs linii poleceñ dla Eventum
422 Group:          Applications/WWW
423 Requires:       %{name}-base = %{version}-%{release}
424 Requires:       php-cli
425 Requires:       php-common >= 3:4.1.0
426 Requires:       php-curl
427 Requires:       php-pear-XML_RPC
428 Requires:       php-xml
429
430 %description cli
431 The Eventum command-line interface allows you to access most of the
432 features of the web interface straight from your command shell.
433
434 %description cli -l pl
435 Interfejs linii poleceñ Eventum pozwala na dostêp do wiêkszo¶ci
436 funkcji interfejsu WWW prosto z linii poleceñ pow³oki.
437
438 %package scm
439 Summary:        Eventum SCM integration
440 Summary(pl):    Integracja SCM dla Eventum
441 Group:          Applications/WWW
442 Requires:       %{name}-base = %{version}-%{release}
443 Requires:       php-cli
444 Requires:       php-common >= 3:4.1.0
445 Requires:       php-pcre
446
447 %description scm
448 This feature allows your software development teams to integrate your
449 Source Control Management system with your Issue Tracking System.
450
451 The integration is implemented in such a way that it will be forward
452 compatible with pretty much any SCM system, such as CVS.
453
454 For installation see
455 </eventum/help.php?topic=scm_integration_installation>.
456
457 %description scm -l pl
458 Ten pakiet pozwala zespo³om programistów na integracjê systemu
459 zarz±dzania ¼ród³ami (SCM - Source Control Management) z systemem
460 ¶ledzenia spraw.
461
462 Integracja jest zaimplementowana tak, aby byæ kompatybilna w przód z
463 prawie ka¿dym systemem SCM, jak np. CVS.
464
465 Szczegó³y na temat instalacji mo¿na przeczytaæ pod
466 </eventum/help.php?topic=scm_integration_installation>.
467
468 %prep
469 %setup -q %{?_snap:-n %{name}-%{_snap}}
470 # undos the source
471 find . -type f -print0 | xargs -0 sed -i -e 's,\r$,,'
472
473 rm -f setup.conf.php # not to be installed by *.php glob
474 rm -rf misc/upgrade/*v1.[123]* # too old to support in PLD Linux
475 rm -f misc/upgrade/flush_compiled_templates.php
476 rm -rf misc/upgrade/*/upgrade_config.php # not needed nor supported in PLD Linux
477
478 # sample, not used in eventum
479 rm -f rpc/xmlrpc_client.php
480
481 # packaging
482 %patch0 -p1
483 %patch1 -p1
484 %patch14 -p1
485 %patch2 -p1
486 %{?with_pear:%patch3 -p1}
487
488 # bug fixes.
489 %patch4 -p1
490 %patch5 -p1
491 %patch6 -p1
492 %patch7 -p1
493 %patch8 -p1
494 %patch9 -p1
495 %patch10 -p1
496 %patch12 -p1
497 %patch13 -p1
498 %patch16 -p1
499 %patch17 -p1
500 %patch18 -p1
501 %patch19 -p1
502 %patch20 -p1
503 %patch21 -p1
504 %patch22 -p1
505 %patch23 -p1
506 %patch24 -p1
507 %patch25 -p1
508
509 sed -e '1s,#!.*/bin/php -q,#!%{_bindir}/php,' misc/cli/eventum > %{name}-cli
510 sed -e '1i#!%{_bindir}/php' misc/scm/process_cvs_commits.php > %{name}-scm
511 sed -e '1i#!%{_bindir}/php' misc/irc/bot.php > %{name}-bot
512 mv misc/cli/eventumrc_example eventumrc
513 sed -i -e '1i#!%{_bindir}/php' misc/*.php
514 chmod +x misc/*.php
515
516 sed -e '
517 s,$private_key\s*=\s*".*";,$private_key = "DEFAULTPRIVATEKEYPLEASERUNSETUP!";,
518 ' < include/private_key.php > private_key.php.in
519 rm -f include/private_key.php
520
521 # replace in remaining scripts config.inc.php to system one
522 grep -rl 'include_once(".*config.inc.php")' . | xargs sed -i -e '
523         s,include_once(".*config.inc.php"),include_once("%{_webappdir}/core.php"),
524 '
525
526 grep -rl 'APP_INC_PATH..*"private_key.php"' . | xargs sed -i -e '
527         s,include_once(APP_INC_PATH.*"private_key.php"),include_once("%{_webappdir}/private_key.php"),
528 '
529
530 # remove backups from patching as we use globs to package files to buildroot
531 find '(' -name '*~' -o -name '*.orig' ')' | xargs -r rm -v
532
533 %install
534 rm -rf $RPM_BUILD_ROOT
535 install -d \
536         $RPM_BUILD_ROOT{%{_webappdir},%{_sysconfdir},%{_bindir},%{_sbindir},%{_libdir}} \
537         $RPM_BUILD_ROOT/etc/{rc.d/init.d,cron.d,sysconfig} \
538         $RPM_BUILD_ROOT/var/{run,log,cache,lib}/%{name} \
539         $RPM_BUILD_ROOT/var/lib/%{name}/routed_{emails,drafts,notes} \
540         $RPM_BUILD_ROOT%{_appdir}/{include,htdocs/misc,upgrade} \
541
542 cp -a *.php css customer images js manage reports rpc setup $RPM_BUILD_ROOT%{_appdir}/htdocs
543 cp -a misc/*.html $RPM_BUILD_ROOT%{_appdir}/htdocs/misc
544 cp -a misc/*.php $RPM_BUILD_ROOT%{_appdir}
545 cp -a templates $RPM_BUILD_ROOT%{_appdir}
546 cp -a include/{customer,custom_field,jpgraph,pear,workflow} $RPM_BUILD_ROOT%{_appdir}/include
547 cp -a include/*.php $RPM_BUILD_ROOT%{_appdir}/include
548 cp -a logs/* $RPM_BUILD_ROOT/var/log/%{name}
549 cp -a misc/upgrade $RPM_BUILD_ROOT%{_appdir}
550
551 cp -a favicon.ico $RPM_BUILD_ROOT%{_appdir}/htdocs/favicon.ico
552 install %{SOURCE12} $RPM_BUILD_ROOT%{_appdir}/htdocs/setup/config.inc.php
553 install %{SOURCE13} $RPM_BUILD_ROOT%{_appdir}/upgrade/upgrade.sh
554
555 # cli
556 install -d $RPM_BUILD_ROOT%{_appdir}/cli
557 cp -a misc/cli/include/class.{misc,command_line}.php $RPM_BUILD_ROOT%{_appdir}/cli
558 cp -a misc/cli/config.inc.php $RPM_BUILD_ROOT%{_sysconfdir}/cli.php
559 install %{name}-cli $RPM_BUILD_ROOT%{_bindir}/%{name}
560 install %{name}-bot $RPM_BUILD_ROOT%{_sbindir}
561
562 # scm
563 install %{name}-scm $RPM_BUILD_ROOT%{_libdir}/scm
564 install %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}/cvs.php
565
566 # private key
567 cp -a private_key.php.in $RPM_BUILD_ROOT%{_webappdir}/private_key.php
568
569 install %{SOURCE1} $RPM_BUILD_ROOT%{_webappdir}/apache.conf
570 install %{SOURCE1} $RPM_BUILD_ROOT%{_webappdir}/httpd.conf
571 install %{SOURCE2} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-queue
572 install %{SOURCE3} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-download
573 install %{SOURCE4} $RPM_BUILD_ROOT/etc/cron.d/%{name}-reminder
574 install %{SOURCE5} $RPM_BUILD_ROOT/etc/cron.d/%{name}-monitor
575 install %{SOURCE7} $RPM_BUILD_ROOT%{_sysconfdir}/irc.php
576 install %{SOURCE8} $RPM_BUILD_ROOT/etc/rc.d/init.d/eventum-irc
577 install %{SOURCE9} $RPM_BUILD_ROOT/etc/sysconfig/eventum-irc
578
579 sed -e '
580 s,%%{APP_VERSION}%%,%{version}%{?_snap:-%{_snap}},
581 s,%%{PHP_PEAR_DIR}%%,%{?with_pear:%{php_pear_dir}}%{!?with_pear:%{_appdir}/includes/pear},
582 s,%%{APP_PATH}%%,%{_appdir},
583 s,%%{SMARTY_DIR}%%,%{_smartydir},
584 s,%%{SYSCONFDIR}%%,%{_webappdir},
585 ' %{SOURCE10} > $RPM_BUILD_ROOT%{_webappdir}/core.php
586
587 # config
588 > $RPM_BUILD_ROOT%{_webappdir}/setup.php
589 mv $RPM_BUILD_ROOT{%{_appdir}/htdocs/config.inc,%{_webappdir}/config}.php
590
591 %if %{with pear}
592 # provided by PEAR
593 rm -rf $RPM_BUILD_ROOT%{_appdir}/include/pear
594 %endif
595
596 # use system Smarty
597 rm -rf $RPM_BUILD_ROOT%{_appdir}/include/Smarty
598 install -d $RPM_BUILD_ROOT%{_smartyplugindir}
599 # These plugins are not in Smarty package (Smarty-2.6.2-3)
600 cp -a \
601         include/Smarty/plugins/function.{calendar,get_{display_style,innerhtml,textarea_size}}.php \
602         include/Smarty/plugins/modifier.highlight_quoted.php \
603         $RPM_BUILD_ROOT%{_smartyplugindir}
604
605 # qmail router
606 %if %{with qmail}
607 d=$RPM_BUILD_ROOT/var/lib/%{name}
608 echo 'root' > $d/.qmail
609 echo 'root' > $d/.qmail-default
610 echo '| %{_libdir}/router-qmail drafts' > $d/.qmail-draft-default
611 echo '| %{_libdir}/router-qmail emails 1' > $d/.qmail-issue-default
612 echo '| %{_libdir}/router-qmail notes' > $d/.qmail-note-default
613 install %{SOURCE11} $RPM_BUILD_ROOT%{_libdir}/router-qmail
614 %endif
615 # postfix router
616 install %{SOURCE14} $RPM_BUILD_ROOT%{_libdir}/router-postfix
617
618 %clean
619 rm -rf $RPM_BUILD_ROOT
620
621 %pre
622 %addusertogroup http %{name}
623
624 %post
625 # check if the package is configured.
626 if grep -q 'header("Location: setup/")' %{_webappdir}/config.php; then
627 if [ -f %{_appdir}/htdocs/setup/index.php ]; then
628 %banner %{name} -e <<EOF
629
630 You haven't yet configured Eventum!
631 Please open in browser <http://localhost/eventum/>
632 If you need access from elsewhere, you need to edit
633 %{_webappdir}/apache.conf and restart apache.
634
635 IMPORTANT: When You have configured Eventum, please uninstall the
636 setup package, so that %{name}-setup is able to secure your Eventum
637 installation.
638
639 EOF
640 #' vim syntax hack
641 else
642 %banner %{name} -e <<EOF
643
644 You haven't yet configured Eventum!
645
646 To setup eventum, please install %{name}-setup and open in browser
647 <http://localhost/eventum/>.
648 If you need access from elsewhere, you need to edit
649 %{_webappdir}/apache.conf and restart apache.
650
651 IMPORTANT: When You have configured Eventum, please uninstall the
652 setup package, so that %{name}-setup is able to secure your Eventum
653 installation.
654
655 EOF
656 #' vim syntax hack
657 fi
658
659 elif grep -q 'DEFAULTPRIVATEKEY' %{_webappdir}/private_key.php; then
660 %banner %{name} -e <<EOF
661
662 You have default private key installed!
663
664 Install %{name}-setup and open up http://yourserver/eventum/setup/
665 -- that will help you setup initial config.
666
667 when have configured Eventum, please uninstall the setup package,
668 so that %{name}-setup is able to secure your Eventum installation.
669
670 EOF
671         elif [ -d %{_appdir}/setup ]; then
672 %banner %{name} -e <<EOF
673
674 If you have have configured Eventum, please uninstall the setup package,
675 so that %{name}-setup is able to secure your Eventum installation.
676
677 EOF
678 fi
679
680 # nuke Smarty templates cache after upgrade
681 rm -f /var/cache/eventum/*.php
682
683 %preun
684 if [ "$1" = "0" ]; then
685         # nuke cache
686         rm -f /var/cache/eventum/*.php 2>/dev/null || :
687 fi
688
689 %pre base
690 %groupadd -P %{name}-base -g 146 %{name}
691 %useradd -P %{name}-base -u 146 -d /var/lib/%{name} -g %{name} -c "Eventum User" %{name}
692
693 %postun base
694 if [ "$1" = "0" ]; then
695         %userremove %{name}
696         %groupremove %{name}
697 fi
698
699 %post router-qmail
700 CF=/etc/qmail/control/virtualdomains
701 if ! grep -q ':%{name}\b' $CF 2>/dev/null; then
702         FQDN=$(awk -F'"' '/define/ && $2 ~ /APP_HOSTNAME/ {print $4}' %{_webappdir}/config.php 2>/dev/null)
703         [ "$FQDN" ] || FQDN=$(hostname -f 2>/dev/null || echo localhost)
704         umask 022
705         echo "#${FQDN}:%{name}" >> $CF
706
707 %banner %{name}-qmail -e <<EOF
708
709 Added "#${FQDN}:%{name}" to $CF,
710 Please verify that it is correct and restart qmail:
711 # service qmail reload
712
713 Consult qmail-send(8) for more information on virtualdomains.
714
715 EOF
716 fi
717
718 %preun router-qmail
719 if [ "$1" = "0" ]; then
720         sed -i -e '/:%{name}\b/d' /etc/qmail/control/virtualdomains
721 fi
722
723 %post setup
724 chmod 660 %{_webappdir}/{config,private_key}.php
725 chown root:eventum %{_webappdir}/{config,private_key}.php
726
727 %postun setup
728 if [ "$1" = "0" ]; then
729         chmod 640 %{_webappdir}/{config,private_key}.php
730         chown root:eventum %{_webappdir}/{config,private_key}.php
731 fi
732
733 %post irc
734 /sbin/chkconfig --add eventum-irc
735 %service eventum-irc restart "Eventum IRC Bot"
736
737 %triggerin -- apache1
738 %webapp_register apache %{_webapp}
739
740 %triggerun -- apache1
741 %webapp_unregister apache %{_webapp}
742
743 %triggerin -- apache >= 2.0.0
744 %webapp_register httpd %{_webapp}
745
746 %triggerun -- apache >= 2.0.0
747 %webapp_unregister httpd %{_webapp}
748
749 # FIXME
750 # only one upgrade trigger is called if you're upgrading over two
751 # versions, say 1.5 to 1.5.3, only 1.5.3 trigger is called.
752 # use common trigger (the highest version and rpmvercmp from poldek?)
753 %triggerpostun -- eventum < 1.5.1-0.257
754 %{_appdir}/upgrade/upgrade.sh %{_appdir}/upgrade/v1.5_to_v1.5.1 <<EOF
755 database_changes.php Perform database changes
756 EOF
757
758 %triggerpostun -- eventum < 1.5.2-0.289
759 %{_appdir}/upgrade/upgrade.sh %{_appdir}/upgrade/v1.5.1_to_v1.5.2 <<EOF
760 database_changes.php Perform database changes
761 set_priority_ranks.php Fix the ranking of priority values
762 EOF
763
764 %triggerpostun -- eventum < 1.5.3-0.291
765 %{_appdir}/upgrade/upgrade.sh %{_appdir}/upgrade/v1.5.2_to_v1.5.3 <<EOF
766 database_changes.php Perform database changes
767 EOF
768
769 %triggerpostun -- eventum < 1.5.4-1.12
770 %{_appdir}/upgrade/upgrade.sh %{_appdir}/upgrade/v1.5.3_to_v1.5.4 <<EOF
771 database_changes.php Perform database changes
772 EOF
773
774 %triggerpostun -- eventum < 1.6.0-RC2.6
775 %{_appdir}/upgrade/upgrade.sh %{_appdir}/upgrade/v1.5.5_to_v1.6.0 <<EOF
776 database_changes.php Perform database changes
777 upgrade_saved_searches.php Upgrade existing custom filters (saved searches)
778 EOF
779
780 %triggerpostun -- eventum < 1.6.1-0.2
781 %{_appdir}/upgrade/upgrade.sh %{_appdir}/upgrade/v1.6.0_to_v1.6.1 <<EOF
782 database_changes.php Perform database changes
783 EOF
784
785 %triggerpostun irc -- eventum-irc < 1.6.1-3.14
786 sed -i -e '
787 s,\$irc_host,$irc_server_hostname,
788 s,\$irc_port,$irc_server_port,
789 s,\$irc_nick,$nickname,
790 s,\$irc_realname,$realname,
791 s,\$irc_username,$username,
792 s,\$irc_password,$password,
793 ' /etc/eventum/irc.php
794
795 %triggerpostun -- eventum < 1.7.0-2.0.48
796 # migrate from apache-config macros
797 if [ -f /etc/%{name}/apache.conf.rpmsave ]; then
798         if [ -d /etc/apache/webapps.d ]; then
799                 cp -f %{_webapps}/%{_webapp}/apache.conf{,.rpmnew}
800                 cp -f /etc/%{name}/apache.conf.rpmsave %{_webapps}/%{_webapp}/apache.conf
801         fi
802
803         if [ -d /etc/httpd/webapps.d ]; then
804                 cp -f %{_webapps}/%{_webapp}/httpd.conf{,.rpmnew}
805                 cp -f /etc/%{name}/apache.conf.rpmsave %{_webapps}/%{_webapp}/httpd.conf
806         fi
807 fi
808
809 if [ -L /etc/apache/conf.d/99_%{_webapp}.conf ]; then
810         /usr/sbin/webapp register apache %{_webapp}
811         rm -f /etc/apache/conf.d/99_%{_webapp}.conf
812         %service -q apache reload
813 fi
814 if [ -L /etc/httpd/httpd.conf/99_%{_webapp}.conf ]; then
815         /usr/sbin/webapp register httpd %{_webapp}
816         rm -f /etc/httpd/httpd.conf/99_%{_webapp}.conf
817         %service -q httpd reload
818 fi
819
820 %{_appdir}/upgrade/upgrade.sh %{_appdir}/upgrade/v1.6.1_to_v1.7.0 <<EOF
821 database_changes.php Perform database changes
822 set_root_message_ids.php Set iss_root_message_id
823 EOF
824
825 # regular configs
826 for i in apache.conf config.php private_key.php setup.php; do
827         if [ -f /etc/eventum/$i.rpmsave ]; then
828                 mv -f %{_webappdir}/$i{,.rpmnew}
829                 mv -f /etc/eventum/$i.rpmsave %{_webappdir}/$i
830         fi
831 done
832
833 %triggerpostun cli -- %{name}-cli < 1.7.0-3.4
834 if [ -f %{_webappdir}/cli.php.rpmsave ]; then
835         mv -f %{_sysconfdir}/cli.php{,.rpmnew}
836         mv -f %{_webappdir}/cli.php.rpmsave %{_sysconfdir}/cli.php
837 fi
838
839 %triggerpostun irc -- %{name}-irc < 1.7.0-3.4
840 if [ -f %{_webappdir}/irc.php.rpmsave ]; then
841         mv -f %{_sysconfdir}/irc.php{,.rpmnew}
842         mv -f %{_webappdir}/irc.php.rpmsave %{_sysconfdir}/irc.php
843 fi
844
845 %files
846 %defattr(644,root,root,755)
847 %doc ChangeLog FAQ INSTALL README UPGRADE CONTRIB
848 %doc docs/* setup/schema.sql
849 %attr(751,root,root) %dir %{_webappdir}
850 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/apache.conf
851 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/httpd.conf
852 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/config.php
853 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/private_key.php
854 %attr(660,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/setup.php
855 %attr(640,root,eventum) %config %verify(not mtime) %{_webappdir}/core.php
856
857 %dir %attr(731,root,eventum) /var/log/%{name}
858 %attr(620,root,eventum) %ghost /var/log/%{name}/*
859
860 %dir %{_appdir}/htdocs
861 %{_appdir}/htdocs/*.php
862 %{_appdir}/htdocs/*.ico
863 %{_appdir}/htdocs/css
864 %{_appdir}/htdocs/customer
865 %{_appdir}/htdocs/images
866 %{_appdir}/htdocs/js
867 %{_appdir}/htdocs/manage
868 %{_appdir}/htdocs/reports
869 %{_appdir}/htdocs/rpc
870 %{_appdir}/htdocs/misc
871
872 %{_appdir}/templates
873 %dir %{_appdir}/upgrade
874 %attr(755,root,root) %{_appdir}/upgrade/upgrade.sh
875 %{_appdir}/upgrade/[!u]*
876
877 %{_smartyplugindir}
878 %if %{without pear}
879 %{_appdir}/include/pear
880 %endif
881
882 %dir %{_appdir}/include
883 %{_appdir}/include/customer
884 %{_appdir}/include/custom_field
885 %{_appdir}/include/jpgraph
886 %{_appdir}/include/workflow
887 %{_appdir}/include/class.[!m]*.php
888 %{_appdir}/include/class.mail.php
889 %{_appdir}/include/class.mail_queue.php
890 %{_appdir}/include/class.mime_helper.php
891 %{_appdir}/include/class.misc.php
892 %{_appdir}/include/db_access.php
893
894 %dir %attr(730,root,eventum) /var/run/%{name}
895 %dir %attr(730,root,eventum) /var/cache/%{name}
896
897 %files base
898 %defattr(644,root,root,755)
899 %attr(751,root,root) %dir %{_sysconfdir}
900 %dir %{_libdir}
901 %dir %{_appdir}
902 # qmail will ignore user, if it's home directory is not owned
903 %attr(750,eventum,eventum) %dir /var/lib/%{name}
904 # saved mail copies
905 %attr(770,root,eventum) %dir /var/lib/%{name}/routed_emails
906 %attr(770,root,eventum) %dir /var/lib/%{name}/routed_drafts
907 %attr(770,root,eventum) %dir /var/lib/%{name}/routed_notes
908
909 %files setup
910 %defattr(644,root,root,755)
911 %{_appdir}/htdocs/setup
912
913 %files mail-queue
914 %defattr(644,root,root,755)
915 %attr(755,root,root) %{_appdir}/process_mail_queue.php
916 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-queue
917
918 %files mail-download
919 %defattr(644,root,root,755)
920 %attr(755,root,root) %{_appdir}/download_emails.php
921 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-download
922
923 %files reminder
924 %defattr(644,root,root,755)
925 %attr(755,root,root) %{_appdir}/check_reminders.php
926 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-reminder
927
928 %files monitor
929 %defattr(644,root,root,755)
930 %{_appdir}/include/class.monitor.php
931 %attr(755,root,root) %{_appdir}/monitor.php
932 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-monitor
933
934 %files route-drafts
935 %defattr(644,root,root,755)
936 %attr(755,root,root) %{_appdir}/route_drafts.php
937
938 %files route-emails
939 %defattr(644,root,root,755)
940 %attr(755,root,root) %{_appdir}/route_emails.php
941
942 %files route-notes
943 %defattr(644,root,root,755)
944 %attr(755,root,root) %{_appdir}/route_notes.php
945
946 %if %{with qmail}
947 %files router-qmail
948 %defattr(644,root,root,755)
949 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) /var/lib/%{name}/.qmail*
950 %attr(755,root,root) %{_libdir}/router-qmail
951 %endif
952
953 %files router-postfix
954 %defattr(644,root,root,755)
955 %attr(755,root,root) %{_libdir}/router-postfix
956
957 %files irc
958 %defattr(644,root,root,755)
959 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/irc.php
960 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/eventum-irc
961 %attr(755,root,root) %{_sbindir}/%{name}-bot
962 %attr(754,root,root) /etc/rc.d/init.d/%{name}-irc
963
964 %files cli
965 %defattr(644,root,root,755)
966 %doc eventumrc
967 %attr(644,root,root) %config %verify(not md5 mtime size) %{_sysconfdir}/cli.php
968 %attr(755,root,root) %{_bindir}/%{name}
969 %{_appdir}/cli
970
971 %files scm
972 %defattr(644,root,root,755)
973 %attr(644,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/cvs.php
974 %attr(755,root,root) %{_libdir}/scm
This page took 0.102896 seconds and 4 git commands to generate.