]> git.pld-linux.org Git - packages/eventum.git/blob - eventum.spec
- fix path to clock_status.php
[packages/eventum.git] / eventum.spec
1 # TODO
2 # - php5 is not tested, but not placing hard conflict on it, as it prevents php4 & php coinstallation
3 # - discard bundled packages (from INSTALL):
4 #  - JpGraph 1.5.3 (last GPL version)
5 #  - Smarty 2.3.0 (http://smarty.php.net)
6 #  - PEAR packages
7 #  - dTree 2.0.5 (http://www.destroydrop.com/javascript/tree/)
8 #  - dynCalendar.js (http://www.phpguru.org/dyncalendar.html)
9 #  - overLIB 3.5.1 (http://www.bosrup.com/web/overlib/)
10 #  - A few other small javascript libraries
11 # - Mail Queue Process, cron or separate package (misc/process_mail_queue.php)
12 # - Email Download (misc/download_emails.php)
13 # - Reminder System (misc/check_reminders.php)
14 # - Heartbeat Monitor (misc/monitor.php)
15 # - Email Routing Script (misc/route_emails.php)
16 # - Note Routing Script (misc/route_notes.php)
17 # - IRC Notification Bot (misc/irc/bot.php)
18 # - Command-line Interface (misc/cli/eventum)
19 Summary:        Eventum Issue / Bug Tracking System
20 Name:           eventum
21 Version:        1.4
22 Release:        0.8
23 License:        GPL
24 Group:          Applications/WWW
25 Source0:        http://mysql.wildyou.net/Downloads/%{name}/%{name}-%{version}.tar.gz
26 # Source0-md5:  361c1355e46a6bbfa54e420964ec92cf
27 Patch0:         %{name}-clock-status.patch
28 URL:            http://dev.mysql.com/downloads/other/eventum/index.html
29 BuildRequires:  sed >= 4.0
30 Requires:       php >= 4.1.0
31 Requires:       php-pcre
32 Requires:       php-mysql
33 Requires:       php-gd
34 Requires:       php-imap
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %define         _appdir %{_datadir}/%{name}
38
39 %description
40 Eventum is a user-friendly and flexible issue tracking system that can
41 be used by a support department to track incoming technical support
42 requests, or by a software development team to quickly organize tasks
43 and bugs. Eventum is used by the MySQL AB Technical Support team, and
44 has allowed us to dramatically improve our response times.
45
46 %prep
47 %setup -q
48 %patch0 -p1
49
50 %build
51
52 %install
53 rm -rf $RPM_BUILD_ROOT
54
55 install -d $RPM_BUILD_ROOT%{_appdir}/locks
56
57 # TODO: php4
58 sed -i -e 's,/usr/local/bin/php,/usr/bin/php,' misc/cli/eventum
59
60 cp -a . $RPM_BUILD_ROOT%{_appdir}
61
62 > $RPM_BUILD_ROOT%{_appdir}/setup.conf.php
63
64 # in doc
65 rm -f $RPM_BUILD_ROOT%{_appdir}/{COPYING,ChangeLog,FAQ,INSTALL,README,UPGRADE}
66
67 %clean
68 rm -rf $RPM_BUILD_ROOT
69
70 %files
71 %defattr(644,root,root,755)
72 %doc ChangeLog FAQ INSTALL README UPGRADE
73 %dir %{_appdir}
74 %attr(640,http,root) %config(noreplace) %{_appdir}/config.inc.php
75 %attr(640,http,root) %config(noreplace) %{_appdir}/setup.conf.php
76 %{_appdir}/*[!cf].php
77
78 %{_appdir}/css
79 %{_appdir}/customer
80 %{_appdir}/docs
81 %{_appdir}/images
82 %{_appdir}/js
83 %{_appdir}/manage
84 %{_appdir}/misc
85 %{_appdir}/reports
86 %{_appdir}/rpc
87 %{_appdir}/setup
88 %{_appdir}/templates
89
90 %dir %attr(755,http,root) %{_appdir}/locks
91
92 %dir %{_appdir}/include
93 %{_appdir}/include/customer
94 %{_appdir}/include/jpgraph
95 %{_appdir}/include/pear
96 %{_appdir}/include/Smarty
97 %{_appdir}/include/workflow
98 %{_appdir}/include/class.*
99 %{_appdir}/include/db_access.php
100 %{_appdir}/include/jsrsServer.inc.php
101 %attr(640,http,root) %{_appdir}/include/private_key.php
102
103 %dir %attr(755,http,root) %{_appdir}/logs
104 %attr(640,http,root) %{_appdir}/logs/*
105
106 %dir %attr(750,http,root) %{_appdir}/templates_c
This page took 0.030772 seconds and 4 git commands to generate.