]> git.pld-linux.org Git - packages/eventum.git/blob - eventum.spec
- add timedisplay patch
[packages/eventum.git] / eventum.spec
1 # TODO
2 # - discard bundled packages (from INSTALL):
3 #  - JpGraph 1.5.3 (last GPL version)
4 #  - dTree 2.0.5 (http://www.destroydrop.com/javascript/tree/)
5 #  - dynCalendar.js (http://www.phpguru.org/dyncalendar.html)
6 #  - overLIB 3.5.1 (http://www.bosrup.com/web/overlib/)
7 #  - A few other small javascript libraries
8 # - 64bit platforms beware? http://bugs.php.net/bug.php?id=30215 (it's actually Smarty related problem)
9 #
10 # Conditional build:
11 %bcond_with     qmail   # build the router-qmail subpackage
12 %bcond_with     order_patch     # with custom issue order patch
13
14 #define _snap   20060330
15 #define _rc             RC3
16 %define _rel    2.20
17
18 %include        /usr/lib/rpm/macros.php
19 Summary:        Eventum Issue / Bug tracking system
20 Summary(pl):    Eventum - system ¶ledzenia spraw/b³êdów
21 Name:           eventum
22 Version:        1.7.1
23 Release:        %{?_snap:0.%{_snap}.}%{?_rc:%{_rc}.}%{_rel}
24 License:        GPL
25 Group:          Applications/WWW
26 #Source0:       http://downloads.mysql.com/snapshots/eventum/%{name}-nightly-%{_snap}.tar.gz
27 Source0:        http://mysql.dataphone.se/Downloads/eventum/%{name}-%{version}.tar.gz
28 # Source0-md5:  e1845de39b4d9bd30ddec9c26031a7d5
29 Source1:        %{name}-apache.conf
30 Source2:        %{name}-mail-queue.cron
31 Source3:        %{name}-mail-download.cron
32 Source4:        %{name}-reminder.cron
33 Source5:        %{name}-monitor.cron
34 Source6:        %{name}-cvs.php
35 Source7:        %{name}-irc.php
36 Source8:        %{name}-irc.init
37 Source9:        %{name}-irc.sysconfig
38 Source10:       %{name}-config.php
39 Source11:       %{name}-router-qmail.sh
40 Source12:       %{name}-config-setup.php
41 Source13:       %{name}-upgrade.sh
42 Source14:       %{name}-router-postfix.sh
43 Patch0:         %{name}-lf.patch
44 Patch1:         %{name}-perms.patch
45 Patch2:         %{name}-cli-wr-separated.patch
46 Patch3:         %{name}-scm-parse-response.patch
47 Patch4:         %{name}-double-decode.patch
48 Patch5:         %{name}-route-mem.patch
49 Patch6:         %{name}-scm-pluscharisbad.patch
50 Patch7:         %{name}-scm-updates.patch
51 Patch8:         %{name}-close-signature.patch
52 Patch9:         %{name}-list-sorting.patch
53 Patch10:        %{name}-workflow-handlenewnote-note_id.patch
54 Patch11:        %{name}-order4b.patch
55 Patch12:        %{name}-cli-errorcheck.patch
56 Patch13:        %{name}-combined.patch
57 Patch14:        %{name}-xml-inline.patch
58 Patch15:        %{name}-timetracking-advanced-logic.patch
59 Patch16:        %{name}-timedisplay.patch
60 # packaging patches that probably never go upstream
61 Patch100:       %{name}-paths.patch
62 Patch101:       %{name}-cvs-config.patch
63 Patch102:       %{name}-irc-mem.patch
64 Patch103:       %{name}-irc-config.patch
65 Patch104:       %{name}-PEAR.patch
66 Patch105:       %{name}-httpclient-clientside.patch
67 Patch106:       %{name}-bot-reconnect.patch
68 Patch107:       %{name}-private-key.patch
69 URL:            http://dev.mysql.com/downloads/other/eventum/
70 BuildRequires:  rpm-php-pearprov >= 4.0.2-98
71 BuildRequires:  rpmbuild(macros) >= 1.268
72 BuildRequires:  sed >= 4.0
73 Requires(triggerpostun):        /usr/bin/php
74 Requires(triggerpostun):        sed >= 4.0
75 Requires:       %{name}-base = %{version}-%{release}
76 Requires:       Smarty >= 2.6.10-4
77 Requires:       apache(mod_dir)
78 Requires:       php >= 3:4.2.0
79 Requires:       php-gd
80 Requires:       php-imap
81 Requires:       php-mysql
82 Requires:       php-pcre
83 Requires:       php-pear-Benchmark
84 Requires:       php-pear-DB
85 Requires:       php-pear-Date
86 Requires:       php-pear-HTTP_Request
87 Requires:       php-pear-Mail
88 Requires:       php-pear-Mail_Mime
89 Requires:       php-pear-Math_Stats
90 Requires:       php-pear-Net_DIME
91 Requires:       php-pear-Net_SMTP
92 Requires:       php-pear-Net_Socket
93 Requires:       php-pear-Net_URL
94 Requires:       php-pear-Net_UserAgent_Detect
95 Requires:       php-pear-PEAR-core
96 Requires:       php-pear-Text_Diff
97 Requires:       php-pear-XML_RPC
98 Requires:       php-session
99 Requires:       webapps
100 BuildArch:      noarch
101 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
102
103 %define         _noautoreq      'pear(/etc/webapps/.*)' 'pear(jpgraph_dir.php)' 'pear(.*Smarty.class.php)'
104
105 %define         _libdir         %{_prefix}/lib/%{name}
106 %define         _appdir         %{_datadir}/%{name}
107 %define         _smartyplugindir        %{_appdir}/include/smarty
108 %define         _smartydir      /usr/share/php/Smarty
109 %define         _webapps        /etc/webapps
110 %define         _webapp         %{name}
111 %define         _webappdir      %{_webapps}/%{_webapp}
112 %define         _sysconfdir     /etc/%{name}
113
114 %description
115 Eventum is a user-friendly and flexible issue tracking system that can
116 be used by a support department to track incoming technical support
117 requests, or by a software development team to quickly organize tasks
118 and bugs. Eventum is used by the MySQL AB Technical Support team, and
119 has allowed us to dramatically improve our response times.
120
121 %description -l pl
122 Eventum to przyjazny dla u¿ytkownika system ¶ledzenia spraw, który
123 mo¿e byæ u¿ywany przez dzia³ obs³ugi do ¶ledzenia przychodz±cych ¿±dañ
124 obs³ugi technicznej albo przez zespó³ tworz±cy oprogramowanie do
125 szybkiej organizacji zadañ i b³êdów. Eventum jest u¿ywany przez zespó³
126 Technical Support MySQL AB i umo¿liwi³ im znacz±co poprawiæ czasy
127 reakcji.
128
129 %package base
130 Summary:        Eventum base package
131 Summary(pl):    Podstawowy pakiet Eventum
132 Group:          Applications/WWW
133 Requires(postun):       /usr/sbin/groupdel
134 Requires(postun):       /usr/sbin/userdel
135 Requires(pre):  /bin/id
136 Requires(pre):  /usr/bin/getgid
137 Requires(pre):  /usr/sbin/groupadd
138 Requires(pre):  /usr/sbin/useradd
139 Provides:       group(eventum)
140 Provides:       user(eventum)
141
142 %description base
143 This package contains base directory structure for Eventum.
144
145 %description base -l pl
146 Ten pakiet zawiera podstawow± strukturê katalogów dla Eventum.
147
148 %package setup
149 Summary:        Eventum setup package
150 Summary(pl):    Pakiet do wstêpnej konfiguracji Eventum
151 Group:          Applications/WWW
152 Requires:       %{name} = %{version}-%{release}
153
154 %description setup
155 Install this package to configure initial Eventum installation. You
156 should uninstall this package when you're done, as it considered
157 insecure to keep the setup files in place.
158
159 %description setup -l pl
160 Ten pakiet nale¿y zainstalowaæ w celu wstêpnej konfiguracji Eventum po
161 pierwszej instalacji. Potem nale¿y go odinstalowaæ, jako ¿e
162 pozostawienie plików instalacyjnych mog³oby byæ niebezpieczne.
163
164 %package mail-queue
165 Summary:        Eventum mail queue process
166 Summary(pl):    Przetwarzanie kolejki poczty Eventum
167 Group:          Applications/WWW
168 Requires:       %{name} = %{version}-%{release}
169 Requires:       crondaemon
170
171 %description mail-queue
172 Beginning with the first release of Eventum, emails are not directly
173 sent out from the various scripts, but rather added to a mail queue
174 table that is processed by a cron job. If an email cannot be sent, it
175 will be marked as such in the mail queue log, and the cron job script
176 will re-try to send it again the next time it runs.
177
178 This package contains the cron job.
179
180 %description mail-queue -l pl
181 Od pierwszego wydania Eventum poczta nie jest wysy³ana bezpo¶rednio z
182 ró¿nych skryptów, lecz dodawana do kolejki przetwarzanej z crona.
183 Je¶li poczta nie mo¿e byæ wys³ana, bêdzie odpowiednio oznaczona w logu
184 kolejki poczty, a skrypt z crona bêdzie próbowa³ wys³aæ j± ponownie
185 nastêpnym razem.
186
187 Ten pakiet zawiera zadanie dla crona.
188
189 %package mail-download
190 Summary:        Eventum email download
191 Summary(pl):    ¦ci±ganie poczty Eventum
192 Group:          Applications/WWW
193 Requires:       %{name} = %{version}-%{release}
194 Requires:       crondaemon
195
196 %description mail-download
197 In order for Eventum's email integration feature to work, you need to
198 setup a cron job to run the script every so often.
199
200 This package contains the cron job.
201
202 %description mail-download -l pl
203 Aby integracja poczty elektronicznej w Eventum dzia³a³a, trzeba
204 ustawiæ zadanie crona, aby uruchamia³ odpowiedni skrypt wystarczaj±co
205 czêsto.
206
207 Ten pakiet zawiera zadanie dla crona.
208
209 %package reminder
210 Summary:        Eventum Reminder System
211 Summary(pl):    System przypominania dla Eventum
212 Group:          Applications/WWW
213 Requires:       %{name} = %{version}-%{release}
214 Requires:       crondaemon
215
216 %description reminder
217 The reminder system was designed with the objective as serving as a
218 safe net for issues that need attention. Depending on what
219 configuration you create, you may have several reminders (or alerts)
220 be sent out whenever an issue needs attention, for whatever parameter
221 you may deem necessary.
222
223 This package contains the cron job.
224
225 %description reminder -l pl
226 System przypominania zosta³ zaprojektowany tak, aby s³u¿y³ jako
227 bezpieczna sieæ dla spraw wymagaj±cych uwagi. W zale¿no¶ci od
228 konfiguracji mo¿na ustawiæ ró¿ne przypominajki (lub alarmy) wysy³ane
229 przy ka¿dej sprawie wymagaj±cej uwagi lub przy parametrze, który mo¿na
230 uwa¿aæ za potrzebny.
231
232 Ten pakiet zawiera zadanie dla crona.
233
234 %package monitor
235 Summary:        Eventum Heartbeat Monitor
236 Summary(pl):    Monitor ¿ycia dla Eventum
237 Group:          Applications/WWW
238 Requires:       %{name} = %{version}-%{release}
239 Requires:       crondaemon
240 Requires:       php-posix
241
242 %description monitor
243 The heartbeat monitor is a feature designed for the administrator that
244 wants to be alerted whenever a common problem in Eventum is detected,
245 like the database server not being available anymore, or maybe when
246 the recommended permissions for certain configuration files are
247 changed.
248
249 Please note that before running the heartbeat monitor, you may need to
250 customize some of the checks to be appropriate for your own system,
251 particularly the permission and file checks on
252 Monitor::checkConfiguration().
253
254 This package contains the cron job.
255
256 %description monitor -l pl
257 Monitor ¿ycia to funkcjonalno¶æ zaprojektowana dla administratora
258 chc±cego byæ alarmowanym przy ka¿dym wykryciu popularnego problemu z
259 Eventum, jak nie dzia³anie serwera bazy danych albo zmiana uprawnieñ
260 do plików konfiguracyjnych.
261
262 Nale¿y zauwa¿yæ, ¿e przed uruchomieniem tego monitora mo¿e byæ
263 konieczne dostosowanie niektórych testów do systemu, w szczególno¶ci
264 testów uprawnieñ i plików w Monitor::checkConfiguration().
265
266 Ten pakiet zawiera zadanie dla crona.
267
268 %package route-drafts
269 Summary:        Eventum Draft Routing
270 Summary(pl):    Przekazywanie szkiców dla Eventum
271 Group:          Applications/WWW
272 Requires:       %{name} = %{version}-%{release}
273 Requires:       eventum(router)
274
275 %description route-drafts
276 The draft routing feature is used to automatically associate a thread
277 of drafts into an Eventum issue. By setting up qmail (or even Postfix)
278 to deliver emails sent to a specific address (usually
279 draft-<number>@<domain>) to the above script, users are able to send
280 drafts written in their mail client to be stored in Eventum. These
281 drafts will NOT broadcasted to the notification list.
282
283 %description route-drafts -l pl
284 Przekazywanie szkiców s³u¿y do automatycznego wi±zania w±tku szkiców z
285 problemem w Eventum. Ustawiaj±c qmaila (czy nawet Postfiksa), aby
286 dostarcza³ pocztê wys³an± na podany adres (zwykle
287 draft-<liczba>@<domena>) do tego skryptu umo¿liwia siê u¿ytkownikom
288 wysy³anie szkiców napisanych w ich kliencie pocztowym do zapisania w
289 Eventum. Szkice te NIE bêd± wysy³ane na listê powiadomieñ.
290
291 %package route-emails
292 Summary:        Eventum Email Routing
293 Summary(pl):    Przekazywanie poczty dla Eventum
294 Group:          Applications/WWW
295 Requires:       %{name} = %{version}-%{release}
296 Requires:       eventum(router)
297
298 %description route-emails
299 The email routing feature is used to automatically associate a thread
300 of emails into an Eventum issue. By setting up qmail (or even postfix)
301 to deliver emails sent to a specific address (usually
302 issue-<number>@<domain>) to the above script, users are able to use
303 their email clients to reply to emails coming from Eventum, and those
304 replies will be automatically associated with the issue and
305 broadcasted to the entire notification list.
306
307 %description route-emails -l pl
308 Funkcjonalno¶æ przekazywania poczty s³u¿y do automatycznego wi±zania
309 w±tku listów ze spraw± w Eventum. Po ustawieniu qmaila (czy nawet
310 postfiksa), aby dostarcza³ listy wysy³ane na pewien adres (zwykle
311 issue-<numer>@<domena>) na powy¿szy skrypt, u¿ytkownicy bêd± mogli
312 u¿ywaæ klientów pocztowych do odpowiadania na listy przychodz±ce z
313 Eventum, a odpowiedzi te bêd± automatycznie wi±zane ze spraw± i
314 rozprowadzane do ca³ej listy og³oszeniowej.
315
316 %package route-notes
317 Summary:        Eventum Note Routing
318 Summary(pl):    Przekazywanie notatek dla Eventum
319 Group:          Applications/WWW
320 Requires:       %{name} = %{version}-%{release}
321 Requires:       eventum(router)
322
323 %description route-notes
324 The note routing feature is used to automatically associate a thread
325 of notes into an Eventum issue. By setting up qmail (or even postfix)
326 to deliver emails sent to a specific address (usually
327 note-<number>@<domain>) to the above script, users are able to use
328 their email clients to reply to internal notes coming from Eventum,
329 and those replies will be automatically associated with the issue and
330 broadcasted to the notification list staff members.
331
332 %description route-notes -l pl
333 Funkcjonalno¶æ przekazywania notatek s³u¿y do automatycznego wi±zania
334 w±tku notatek ze spraw± w Eventum. Po ustawieniu qmaila (czy nawet
335 postfiksa), aby dostarcza³ listy wysy³ane na pewien adres (zwykle
336 note-<numer>@<domena>) na powy¿szy skrypt, u¿ytkownicy bêd± mogli
337 u¿ywaæ klientów pocztowych do odpowiadania na wewnêtrzne notatki
338 pochodz±ce od Eventu, a odpowiedzi te bêd± automatycznie wi±zane ze
339 spraw± i rozprowadzane do cz³onków personelu listy og³oszeniowej.
340
341 %package router-qmail
342 Summary:        Eventum Mail Routing - qmail
343 Summary(pl):    Przekazywanie poczty Eventum - qmail
344 Group:          Applications/Mail
345 # loose dep is intentional. qmail subpackage isn't built on PLD
346 # builders and there really nothing changes.
347 Requires:       %{name} >= %{version}-%{release}
348 Requires:       qmail >= 1.03
349 Provides:       eventum(router)
350 Obsoletes:      eventum(router)
351
352 %description router-qmail
353 This package provides way of routing notes and emails back to Eventum
354 via qmail.
355
356 %description router-qmail -l pl
357 Ten pakiet udostêpnia metodê przekazywania notatek i listów do Eventum
358 przez qmaila.
359
360 %package router-postfix
361 Summary:        Eventum Mail Routing - Postfix
362 Summary(pl):    Przekazywanie poczty Eventum - Postfix
363 Group:          Applications/Mail
364 Requires:       %{name} = %{version}-%{release}
365 Requires:       postfix
366 Provides:       eventum(router)
367 Obsoletes:      eventum(router)
368
369 %description router-postfix
370 This package provides way of routing notes and emails back to Eventum
371 via Postfix.
372
373 The Postfix configuration instructions you can find from
374 <http://eventum.mysql.org/wiki/index.php/Setting_up_email_routing_with_postfix>.
375
376 %description router-postfix -l pl
377 Ten pakiet udostêpnia metodê przekazywania notatek i listów do Eventum
378 przez Postfiksa.
379
380 Opis konfiguracji Postfiksa mo¿na znale¼æ pod adresem
381 <http://eventum.mysql.org/wiki/index.php/Setting_up_email_routing_with_postfix>.
382
383 %package irc
384 Summary:        Eventum IRC Notification Bot
385 Summary(pl):    IRC-owy bot powiadamiaj±cy dla Eventum
386 Group:          Applications/WWW
387 Requires(post,preun):   /sbin/chkconfig
388 Requires(triggerpostun):        sed >= 4.0
389 Requires:       %{name} = %{version}-%{release}
390 Requires:       php-pear-Net_SmartIRC
391 Requires:       php-sockets
392 Requires:       rc-scripts >= 0.4.0.18
393
394 %description irc
395 The IRC notification bot is a nice feature for remote teams that want
396 to handle issues and want to have a quick and easy way to get simple
397 notifications. Right now the bot notifies of the following actions:
398 - New Issues
399 - Blocked emails
400 - Issues that got their assignment list changed
401
402 NOTE: You will need to manually edit the bot.php script to set your
403 appropriate preferences, like IRC server and channel that the bot
404 should join.
405
406 %description irc -l pl
407 IRC-owy bot powiadamiaj±cy to mi³a funkcjonalno¶æ dla zdalnych
408 zespo³ów chc±cych obs³ugiwaæ sprawy i mieæ szybki i ³atwy sposób na
409 uzyskiwanie prostych powiadomieñ. Aktualnie bot powiadamia o
410 nastêpuj±cych zdarzeniach:
411 - nowych sprawach
412 - zablokowanych listach
413 - sprawach, dla których zmieni³a siê lista powi±zañ
414
415 UWAGA: w celu wprowadzenia w³asnych ustawieñ, takich jak serwer IRC i
416 kana³ u¿ywany przez bota, trzeba rêcznie zmodyfikowaæ skrypt bot.php .
417
418 %package cli
419 Summary:        Eventum command-line interface
420 Summary(pl):    Interfejs linii poleceñ dla Eventum
421 Group:          Applications/WWW
422 Requires:       %{name}-base = %{version}-%{release}
423 Requires:       php-cli
424 Requires:       php-common >= 3:4.1.0
425 Requires:       php-pear-XML_RPC
426
427 %description cli
428 The Eventum command-line interface allows you to access most of the
429 features of the web interface straight from your command shell.
430
431 %description cli -l pl
432 Interfejs linii poleceñ Eventum pozwala na dostêp do wiêkszo¶ci
433 funkcji interfejsu WWW prosto z linii poleceñ pow³oki.
434
435 %package scm
436 Summary:        Eventum SCM integration
437 Summary(pl):    Integracja SCM dla Eventum
438 Group:          Applications/WWW
439 Requires:       %{name}-base = %{version}-%{release}
440 Requires:       php-cli
441 Requires:       php-common >= 3:4.1.0
442 Requires:       php-pcre
443
444 %description scm
445 This feature allows your software development teams to integrate your
446 Source Control Management system with your Issue Tracking System.
447
448 The integration is implemented in such a way that it will be forward
449 compatible with pretty much any SCM system, such as CVS.
450
451 For installation see
452 </eventum/help.php?topic=scm_integration_installation>.
453
454 %description scm -l pl
455 Ten pakiet pozwala zespo³om programistów na integracjê systemu
456 zarz±dzania ¼ród³ami (SCM - Source Control Management) z systemem
457 ¶ledzenia spraw.
458
459 Integracja jest zaimplementowana tak, aby byæ kompatybilna w przód z
460 prawie ka¿dym systemem SCM, jak np. CVS.
461
462 Szczegó³y na temat instalacji mo¿na przeczytaæ pod
463 </eventum/help.php?topic=scm_integration_installation>.
464
465 %prep
466 %setup -q %{?_snap:-n %{name}-%{_snap}}
467 # undos the source
468 find . -type f -print0 | xargs -0 sed -i -e 's,\r$,,'
469
470 rm -f setup.conf.php # not to be installed by *.php glob
471 rm -rf misc/upgrade/*v1.[123]* # too old to support in PLD Linux
472 rm -f misc/upgrade/flush_compiled_templates.php
473 rm -rf misc/upgrade/*/upgrade_config.php # not needed in PLD Linux
474
475 # sample, not used in eventum
476 rm -f rpc/xmlrpc_client.php
477
478 # bug fixes.
479 %patch0 -p1
480 %patch1 -p1
481 %patch2 -p1
482 %patch3 -p1
483 %patch4 -p1
484 %patch5 -p1
485 %patch6 -p1
486 %patch7 -p1
487 %patch8 -p1
488 %patch9 -p1
489 %patch10 -p1
490 %{?with_order_patch:%patch11 -p1}
491 %patch12 -p1
492 %patch13 -p1
493 %patch14 -p1
494 %patch15 -p1
495 %patch16 -p1
496
497 # packaging
498 %patch100 -p1
499 %patch101 -p1
500 %patch102 -p1
501 %patch103 -p1
502 %patch104 -p1
503 %patch105 -p1
504 %patch106 -p1
505 %patch107 -p1
506
507 sed -e '1s,#!.*/bin/php -q,#!%{_bindir}/php,' misc/cli/eventum > %{name}-cli
508 sed -e '1i#!%{_bindir}/php' misc/scm/process_cvs_commits.php > %{name}-scm
509 sed -e '1i#!%{_bindir}/php' misc/irc/bot.php > %{name}-bot
510 mv misc/cli/eventumrc_example eventumrc
511 sed -i -e '1i#!%{_bindir}/php' misc/*.php
512 chmod +x misc/*.php
513 mv include/private_key.php private_key.php.in
514
515 # replace in remaining scripts config.inc.php to system one
516 grep -rl 'include_once(".*config.inc.php")' . | xargs sed -i -e '
517         s,include_once(".*config.inc.php"),include_once("%{_webappdir}/core.php"),
518 '
519
520 grep -rl 'APP_INC_PATH..*"private_key.php"' . | xargs sed -i -e '
521         s,include_once(APP_INC_PATH.*"private_key.php"),include_once("%{_webappdir}/private_key.php"),
522 '
523
524 # remove backups from patching as we use globs to package files to buildroot
525 find '(' -name '*~' -o -name '*.orig' ')' | xargs -r rm -v
526
527 %install
528 rm -rf $RPM_BUILD_ROOT
529 install -d \
530         $RPM_BUILD_ROOT{%{_webappdir},%{_sysconfdir},%{_bindir},%{_sbindir},%{_libdir}} \
531         $RPM_BUILD_ROOT/etc/{rc.d/init.d,cron.d,sysconfig} \
532         $RPM_BUILD_ROOT/var/{run,log,cache,lib}/%{name} \
533         $RPM_BUILD_ROOT/var/lib/%{name}/routed_{emails,drafts,notes} \
534         $RPM_BUILD_ROOT%{_appdir}/{include,htdocs/misc,upgrade} \
535
536 cp -a *.php css customer images js manage reports rpc setup $RPM_BUILD_ROOT%{_appdir}/htdocs
537 cp -a misc/*.html $RPM_BUILD_ROOT%{_appdir}/htdocs/misc
538 cp -a misc/*.php $RPM_BUILD_ROOT%{_appdir}
539 cp -a templates $RPM_BUILD_ROOT%{_appdir}
540 cp -a include/{customer,custom_field,jpgraph,workflow} $RPM_BUILD_ROOT%{_appdir}/include
541 cp -a include/*.php $RPM_BUILD_ROOT%{_appdir}/include
542 cp -a logs/* $RPM_BUILD_ROOT/var/log/%{name}
543 cp -a misc/upgrade $RPM_BUILD_ROOT%{_appdir}
544
545 cp -a favicon.ico $RPM_BUILD_ROOT%{_appdir}/htdocs/favicon.ico
546 install %{SOURCE12} $RPM_BUILD_ROOT%{_appdir}/htdocs/setup/config.inc.php
547 install %{SOURCE13} $RPM_BUILD_ROOT%{_appdir}/upgrade/upgrade.sh
548
549 # cli
550 install -d $RPM_BUILD_ROOT%{_appdir}/cli
551 cp -a misc/cli/include/class.{misc,command_line}.php $RPM_BUILD_ROOT%{_appdir}/cli
552 cp -a misc/cli/config.inc.php $RPM_BUILD_ROOT%{_sysconfdir}/cli.php
553 install %{name}-cli $RPM_BUILD_ROOT%{_bindir}/%{name}
554 install %{name}-bot $RPM_BUILD_ROOT%{_sbindir}
555
556 # scm
557 install %{name}-scm $RPM_BUILD_ROOT%{_libdir}/scm
558 install %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}/cvs.php
559
560 # private key
561 cp -a private_key.php.in $RPM_BUILD_ROOT%{_webappdir}/private_key.php
562
563 install %{SOURCE1} $RPM_BUILD_ROOT%{_webappdir}/apache.conf
564 install %{SOURCE1} $RPM_BUILD_ROOT%{_webappdir}/httpd.conf
565 install %{SOURCE2} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-queue
566 install %{SOURCE3} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-download
567 install %{SOURCE4} $RPM_BUILD_ROOT/etc/cron.d/%{name}-reminder
568 install %{SOURCE5} $RPM_BUILD_ROOT/etc/cron.d/%{name}-monitor
569 install %{SOURCE7} $RPM_BUILD_ROOT%{_sysconfdir}/irc.php
570 install %{SOURCE8} $RPM_BUILD_ROOT/etc/rc.d/init.d/eventum-irc
571 install %{SOURCE9} $RPM_BUILD_ROOT/etc/sysconfig/eventum-irc
572
573 sed -e '
574 s,%%{APP_VERSION}%%,%{version}%{?_snap:-%{_snap}}%{?_rc:-%{_rc}},
575 s,%%{PHP_PEAR_DIR}%%,%{php_pear_dir},
576 s,%%{APP_PATH}%%,%{_appdir},
577 s,%%{SMARTY_DIR}%%,%{_smartydir},
578 s,%%{SYSCONFDIR}%%,%{_webappdir},
579 ' %{SOURCE10} > $RPM_BUILD_ROOT%{_webappdir}/core.php
580
581 # config
582 > $RPM_BUILD_ROOT%{_webappdir}/setup.php
583 mv $RPM_BUILD_ROOT{%{_appdir}/htdocs/config.inc,%{_webappdir}/config}.php
584
585 install -d $RPM_BUILD_ROOT%{_smartyplugindir}
586 # These plugins are not in Smarty package (Smarty-2.6.2-3)
587 cp -a \
588         include/Smarty/plugins/function.{calendar,get_{display_style,innerhtml,textarea_size}}.php \
589         include/Smarty/plugins/modifier.highlight_quoted.php \
590         $RPM_BUILD_ROOT%{_smartyplugindir}
591
592 # qmail router
593 %if %{with qmail}
594 d=$RPM_BUILD_ROOT/var/lib/%{name}
595 echo 'root' > $d/.qmail
596 echo 'root' > $d/.qmail-default
597 echo '| %{_libdir}/router-qmail drafts' > $d/.qmail-draft-default
598 echo '| %{_libdir}/router-qmail emails 1' > $d/.qmail-issue-default
599 echo '| %{_libdir}/router-qmail notes' > $d/.qmail-note-default
600 install %{SOURCE11} $RPM_BUILD_ROOT%{_libdir}/router-qmail
601 %endif
602 # postfix router
603 install %{SOURCE14} $RPM_BUILD_ROOT%{_libdir}/router-postfix
604
605 %clean
606 rm -rf $RPM_BUILD_ROOT
607
608 %pre
609 %addusertogroup http %{name}
610
611 %post
612 # check if the package is configured.
613 if grep -q 'header("Location: setup/")' %{_webappdir}/config.php; then
614 if [ -f %{_appdir}/htdocs/setup/index.php ]; then
615 %banner %{name} -e <<EOF
616
617 You haven't yet configured Eventum!
618 Please open in browser <http://localhost/eventum/>
619 If you need access from elsewhere, you need to edit
620 %{_webappdir}/apache.conf and restart apache.
621
622 IMPORTANT: When You have configured Eventum, please uninstall the
623 setup package, so that %{name}-setup is able to secure your Eventum
624 installation.
625
626 EOF
627 #' vim syntax hack
628 else
629 %banner %{name} -e <<EOF
630
631 You haven't yet configured Eventum!
632
633 To setup eventum, please install %{name}-setup and open in browser
634 <http://localhost/eventum/>.
635 If you need access from elsewhere, you need to edit
636 %{_webappdir}/apache.conf and restart apache.
637
638 IMPORTANT: When You have configured Eventum, please uninstall the
639 setup package, so that %{name}-setup is able to secure your Eventum
640 installation.
641
642 EOF
643 #' vim syntax hack
644 fi
645
646 elif grep -q 'DEFAULTPRIVATEKEY' %{_webappdir}/private_key.php; then
647 %banner %{name} -e <<EOF
648
649 You have default private key installed!
650
651 Install %{name}-setup and open up http://yourserver/eventum/setup/
652 -- that will help you setup initial config.
653
654 when have configured Eventum, please uninstall the setup package,
655 so that %{name}-setup is able to secure your Eventum installation.
656
657 EOF
658         elif [ -d %{_appdir}/setup ]; then
659 %banner %{name} -e <<EOF
660
661 If you have have configured Eventum, please uninstall the setup package,
662 so that %{name}-setup is able to secure your Eventum installation.
663
664 EOF
665 fi
666
667 # nuke Smarty templates cache after upgrade
668 rm -f /var/cache/eventum/*.php
669
670 %preun
671 if [ "$1" = "0" ]; then
672         # nuke cache
673         rm -f /var/cache/eventum/*.php 2>/dev/null || :
674 fi
675
676 %pre base
677 %groupadd -P %{name}-base -g 146 %{name}
678 %useradd -P %{name}-base -u 146 -d /var/lib/%{name} -g %{name} -c "Eventum User" %{name}
679
680 %postun base
681 if [ "$1" = "0" ]; then
682         %userremove %{name}
683         %groupremove %{name}
684 fi
685
686 %post router-qmail
687 CF=/etc/qmail/control/virtualdomains
688 if ! grep -q ':%{name}\b' $CF 2>/dev/null; then
689         FQDN=$(awk -F'"' '/define/ && $2 ~ /APP_HOSTNAME/ {print $4}' %{_webappdir}/config.php 2>/dev/null)
690         [ "$FQDN" ] || FQDN=$(hostname -f 2>/dev/null || echo localhost)
691         umask 022
692         echo "#${FQDN}:%{name}" >> $CF
693
694 %banner %{name}-qmail -e <<EOF
695
696 Added "#${FQDN}:%{name}" to $CF,
697 Please verify that it is correct and restart qmail:
698 # service qmail reload
699
700 Consult qmail-send(8) for more information on virtualdomains.
701
702 EOF
703 fi
704
705 %preun router-qmail
706 if [ "$1" = "0" ]; then
707         sed -i -e '/:%{name}\b/d' /etc/qmail/control/virtualdomains
708 fi
709
710 %post setup
711 chmod 660 %{_webappdir}/{config,private_key}.php
712 chown root:eventum %{_webappdir}/{config,private_key}.php
713
714 %postun setup
715 if [ "$1" = "0" ]; then
716         chmod 640 %{_webappdir}/{config,private_key}.php
717         chown root:eventum %{_webappdir}/{config,private_key}.php
718 fi
719
720 %post irc
721 /sbin/chkconfig --add eventum-irc
722 %service eventum-irc restart "Eventum IRC Bot"
723
724 %triggerin -- apache1
725 %webapp_register apache %{_webapp}
726
727 %triggerun -- apache1
728 %webapp_unregister apache %{_webapp}
729
730 %triggerin -- apache < 2.2.0, apache-base
731 %webapp_register httpd %{_webapp}
732
733 %triggerun -- apache < 2.2.0, apache-base
734 %webapp_unregister httpd %{_webapp}
735
736 # FIXME
737 # only one upgrade trigger is called if you're upgrading over two
738 # versions, say 1.5 to 1.5.3, only 1.5.3 trigger is called.
739 # use common trigger (the highest version and rpmvercmp from poldek?)
740 %triggerpostun -- eventum < 1.5.1-0.257
741 %{_appdir}/upgrade/upgrade.sh %{_appdir}/upgrade/v1.5_to_v1.5.1 <<EOF
742 database_changes.php Perform database changes
743 EOF
744
745 %triggerpostun -- eventum < 1.5.2-0.289
746 %{_appdir}/upgrade/upgrade.sh %{_appdir}/upgrade/v1.5.1_to_v1.5.2 <<EOF
747 database_changes.php Perform database changes
748 set_priority_ranks.php Fix the ranking of priority values
749 EOF
750
751 %triggerpostun -- eventum < 1.5.3-0.291
752 %{_appdir}/upgrade/upgrade.sh %{_appdir}/upgrade/v1.5.2_to_v1.5.3 <<EOF
753 database_changes.php Perform database changes
754 EOF
755
756 %triggerpostun -- eventum < 1.5.4-1.12
757 %{_appdir}/upgrade/upgrade.sh %{_appdir}/upgrade/v1.5.3_to_v1.5.4 <<EOF
758 database_changes.php Perform database changes
759 EOF
760
761 %triggerpostun -- eventum < 1.6.0-RC2.6
762 %{_appdir}/upgrade/upgrade.sh %{_appdir}/upgrade/v1.5.5_to_v1.6.0 <<EOF
763 database_changes.php Perform database changes
764 upgrade_saved_searches.php Upgrade existing custom filters (saved searches)
765 EOF
766
767 %triggerpostun -- eventum < 1.6.1-0.2
768 %{_appdir}/upgrade/upgrade.sh %{_appdir}/upgrade/v1.6.0_to_v1.6.1 <<EOF
769 database_changes.php Perform database changes
770 EOF
771
772 %triggerpostun irc -- eventum-irc < 1.6.1-3.14
773 sed -i -e '
774 s,\$irc_host,$irc_server_hostname,
775 s,\$irc_port,$irc_server_port,
776 s,\$irc_nick,$nickname,
777 s,\$irc_realname,$realname,
778 s,\$irc_username,$username,
779 s,\$irc_password,$password,
780 ' /etc/eventum/irc.php
781
782 %triggerpostun -- eventum < 1.7.0-2.0.48
783 # migrate from apache-config macros
784 if [ -f /etc/%{name}/apache.conf.rpmsave ]; then
785         if [ -d /etc/apache/webapps.d ]; then
786                 cp -f %{_webapps}/%{_webapp}/apache.conf{,.rpmnew}
787                 cp -f /etc/%{name}/apache.conf.rpmsave %{_webapps}/%{_webapp}/apache.conf
788         fi
789
790         if [ -d /etc/httpd/webapps.d ]; then
791                 cp -f %{_webapps}/%{_webapp}/httpd.conf{,.rpmnew}
792                 cp -f /etc/%{name}/apache.conf.rpmsave %{_webapps}/%{_webapp}/httpd.conf
793         fi
794 fi
795
796 if [ -L /etc/apache/conf.d/99_%{_webapp}.conf ]; then
797         /usr/sbin/webapp register apache %{_webapp}
798         rm -f /etc/apache/conf.d/99_%{_webapp}.conf
799         %service -q apache reload
800 fi
801 if [ -L /etc/httpd/httpd.conf/99_%{_webapp}.conf ]; then
802         /usr/sbin/webapp register httpd %{_webapp}
803         rm -f /etc/httpd/httpd.conf/99_%{_webapp}.conf
804         %service -q httpd reload
805 fi
806
807 %{_appdir}/upgrade/upgrade.sh %{_appdir}/upgrade/v1.6.1_to_v1.7.0 <<EOF
808 database_changes.php Perform database changes
809 set_root_message_ids.php Set iss_root_message_id
810 EOF
811
812 # regular configs
813 for i in apache.conf config.php private_key.php setup.php; do
814         if [ -f /etc/eventum/$i.rpmsave ]; then
815                 mv -f %{_webappdir}/$i{,.rpmnew}
816                 mv -f /etc/eventum/$i.rpmsave %{_webappdir}/$i
817         fi
818 done
819
820 %triggerpostun cli -- %{name}-cli < 1.7.0-3.4
821 if [ -f %{_webappdir}/cli.php.rpmsave ]; then
822         mv -f %{_sysconfdir}/cli.php{,.rpmnew}
823         mv -f %{_webappdir}/cli.php.rpmsave %{_sysconfdir}/cli.php
824 fi
825
826 %triggerpostun irc -- %{name}-irc < 1.7.0-3.4
827 if [ -f %{_webappdir}/irc.php.rpmsave ]; then
828         mv -f %{_sysconfdir}/irc.php{,.rpmnew}
829         mv -f %{_webappdir}/irc.php.rpmsave %{_sysconfdir}/irc.php
830 fi
831
832 %files
833 %defattr(644,root,root,755)
834 %doc ChangeLog FAQ INSTALL README UPGRADE CONTRIB
835 %doc docs/* setup/schema.sql
836 %attr(751,root,root) %dir %{_webappdir}
837 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/apache.conf
838 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/httpd.conf
839 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/config.php
840 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/private_key.php
841 %attr(660,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/setup.php
842 %attr(640,root,eventum) %config %verify(not mtime) %{_webappdir}/core.php
843
844 %dir %attr(731,root,eventum) /var/log/%{name}
845 %attr(620,root,eventum) %ghost /var/log/%{name}/*
846
847 %dir %{_appdir}/htdocs
848 %{_appdir}/htdocs/*.php
849 %{_appdir}/htdocs/*.ico
850 %{_appdir}/htdocs/css
851 %{_appdir}/htdocs/customer
852 %{_appdir}/htdocs/images
853 %{_appdir}/htdocs/js
854 %{_appdir}/htdocs/manage
855 %{_appdir}/htdocs/reports
856 %{_appdir}/htdocs/rpc
857 %{_appdir}/htdocs/misc
858 %{_appdir}/templates
859 %dir %{_appdir}/upgrade
860 %attr(755,root,root) %{_appdir}/upgrade/upgrade.sh
861 %{_appdir}/upgrade/[!u]*
862 %{_smartyplugindir}
863
864 %dir %{_appdir}/include
865 %{_appdir}/include/customer
866 %{_appdir}/include/custom_field
867 %{_appdir}/include/jpgraph
868 %{_appdir}/include/workflow
869 %{_appdir}/include/class.[!m]*.php
870 %{_appdir}/include/class.mail.php
871 %{_appdir}/include/class.mail_queue.php
872 %{_appdir}/include/class.mime_helper.php
873 %{_appdir}/include/class.misc.php
874 %{_appdir}/include/db_access.php
875
876 %dir %attr(730,root,eventum) /var/run/%{name}
877 %dir %attr(730,root,eventum) /var/cache/%{name}
878
879 %files base
880 %defattr(644,root,root,755)
881 %attr(751,root,root) %dir %{_sysconfdir}
882 %dir %{_libdir}
883 %dir %{_appdir}
884 # qmail will ignore user, if it's home directory is not owned
885 %attr(750,eventum,eventum) %dir /var/lib/%{name}
886 # saved mail copies
887 %attr(770,root,eventum) %dir /var/lib/%{name}/routed_emails
888 %attr(770,root,eventum) %dir /var/lib/%{name}/routed_drafts
889 %attr(770,root,eventum) %dir /var/lib/%{name}/routed_notes
890
891 %files setup
892 %defattr(644,root,root,755)
893 %{_appdir}/htdocs/setup
894
895 %files mail-queue
896 %defattr(644,root,root,755)
897 %attr(755,root,root) %{_appdir}/process_mail_queue.php
898 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-queue
899
900 %files mail-download
901 %defattr(644,root,root,755)
902 %attr(755,root,root) %{_appdir}/download_emails.php
903 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-download
904
905 %files reminder
906 %defattr(644,root,root,755)
907 %attr(755,root,root) %{_appdir}/check_reminders.php
908 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-reminder
909
910 %files monitor
911 %defattr(644,root,root,755)
912 %{_appdir}/include/class.monitor.php
913 %attr(755,root,root) %{_appdir}/monitor.php
914 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-monitor
915
916 %files route-drafts
917 %defattr(644,root,root,755)
918 %attr(755,root,root) %{_appdir}/route_drafts.php
919
920 %files route-emails
921 %defattr(644,root,root,755)
922 %attr(755,root,root) %{_appdir}/route_emails.php
923
924 %files route-notes
925 %defattr(644,root,root,755)
926 %attr(755,root,root) %{_appdir}/route_notes.php
927
928 %if %{with qmail}
929 %files router-qmail
930 %defattr(644,root,root,755)
931 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) /var/lib/%{name}/.qmail*
932 %attr(755,root,root) %{_libdir}/router-qmail
933 %endif
934
935 %files router-postfix
936 %defattr(644,root,root,755)
937 %attr(755,root,root) %{_libdir}/router-postfix
938
939 %files irc
940 %defattr(644,root,root,755)
941 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/irc.php
942 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/eventum-irc
943 %attr(755,root,root) %{_sbindir}/%{name}-bot
944 %attr(754,root,root) /etc/rc.d/init.d/%{name}-irc
945
946 %files cli
947 %defattr(644,root,root,755)
948 %doc eventumrc
949 %attr(644,root,root) %config %verify(not md5 mtime size) %{_sysconfdir}/cli.php
950 %attr(755,root,root) %{_bindir}/%{name}
951 %{_appdir}/cli
952
953 %files scm
954 %defattr(644,root,root,755)
955 %attr(644,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/cvs.php
956 %attr(755,root,root) %{_libdir}/scm
This page took 0.092999 seconds and 4 git commands to generate.