]> git.pld-linux.org Git - packages/eventum.git/blob - eventum.spec
- pear Net_POP3 is not used at all
[packages/eventum.git] / eventum.spec
1 # TODO
2 # - discard bundled packages (from INSTALL):
3 #  - JpGraph 1.5.3 (last GPL version)
4 #  - dTree 2.0.5 (http://www.destroydrop.com/javascript/tree/)
5 #  - dynCalendar.js (http://www.phpguru.org/dyncalendar.html)
6 #  - overLIB 3.5.1 (http://www.bosrup.com/web/overlib/)
7 #  - A few other small javascript libraries
8 # - 64bit platforms beware? http://bugs.php.net/bug.php?id=30215 (it's actually Smarty related problem)
9
10 %bcond_without  pear    # build with system PEAR packages (or use bundled ones)
11 %bcond_with     qmail   # build the router-qmail subpackage
12
13 # snapshot: DATE
14 %define _snap 20060118
15
16 # release candidate
17 #define _rc             2
18
19 %define _rel    0.2
20
21 %if 0%{?_rc:1}
22 %define _source http://eventum.mysql.org/eventum-1.7.0.tar.gz
23 %else
24 %if 0%{?_snap}
25 %define _source http://downloads.mysql.com/snapshots/%{name}/%{name}-nightly-%{_snap}.tar.gz
26 %else
27 %define _source http://mysql.dataphone.se/Downloads/%{name}/%{name}-%{version}.tar.gz
28 %endif
29 %endif
30
31 %{?with_pear:%include   /usr/lib/rpm/macros.php}
32 Summary:        Eventum Issue / Bug tracking system
33 Summary(pl):    Eventum - system ¶ledzenia spraw/b³êdów
34 Name:           eventum
35 Version:        1.7.0
36 Release:        %{?_snap:4.%{_snap}.}%{?_rc:%{_rc}.}%{_rel}
37 License:        GPL
38 Group:          Applications/WWW
39 Source0:        %{_source}
40 # Source0-md5:  dafef066667ead53f415c11690033b93
41 Source1:        %{name}-apache.conf
42 Source2:        %{name}-mail-queue.cron
43 Source3:        %{name}-mail-download.cron
44 Source4:        %{name}-reminder.cron
45 Source5:        %{name}-monitor.cron
46 Source6:        %{name}-cvs.php
47 Source7:        %{name}-irc.php
48 Source8:        %{name}-irc.init
49 Source9:        %{name}-irc.sysconfig
50 Source10:       %{name}-config.php
51 Source11:       %{name}-router-qmail.sh
52 Source12:       http://dev.mysql.com/common/favicon.ico
53 # Source12-md5: 858be0130832da4144c08d4b59116411
54 Source13:       %{name}-config-setup.php
55 Source14:       %{name}-upgrade.sh
56 Patch0:         %{name}-paths.patch
57 Patch1:         %{name}-cvs-config.patch
58 Patch2:         %{name}-irc-config.patch
59 Patch3:         %{name}-PEAR.patch
60 Patch4:         http://glen.alkohol.ee/pld/%{name}-reply-subject.patch
61 Patch5:         %{name}-lf.patch
62 Patch6:         http://glen.alkohol.ee/pld/%{name}-maq-subject.patch
63 Patch7:         %{name}-bot-reconnect.patch
64 Patch8:         %{name}-perms.patch
65 Patch9:         http://glen.alkohol.ee/pld/%{name}-httpclient-clientside.patch
66 Patch10:        %{name}-cli-wr-separated.patch
67 Patch12:        %{name}-htmloptions-truncate.patch
68 Patch13:        http://glen.alkohol.ee/pld/%{name}-link_filter-updates.patch
69 Patch14:        http://glen.alkohol.ee/pld/%{name}-irc-mem.patch
70 Patch16:        http://glen.alkohol.ee/pld/eventum-recent_activity-usability.patch
71 Patch17:        http://glen.alkohol.ee/pld/eventum-upload-error-keep-popup.patch
72 Patch18:        http://glen.alkohol.ee/pld/eventum-scm-parse-response.patch
73 URL:            http://dev.mysql.com/downloads/other/eventum/
74 %{?with_pear:BuildRequires:     rpm-php-pearprov >= 4.0.2-98}
75 BuildRequires:  rpmbuild(macros) >= 1.268
76 BuildRequires:  sed >= 4.0
77 Requires:       %{name}-base = %{version}-%{release}
78 Requires:       Smarty >= 2.6.2
79 Requires:       php >= 3:4.2.0
80 Requires:       php-gd
81 Requires:       php-imap
82 Requires:       php-mysql
83 Requires:       php-pcre
84 Requires:       php-session
85 %if %{with pear}
86 Requires:       php-pear-Benchmark
87 Requires:       php-pear-DB
88 Requires:       php-pear-Date
89 Requires:       php-pear-HTTP_Request
90 Requires:       php-pear-Mail
91 Requires:       php-pear-Math_Stats
92 Requires:       php-pear-Net_DIME
93 Requires:       php-pear-Net_SMTP
94 Requires:       php-pear-Net_Socket
95 Requires:       php-pear-Net_URL
96 Requires:       php-pear-Net_UserAgent_Detect
97 Requires:       php-pear-PEAR-core
98 Requires:       php-pear-Text_Diff
99 Requires:       php-pear-XML_RPC
100 %endif
101 Requires(triggerpostun):        /usr/bin/php
102 Requires(triggerpostun):        sed >= 4.0
103 Requires:       apache(mod_dir)
104 Requires:       webapps
105 Requires:       webserver = apache
106 BuildArch:      noarch
107 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
108
109 %define         _noautoreq      'pear(/etc/webapps/.*)' 'pear(jpgraph_dir.php)' 'pear(.*Smarty.class.php)'
110
111 %define         _libdir         %{_prefix}/lib/%{name}
112 %define         _appdir         %{_datadir}/%{name}
113 %define         _smartyplugindir        %{_appdir}/include/smarty
114 %define         _smartydir      /usr/share/php/Smarty
115 %define         _webapps        /etc/webapps
116 %define         _webapp         %{name}
117 %define         _webappdir      %{_webapps}/%{_webapp}
118 %define         _sysconfdir     /etc/%{name}
119
120 %description
121 Eventum is a user-friendly and flexible issue tracking system that can
122 be used by a support department to track incoming technical support
123 requests, or by a software development team to quickly organize tasks
124 and bugs. Eventum is used by the MySQL AB Technical Support team, and
125 has allowed us to dramatically improve our response times.
126
127 %description -l pl
128 Eventum to przyjazny dla u¿ytkownika system ¶ledzenia spraw, który
129 mo¿e byæ u¿ywany przez dzia³ obs³ugi do ¶ledzenia przychodz±cych ¿±dañ
130 obs³ugi technicznej albo przez zespó³ tworz±cy oprogramowanie do
131 szybkiej organizacji zadañ i b³êdów. Eventum jest u¿ywany przez zespó³
132 Technical Support MySQL AB i umo¿liwi³ im znacz±co poprawiæ czasy
133 reakcji.
134
135 %package base
136 Summary:        Eventum base package
137 Summary(pl):    Podstawowy pakiet Eventum
138 Group:          Applications/WWW
139 Requires(postun):       /usr/sbin/groupdel
140 Requires(postun):       /usr/sbin/userdel
141 Requires(pre):  /bin/id
142 Requires(pre):  /usr/bin/getgid
143 Requires(pre):  /usr/sbin/groupadd
144 Requires(pre):  /usr/sbin/useradd
145 Provides:       group(eventum)
146 Provides:       user(eventum)
147
148 %description base
149 This package contains base directory structure for Eventum.
150
151 %description base -l pl
152 Ten pakiet zawiera podstawow± strukturê katalogów dla Eventum.
153
154 %package setup
155 Summary:        Eventum setup package
156 Summary(pl):    Pakiet do wstêpnej konfiguracji Eventum
157 Group:          Applications/WWW
158 Requires:       %{name} = %{version}-%{release}
159
160 %description setup
161 Install this package to configure initial Eventum installation. You
162 should uninstall this package when you're done, as it considered
163 insecure to keep the setup files in place.
164
165 %description setup -l pl
166 Ten pakiet nale¿y zainstalowaæ w celu wstêpnej konfiguracji Eventum po
167 pierwszej instalacji. Potem nale¿y go odinstalowaæ, jako ¿e
168 pozostawienie plików instalacyjnych mog³oby byæ niebezpieczne.
169
170 %package mail-queue
171 Summary:        Eventum mail queue process
172 Summary(pl):    Przetwarzanie kolejki poczty Eventum
173 Group:          Applications/WWW
174 Requires:       %{name} = %{version}-%{release}
175 Requires:       /usr/bin/php
176 Requires:       crondaemon
177
178 %description mail-queue
179 Beginning with the first release of Eventum, emails are not directly
180 sent out from the various scripts, but rather added to a mail queue
181 table that is processed by a cron job. If an email cannot be sent, it
182 will be marked as such in the mail queue log, and the cron job script
183 will re-try to send it again the next time it runs.
184
185 This package contains the cron job.
186
187 %description mail-queue -l pl
188 Od pierwszego wydania Eventum poczta nie jest wysy³ana bezpo¶rednio z
189 ró¿nych skryptów, lecz dodawana do kolejki przetwarzanej z crona.
190 Je¶li poczta nie mo¿e byæ wys³ana, bêdzie odpowiednio oznaczona w logu
191 kolejki poczty, a skrypt z crona bêdzie próbowa³ wys³aæ j± ponownie
192 nastêpnym razem.
193
194 Ten pakiet zawiera zadanie dla crona.
195
196 %package mail-download
197 Summary:        Eventum email download
198 Summary(pl):    ¦ci±ganie poczty Eventum
199 Group:          Applications/WWW
200 Requires:       %{name} = %{version}-%{release}
201 Requires:       /usr/bin/php
202 Requires:       crondaemon
203
204 %description mail-download
205 In order for Eventum's email integration feature to work, you need to
206 setup a cron job to run the script every so often.
207
208 This package contains the cron job.
209
210 %description mail-download -l pl
211 Aby integracja poczty elektronicznej w Eventum dzia³a³a, trzeba
212 ustawiæ zadanie crona, aby uruchamia³ odpowiedni skrypt wystarczaj±co
213 czêsto.
214
215 Ten pakiet zawiera zadanie dla crona.
216
217 %package reminder
218 Summary:        Eventum Reminder System
219 Summary(pl):    System przypominania dla Eventum
220 Group:          Applications/WWW
221 Requires:       %{name} = %{version}-%{release}
222 Requires:       /usr/bin/php
223 Requires:       crondaemon
224
225 %description reminder
226 The reminder system was designed with the objective as serving as a
227 safe net for issues that need attention. Depending on what
228 configuration you create, you may have several reminders (or alerts)
229 be sent out whenever an issue needs attention, for whatever parameter
230 you may deem necessary.
231
232 This package contains the cron job.
233
234 %description reminder -l pl
235 System przypominania zosta³ zaprojektowany tak, aby s³u¿y³ jako
236 bezpieczna sieæ dla spraw wymagaj±cych uwagi. W zale¿no¶ci od
237 konfiguracji mo¿na ustawiæ ró¿ne przypominajki (lub alarmy) wysy³ane
238 przy ka¿dej sprawie wymagaj±cej uwagi lub przy parametrze, który mo¿na
239 uwa¿aæ za potrzebny.
240
241 Ten pakiet zawiera zadanie dla crona.
242
243 %package monitor
244 Summary:        Eventum Heartbeat Monitor
245 Summary(pl):    Monitor ¿ycia dla Eventum
246 Group:          Applications/WWW
247 Requires:       %{name} = %{version}-%{release}
248 Requires:       /usr/bin/php
249 Requires:       crondaemon
250 Requires:       php-posix
251
252 %description monitor
253 The heartbeat monitor is a feature designed for the administrator that
254 wants to be alerted whenever a common problem in Eventum is detected,
255 like the database server not being available anymore, or maybe when
256 the recommended permissions for certain configuration files are
257 changed.
258
259 Please note that before running the heartbeat monitor, you may need to
260 customize some of the checks to be appropriate for your own system,
261 particularly the permission and file checks on
262 Monitor::checkConfiguration().
263
264 This package contains the cron job.
265
266 %description monitor -l pl
267 Monitor ¿ycia to funkcjonalno¶æ zaprojektowana dla administratora
268 chc±cego byæ alarmowanym przy ka¿dym wykryciu popularnego problemu z
269 Eventum, jak nie dzia³anie serwera bazy danych albo zmiana uprawnieñ
270 do plików konfiguracyjnych.
271
272 Nale¿y zauwa¿yæ, ¿e przed uruchomieniem tego monitora mo¿e byæ
273 konieczne dostosowanie niektórych testów do systemu, w szczególno¶ci
274 testów uprawnieñ i plików w Monitor::checkConfiguration().
275
276 Ten pakiet zawiera zadanie dla crona.
277
278 %package route-drafts
279 Summary:        Eventum Draft Routing
280 Group:          Applications/WWW
281 Requires:       %{name} = %{version}-%{release}
282 Requires:       /usr/bin/php
283 Requires:       eventum(router)
284
285 %description route-drafts
286 The draft routing feature is used to automatically associate a thread
287 of drafts into an Eventum issue. By setting up qmail (or even postfix)
288 to deliver emails sent to a specific address (usually
289 draft-<number>@<domain>) to the above script, users are able to send
290 drafts written in their mail client to be stored in Eventum. These
291 drafts will NOT broadcasted to the notification list.
292
293 %package route-emails
294 Summary:        Eventum Email Routing
295 Summary(pl):    Przekazywanie poczty dla Eventum
296 Group:          Applications/WWW
297 Requires:       %{name} = %{version}-%{release}
298 Requires:       /usr/bin/php
299 Requires:       eventum(router)
300
301 %description route-emails
302 The email routing feature is used to automatically associate a thread
303 of emails into an Eventum issue. By setting up qmail (or even postfix)
304 to deliver emails sent to a specific address (usually
305 issue-<number>@<domain>) to the above script, users are able to use
306 their email clients to reply to emails coming from Eventum, and those
307 replies will be automatically associated with the issue and
308 broadcasted to the entire notification list.
309
310 %description route-emails -l pl
311 Funkcjonalno¶æ przekazywania poczty s³u¿y do automatycznego wi±zania
312 w±tku listów ze spraw± w Eventum. Po ustawieniu qmaila (czy nawet
313 postfiksa), aby dostarcza³ listy wysy³ane na pewien adres (zwykle
314 issue-<numer>@<domena>) na powy¿szy skrypt, u¿ytkownicy bêd± mogli
315 u¿ywaæ klientów pocztowych do odpowiadania na listy przychodz±ce z
316 Eventum, a odpowiedzi te bêd± automatycznie wi±zane ze spraw± i
317 rozprowadzane do ca³ej listy og³oszeniowej.
318
319 %package route-notes
320 Summary:        Eventum Note Routing
321 Summary(pl):    Przekazywanie notatek dla Eventum
322 Group:          Applications/WWW
323 Requires:       %{name} = %{version}-%{release}
324 Requires:       /usr/bin/php
325 Requires:       eventum(router)
326
327 %description route-notes
328 The note routing feature is used to automatically associate a thread
329 of notes into an Eventum issue. By setting up qmail (or even postfix)
330 to deliver emails sent to a specific address (usually
331 note-<number>@<domain>) to the above script, users are able to use
332 their email clients to reply to internal notes coming from Eventum,
333 and those replies will be automatically associated with the issue and
334 broadcasted to the notification list staff members.
335
336 %description route-notes -l pl
337 Funkcjonalno¶æ przekazywania notatek s³u¿y do automatycznego wi±zania
338 w±tku notatek ze spraw± w Eventum. Po ustawieniu qmaila (czy nawet
339 postfiksa), aby dostarcza³ listy wysy³ane na pewien adres (zwykle
340 note-<numer>@<domena>) na powy¿szy skrypt, u¿ytkownicy bêd± mogli
341 u¿ywaæ klientów pocztowych do odpowiadania na wewnêtrzne notatki
342 pochodz±ce od Eventu, a odpowiedzi te bêd± automatycznie wi±zane ze
343 spraw± i rozprowadzane do cz³onków personelu listy og³oszeniowej.
344
345 %package router-qmail
346 Summary:        Eventum Mail Routing - qmail
347 Summary(pl):    Przekazywanie poczty Eventum - qmail
348 Group:          Applications/Mail
349 # loose dep is intentional. qmail subpackage isn't built on PLD
350 # builders and there really nothing changes.
351 Requires:       %{name} >= %{version}-%{release}
352 Requires:       qmail >= 1.03
353 Provides:       eventum(router)
354 Obsoletes:      eventum(router)
355
356 %description router-qmail
357 This package provides way of routing notes and emails back to Eventum
358 via qmail.
359
360 %description router-qmail -l pl
361 Ten pakiet udostêpnia metodê przekazywania notatek i listów do Eventum
362 przez qmaila.
363
364 %package router-postfix
365 Summary:        Eventum Mail Routing - Postfix
366 Summary(pl):    Przekazywanie poczty Eventum - Postfix
367 Group:          Applications/Mail
368 Requires:       %{name} = %{version}-%{release}
369 Requires:       postfix
370 Provides:       eventum(router)
371 Obsoletes:      eventum(router)
372
373 %description router-postfix
374 This package provides way of routing notes and emails back to Eventum
375 via Postfix.
376
377 %description router-postfix -l pl
378 Ten pakiet udostêpnia metodê przekazywania notatek i listów do Eventum
379 przez Postfiksa.
380
381 %package irc
382 Summary:        Eventum IRC Notification Bot
383 Summary(pl):    IRC-owy bot powiadamiaj±cy dla Eventum
384 Group:          Applications/WWW
385 Requires(triggerpostun):        sed >= 4.0
386 Requires:       %{name} = %{version}-%{release}
387 Requires:       /usr/bin/php
388 Requires:       php-pear-Net_SmartIRC
389 Requires:       php-sockets
390 Requires:       rc-scripts >= 0.4.0.18
391
392 %description irc
393 The IRC notification bot is a nice feature for remote teams that want
394 to handle issues and want to have a quick and easy way to get simple
395 notifications. Right now the bot notifies of the following actions:
396 - New Issues
397 - Blocked emails
398 - Issues that got their assignment list changed
399
400 NOTE: You will need to manually edit the bot.php script to set your
401 appropriate preferences, like IRC server and channel that the bot
402 should join.
403
404 %description irc -l pl
405 IRC-owy bot powiadamiaj±cy to mi³a funkcjonalno¶æ dla zdalnych
406 zespo³ów chc±cych obs³ugiwaæ sprawy i mieæ szybki i ³atwy sposób na
407 uzyskiwanie prostych powiadomieñ. Aktualnie bot powiadamia o
408 nastêpuj±cych zdarzeniach:
409 - nowych sprawach
410 - zablokowanych listach
411 - sprawach, dla których zmieni³a siê lista powi±zañ
412
413 UWAGA: w celu wprowadzenia w³asnych ustawieñ, takich jak serwer IRC i
414 kana³ u¿ywany przez bota, trzeba rêcznie zmodyfikowaæ skrypt bot.php .
415
416 %package cli
417 Summary:        Eventum command-line interface
418 Summary(pl):    Interfejs linii poleceñ dla Eventum
419 Group:          Applications/WWW
420 Requires:       %{name}-base = %{version}-%{release}
421 Requires:       php-cli
422 Requires:       php-common >= 3:4.1.0
423 Requires:       php-curl
424 Requires:       php-pear-XML_RPC
425 Requires:       php-xml
426
427 %description cli
428 The Eventum command-line interface allows you to access most of the
429 features of the web interface straight from your command shell.
430
431 %description cli -l pl
432 Interfejs linii poleceñ Eventum pozwala na dostêp do wiêkszo¶ci
433 funkcji interfejsu WWW prosto z linii poleceñ pow³oki.
434
435 %package scm
436 Summary:        Eventum SCM integration
437 Summary(pl):    Integracja SCM dla Eventum
438 Group:          Applications/WWW
439 Requires:       %{name}-base = %{version}-%{release}
440 Requires:       php-cli
441 Requires:       php-common >= 3:4.1.0
442 Requires:       php-pcre
443
444 %description scm
445 This feature allows your software development teams to integrate your
446 Source Control Management system with your Issue Tracking System.
447
448 The integration is implemented in such a way that it will be forward
449 compatible with pretty much any SCM system, such as CVS.
450
451 For installation see
452 </eventum/help.php?topic=scm_integration_installation>.
453
454 %description scm -l pl
455 Ten pakiet pozwala zespo³om programistów na integracjê systemu
456 zarz±dzania ¼ród³ami (SCM - Source Control Management) z systemem
457 ¶ledzenia spraw.
458
459 Integracja jest zaimplementowana tak, aby byæ kompatybilna w przód z
460 prawie ka¿dym systemem SCM, jak np. CVS.
461
462 Szczegó³y na temat instalacji mo¿na przeczytaæ pod
463 </eventum/help.php?topic=scm_integration_installation>.
464
465 %prep
466 %setup -q %{?_snap:-n %{name}-%{_snap}}
467 # undos the source
468 find . -type f -print0 | xargs -0 sed -i -e 's,\r$,,'
469
470 rm -f setup.conf.php # not to be installed by *.php glob
471 rm -rf misc/upgrade/*v1.[123]* # too old to support in PLD Linux
472 rm -f misc/upgrade/flush_compiled_templates.php
473 rm -rf misc/upgrade/*/upgrade_config.php # not needed nor supported in PLD Linux
474
475 # sample, not used in eventum
476 rm -f rpc/xmlrpc_client.php
477
478 # packaging
479 %patch0 -p1
480 %patch1 -p1
481 %patch14 -p1
482 %patch2 -p1
483 %{?with_pear:%patch3 -p1}
484
485 # bug fixes.
486 %patch4 -p1
487 %patch5 -p1
488 %patch6 -p1
489 %patch7 -p1
490 %patch8 -p1
491 %patch9 -p1
492 %patch10 -p1
493 %patch12 -p1
494 %patch13 -p1
495 %patch16 -p1
496 %patch17 -p1
497 %patch18 -p1
498
499 sed -e '1s,#!.*/bin/php -q,#!%{_bindir}/php,' misc/cli/eventum > %{name}-cli
500 sed -e '1i#!%{_bindir}/php' misc/scm/process_cvs_commits.php > %{name}-scm
501 sed -e '1i#!%{_bindir}/php' misc/irc/bot.php > %{name}-bot
502 mv misc/cli/eventumrc_example eventumrc
503
504 sed -e '
505 s,$private_key\s*=\s*".*";,$private_key = "DEFAULTPRIVATEKEYPLEASERUNSETUP!";,
506 ' < include/private_key.php > private_key.php.in
507 rm -f include/private_key.php
508
509 # replace in remaining scripts config.inc.php to system one
510 grep -rl 'include_once(".*config.inc.php")' . | xargs sed -i -e '
511         s,include_once(".*config.inc.php"),include_once("%{_webappdir}/core.php"),
512 '
513
514 grep -rl 'APP_INC_PATH..*"private_key.php"' . | xargs sed -i -e '
515         s,include_once(APP_INC_PATH.*"private_key.php"),include_once("%{_webappdir}/private_key.php"),
516 '
517
518 # remove backups from patching as we use globs to package files to buildroot
519 find '(' -name '*~' -o -name '*.orig' ')' | xargs -r rm -v
520
521 %install
522 rm -rf $RPM_BUILD_ROOT
523 install -d \
524         $RPM_BUILD_ROOT{%{_webappdir},%{_sysconfdir},%{_bindir},%{_sbindir},%{_libdir}} \
525         $RPM_BUILD_ROOT/etc/{rc.d/init.d,cron.d,sysconfig} \
526         $RPM_BUILD_ROOT/var/{run,log,cache,lib}/%{name} \
527         $RPM_BUILD_ROOT/var/lib/%{name}/routed_{emails,drafts,notes} \
528         $RPM_BUILD_ROOT%{_appdir}/{include,htdocs/misc,upgrade} \
529
530 cp -a *.php css customer images js manage reports rpc setup $RPM_BUILD_ROOT%{_appdir}/htdocs
531 cp -a misc/*.html $RPM_BUILD_ROOT%{_appdir}/htdocs/misc
532 cp -a misc/*.php $RPM_BUILD_ROOT%{_appdir}
533 cp -a templates $RPM_BUILD_ROOT%{_appdir}
534 cp -a include/{customer,jpgraph,pear,workflow} $RPM_BUILD_ROOT%{_appdir}/include
535 cp -a include/*.php $RPM_BUILD_ROOT%{_appdir}/include
536 cp -a logs/* $RPM_BUILD_ROOT/var/log/%{name}
537 cp -a misc/upgrade $RPM_BUILD_ROOT%{_appdir}
538
539 install %{SOURCE12} $RPM_BUILD_ROOT%{_appdir}/htdocs/favicon.ico
540 install %{SOURCE13} $RPM_BUILD_ROOT%{_appdir}/htdocs/setup/config.inc.php
541 install %{SOURCE14} $RPM_BUILD_ROOT%{_appdir}/upgrade/upgrade.sh
542
543 # cli
544 install -d $RPM_BUILD_ROOT%{_appdir}/cli
545 cp -a misc/cli/include/class.{misc,command_line}.php $RPM_BUILD_ROOT%{_appdir}/cli
546 cp -a misc/cli/config.inc.php $RPM_BUILD_ROOT%{_sysconfdir}/cli.php
547 install %{name}-cli $RPM_BUILD_ROOT%{_bindir}/%{name}
548 install %{name}-bot $RPM_BUILD_ROOT%{_sbindir}
549
550 # scm
551 install %{name}-scm $RPM_BUILD_ROOT%{_libdir}/scm
552 install %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}/cvs.php
553
554 # private key
555 cp -a private_key.php.in $RPM_BUILD_ROOT%{_webappdir}/private_key.php
556
557 install %{SOURCE1} $RPM_BUILD_ROOT%{_webappdir}/apache.conf
558 install %{SOURCE1} $RPM_BUILD_ROOT%{_webappdir}/httpd.conf
559 install %{SOURCE2} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-queue
560 install %{SOURCE3} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-download
561 install %{SOURCE4} $RPM_BUILD_ROOT/etc/cron.d/%{name}-reminder
562 install %{SOURCE5} $RPM_BUILD_ROOT/etc/cron.d/%{name}-monitor
563 install %{SOURCE7} $RPM_BUILD_ROOT%{_sysconfdir}/irc.php
564 install %{SOURCE8} $RPM_BUILD_ROOT/etc/rc.d/init.d/eventum-irc
565 install %{SOURCE9} $RPM_BUILD_ROOT/etc/sysconfig/eventum-irc
566
567 sed -e '
568 s,%%{APP_VERSION}%%,%{version}%{?_snap:-%{_snap}},
569 s,%%{PHP_PEAR_DIR}%%,%{?with_pear:%{php_pear_dir}}%{!?with_pear:%{_appdir}/includes/pear},
570 s,%%{APP_PATH}%%,%{_appdir},
571 s,%%{SMARTY_DIR}%%,%{_smartydir},
572 s,%%{SYSCONFDIR}%%,%{_webappdir},
573 ' %{SOURCE10} > $RPM_BUILD_ROOT%{_webappdir}/core.php
574
575 # config
576 > $RPM_BUILD_ROOT%{_webappdir}/setup.php
577 mv $RPM_BUILD_ROOT{%{_appdir}/htdocs/config.inc,%{_webappdir}/config}.php
578
579 %if %{with pear}
580 # provided by PEAR
581 rm -rf $RPM_BUILD_ROOT%{_appdir}/include/pear
582 %endif
583
584 # use system Smarty
585 rm -rf $RPM_BUILD_ROOT%{_appdir}/include/Smarty
586 install -d $RPM_BUILD_ROOT%{_smartyplugindir}
587 # These plugins are not in Smarty package (Smarty-2.6.2-3)
588 cp -a \
589         include/Smarty/plugins/function.{calendar,get_{display_style,innerhtml,textarea_size}}.php \
590         include/Smarty/plugins/modifier.highlight_quoted.php \
591         $RPM_BUILD_ROOT%{_smartyplugindir}
592
593 # qmail router
594 %if %{with qmail}
595 d=$RPM_BUILD_ROOT/var/lib/%{name}
596 echo 'root' > $d/.qmail
597 echo 'root' > $d/.qmail-default
598 echo '| %{_libdir}/router-qmail drafts' > $d/.qmail-draft-default
599 echo '| %{_libdir}/router-qmail emails 1' > $d/.qmail-issue-default
600 echo '| %{_libdir}/router-qmail notes' > $d/.qmail-note-default
601 install %{SOURCE11} $RPM_BUILD_ROOT%{_libdir}/router-qmail
602 %endif
603
604 %clean
605 rm -rf $RPM_BUILD_ROOT
606
607 %pre
608 %addusertogroup http %{name}
609
610 %post
611 # check if the package is configured.
612 if grep -q 'header("Location: setup/")' %{_webappdir}/config.php; then
613 if [ -f %{_appdir}/htdocs/setup/index.php ]; then
614 %banner %{name} -e <<EOF
615
616 You haven't yet configured Eventum!
617 Please open in browser <http://localhost/eventum/>
618 If you need access from elsewhere, you need to edit
619 %{_webappdir}/apache.conf and restart apache.
620
621 IMPORTANT: When You have configured Eventum, please uninstall the
622 setup package, so that %{name}-setup is able to secure your Eventum
623 installation.
624
625 EOF
626 #' vim syntax hack
627 else
628 %banner %{name} -e <<EOF
629
630 You haven't yet configured Eventum!
631
632 To setup eventum, please install %{name}-setup and open in browser
633 <http://localhost/eventum/>.
634 If you need access from elsewhere, you need to edit
635 %{_webappdir}/apache.conf and restart apache.
636
637 IMPORTANT: When You have configured Eventum, please uninstall the
638 setup package, so that %{name}-setup is able to secure your Eventum
639 installation.
640
641 EOF
642 #' vim syntax hack
643 fi
644
645 elif grep -q 'DEFAULTPRIVATEKEY' %{_webappdir}/private_key.php; then
646 %banner %{name} -e <<EOF
647
648 You have default private key installed!
649
650 Install %{name}-setup and open up http://yourserver/eventum/setup/
651 -- that will help you setup initial config.
652
653 when have configured Eventum, please uninstall the setup package,
654 so that %{name}-setup is able to secure your Eventum installation.
655
656 EOF
657         elif [ -d %{_appdir}/setup ]; then
658 %banner %{name} -e <<EOF
659
660 If you have have configured Eventum, please uninstall the setup package,
661 so that %{name}-setup is able to secure your Eventum installation.
662
663 EOF
664 fi
665
666 # nuke Smarty templates cache after upgrade
667 rm -f /var/cache/eventum/*.php
668
669 %preun
670 if [ "$1" = "0" ]; then
671         # nuke cache
672         rm -f /var/cache/eventum/*.php 2>/dev/null || :
673 fi
674
675 %pre base
676 %groupadd -P %{name}-base -g 146 %{name}
677 %useradd -P %{name}-base -u 146 -d /var/lib/%{name} -g %{name} -c "Eventum User" %{name}
678
679 %postun base
680 if [ "$1" = "0" ]; then
681         %userremove %{name}
682         %groupremove %{name}
683 fi
684
685 %post router-qmail
686 CF=/etc/qmail/control/virtualdomains
687 if ! grep -q ':%{name}\b' $CF 2>/dev/null; then
688         FQDN=$(awk -F'"' '/define/ && $2 ~ /APP_HOSTNAME/ {print $4}' %{_webappdir}/config.php 2>/dev/null)
689         [ "$FQDN" ] || FQDN=$(hostname -f 2>/dev/null || echo localhost)
690         umask 022
691         echo "#${FQDN}:%{name}" >> $CF
692
693 %banner %{name}-qmail -e <<EOF
694
695 Added "#${FQDN}:%{name}" to $CF,
696 Please verify that it is correct and restart qmail:
697 # service qmail reload
698
699 Consult qmail-send(8) for more information on virtualdomains.
700
701 EOF
702 fi
703
704 %preun router-qmail
705 if [ "$1" = "0" ]; then
706         sed -i -e '/:%{name}\b/d' /etc/qmail/control/virtualdomains
707 fi
708
709 %post setup
710 chmod 660 %{_webappdir}/{config,private_key}.php
711 chown root:eventum %{_webappdir}/{config,private_key}.php
712
713 %postun setup
714 if [ "$1" = "0" ]; then
715         chmod 640 %{_webappdir}/{config,private_key}.php
716         chown root:eventum %{_webappdir}/{config,private_key}.php
717 fi
718
719 %post irc
720 /sbin/chkconfig --add eventum-irc
721 %service eventum-irc restart "Eventum IRC Bot"
722
723 %triggerin -- apache1
724 %webapp_register apache %{_webapp}
725
726 %triggerun -- apache1
727 %webapp_unregister apache %{_webapp}
728
729 %triggerin -- apache >= 2.0.0
730 %webapp_register httpd %{_webapp}
731
732 %triggerun -- apache >= 2.0.0
733 %webapp_unregister httpd %{_webapp}
734
735 # FIXME
736 # only one upgrade trigger is called if you're upgrading over two
737 # versions, say 1.5 to 1.5.3, only 1.5.3 trigger is called.
738 # use common trigger (the highest version and rpmvercmp from poldek?)
739 %triggerpostun -- eventum < 1.5.1-0.257
740 %{_appdir}/upgrade/upgrade.sh %{_appdir}/upgrade/v1.5_to_v1.5.1 <<EOF
741 database_changes.php Perform database changes
742 EOF
743
744 %triggerpostun -- eventum < 1.5.2-0.289
745 %{_appdir}/upgrade/upgrade.sh %{_appdir}/upgrade/v1.5.1_to_v1.5.2 <<EOF
746 database_changes.php Perform database changes
747 set_priority_ranks.php Fix the ranking of priority values
748 EOF
749
750 %triggerpostun -- eventum < 1.5.3-0.291
751 %{_appdir}/upgrade/upgrade.sh %{_appdir}/upgrade/v1.5.2_to_v1.5.3 <<EOF
752 database_changes.php Perform database changes
753 EOF
754
755 %triggerpostun -- eventum < 1.5.4-1.12
756 %{_appdir}/upgrade/upgrade.sh %{_appdir}/upgrade/v1.5.3_to_v1.5.4 <<EOF
757 database_changes.php Perform database changes
758 EOF
759
760 %triggerpostun -- eventum < 1.6.0-RC2.6
761 %{_appdir}/upgrade/upgrade.sh %{_appdir}/upgrade/v1.5.5_to_v1.6.0 <<EOF
762 database_changes.php Perform database changes
763 upgrade_saved_searches.php Upgrade existing custom filters (saved searches)
764 EOF
765
766 %triggerpostun -- eventum < 1.6.1-0.2
767 %{_appdir}/upgrade/upgrade.sh %{_appdir}/upgrade/v1.6.0_to_v1.6.1 <<EOF
768 database_changes.php Perform database changes
769 EOF
770
771 %triggerpostun irc -- eventum-irc < 1.6.1-3.14
772 sed -i -e '
773 s,\$irc_host,$irc_server_hostname,
774 s,\$irc_port,$irc_server_port,
775 s,\$irc_nick,$nickname,
776 s,\$irc_realname,$realname,
777 s,\$irc_username,$username,
778 s,\$irc_password,$password,
779 ' /etc/eventum/irc.php
780
781 %triggerpostun -- eventum < 1.7.0-2.0.48
782 # migrate from apache-config macros
783 if [ -f /etc/%{name}/apache.conf.rpmsave ]; then
784         if [ -d /etc/apache/webapps.d ]; then
785                 cp -f %{_webapps}/%{_webapp}/apache.conf{,.rpmnew}
786                 cp -f /etc/%{name}/apache.conf.rpmsave %{_webapps}/%{_webapp}/apache.conf
787         fi
788
789         if [ -d /etc/httpd/webapps.d ]; then
790                 cp -f %{_webapps}/%{_webapp}/httpd.conf{,.rpmnew}
791                 cp -f /etc/%{name}/apache.conf.rpmsave %{_webapps}/%{_webapp}/httpd.conf
792         fi
793 fi
794
795 if [ -L /etc/apache/conf.d/99_%{_webapp}.conf ]; then
796         /usr/sbin/webapp register apache %{_webapp}
797         rm -f /etc/apache/conf.d/99_%{_webapp}.conf
798         %service -q apache reload
799 fi
800 if [ -L /etc/httpd/httpd.conf/99_%{_webapp}.conf ]; then
801         /usr/sbin/webapp register httpd %{_webapp}
802         rm -f /etc/httpd/httpd.conf/99_%{_webapp}.conf
803         %service -q httpd reload
804 fi
805
806 %{_appdir}/upgrade/upgrade.sh %{_appdir}/upgrade/v1.6.1_to_v1.7.0 <<EOF
807 database_changes.php Perform database changes
808 set_root_message_ids.php Set iss_root_message_id
809 EOF
810
811 # regular configs
812 for i in apache.conf config.php private_key.php setup.php; do
813         if [ -f /etc/eventum/$i.rpmsave ]; then
814                 mv -f %{_webappdir}/$i{,.rpmnew}
815                 mv -f /etc/eventum/$i.rpmsave %{_webappdir}/$i
816         fi
817 done
818
819 %triggerpostun cli -- %{name}-cli < 1.7.0-3.4
820 if [ -f %{_webappdir}/cli.php.rpmsave ]; then
821         mv -f %{_sysconfdir}/cli.php{,.rpmnew}
822         mv -f %{_webappdir}/cli.php.rpmsave %{_sysconfdir}/cli.php
823 fi
824
825 %triggerpostun irc -- %{name}-irc < 1.7.0-3.4
826 if [ -f %{_webappdir}/irc.php.rpmsave ]; then
827         mv -f %{_sysconfdir}/irc.php{,.rpmnew}
828         mv -f %{_webappdir}/irc.php.rpmsave %{_sysconfdir}/irc.php
829 fi
830
831 %files
832 %defattr(644,root,root,755)
833 %doc ChangeLog FAQ INSTALL README UPGRADE CONTRIB
834 %doc docs/* setup/schema.sql
835 %attr(751,root,root) %dir %{_webappdir}
836 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/apache.conf
837 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/httpd.conf
838 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/config.php
839 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/private_key.php
840 %attr(660,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/setup.php
841 %attr(640,root,eventum) %config %verify(not mtime) %{_webappdir}/core.php
842
843 %dir %attr(731,root,eventum) /var/log/%{name}
844 %attr(620,root,eventum) %ghost /var/log/%{name}/*
845
846 %dir %{_appdir}/htdocs
847 %{_appdir}/htdocs/*.php
848 %{_appdir}/htdocs/*.ico
849 %{_appdir}/htdocs/css
850 %{_appdir}/htdocs/customer
851 %{_appdir}/htdocs/images
852 %{_appdir}/htdocs/js
853 %{_appdir}/htdocs/manage
854 %{_appdir}/htdocs/reports
855 %{_appdir}/htdocs/rpc
856 %{_appdir}/htdocs/misc
857
858 %{_appdir}/templates
859 %dir %{_appdir}/upgrade
860 %attr(755,root,root) %{_appdir}/upgrade/upgrade.sh
861 %{_appdir}/upgrade/[!u]*
862
863 %{_smartyplugindir}
864 %if %{without pear}
865 %{_appdir}/include/pear
866 %endif
867
868 %dir %{_appdir}/include
869 %{_appdir}/include/customer
870 %{_appdir}/include/jpgraph
871 %{_appdir}/include/workflow
872 %{_appdir}/include/class.[!m]*.php
873 %{_appdir}/include/class.mail.php
874 %{_appdir}/include/class.mail_queue.php
875 %{_appdir}/include/class.mime_helper.php
876 %{_appdir}/include/class.misc.php
877 %{_appdir}/include/db_access.php
878
879 %dir %attr(730,root,eventum) /var/run/%{name}
880 %dir %attr(730,root,eventum) /var/cache/%{name}
881
882 %files base
883 %defattr(644,root,root,755)
884 %attr(751,root,root) %dir %{_sysconfdir}
885 %dir %{_libdir}
886 %dir %{_appdir}
887 # qmail will ignore user, if it's home directory is not owned
888 %attr(750,eventum,eventum) %dir /var/lib/%{name}
889 # saved mail copies
890 %attr(770,root,eventum) %dir /var/lib/%{name}/routed_emails
891 %attr(770,root,eventum) %dir /var/lib/%{name}/routed_drafts
892 %attr(770,root,eventum) %dir /var/lib/%{name}/routed_notes
893
894 %files setup
895 %defattr(644,root,root,755)
896 %{_appdir}/htdocs/setup
897
898 %files mail-queue
899 %defattr(644,root,root,755)
900 %{_appdir}/process_mail_queue.php
901 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-queue
902
903 %files mail-download
904 %defattr(644,root,root,755)
905 %{_appdir}/download_emails.php
906 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-download
907
908 %files reminder
909 %defattr(644,root,root,755)
910 %{_appdir}/check_reminders.php
911 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-reminder
912
913 %files monitor
914 %defattr(644,root,root,755)
915 %{_appdir}/include/class.monitor.php
916 %{_appdir}/monitor.php
917 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-monitor
918
919 %files route-drafts
920 %defattr(644,root,root,755)
921 %{_appdir}/route_drafts.php
922
923 %files route-emails
924 %defattr(644,root,root,755)
925 %{_appdir}/route_emails.php
926
927 %files route-notes
928 %defattr(644,root,root,755)
929 %{_appdir}/route_notes.php
930
931 %if %{with qmail}
932 %files router-qmail
933 %defattr(644,root,root,755)
934 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) /var/lib/%{name}/.qmail*
935 %attr(755,root,root) %{_libdir}/router-qmail
936 %endif
937
938 %files router-postfix
939 %defattr(644,root,root,755)
940
941 %files irc
942 %defattr(644,root,root,755)
943 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/irc.php
944 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/eventum-irc
945 %attr(755,root,root) %{_sbindir}/%{name}-bot
946 %attr(754,root,root) /etc/rc.d/init.d/%{name}-irc
947
948 %files cli
949 %defattr(644,root,root,755)
950 %doc eventumrc
951 %attr(644,root,root) %config %verify(not md5 mtime size) %{_sysconfdir}/cli.php
952 %attr(755,root,root) %{_bindir}/%{name}
953 %{_appdir}/cli
954
955 %files scm
956 %defattr(644,root,root,755)
957 %attr(644,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/cvs.php
958 %attr(755,root,root) %{_libdir}/scm
This page took 0.126676 seconds and 4 git commands to generate.