]> git.pld-linux.org Git - packages/eventum.git/blob - eventum.spec
- add maildecode fix and typo fix patches
[packages/eventum.git] / eventum.spec
1 # TODO
2 # - system pear is incompatible, at least pear DB class seems broke Eventum
3 # - php5 is not tested, but not placing hard conflict on it, as it prevents php4 & php coinstallation
4 # - discard bundled packages (from INSTALL):
5 #  - JpGraph 1.5.3 (last GPL version)
6 #  - dTree 2.0.5 (http://www.destroydrop.com/javascript/tree/)
7 #  - dynCalendar.js (http://www.phpguru.org/dyncalendar.html)
8 #  - overLIB 3.5.1 (http://www.bosrup.com/web/overlib/)
9 #  - A few other small javascript libraries
10 # - create eventum-router-qmail, eventum-router-postfix for -route-mails and -route-notes
11 # - need start-stop-daemon (from dpkg for now)
12 # - use eventum user for irc bot?
13
14 %bcond_with     pear    # build with system PEAR packages (or use bundled ones)
15
16 # snapshot: DATE
17 #define _snap 20050124
18
19 %if 0%{?_snap}
20 %define _source http://downloads.mysql.com/snapshots/%{name}/%{name}-nightly-%{_snap}.tar.gz
21 %else
22 %define _source http://mysql.wildyou.net/Downloads/%{name}/%{name}-%{version}.tar.gz
23 %endif
24
25 %define _rel 1.137
26
27 Summary:        Eventum Issue - a bug tracking system
28 Summary(pl):    Eventum - system ¶ledzenia spraw/b³êdów
29 Name:           eventum
30 Version:        1.4
31 Release:        %{?_snap:0.%{_snap}.}%{_rel}
32 License:        GPL
33 Group:          Applications/WWW
34 Source0:        %{_source}
35 # Source0-md5:  361c1355e46a6bbfa54e420964ec92cf
36 Source1:        %{name}-apache.conf
37 Source2:        %{name}-mail-queue.cron
38 Source3:        %{name}-mail-download.cron
39 Source4:        %{name}-reminder.cron
40 Source5:        %{name}-monitor.cron
41 Source6:        %{name}-cvs.php
42 Source7:        %{name}-irc.php
43 Source8:        %{name}-irc.init
44 Patch0:         %{name}-paths.patch
45 Patch1:         %{name}-scm-encode.patch
46 Patch2:         %{name}-cvs-config.patch
47 Patch3:         %{name}-irc-config.patch
48 Patch4:         %{name}-PEAR.patch
49 Patch10:                %{name}-clock-status.patch
50 Patch11:                %{name}-scm_checkin_associated.patch
51 Patch12:                %{name}-mail-queue.tpl.patch
52 Patch13:                %{name}-maildecode.patch
53 Patch14:                %{name}-send-typo.patch
54 URL:            http://dev.mysql.com/downloads/other/eventum/index.html
55 BuildRequires:  rpmbuild(macros) >= 1.177
56 BuildRequires:  sed >= 4.0
57 Requires:       php >= 4.1.0
58 Requires:       php-gd
59 Requires:       php-imap
60 Requires:       php-mysql
61 Requires:       php-pcre
62 Requires:       %{name}-base = %{epoch}:%{version}-%{release}
63 %if %{with pear}
64 Requires:       Smarty >= 2.6.2
65 Requires:       php-pear-Benchmark
66 Requires:       php-pear-DB
67 Requires:       php-pear-Date
68 Requires:       php-pear-HTTP_Request
69 Requires:       php-pear-Mail
70 Requires:       php-pear-Math_Stats
71 Requires:       php-pear-Net_DIME
72 Requires:       php-pear-Net_POP3
73 Requires:       php-pear-Net_SMTP
74 Requires:       php-pear-Net_SmartIRC
75 Requires:       php-pear-Net_Socket
76 Requires:       php-pear-Net_URL
77 Requires:       php-pear-Net_UserAgent_Detect
78 Requires:       php-pear-PEAR
79 Requires:       php-pear-Text_Diff
80 Requires:       php-pear-XML_RPC
81 %endif
82 #Requires:      apache-mod_dir
83 # conflict with non-confdir apache
84 Conflicts:      apache1 < 1.3.33-1.1
85 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
86
87 %define         _sysconfdir     /etc/%{name}
88 %define         _appdir %{_datadir}/%{name}
89 %define         _smartyplugindir        %{php_pear_dir}/Smarty/plugins
90
91 %define         _apache1dir     /etc/apache
92 %define         _apache2dir     /etc/httpd
93
94 %description
95 Eventum is a user-friendly and flexible issue tracking system that can
96 be used by a support department to track incoming technical support
97 requests, or by a software development team to quickly organize tasks
98 and bugs. Eventum is used by the MySQL AB Technical Support team, and
99 has allowed us to dramatically improve our response times.
100
101 %description -l pl
102 Eventum to przyjazny dla u¿ytkownika system ¶ledzenia spraw, który
103 mo¿e byæ u¿ywany przez dzia³ obs³ugi do ¶ledzenia przychodz±cych ¿±dañ
104 obs³ugi technicznej albo przez zespó³ tworz±cy oprogramowanie do
105 szybkiej organizacji zadañ i b³êdów. Eventum jest u¿ywany przez zespó³
106 Technical Support MySQL AB i umo¿liwi³ im znacz±co poprawiæ czasy
107 reakcji.
108
109 %package base
110 Summary:        Eventum base package
111 Summary(pl):    Podstawowy pakiet Eventum
112 Group:          Applications/WWW
113
114 %description base
115 This package contains base directory structure for Eventum.
116
117 %description base -l pl
118 Ten pakiet zawiera podstawow± strukturê katalogów dla Eventum.
119
120 %package setup
121 Summary:        Eventum setup package
122 Summary(pl):    Pakiet do wstêpnej konfiguracji Eventum
123 Group:          Applications/WWW
124 PreReq:         %{name} = %{epoch}:%{version}-%{release}
125
126 %description setup
127 Install this package to configure initial Eventum installation. You
128 should uninstall this package when you're done, as it considered
129 insecure to keep the setup files in place.
130
131 %description setup -l pl
132 Ten pakiet nale¿y zainstalowaæ w celu wstêpnej konfiguracji Eventum po
133 pierwszej instalacji. Potem nale¿y go odinstalowaæ, jako ¿e
134 pozostawienie plików instalacyjnych mog³oby byæ niebezpieczne.
135
136 %package mail-queue
137 Summary:        Eventum mail queue process
138 Summary(pl):    Przetwarzanie kolejki poczty Eventum
139 Group:          Applications/WWW
140 Requires:       %{name} = %{epoch}:%{version}-%{release}
141 Requires:       crondaemon
142 Requires:       php4 >= 4.1.0
143
144 %description mail-queue
145 Beginning with the first release of Eventum, emails are not directly
146 sent out from the various scripts, but rather added to a mail queue
147 table that is processed by a cron job. If an email cannot be sent, it
148 will be marked as such in the mail queue log, and the cron job script
149 will re-try to send it again the next time it runs.
150
151 This package contains the cron job.
152
153 %description mail-queue -l pl
154 Od pierwszego wydania Eventum poczta nie jest wysy³ana bezpo¶rednio z
155 ró¿nych skryptów, lecz dodawana do kolejki przetwarzanej z crona.
156 Je¶li poczta nie mo¿e byæ wys³ana, bêdzie odpowiednio oznaczona w logu
157 kolejki poczty, a skrypt z crona bêdzie próbowa³ wys³aæ j± ponownie
158 nastêpnym razem.
159
160 Ten pakiet zawiera zadanie dla crona.
161
162 %package mail-download
163 Summary:        Eventum email download
164 Summary(pl):    ¦ci±ganie poczty Eventum
165 Group:          Applications/WWW
166 Requires:       %{name} = %{epoch}:%{version}-%{release}
167 Requires:       crondaemon
168 Requires:       php4 >= 4.1.0
169
170 %description mail-download
171 In order for Eventum's email integration feature to work, you need to
172 setup a cron job to run the script every so often.
173
174 This package contains the cron job.
175
176 %description mail-download -l pl
177 Aby integracja poczty elektronicznej w Eventum dzia³a³a, trzeba
178 ustawiæ zadanie crona, aby uruchamia³ odpowiedni skrypt wystarczaj±co
179 czêsto.
180
181 Ten pakiet zawiera zadanie dla crona.
182
183 %package reminder
184 Summary:        Eventum Reminder System
185 Summary(pl):    System przypominania dla Eventum
186 Group:          Applications/WWW
187 Requires:       %{name} = %{epoch}:%{version}-%{release}
188 Requires:       php4 >= 4.1.0
189 Requires:       crondaemon
190
191 %description reminder
192 The reminder system was designed with the objective as serving as a
193 safe net for issues that need attention. Depending on what
194 configuration you create, you may have several reminders (or alerts)
195 be sent out whenever an issue needs attention, for whatever parameter
196 you may deem necessary.
197
198 This package contains the cron job.
199
200 %description reminder -l pl
201 System przypominania zosta³ zaprojektowany tak, aby s³u¿y³ jako
202 bezpieczna sieæ dla spraw wymagaj±cych uwagi. W zale¿no¶ci od
203 konfiguracji mo¿na ustawiæ ró¿ne przypominajki (lub alarmy) wysy³ane
204 przy ka¿dej sprawie wymagaj±cej uwagi lub przy parametrze, który mo¿na
205 uwa¿aæ za potrzebny.
206
207 Ten pakiet zawiera zadanie dla crona.
208
209 %package monitor
210 Summary:        Eventum Heartbeat Monitor
211 Summary(pl):    Monitor ¿ycia dla Eventum
212 Group:          Applications/WWW
213 Requires:       %{name} = %{epoch}:%{version}-%{release}
214 Requires:       php4 >= 4.1.0
215 Requires:       crondaemon
216
217 %description monitor
218 The heartbeat monitor is a feature designed for the administrator that
219 wants to be alerted whenever a common problem in Eventum is detected,
220 like the database server not being available anymore, or maybe when
221 the recommended permissions for certain configuration files are
222 changed.
223
224 Please note that before running the heartbeat monitor, you may need to
225 customize some of the checks to be appropriate for your own system,
226 particularly the permission and file checks on
227 Monitor::checkConfiguration().
228
229 This package contains the cron job.
230
231 %description monitor -l pl
232 Monitor ¿ycia to funkcjonalno¶æ zaprojektowana dla administratora
233 chc±cego byæ alarmowanym przy ka¿dym wykryciu popularnego problemu z
234 Eventum, jak nie dzia³anie serwera bazy danych albo zmiana uprawnieñ
235 do plików konfiguracyjnych.
236
237 Nale¿y zauwa¿yæ, ¿e przed uruchomieniem tego monitora mo¿e byæ
238 konieczne dostosowanie niektórych testów do systemu, w szczególno¶ci
239 testów uprawnieñ i plików w Monitor::checkConfiguration().
240
241 Ten pakiet zawiera zadanie dla crona.
242
243 %package route-emails
244 Summary:        Eventum Email Routing
245 Summary(pl):    Przekazywanie poczty dla Eventum
246 Group:          Applications/WWW
247 Requires:       %{name} = %{epoch}:%{version}-%{release}
248 Requires:       php4 >= 4.1.0
249 #Requires:      eventum-router
250
251 %description route-emails
252 The email routing feature is used to automatically associate a thread
253 of emails into an Eventum issue. By setting up qmail (or even postfix)
254 to deliver emails sent to a specific address (usually
255 issue-<number>@<domain>) to the above script, users are able to use
256 their email clients to reply to emails coming from Eventum, and those
257 replies will be automatically associated with the issue and
258 broadcasted to the entire notification list.
259
260 %description route-emails -l pl
261 Funkcjonalno¶æ przekazywania poczty s³u¿y do automatycznego wi±zania
262 w±tku listów ze spraw± w Eventum. Po ustawieniu qmaila (czy nawet
263 postfiksa), aby dostarcza³ listy wysy³ane na pewien adres (zwykle
264 issue-<numer>@<domena>) na powy¿szy skrypt, u¿ytkownicy bêd± mogli
265 u¿ywaæ klientów pocztowych do odpowiadania na listy przychodz±ce z
266 Eventum, a odpowiedzi te bêd± automatycznie wi±zane ze spraw± i
267 rozprowadzane do ca³ej listy og³oszeniowej.
268
269 %package route-notes
270 Summary:        Eventum Note Routing
271 Summary(pl):    Przekazywanie notatek dla Eventum
272 Group:          Applications/WWW
273 Requires:       %{name} = %{epoch}:%{version}-%{release}
274 Requires:       php4 >= 4.1.0
275 #Requires:      eventum-router
276
277 %description route-notes
278 The note routing feature is used to automatically associate a thread
279 of notes into an Eventum issue. By setting up qmail (or even postfix)
280 to deliver emails sent to a specific address (usually
281 note-<number>@<domain>) to the above script, users are able to use
282 their email clients to reply to internal notes coming from Eventum,
283 and those replies will be automatically associated with the issue and
284 broadcasted to the notification list staff members.
285
286 %description route-notes -l pl
287 Funkcjonalno¶æ przekazywania notatek s³u¿y do automatycznego wi±zania
288 w±tku notatek ze spraw± w Eventum. Po ustawieniu qmaila (czy nawet
289 postfiksa), aby dostarcza³ listy wysy³ane na pewien adres (zwykle
290 note-<numer>@<domena>) na powy¿szy skrypt, u¿ytkownicy bêd± mogli
291 u¿ywaæ klientów pocztowych do odpowiadania na wewnêtrzne notatki
292 pochodz±ce od Eventu, a odpowiedzi te bêd± automatycznie wi±zane ze
293 spraw± i rozprowadzane do cz³onków personelu listy og³oszeniowej.
294
295 %package irc
296 Summary:        Eventum IRC Notification Bot
297 Summary(pl):    IRC-owy bot powiadamiaj±cy dla Eventum
298 Group:          Applications/WWW
299 Requires:       %{name} = %{epoch}:%{version}-%{release}
300 Requires:       php >= 4.1.0
301 Requires:       php-sockets
302 # FIXME just need start-stop-daemon
303 Requires:       dpkg
304
305 %description irc
306 The IRC notification bot is a nice feature for remote teams that want
307 to handle issues and want to have a quick and easy way to get simple
308 notifications. Right now the bot notifies of the following actions:
309 - New Issues
310 - Blocked emails
311 - Issues that got their assignment list changed
312
313 NOTE: You will need to manually edit the bot.php script to set your
314 appropriate preferences, like IRC server and channel that the bot
315 should join.
316
317 %description irc -l pl
318 IRC-owy bot powiadamiaj±cy to mi³a funkcjonalno¶æ dla zdalnych
319 zespo³ów chc±cych obs³ugiwaæ sprawy i mieæ szybki i ³atwy sposób na
320 uzyskiwanie prostych powiadomieñ. Aktualnie bot powiadamia o
321 nastêpuj±cych zdarzeniach:
322 - nowych sprawach
323 - zablokowanych listach
324 - sprawach, dla których zmieni³a siê lista powi±zañ
325
326 UWAGA: w celu wprowadzenia w³asnych ustawieñ, takich jak serwer IRC i
327 kana³ u¿ywany przez bota, trzeba rêcznie zmodyfikowaæ skrypt bot.php .
328
329 %package cli
330 Summary:        Eventum command-line interface
331 Summary(pl):    Interfejs linii poleceñ dla Eventum
332 Group:          Applications/WWW
333 Requires:       %{name} = %{epoch}:%{version}-%{release}
334 Requires:       php4 >= 4.1.0
335 Requires:       php4-cli
336 Requires:       php4-curl
337 Requires:       php4-xml
338 Requires:       php-pear-XML_RPC
339
340 %description cli
341 The Eventum command-line interface allows you to access most of the
342 features of the web interface straight from your command shell.
343
344 %description cli -l pl
345 Interfejs linii poleceñ Eventum pozwala na dostêp do wiêkszo¶ci
346 funkcji interfejsu WWW prosto z linii poleceñ pow³oki.
347
348 %package scm
349 Summary:        Eventum SCM integration
350 Summary(pl):    Integracja SCM dla Eventum
351 Group:          Applications/WWW
352 Requires:       %{name}-base = %{epoch}:%{version}-%{release}
353 Requires:       php4 >= 4.1.0
354
355 %description scm
356 This feature allows your software development teams to integrate your
357 Source Control Management system with your Issue Tracking System.
358
359 The integration is implemented in such a way that it will be forward
360 compatible with pretty much any SCM system, such as CVS.
361
362 For installation see
363 /eventum/help.php?topic=scm_integration_installation .
364
365 %description scm -l pl
366 Ten pakiet pozwala zespo³om programistów na integracjê systemu
367 zarz±dzania ¼ród³ami (SCM - Source Control Management) z systemem
368 ¶ledzenia spraw.
369
370 Integracja jest zaimplementowana tak, aby byæ kompatybilna w przód z
371 prawie ka¿dym systemem SCM, jak np. CVS.
372
373 Szczegó³y na temat instalacji mo¿na przeczytaæ pod
374 /eventum/help.php?topic=scm_integration_installation .
375
376 %prep
377 %setup -q %{?_snap:-n %{name}-%{_snap}}
378 # undos the source
379 find . -type f -print0 | xargs -0 sed -i -e 's,
380 $,,'
381
382 # packaging
383 %patch0 -p1 -b .paths
384 %patch1 -p1
385 %patch2 -p1
386 %patch3 -p1
387 %{?with_pear:%patch4 -p1 -b .PEAR}
388
389 # bug fixes
390 %patch10 -p1
391 %patch11 -p1
392 %patch12 -p1
393 %patch13 -p1
394 %patch14 -p1
395
396 rm -f */*~ */*/*~
397
398 %install
399 rm -rf $RPM_BUILD_ROOT
400 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_bindir},%{_appdir}} \
401         $RPM_BUILD_ROOT{/etc/{rc.d/init.d,cron.d},/var/log/%{name}} \
402         $RPM_BUILD_ROOT{/var/run/eventum,/var/cache/eventum}
403
404 cp -a *.php {css,customer,images,include,js} \
405         {manage,misc,reports,rpc,setup,templates} $RPM_BUILD_ROOT%{_appdir}
406 cp -a logs/* $RPM_BUILD_ROOT/var/log/%{name}
407
408 > $RPM_BUILD_ROOT%{_appdir}/setup.conf.php
409
410 sed -i -e 's,/usr/local/bin/php,/usr/bin/php4,' $RPM_BUILD_ROOT%{_appdir}/misc/cli/eventum
411 echo '#!/usr/bin/php4 -q' > %{name}-scm
412 cat $RPM_BUILD_ROOT%{_appdir}/misc/scm/process_cvs_commits.php >> %{name}-scm
413
414 # change private key, so we can easily grep
415 sed -i -e '
416 s,$private_key\s*=\s*".*";,$private_key = "DEFAULTPRIVATEKEYPLEASERUNSETUP!";,
417 ' $RPM_BUILD_ROOT%{_appdir}/include/private_key.php
418
419 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/apache.conf
420 install %{SOURCE2} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-queue
421 install %{SOURCE3} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-download
422 install %{SOURCE4} $RPM_BUILD_ROOT/etc/cron.d/%{name}-reminder
423 install %{SOURCE5} $RPM_BUILD_ROOT/etc/cron.d/%{name}-monitor
424 install %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}/cvs.php
425 install %{SOURCE7} $RPM_BUILD_ROOT%{_sysconfdir}/irc.php
426 install %{SOURCE8} $RPM_BUILD_ROOT/etc/rc.d/init.d/eventum-irc
427
428 # in conf
429 mv $RPM_BUILD_ROOT%{_appdir}/config.inc.php $RPM_BUILD_ROOT%{_sysconfdir}/config.php
430 mv $RPM_BUILD_ROOT%{_appdir}/setup.conf.php $RPM_BUILD_ROOT%{_sysconfdir}/setup.php
431 mv $RPM_BUILD_ROOT%{_appdir}/include/private_key.php $RPM_BUILD_ROOT%{_sysconfdir}
432 mv $RPM_BUILD_ROOT%{_appdir}/misc/cli/config.inc.php $RPM_BUILD_ROOT%{_sysconfdir}/cli.php
433 ln -s %{_sysconfdir}/config.php $RPM_BUILD_ROOT%{_appdir}/config.inc.php
434 ln -s %{_sysconfdir}/setup.php $RPM_BUILD_ROOT%{_appdir}/setup.conf.php
435 ln -s %{_sysconfdir}/private_key.php $RPM_BUILD_ROOT%{_appdir}/include/private_key.php
436
437 # in doc
438 rm -rf $RPM_BUILD_ROOT%{_appdir}/misc/upgrade
439 # sample, not used in eventum
440 rm -rf $RPM_BUILD_ROOT%{_appdir}/rpc/xmlrpc_client.php
441
442 # in bindir
443 mv $RPM_BUILD_ROOT%{_appdir}/misc/cli/eventum $RPM_BUILD_ROOT%{_bindir}
444 rm -f $RPM_BUILD_ROOT%{_appdir}/misc/{cli/eventumrc_example,scm/process_cvs_commits.php}
445 cp misc/cli/eventumrc_example eventumrc
446 install %{name}-scm $RPM_BUILD_ROOT%{_bindir}/%{name}-scm
447
448 %if %{with pear}
449 # provided by PEAR
450 rm -rf $RPM_BUILD_ROOT%{_appdir}/misc/cli/include/pear
451 rm -rf $RPM_BUILD_ROOT%{_appdir}/include/pear
452
453 # use system Smarty
454 rm -rf $RPM_BUILD_ROOT%{_appdir}/include/Smarty
455 install -d $RPM_BUILD_ROOT%{_smartyplugindir}
456 # These plugins are not in Smarty package (Smarty-2.6.2-3)
457 cp -a include/Smarty/plugins/function.{calendar,get_{display_style,innerhtml,textarea_size}}.php $RPM_BUILD_ROOT%{_smartyplugindir}
458 %endif
459
460 %clean
461 rm -rf $RPM_BUILD_ROOT
462
463 %post
464 # apache1
465 if [ -f %{_apache1dir}/apache.conf ]; then
466         ln -sf %{_sysconfdir}/apache.conf %{_apache1dir}/conf.d/99_%{name}.conf
467         if [ -f /var/lock/subsys/apache ]; then
468                 /etc/rc.d/init.d/apache restart 1>&2
469         fi
470 fi
471 # apache2
472 if [ -d %{_apache2dir}/httpd.conf ]; then
473         ln -sf %{_sysconfdir}/apache.conf %{_apache2dir}/httpd.conf/99_%{name}.conf
474         if [ -f /var/lock/subsys/httpd ]; then
475                 /etc/rc.d/init.d/httpd restart 1>&2
476         fi
477 fi
478
479 # check if the package is configured.
480 if grep -q 'header("Location: setup/")' %{_sysconfdir}/config.php; then
481 %banner %{name} -e <<EOF
482
483 You haven't yet configured Eventum!
484
485 Install %{name}-setup and open up http://yourserver/eventum/
486 -- that will help you setup initial config.
487
488 when have configured Eventum, please uninstall the setup package,
489 so that %{name}-setup is able to secure your Eventum installation.
490
491 EOF
492 #' vim stupidity.
493
494 elif grep -q 'DEFAULTPRIVATEKEY' %{_sysconfdir}/private_key.php; then
495 %banner %{name} -e <<EOF
496
497 You have default private key installed!
498
499 Install %{name}-setup and open up http://yourserver/eventum/setup/
500 -- that will help you setup initial config.
501
502 when have configured Eventum, please uninstall the setup package,
503 so that %{name}-setup is able to secure your Eventum installation.
504
505 EOF
506         elif [ -d %{_appdir}/setup ]; then
507 %banner %{name} -e <<EOF
508
509 If you have have configured Eventum, please uninstall the setup package,
510 so that %{name}-setup is able to secure your Eventum installation.
511
512 EOF
513 fi
514
515
516 %preun
517 if [ "$1" = "0" ]; then
518         # apache1
519         if [ -f %{_apache1dir}/apache.conf ]; then
520                 rm -f %{_apache1dir}/conf.d/99_%{name}.conf
521                 if [ -f /var/lock/subsys/apache ]; then
522                         /etc/rc.d/init.d/apache restart 1>&2
523                 fi
524         fi
525         # apache2
526         if [ -d %{_apache2dir}/httpd.conf ]; then
527                 rm -f %{_apache1dir}/httpd.conf/99_%{name}.conf
528                 if [ -f /var/lock/subsys/httpd ]; then
529                         /etc/rc.d/init.d/httpd restart 1>&2
530                 fi
531         fi
532 fi
533
534 %post setup
535 chmod 660 %{_sysconfdir}/{config,private_key}.php
536 chown root:http %{_sysconfdir}/{config,private_key}.php
537
538 %postun setup
539 if [ "$1" = "0" ]; then
540         chmod 640 %{_sysconfdir}/{config,private_key}.php
541         chown root:http %{_sysconfdir}/{config,private_key}.php
542 fi
543
544 %files
545 %defattr(644,root,root,755)
546 %doc ChangeLog FAQ INSTALL README UPGRADE misc/upgrade docs/* rpc/xmlrpc_client.php
547 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/apache.conf
548 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/config.php
549 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/private_key.php
550 %attr(660,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/setup.php
551
552 %dir %{_appdir}
553 %dir %{_appdir}/misc
554
555 %dir %attr(731,root,http) /var/log/%{name}
556 %attr(620,root,http) %ghost /var/log/%{name}/*
557
558 %{_appdir}/*.php
559 %{_appdir}/css
560 %{_appdir}/customer
561 %{_appdir}/images
562 %{_appdir}/js
563 %{_appdir}/manage
564 %{_appdir}/reports
565 %{_appdir}/rpc
566 %{_appdir}/templates
567
568 %if %{with pear}
569 %{_smartyplugindir}/*
570 %else
571 %{_appdir}/include/pear
572 %{_appdir}/include/Smarty
573 %endif
574
575 %dir %{_appdir}/include
576 %{_appdir}/include/customer
577 %{_appdir}/include/jpgraph
578 %{_appdir}/include/workflow
579 %{_appdir}/include/*.php
580
581 %dir %attr(730,root,http) /var/run/%{name}
582 %dir %attr(730,root,http) /var/cache/%{name}
583
584 %{_appdir}/misc/blank.html
585
586 %files base
587 %defattr(644,root,root,755)
588 %attr(751,root,root) %dir %{_sysconfdir}
589
590 %files setup
591 %defattr(644,root,root,755)
592 %{_appdir}/setup
593
594 %files mail-queue
595 %defattr(644,root,root,755)
596 %{_appdir}/misc/process_mail_queue.php
597 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-queue
598
599 %files mail-download
600 %defattr(644,root,root,755)
601 %{_appdir}/misc/download_emails.php
602 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-download
603
604 %files reminder
605 %defattr(644,root,root,755)
606 %{_appdir}/misc/check_reminders.php
607 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-reminder
608
609 %files monitor
610 %defattr(644,root,root,755)
611 %{_appdir}/misc/monitor.php
612 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-monitor
613
614 %files route-emails
615 %defattr(644,root,root,755)
616 %{_appdir}/misc/route_emails.php
617
618 %files route-notes
619 %defattr(644,root,root,755)
620 %{_appdir}/misc/route_drafts.php
621 %{_appdir}/misc/route_notes.php
622
623 %files irc
624 %defattr(644,root,root,755)
625 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/irc.php
626 %{_appdir}/misc/irc
627 %attr(754,root,root) /etc/rc.d/init.d/%{name}-irc
628
629 %files cli
630 %defattr(644,root,root,755)
631 %doc eventumrc
632 %attr(644,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/cli.php
633 %attr(755,root,root) %{_bindir}/%{name}
634 %dir %{_appdir}/misc/cli
635 %{_appdir}/misc/cli/include
636
637 %files scm
638 %defattr(644,root,root,755)
639 %attr(644,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/cvs.php
640 # FIXME: not sure about this naming.
641 %attr(755,root,root) %{_bindir}/%{name}-scm
This page took 0.486525 seconds and 4 git commands to generate.