]> git.pld-linux.org Git - packages/eventum.git/blob - eventum.spec
- use _appdir macro
[packages/eventum.git] / eventum.spec
1 # TODO
2 # - php5 is not tested, but not placing hard conflict on it, as it prevents php4 & php coinstallation
3 # - discard bundled packages (from INSTALL):
4 #  - JpGraph 1.5.3 (last GPL version)
5 #  - Smarty 2.3.0 (http://smarty.php.net)
6 #  - PEAR packages
7 #  - dTree 2.0.5 (http://www.destroydrop.com/javascript/tree/)
8 #  - dynCalendar.js (http://www.phpguru.org/dyncalendar.html)
9 #  - overLIB 3.5.1 (http://www.bosrup.com/web/overlib/)
10 #  - A few other small javascript libraries
11 # - Mail Queue Process, cron or separate package (misc/process_mail_queue.php)
12 # - Email Download (misc/download_emails.php)
13 # - Reminder System (misc/check_reminders.php)
14 # - Heartbeat Monitor (misc/monitor.php)
15 # - Email Routing Script (misc/route_emails.php)
16 # - Note Routing Script (misc/route_notes.php)
17 # - IRC Notification Bot (misc/irc/bot.php)
18 # - Command-line Interface (misc/cli/eventum)
19 Summary:        Eventum Issue / Bug Tracking System
20 Name:           eventum
21 Version:        1.4
22 Release:        0.7
23 License:        GPL
24 Group:          Applications/WWW
25 Source0:        http://mysql.wildyou.net/Downloads/%{name}/%{name}-%{version}.tar.gz
26 # Source0-md5:  361c1355e46a6bbfa54e420964ec92cf
27 URL:            http://dev.mysql.com/downloads/other/eventum/index.html
28 BuildRequires:  sed >= 4.0
29 Requires:       php >= 4.1.0
30 Requires:       php-pcre
31 Requires:       php-mysql
32 Requires:       php-gd
33 Requires:       php-imap
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %define         _appdir %{_datadir}/%{name}
37
38 %description
39 Eventum is a user-friendly and flexible issue tracking system that can
40 be used by a support department to track incoming technical support
41 requests, or by a software development team to quickly organize tasks
42 and bugs. Eventum is used by the MySQL AB Technical Support team, and
43 has allowed us to dramatically improve our response times.
44
45 %prep
46 %setup -q
47
48 %build
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52
53 install -d $RPM_BUILD_ROOT%{_appdir}/locks
54
55 # TODO: php4
56 sed -i -e 's,/usr/local/bin/php,/usr/bin/php,' misc/cli/eventum
57
58 cp -a . $RPM_BUILD_ROOT%{_appdir}
59
60 > $RPM_BUILD_ROOT%{_appdir}/setup.conf.php
61
62 # in doc
63 rm -f $RPM_BUILD_ROOT%{_appdir}/{COPYING,ChangeLog,FAQ,INSTALL,README,UPGRADE}
64
65 %clean
66 rm -rf $RPM_BUILD_ROOT
67
68 %files
69 %defattr(644,root,root,755)
70 %doc ChangeLog FAQ INSTALL README UPGRADE
71 %dir %{_appdir}
72 %attr(640,http,root) %config(noreplace) %{_appdir}/config.inc.php
73 %attr(640,http,root) %config(noreplace) %{_appdir}/setup.conf.php
74 %{_appdir}/*[!cf].php
75
76 %{_appdir}/css
77 %{_appdir}/customer
78 %{_appdir}/docs
79 %{_appdir}/images
80 %{_appdir}/js
81 %{_appdir}/manage
82 %{_appdir}/misc
83 %{_appdir}/reports
84 %{_appdir}/rpc
85 %{_appdir}/setup
86 %{_appdir}/templates
87
88 %dir %attr(755,http,root) %{_appdir}/locks
89
90 %dir %{_appdir}/include
91 %{_appdir}/include/customer
92 %{_appdir}/include/jpgraph
93 %{_appdir}/include/pear
94 %{_appdir}/include/Smarty
95 %{_appdir}/include/workflow
96 %{_appdir}/include/class.*
97 %{_appdir}/include/db_access.php
98 %{_appdir}/include/jsrsServer.inc.php
99 %attr(640,http,root) %{_appdir}/include/private_key.php
100
101 %dir %attr(755,http,root) %{_appdir}/logs
102 %attr(640,http,root) %{_appdir}/logs/*
103
104 %dir %attr(750,http,root) %{_appdir}/templates_c
This page took 0.042251 seconds and 4 git commands to generate.