]> git.pld-linux.org Git - packages/eventum.git/blob - eventum.spec
- more
[packages/eventum.git] / eventum.spec
1 # TODO
2 # - discard bundled packages (from INSTALL):
3 #  - JpGraph 1.5.3 (last GPL version)
4 #  - dTree 2.0.5 (http://www.destroydrop.com/javascript/tree/)
5 #  - dynCalendar.js (http://www.phpguru.org/dyncalendar.html)
6 #  - overLIB 3.5.1 (http://www.bosrup.com/web/overlib/)
7 #  - A few other small javascript libraries
8 # - 64bit platforms beware? http://bugs.php.net/bug.php?id=30215 (it's actually Smarty related problem)
9 #
10 # Conditional build:
11 %bcond_without  pear    # build with system PEAR packages (or use bundled ones)
12 %bcond_with     qmail   # build the router-qmail subpackage
13 #
14 # snapshot: DATE
15 %define _snap 20060220
16
17 %define _rel    0.6
18
19 %{?with_pear:%include   /usr/lib/rpm/macros.php}
20 Summary:        Eventum Issue / Bug tracking system
21 Summary(pl):    Eventum - system ¶ledzenia spraw/b³êdów
22 Name:           eventum
23 Version:        1.7.0
24 Release:        %{?_snap:4.%{_snap}.}%{?_rc:%{_rc}.}%{_rel}
25 License:        GPL
26 Group:          Applications/WWW
27 #Source0:       http://mysql.dataphone.se/Downloads/%{name}/%{name}-%{version}.tar.gz
28 Source0:        http://downloads.mysql.com/snapshots/%{name}/%{name}-nightly-%{_snap}.tar.gz
29 # Source0-md5:  f2bc584ac2d0fd67bec954f43abe920c
30 Source1:        %{name}-apache.conf
31 Source2:        %{name}-mail-queue.cron
32 Source3:        %{name}-mail-download.cron
33 Source4:        %{name}-reminder.cron
34 Source5:        %{name}-monitor.cron
35 Source6:        %{name}-cvs.php
36 Source7:        %{name}-irc.php
37 Source8:        %{name}-irc.init
38 Source9:        %{name}-irc.sysconfig
39 Source10:       %{name}-config.php
40 Source11:       %{name}-router-qmail.sh
41 Source12:       %{name}-config-setup.php
42 Source13:       %{name}-upgrade.sh
43 Source14:       %{name}-router-postfix.sh
44 Patch0:         %{name}-paths.patch
45 Patch1:         %{name}-cvs-config.patch
46 Patch2:         %{name}-irc-config.patch
47 Patch3:         %{name}-PEAR.patch
48 Patch4:         http://glen.alkohol.ee/pld/%{name}-reply-subject.patch
49 Patch5:         %{name}-lf.patch
50 Patch6:         http://glen.alkohol.ee/pld/%{name}-maq-subject.patch
51 Patch7:         %{name}-bot-reconnect.patch
52 Patch8:         %{name}-perms.patch
53 Patch9:         http://glen.alkohol.ee/pld/%{name}-httpclient-clientside.patch
54 Patch10:        %{name}-cli-wr-separated.patch
55 Patch12:        %{name}-htmloptions-truncate.patch
56 Patch13:        http://glen.alkohol.ee/pld/%{name}-link_filter-updates.patch
57 Patch14:        http://glen.alkohol.ee/pld/%{name}-irc-mem.patch
58 Patch16:        http://glen.alkohol.ee/pld/eventum-recent_activity-usability.patch
59 Patch17:        http://glen.alkohol.ee/pld/eventum-upload-error-keep-popup.patch
60 Patch18:        http://glen.alkohol.ee/pld/eventum-scm-parse-response.patch
61 Patch19:        eventum-double-decode.patch
62 Patch20:        http://glen.alkohol.ee/pld/eventum-keep-submitbutton.patch
63 Patch21:        http://glen.alkohol.ee/pld/eventum-tt-unhide.patch
64 Patch22:        %{name}-route-mem.patch
65 URL:            http://dev.mysql.com/downloads/other/eventum/
66 %{?with_pear:BuildRequires:     rpm-php-pearprov >= 4.0.2-98}
67 BuildRequires:  rpmbuild(macros) >= 1.268
68 BuildRequires:  sed >= 4.0
69 Requires:       %{name}-base = %{version}-%{release}
70 Requires:       Smarty >= 2.6.10-4
71 Requires:       php >= 3:4.2.0
72 Requires:       php-gd
73 Requires:       php-imap
74 Requires:       php-mysql
75 Requires:       php-pcre
76 Requires:       php-session
77 %if %{with pear}
78 Requires:       php-pear-Benchmark
79 Requires:       php-pear-DB
80 Requires:       php-pear-Date
81 Requires:       php-pear-HTTP_Request
82 Requires:       php-pear-Mail
83 Requires:       php-pear-Math_Stats
84 Requires:       php-pear-Net_DIME
85 Requires:       php-pear-Net_SMTP
86 Requires:       php-pear-Net_Socket
87 Requires:       php-pear-Net_URL
88 Requires:       php-pear-Net_UserAgent_Detect
89 Requires:       php-pear-PEAR-core
90 Requires:       php-pear-Text_Diff
91 Requires:       php-pear-XML_RPC
92 %endif
93 Requires(triggerpostun):        /usr/bin/php
94 Requires(triggerpostun):        sed >= 4.0
95 Requires:       apache(mod_dir)
96 Requires:       webapps
97 Requires:       webserver = apache
98 BuildArch:      noarch
99 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
100
101 %define         _noautoreq      'pear(/etc/webapps/.*)' 'pear(jpgraph_dir.php)' 'pear(.*Smarty.class.php)'
102
103 %define         _libdir         %{_prefix}/lib/%{name}
104 %define         _appdir         %{_datadir}/%{name}
105 %define         _smartyplugindir        %{_appdir}/include/smarty
106 %define         _smartydir      /usr/share/php/Smarty
107 %define         _webapps        /etc/webapps
108 %define         _webapp         %{name}
109 %define         _webappdir      %{_webapps}/%{_webapp}
110 %define         _sysconfdir     /etc/%{name}
111
112 %description
113 Eventum is a user-friendly and flexible issue tracking system that can
114 be used by a support department to track incoming technical support
115 requests, or by a software development team to quickly organize tasks
116 and bugs. Eventum is used by the MySQL AB Technical Support team, and
117 has allowed us to dramatically improve our response times.
118
119 %description -l pl
120 Eventum to przyjazny dla u¿ytkownika system ¶ledzenia spraw, który
121 mo¿e byæ u¿ywany przez dzia³ obs³ugi do ¶ledzenia przychodz±cych ¿±dañ
122 obs³ugi technicznej albo przez zespó³ tworz±cy oprogramowanie do
123 szybkiej organizacji zadañ i b³êdów. Eventum jest u¿ywany przez zespó³
124 Technical Support MySQL AB i umo¿liwi³ im znacz±co poprawiæ czasy
125 reakcji.
126
127 %package base
128 Summary:        Eventum base package
129 Summary(pl):    Podstawowy pakiet Eventum
130 Group:          Applications/WWW
131 Requires(postun):       /usr/sbin/groupdel
132 Requires(postun):       /usr/sbin/userdel
133 Requires(pre):  /bin/id
134 Requires(pre):  /usr/bin/getgid
135 Requires(pre):  /usr/sbin/groupadd
136 Requires(pre):  /usr/sbin/useradd
137 Provides:       group(eventum)
138 Provides:       user(eventum)
139
140 %description base
141 This package contains base directory structure for Eventum.
142
143 %description base -l pl
144 Ten pakiet zawiera podstawow± strukturê katalogów dla Eventum.
145
146 %package setup
147 Summary:        Eventum setup package
148 Summary(pl):    Pakiet do wstêpnej konfiguracji Eventum
149 Group:          Applications/WWW
150 Requires:       %{name} = %{version}-%{release}
151
152 %description setup
153 Install this package to configure initial Eventum installation. You
154 should uninstall this package when you're done, as it considered
155 insecure to keep the setup files in place.
156
157 %description setup -l pl
158 Ten pakiet nale¿y zainstalowaæ w celu wstêpnej konfiguracji Eventum po
159 pierwszej instalacji. Potem nale¿y go odinstalowaæ, jako ¿e
160 pozostawienie plików instalacyjnych mog³oby byæ niebezpieczne.
161
162 %package mail-queue
163 Summary:        Eventum mail queue process
164 Summary(pl):    Przetwarzanie kolejki poczty Eventum
165 Group:          Applications/WWW
166 Requires:       %{name} = %{version}-%{release}
167 Requires:       crondaemon
168
169 %description mail-queue
170 Beginning with the first release of Eventum, emails are not directly
171 sent out from the various scripts, but rather added to a mail queue
172 table that is processed by a cron job. If an email cannot be sent, it
173 will be marked as such in the mail queue log, and the cron job script
174 will re-try to send it again the next time it runs.
175
176 This package contains the cron job.
177
178 %description mail-queue -l pl
179 Od pierwszego wydania Eventum poczta nie jest wysy³ana bezpo¶rednio z
180 ró¿nych skryptów, lecz dodawana do kolejki przetwarzanej z crona.
181 Je¶li poczta nie mo¿e byæ wys³ana, bêdzie odpowiednio oznaczona w logu
182 kolejki poczty, a skrypt z crona bêdzie próbowa³ wys³aæ j± ponownie
183 nastêpnym razem.
184
185 Ten pakiet zawiera zadanie dla crona.
186
187 %package mail-download
188 Summary:        Eventum email download
189 Summary(pl):    ¦ci±ganie poczty Eventum
190 Group:          Applications/WWW
191 Requires:       %{name} = %{version}-%{release}
192 Requires:       crondaemon
193
194 %description mail-download
195 In order for Eventum's email integration feature to work, you need to
196 setup a cron job to run the script every so often.
197
198 This package contains the cron job.
199
200 %description mail-download -l pl
201 Aby integracja poczty elektronicznej w Eventum dzia³a³a, trzeba
202 ustawiæ zadanie crona, aby uruchamia³ odpowiedni skrypt wystarczaj±co
203 czêsto.
204
205 Ten pakiet zawiera zadanie dla crona.
206
207 %package reminder
208 Summary:        Eventum Reminder System
209 Summary(pl):    System przypominania dla Eventum
210 Group:          Applications/WWW
211 Requires:       %{name} = %{version}-%{release}
212 Requires:       crondaemon
213
214 %description reminder
215 The reminder system was designed with the objective as serving as a
216 safe net for issues that need attention. Depending on what
217 configuration you create, you may have several reminders (or alerts)
218 be sent out whenever an issue needs attention, for whatever parameter
219 you may deem necessary.
220
221 This package contains the cron job.
222
223 %description reminder -l pl
224 System przypominania zosta³ zaprojektowany tak, aby s³u¿y³ jako
225 bezpieczna sieæ dla spraw wymagaj±cych uwagi. W zale¿no¶ci od
226 konfiguracji mo¿na ustawiæ ró¿ne przypominajki (lub alarmy) wysy³ane
227 przy ka¿dej sprawie wymagaj±cej uwagi lub przy parametrze, który mo¿na
228 uwa¿aæ za potrzebny.
229
230 Ten pakiet zawiera zadanie dla crona.
231
232 %package monitor
233 Summary:        Eventum Heartbeat Monitor
234 Summary(pl):    Monitor ¿ycia dla Eventum
235 Group:          Applications/WWW
236 Requires:       %{name} = %{version}-%{release}
237 Requires:       crondaemon
238 Requires:       php-posix
239
240 %description monitor
241 The heartbeat monitor is a feature designed for the administrator that
242 wants to be alerted whenever a common problem in Eventum is detected,
243 like the database server not being available anymore, or maybe when
244 the recommended permissions for certain configuration files are
245 changed.
246
247 Please note that before running the heartbeat monitor, you may need to
248 customize some of the checks to be appropriate for your own system,
249 particularly the permission and file checks on
250 Monitor::checkConfiguration().
251
252 This package contains the cron job.
253
254 %description monitor -l pl
255 Monitor ¿ycia to funkcjonalno¶æ zaprojektowana dla administratora
256 chc±cego byæ alarmowanym przy ka¿dym wykryciu popularnego problemu z
257 Eventum, jak nie dzia³anie serwera bazy danych albo zmiana uprawnieñ
258 do plików konfiguracyjnych.
259
260 Nale¿y zauwa¿yæ, ¿e przed uruchomieniem tego monitora mo¿e byæ
261 konieczne dostosowanie niektórych testów do systemu, w szczególno¶ci
262 testów uprawnieñ i plików w Monitor::checkConfiguration().
263
264 Ten pakiet zawiera zadanie dla crona.
265
266 %package route-drafts
267 Summary:        Eventum Draft Routing
268 Summary(pl):    Przekazywanie szkiców dla Eventum
269 Group:          Applications/WWW
270 Requires:       %{name} = %{version}-%{release}
271 Requires:       eventum(router)
272
273 %description route-drafts
274 The draft routing feature is used to automatically associate a thread
275 of drafts into an Eventum issue. By setting up qmail (or even Postfix)
276 to deliver emails sent to a specific address (usually
277 draft-<number>@<domain>) to the above script, users are able to send
278 drafts written in their mail client to be stored in Eventum. These
279 drafts will NOT broadcasted to the notification list.
280
281 %description route-drafts -l pl
282 Przekazywanie szkiców s³u¿y do automatycznego wi±zania w±tku szkiców z
283 problemem w Eventum. Ustawiaj±c qmaila (czy nawet Postfiksa), aby
284 dostarcza³ pocztê wys³an± na podany adres (zwykle
285 draft-<liczba>@<domena>) do tego skryptu umo¿liwia siê u¿ytkownikom
286 wysy³anie szkiców napisanych w ich kliencie pocztowym do zapisania w
287 Eventum. Szkice te NIE bêd± wysy³ane na listê powiadomieñ.
288
289 %package route-emails
290 Summary:        Eventum Email Routing
291 Summary(pl):    Przekazywanie poczty dla Eventum
292 Group:          Applications/WWW
293 Requires:       %{name} = %{version}-%{release}
294 Requires:       eventum(router)
295
296 %description route-emails
297 The email routing feature is used to automatically associate a thread
298 of emails into an Eventum issue. By setting up qmail (or even postfix)
299 to deliver emails sent to a specific address (usually
300 issue-<number>@<domain>) to the above script, users are able to use
301 their email clients to reply to emails coming from Eventum, and those
302 replies will be automatically associated with the issue and
303 broadcasted to the entire notification list.
304
305 %description route-emails -l pl
306 Funkcjonalno¶æ przekazywania poczty s³u¿y do automatycznego wi±zania
307 w±tku listów ze spraw± w Eventum. Po ustawieniu qmaila (czy nawet
308 postfiksa), aby dostarcza³ listy wysy³ane na pewien adres (zwykle
309 issue-<numer>@<domena>) na powy¿szy skrypt, u¿ytkownicy bêd± mogli
310 u¿ywaæ klientów pocztowych do odpowiadania na listy przychodz±ce z
311 Eventum, a odpowiedzi te bêd± automatycznie wi±zane ze spraw± i
312 rozprowadzane do ca³ej listy og³oszeniowej.
313
314 %package route-notes
315 Summary:        Eventum Note Routing
316 Summary(pl):    Przekazywanie notatek dla Eventum
317 Group:          Applications/WWW
318 Requires:       %{name} = %{version}-%{release}
319 Requires:       eventum(router)
320
321 %description route-notes
322 The note routing feature is used to automatically associate a thread
323 of notes into an Eventum issue. By setting up qmail (or even postfix)
324 to deliver emails sent to a specific address (usually
325 note-<number>@<domain>) to the above script, users are able to use
326 their email clients to reply to internal notes coming from Eventum,
327 and those replies will be automatically associated with the issue and
328 broadcasted to the notification list staff members.
329
330 %description route-notes -l pl
331 Funkcjonalno¶æ przekazywania notatek s³u¿y do automatycznego wi±zania
332 w±tku notatek ze spraw± w Eventum. Po ustawieniu qmaila (czy nawet
333 postfiksa), aby dostarcza³ listy wysy³ane na pewien adres (zwykle
334 note-<numer>@<domena>) na powy¿szy skrypt, u¿ytkownicy bêd± mogli
335 u¿ywaæ klientów pocztowych do odpowiadania na wewnêtrzne notatki
336 pochodz±ce od Eventu, a odpowiedzi te bêd± automatycznie wi±zane ze
337 spraw± i rozprowadzane do cz³onków personelu listy og³oszeniowej.
338
339 %package router-qmail
340 Summary:        Eventum Mail Routing - qmail
341 Summary(pl):    Przekazywanie poczty Eventum - qmail
342 Group:          Applications/Mail
343 # loose dep is intentional. qmail subpackage isn't built on PLD
344 # builders and there really nothing changes.
345 Requires:       %{name} >= %{version}-%{release}
346 Requires:       qmail >= 1.03
347 Provides:       eventum(router)
348 Obsoletes:      eventum(router)
349
350 %description router-qmail
351 This package provides way of routing notes and emails back to Eventum
352 via qmail.
353
354 %description router-qmail -l pl
355 Ten pakiet udostêpnia metodê przekazywania notatek i listów do Eventum
356 przez qmaila.
357
358 %package router-postfix
359 Summary:        Eventum Mail Routing - Postfix
360 Summary(pl):    Przekazywanie poczty Eventum - Postfix
361 Group:          Applications/Mail
362 Requires:       %{name} = %{version}-%{release}
363 Requires:       postfix
364 Provides:       eventum(router)
365 Obsoletes:      eventum(router)
366
367 %description router-postfix
368 This package provides way of routing notes and emails back to Eventum
369 via Postfix.
370
371 The Postfix configuration instructions you can find from
372 <http://eventum.mysql.org/wiki/index.php/Setting_up_email_routing_with_postfix>.
373
374 %description router-postfix -l pl
375 Ten pakiet udostêpnia metodê przekazywania notatek i listów do Eventum
376 przez Postfiksa.
377
378 Opis konfiguracji Postfiksa mo¿na znale¼æ pod adresem
379 <http://eventum.mysql.org/wiki/index.php/Setting_up_email_routing_with_postfix>.
380
381 %package irc
382 Summary:        Eventum IRC Notification Bot
383 Summary(pl):    IRC-owy bot powiadamiaj±cy dla Eventum
384 Group:          Applications/WWW
385 Requires(triggerpostun):        sed >= 4.0
386 Requires:       %{name} = %{version}-%{release}
387 Requires:       php-pear-Net_SmartIRC
388 Requires:       php-sockets
389 Requires:       rc-scripts >= 0.4.0.18
390
391 %description irc
392 The IRC notification bot is a nice feature for remote teams that want
393 to handle issues and want to have a quick and easy way to get simple
394 notifications. Right now the bot notifies of the following actions:
395 - New Issues
396 - Blocked emails
397 - Issues that got their assignment list changed
398
399 NOTE: You will need to manually edit the bot.php script to set your
400 appropriate preferences, like IRC server and channel that the bot
401 should join.
402
403 %description irc -l pl
404 IRC-owy bot powiadamiaj±cy to mi³a funkcjonalno¶æ dla zdalnych
405 zespo³ów chc±cych obs³ugiwaæ sprawy i mieæ szybki i ³atwy sposób na
406 uzyskiwanie prostych powiadomieñ. Aktualnie bot powiadamia o
407 nastêpuj±cych zdarzeniach:
408 - nowych sprawach
409 - zablokowanych listach
410 - sprawach, dla których zmieni³a siê lista powi±zañ
411
412 UWAGA: w celu wprowadzenia w³asnych ustawieñ, takich jak serwer IRC i
413 kana³ u¿ywany przez bota, trzeba rêcznie zmodyfikowaæ skrypt bot.php .
414
415 %package cli
416 Summary:        Eventum command-line interface
417 Summary(pl):    Interfejs linii poleceñ dla Eventum
418 Group:          Applications/WWW
419 Requires:       %{name}-base = %{version}-%{release}
420 Requires:       php-cli
421 Requires:       php-common >= 3:4.1.0
422 Requires:       php-curl
423 Requires:       php-pear-XML_RPC
424 Requires:       php-xml
425
426 %description cli
427 The Eventum command-line interface allows you to access most of the
428 features of the web interface straight from your command shell.
429
430 %description cli -l pl
431 Interfejs linii poleceñ Eventum pozwala na dostêp do wiêkszo¶ci
432 funkcji interfejsu WWW prosto z linii poleceñ pow³oki.
433
434 %package scm
435 Summary:        Eventum SCM integration
436 Summary(pl):    Integracja SCM dla Eventum
437 Group:          Applications/WWW
438 Requires:       %{name}-base = %{version}-%{release}
439 Requires:       php-cli
440 Requires:       php-common >= 3:4.1.0
441 Requires:       php-pcre
442
443 %description scm
444 This feature allows your software development teams to integrate your
445 Source Control Management system with your Issue Tracking System.
446
447 The integration is implemented in such a way that it will be forward
448 compatible with pretty much any SCM system, such as CVS.
449
450 For installation see
451 </eventum/help.php?topic=scm_integration_installation>.
452
453 %description scm -l pl
454 Ten pakiet pozwala zespo³om programistów na integracjê systemu
455 zarz±dzania ¼ród³ami (SCM - Source Control Management) z systemem
456 ¶ledzenia spraw.
457
458 Integracja jest zaimplementowana tak, aby byæ kompatybilna w przód z
459 prawie ka¿dym systemem SCM, jak np. CVS.
460
461 Szczegó³y na temat instalacji mo¿na przeczytaæ pod
462 </eventum/help.php?topic=scm_integration_installation>.
463
464 %prep
465 %setup -q %{?_snap:-n %{name}-%{_snap}}
466 # undos the source
467 find . -type f -print0 | xargs -0 sed -i -e 's,\r$,,'
468
469 rm -f setup.conf.php # not to be installed by *.php glob
470 rm -rf misc/upgrade/*v1.[123]* # too old to support in PLD Linux
471 rm -f misc/upgrade/flush_compiled_templates.php
472 rm -rf misc/upgrade/*/upgrade_config.php # not needed nor supported in PLD Linux
473
474 # sample, not used in eventum
475 rm -f rpc/xmlrpc_client.php
476
477 # packaging
478 %patch0 -p1
479 %patch1 -p1
480 %patch14 -p1
481 %patch2 -p1
482 %{?with_pear:%patch3 -p1}
483
484 # bug fixes.
485 %patch4 -p1
486 %patch5 -p1
487 %patch6 -p1
488 %patch7 -p1
489 %patch8 -p1
490 %patch9 -p1
491 %patch10 -p1
492 %patch12 -p1
493 %patch13 -p1
494 %patch16 -p1
495 %patch17 -p1
496 %patch18 -p1
497 %patch19 -p1
498 %patch20 -p1
499 %patch21 -p1
500 %patch22 -p1
501
502 sed -e '1s,#!.*/bin/php -q,#!%{_bindir}/php,' misc/cli/eventum > %{name}-cli
503 sed -e '1i#!%{_bindir}/php' misc/scm/process_cvs_commits.php > %{name}-scm
504 sed -e '1i#!%{_bindir}/php' misc/irc/bot.php > %{name}-bot
505 mv misc/cli/eventumrc_example eventumrc
506 sed -i -e '1i#!%{_bindir}/php' misc/*.php
507 chmod +x misc/*.php
508
509 sed -e '
510 s,$private_key\s*=\s*".*";,$private_key = "DEFAULTPRIVATEKEYPLEASERUNSETUP!";,
511 ' < include/private_key.php > private_key.php.in
512 rm -f include/private_key.php
513
514 # replace in remaining scripts config.inc.php to system one
515 grep -rl 'include_once(".*config.inc.php")' . | xargs sed -i -e '
516         s,include_once(".*config.inc.php"),include_once("%{_webappdir}/core.php"),
517 '
518
519 grep -rl 'APP_INC_PATH..*"private_key.php"' . | xargs sed -i -e '
520         s,include_once(APP_INC_PATH.*"private_key.php"),include_once("%{_webappdir}/private_key.php"),
521 '
522
523 # remove backups from patching as we use globs to package files to buildroot
524 find '(' -name '*~' -o -name '*.orig' ')' | xargs -r rm -v
525
526 %install
527 rm -rf $RPM_BUILD_ROOT
528 install -d \
529         $RPM_BUILD_ROOT{%{_webappdir},%{_sysconfdir},%{_bindir},%{_sbindir},%{_libdir}} \
530         $RPM_BUILD_ROOT/etc/{rc.d/init.d,cron.d,sysconfig} \
531         $RPM_BUILD_ROOT/var/{run,log,cache,lib}/%{name} \
532         $RPM_BUILD_ROOT/var/lib/%{name}/routed_{emails,drafts,notes} \
533         $RPM_BUILD_ROOT%{_appdir}/{include,htdocs/misc,upgrade} \
534
535 cp -a *.php css customer images js manage reports rpc setup $RPM_BUILD_ROOT%{_appdir}/htdocs
536 cp -a misc/*.html $RPM_BUILD_ROOT%{_appdir}/htdocs/misc
537 cp -a misc/*.php $RPM_BUILD_ROOT%{_appdir}
538 cp -a templates $RPM_BUILD_ROOT%{_appdir}
539 cp -a include/{customer,custom_field,jpgraph,pear,workflow} $RPM_BUILD_ROOT%{_appdir}/include
540 cp -a include/*.php $RPM_BUILD_ROOT%{_appdir}/include
541 cp -a logs/* $RPM_BUILD_ROOT/var/log/%{name}
542 cp -a misc/upgrade $RPM_BUILD_ROOT%{_appdir}
543
544 cp -a favicon.ico $RPM_BUILD_ROOT%{_appdir}/htdocs/favicon.ico
545 install %{SOURCE12} $RPM_BUILD_ROOT%{_appdir}/htdocs/setup/config.inc.php
546 install %{SOURCE13} $RPM_BUILD_ROOT%{_appdir}/upgrade/upgrade.sh
547
548 # cli
549 install -d $RPM_BUILD_ROOT%{_appdir}/cli
550 cp -a misc/cli/include/class.{misc,command_line}.php $RPM_BUILD_ROOT%{_appdir}/cli
551 cp -a misc/cli/config.inc.php $RPM_BUILD_ROOT%{_sysconfdir}/cli.php
552 install %{name}-cli $RPM_BUILD_ROOT%{_bindir}/%{name}
553 install %{name}-bot $RPM_BUILD_ROOT%{_sbindir}
554
555 # scm
556 install %{name}-scm $RPM_BUILD_ROOT%{_libdir}/scm
557 install %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}/cvs.php
558
559 # private key
560 cp -a private_key.php.in $RPM_BUILD_ROOT%{_webappdir}/private_key.php
561
562 install %{SOURCE1} $RPM_BUILD_ROOT%{_webappdir}/apache.conf
563 install %{SOURCE1} $RPM_BUILD_ROOT%{_webappdir}/httpd.conf
564 install %{SOURCE2} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-queue
565 install %{SOURCE3} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-download
566 install %{SOURCE4} $RPM_BUILD_ROOT/etc/cron.d/%{name}-reminder
567 install %{SOURCE5} $RPM_BUILD_ROOT/etc/cron.d/%{name}-monitor
568 install %{SOURCE7} $RPM_BUILD_ROOT%{_sysconfdir}/irc.php
569 install %{SOURCE8} $RPM_BUILD_ROOT/etc/rc.d/init.d/eventum-irc
570 install %{SOURCE9} $RPM_BUILD_ROOT/etc/sysconfig/eventum-irc
571
572 sed -e '
573 s,%%{APP_VERSION}%%,%{version}%{?_snap:-%{_snap}},
574 s,%%{PHP_PEAR_DIR}%%,%{?with_pear:%{php_pear_dir}}%{!?with_pear:%{_appdir}/includes/pear},
575 s,%%{APP_PATH}%%,%{_appdir},
576 s,%%{SMARTY_DIR}%%,%{_smartydir},
577 s,%%{SYSCONFDIR}%%,%{_webappdir},
578 ' %{SOURCE10} > $RPM_BUILD_ROOT%{_webappdir}/core.php
579
580 # config
581 > $RPM_BUILD_ROOT%{_webappdir}/setup.php
582 mv $RPM_BUILD_ROOT{%{_appdir}/htdocs/config.inc,%{_webappdir}/config}.php
583
584 %if %{with pear}
585 # provided by PEAR
586 rm -rf $RPM_BUILD_ROOT%{_appdir}/include/pear
587 %endif
588
589 # use system Smarty
590 rm -rf $RPM_BUILD_ROOT%{_appdir}/include/Smarty
591 install -d $RPM_BUILD_ROOT%{_smartyplugindir}
592 # These plugins are not in Smarty package (Smarty-2.6.2-3)
593 cp -a \
594         include/Smarty/plugins/function.{calendar,get_{display_style,innerhtml,textarea_size}}.php \
595         include/Smarty/plugins/modifier.highlight_quoted.php \
596         $RPM_BUILD_ROOT%{_smartyplugindir}
597
598 # qmail router
599 %if %{with qmail}
600 d=$RPM_BUILD_ROOT/var/lib/%{name}
601 echo 'root' > $d/.qmail
602 echo 'root' > $d/.qmail-default
603 echo '| %{_libdir}/router-qmail drafts' > $d/.qmail-draft-default
604 echo '| %{_libdir}/router-qmail emails 1' > $d/.qmail-issue-default
605 echo '| %{_libdir}/router-qmail notes' > $d/.qmail-note-default
606 install %{SOURCE11} $RPM_BUILD_ROOT%{_libdir}/router-qmail
607 %endif
608 # postfix router
609 install %{SOURCE14} $RPM_BUILD_ROOT%{_libdir}/router-postfix
610
611 %clean
612 rm -rf $RPM_BUILD_ROOT
613
614 %pre
615 %addusertogroup http %{name}
616
617 %post
618 # check if the package is configured.
619 if grep -q 'header("Location: setup/")' %{_webappdir}/config.php; then
620 if [ -f %{_appdir}/htdocs/setup/index.php ]; then
621 %banner %{name} -e <<EOF
622
623 You haven't yet configured Eventum!
624 Please open in browser <http://localhost/eventum/>
625 If you need access from elsewhere, you need to edit
626 %{_webappdir}/apache.conf and restart apache.
627
628 IMPORTANT: When You have configured Eventum, please uninstall the
629 setup package, so that %{name}-setup is able to secure your Eventum
630 installation.
631
632 EOF
633 #' vim syntax hack
634 else
635 %banner %{name} -e <<EOF
636
637 You haven't yet configured Eventum!
638
639 To setup eventum, please install %{name}-setup and open in browser
640 <http://localhost/eventum/>.
641 If you need access from elsewhere, you need to edit
642 %{_webappdir}/apache.conf and restart apache.
643
644 IMPORTANT: When You have configured Eventum, please uninstall the
645 setup package, so that %{name}-setup is able to secure your Eventum
646 installation.
647
648 EOF
649 #' vim syntax hack
650 fi
651
652 elif grep -q 'DEFAULTPRIVATEKEY' %{_webappdir}/private_key.php; then
653 %banner %{name} -e <<EOF
654
655 You have default private key installed!
656
657 Install %{name}-setup and open up http://yourserver/eventum/setup/
658 -- that will help you setup initial config.
659
660 when have configured Eventum, please uninstall the setup package,
661 so that %{name}-setup is able to secure your Eventum installation.
662
663 EOF
664         elif [ -d %{_appdir}/setup ]; then
665 %banner %{name} -e <<EOF
666
667 If you have have configured Eventum, please uninstall the setup package,
668 so that %{name}-setup is able to secure your Eventum installation.
669
670 EOF
671 fi
672
673 # nuke Smarty templates cache after upgrade
674 rm -f /var/cache/eventum/*.php
675
676 %preun
677 if [ "$1" = "0" ]; then
678         # nuke cache
679         rm -f /var/cache/eventum/*.php 2>/dev/null || :
680 fi
681
682 %pre base
683 %groupadd -P %{name}-base -g 146 %{name}
684 %useradd -P %{name}-base -u 146 -d /var/lib/%{name} -g %{name} -c "Eventum User" %{name}
685
686 %postun base
687 if [ "$1" = "0" ]; then
688         %userremove %{name}
689         %groupremove %{name}
690 fi
691
692 %post router-qmail
693 CF=/etc/qmail/control/virtualdomains
694 if ! grep -q ':%{name}\b' $CF 2>/dev/null; then
695         FQDN=$(awk -F'"' '/define/ && $2 ~ /APP_HOSTNAME/ {print $4}' %{_webappdir}/config.php 2>/dev/null)
696         [ "$FQDN" ] || FQDN=$(hostname -f 2>/dev/null || echo localhost)
697         umask 022
698         echo "#${FQDN}:%{name}" >> $CF
699
700 %banner %{name}-qmail -e <<EOF
701
702 Added "#${FQDN}:%{name}" to $CF,
703 Please verify that it is correct and restart qmail:
704 # service qmail reload
705
706 Consult qmail-send(8) for more information on virtualdomains.
707
708 EOF
709 fi
710
711 %preun router-qmail
712 if [ "$1" = "0" ]; then
713         sed -i -e '/:%{name}\b/d' /etc/qmail/control/virtualdomains
714 fi
715
716 %post setup
717 chmod 660 %{_webappdir}/{config,private_key}.php
718 chown root:eventum %{_webappdir}/{config,private_key}.php
719
720 %postun setup
721 if [ "$1" = "0" ]; then
722         chmod 640 %{_webappdir}/{config,private_key}.php
723         chown root:eventum %{_webappdir}/{config,private_key}.php
724 fi
725
726 %post irc
727 /sbin/chkconfig --add eventum-irc
728 %service eventum-irc restart "Eventum IRC Bot"
729
730 %triggerin -- apache1
731 %webapp_register apache %{_webapp}
732
733 %triggerun -- apache1
734 %webapp_unregister apache %{_webapp}
735
736 %triggerin -- apache >= 2.0.0
737 %webapp_register httpd %{_webapp}
738
739 %triggerun -- apache >= 2.0.0
740 %webapp_unregister httpd %{_webapp}
741
742 # FIXME
743 # only one upgrade trigger is called if you're upgrading over two
744 # versions, say 1.5 to 1.5.3, only 1.5.3 trigger is called.
745 # use common trigger (the highest version and rpmvercmp from poldek?)
746 %triggerpostun -- eventum < 1.5.1-0.257
747 %{_appdir}/upgrade/upgrade.sh %{_appdir}/upgrade/v1.5_to_v1.5.1 <<EOF
748 database_changes.php Perform database changes
749 EOF
750
751 %triggerpostun -- eventum < 1.5.2-0.289
752 %{_appdir}/upgrade/upgrade.sh %{_appdir}/upgrade/v1.5.1_to_v1.5.2 <<EOF
753 database_changes.php Perform database changes
754 set_priority_ranks.php Fix the ranking of priority values
755 EOF
756
757 %triggerpostun -- eventum < 1.5.3-0.291
758 %{_appdir}/upgrade/upgrade.sh %{_appdir}/upgrade/v1.5.2_to_v1.5.3 <<EOF
759 database_changes.php Perform database changes
760 EOF
761
762 %triggerpostun -- eventum < 1.5.4-1.12
763 %{_appdir}/upgrade/upgrade.sh %{_appdir}/upgrade/v1.5.3_to_v1.5.4 <<EOF
764 database_changes.php Perform database changes
765 EOF
766
767 %triggerpostun -- eventum < 1.6.0-RC2.6
768 %{_appdir}/upgrade/upgrade.sh %{_appdir}/upgrade/v1.5.5_to_v1.6.0 <<EOF
769 database_changes.php Perform database changes
770 upgrade_saved_searches.php Upgrade existing custom filters (saved searches)
771 EOF
772
773 %triggerpostun -- eventum < 1.6.1-0.2
774 %{_appdir}/upgrade/upgrade.sh %{_appdir}/upgrade/v1.6.0_to_v1.6.1 <<EOF
775 database_changes.php Perform database changes
776 EOF
777
778 %triggerpostun irc -- eventum-irc < 1.6.1-3.14
779 sed -i -e '
780 s,\$irc_host,$irc_server_hostname,
781 s,\$irc_port,$irc_server_port,
782 s,\$irc_nick,$nickname,
783 s,\$irc_realname,$realname,
784 s,\$irc_username,$username,
785 s,\$irc_password,$password,
786 ' /etc/eventum/irc.php
787
788 %triggerpostun -- eventum < 1.7.0-2.0.48
789 # migrate from apache-config macros
790 if [ -f /etc/%{name}/apache.conf.rpmsave ]; then
791         if [ -d /etc/apache/webapps.d ]; then
792                 cp -f %{_webapps}/%{_webapp}/apache.conf{,.rpmnew}
793                 cp -f /etc/%{name}/apache.conf.rpmsave %{_webapps}/%{_webapp}/apache.conf
794         fi
795
796         if [ -d /etc/httpd/webapps.d ]; then
797                 cp -f %{_webapps}/%{_webapp}/httpd.conf{,.rpmnew}
798                 cp -f /etc/%{name}/apache.conf.rpmsave %{_webapps}/%{_webapp}/httpd.conf
799         fi
800 fi
801
802 if [ -L /etc/apache/conf.d/99_%{_webapp}.conf ]; then
803         /usr/sbin/webapp register apache %{_webapp}
804         rm -f /etc/apache/conf.d/99_%{_webapp}.conf
805         %service -q apache reload
806 fi
807 if [ -L /etc/httpd/httpd.conf/99_%{_webapp}.conf ]; then
808         /usr/sbin/webapp register httpd %{_webapp}
809         rm -f /etc/httpd/httpd.conf/99_%{_webapp}.conf
810         %service -q httpd reload
811 fi
812
813 %{_appdir}/upgrade/upgrade.sh %{_appdir}/upgrade/v1.6.1_to_v1.7.0 <<EOF
814 database_changes.php Perform database changes
815 set_root_message_ids.php Set iss_root_message_id
816 EOF
817
818 # regular configs
819 for i in apache.conf config.php private_key.php setup.php; do
820         if [ -f /etc/eventum/$i.rpmsave ]; then
821                 mv -f %{_webappdir}/$i{,.rpmnew}
822                 mv -f /etc/eventum/$i.rpmsave %{_webappdir}/$i
823         fi
824 done
825
826 %triggerpostun cli -- %{name}-cli < 1.7.0-3.4
827 if [ -f %{_webappdir}/cli.php.rpmsave ]; then
828         mv -f %{_sysconfdir}/cli.php{,.rpmnew}
829         mv -f %{_webappdir}/cli.php.rpmsave %{_sysconfdir}/cli.php
830 fi
831
832 %triggerpostun irc -- %{name}-irc < 1.7.0-3.4
833 if [ -f %{_webappdir}/irc.php.rpmsave ]; then
834         mv -f %{_sysconfdir}/irc.php{,.rpmnew}
835         mv -f %{_webappdir}/irc.php.rpmsave %{_sysconfdir}/irc.php
836 fi
837
838 %files
839 %defattr(644,root,root,755)
840 %doc ChangeLog FAQ INSTALL README UPGRADE CONTRIB
841 %doc docs/* setup/schema.sql
842 %attr(751,root,root) %dir %{_webappdir}
843 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/apache.conf
844 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/httpd.conf
845 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/config.php
846 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/private_key.php
847 %attr(660,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/setup.php
848 %attr(640,root,eventum) %config %verify(not mtime) %{_webappdir}/core.php
849
850 %dir %attr(731,root,eventum) /var/log/%{name}
851 %attr(620,root,eventum) %ghost /var/log/%{name}/*
852
853 %dir %{_appdir}/htdocs
854 %{_appdir}/htdocs/*.php
855 %{_appdir}/htdocs/*.ico
856 %{_appdir}/htdocs/css
857 %{_appdir}/htdocs/customer
858 %{_appdir}/htdocs/images
859 %{_appdir}/htdocs/js
860 %{_appdir}/htdocs/manage
861 %{_appdir}/htdocs/reports
862 %{_appdir}/htdocs/rpc
863 %{_appdir}/htdocs/misc
864
865 %{_appdir}/templates
866 %dir %{_appdir}/upgrade
867 %attr(755,root,root) %{_appdir}/upgrade/upgrade.sh
868 %{_appdir}/upgrade/[!u]*
869
870 %{_smartyplugindir}
871 %if %{without pear}
872 %{_appdir}/include/pear
873 %endif
874
875 %dir %{_appdir}/include
876 %{_appdir}/include/customer
877 %{_appdir}/include/custom_field
878 %{_appdir}/include/jpgraph
879 %{_appdir}/include/workflow
880 %{_appdir}/include/class.[!m]*.php
881 %{_appdir}/include/class.mail.php
882 %{_appdir}/include/class.mail_queue.php
883 %{_appdir}/include/class.mime_helper.php
884 %{_appdir}/include/class.misc.php
885 %{_appdir}/include/db_access.php
886
887 %dir %attr(730,root,eventum) /var/run/%{name}
888 %dir %attr(730,root,eventum) /var/cache/%{name}
889
890 %files base
891 %defattr(644,root,root,755)
892 %attr(751,root,root) %dir %{_sysconfdir}
893 %dir %{_libdir}
894 %dir %{_appdir}
895 # qmail will ignore user, if it's home directory is not owned
896 %attr(750,eventum,eventum) %dir /var/lib/%{name}
897 # saved mail copies
898 %attr(770,root,eventum) %dir /var/lib/%{name}/routed_emails
899 %attr(770,root,eventum) %dir /var/lib/%{name}/routed_drafts
900 %attr(770,root,eventum) %dir /var/lib/%{name}/routed_notes
901
902 %files setup
903 %defattr(644,root,root,755)
904 %{_appdir}/htdocs/setup
905
906 %files mail-queue
907 %defattr(644,root,root,755)
908 %attr(755,root,root) %{_appdir}/process_mail_queue.php
909 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-queue
910
911 %files mail-download
912 %defattr(644,root,root,755)
913 %attr(755,root,root) %{_appdir}/download_emails.php
914 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-download
915
916 %files reminder
917 %defattr(644,root,root,755)
918 %attr(755,root,root) %{_appdir}/check_reminders.php
919 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-reminder
920
921 %files monitor
922 %defattr(644,root,root,755)
923 %{_appdir}/include/class.monitor.php
924 %attr(755,root,root) %{_appdir}/monitor.php
925 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-monitor
926
927 %files route-drafts
928 %defattr(644,root,root,755)
929 %attr(755,root,root) %{_appdir}/route_drafts.php
930
931 %files route-emails
932 %defattr(644,root,root,755)
933 %attr(755,root,root) %{_appdir}/route_emails.php
934
935 %files route-notes
936 %defattr(644,root,root,755)
937 %attr(755,root,root) %{_appdir}/route_notes.php
938
939 %if %{with qmail}
940 %files router-qmail
941 %defattr(644,root,root,755)
942 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) /var/lib/%{name}/.qmail*
943 %attr(755,root,root) %{_libdir}/router-qmail
944 %endif
945
946 %files router-postfix
947 %defattr(644,root,root,755)
948 %attr(755,root,root) %{_libdir}/router-postfix
949
950 %files irc
951 %defattr(644,root,root,755)
952 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/irc.php
953 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/eventum-irc
954 %attr(755,root,root) %{_sbindir}/%{name}-bot
955 %attr(754,root,root) /etc/rc.d/init.d/%{name}-irc
956
957 %files cli
958 %defattr(644,root,root,755)
959 %doc eventumrc
960 %attr(644,root,root) %config %verify(not md5 mtime size) %{_sysconfdir}/cli.php
961 %attr(755,root,root) %{_bindir}/%{name}
962 %{_appdir}/cli
963
964 %files scm
965 %defattr(644,root,root,755)
966 %attr(644,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/cvs.php
967 %attr(755,root,root) %{_libdir}/scm
This page took 0.140229 seconds and 4 git commands to generate.