]> git.pld-linux.org Git - packages/eventum.git/blob - eventum.spec
drop pear dependencies; mostly inaccurate and deps already listed
[packages/eventum.git] / eventum.spec
1 #
2 # Conditional build:
3 %bcond_with     order   # with experimental order patch
4
5 %define         rel             1
6 %define         subver  365
7 %define         githash 65c5538f
8 %define         php_min_version 5.6.0
9 Summary:        Eventum Issue / Bug tracking system
10 Summary(pl.UTF-8):      Eventum - system śledzenia spraw/błędów
11 Name:           eventum
12 Version:        3.3.4
13 Release:        %{?subver:1.%{subver}.%{?githash:g%{githash}.}}%{rel}
14 License:        GPL v2+
15 Group:          Applications/WWW
16 #Source0:       https://github.com/eventum/eventum/releases/download/v%{version}/%{name}-%{version}.tar.gz
17 Source0:        https://github.com/eventum/eventum/releases/download/snapshot/%{name}-%{version}-%{subver}-g%{githash}.tar.gz
18 # Source0-md5:  dd6a22d5798358e687b0a68eeb189581
19 Source1:        %{name}-apache.conf
20 Source2:        %{name}-mail-queue.cron
21 Source3:        %{name}-mail-download.cron
22 Source4:        %{name}-reminder.cron
23 Source5:        %{name}-monitor.cron
24 Source8:        %{name}-irc.init
25 Source9:        %{name}-irc.sysconfig
26 Source10:       sphinx.crontab
27 Source13:       %{name}-router-postfix.sh
28 Source14:       %{name}.logrotate
29 Source15:       %{name}-lighttpd.conf
30 Source16:       http://www.isocra.com/images/updown2.gif
31 # Source16-md5: deb6eeb2552ba757d3a949ed10c4107d
32 Source17:       %{name}.tmpfiles
33 Patch2:         %{name}-order.patch
34 #Patch3:                group-users.patch
35 #Patch4:                https://github.com/glensc/eventum/compare/cf_escape.patch
36 # packaging patches that probably never go upstream
37 Patch100:       %{name}-paths.patch
38 Patch107:       %{name}-gettext.patch
39 Patch108:       autoload.patch
40 # some tests
41 Patch200:       %{name}-fixed-nav.patch
42 URL:            https://wiki.github.com/eventum/eventum/
43 BuildRequires:  gettext-tools
44 BuildRequires:  rpmbuild(macros) >= 1.654
45 BuildRequires:  sed >= 4.0
46 Requires(postun):       /usr/sbin/groupdel
47 Requires(postun):       /usr/sbin/userdel
48 Requires(pre):  /bin/id
49 Requires(pre):  /usr/bin/getgid
50 Requires(pre):  /usr/sbin/groupadd
51 Requires(pre):  /usr/sbin/useradd
52 Requires:       fonts-TTF-RedHat-liberation
53 Requires:       php(core) >= %{php_min_version}
54 Requires:       php(filter)
55 Requires:       php(iconv)
56 Requires:       php(imap)
57 Requires:       php(json)
58 Requires:       php(mbstring)
59 Requires:       php(pcre)
60 Requires:       php(pdo_mysql)
61 Requires:       php(session)
62 Requires:       php-Smarty >= 3.1
63 Requires:       php-Smarty-plugin-gettext
64 Requires:       php-ZendFramework-Config >= 2.4
65 Requires:       php-ZendFramework-Loader >= 2.4
66 Requires:       php-ZendFramework-Mail >= 2.4.13-2
67 Requires:       php-ZendFramework-Mime >= 2.4
68 Requires:       php-ZendFramework-ServiceManager >= 2.4
69 Requires:       php-ZendFramework-Validator >= 2.4
70 Requires:       php-monolog >= 1.17.2
71 Requires:       php-pear-Math_Stats
72 Requires:       php-pear-Net_SMTP
73 Requires:       php-pear-Net_Socket
74 Requires:       php-pear-Net_URL
75 Requires:       php-pear-PEAR-core
76 Requires:       php-pear-Text_Diff
77 Requires:       php-psr-Log >= 1.0.0-2
78 Requires:       phplot >= 5.8.0
79 Requires:       webapps
80 Requires:       webserver(access)
81 Requires:       webserver(alias)
82 Requires:       webserver(indexfile)
83 Requires:       webserver(php) >= 4.2.0
84 Suggests:       localedb
85 Suggests:       php(mcrypt)
86 Suggests:       php(openssl)
87 Suggests:       php-pear-Net_POP3
88 Suggests:       webserver(setenv)
89 Provides:       group(eventum)
90 Provides:       user(eventum)
91 Obsoletes:      eventum-base < 3.0.3-1.305
92 Obsoletes:      eventum-route-drafts < 3.0.8-1.1
93 Obsoletes:      eventum-route-emails < 3.0.8-1.1
94 Obsoletes:      eventum-route-notes < 3.0.8-1.1
95 Conflicts:      logrotate < 3.8.0
96 BuildArch:      noarch
97 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
98
99 %define         _libdir         %{_prefix}/lib/%{name}
100 %define         _appdir         %{_datadir}/%{name}
101 %define         _smartydir      %{php_data_dir}/Smarty
102 %define         _webapps        /etc/webapps
103 %define         _webapp         %{name}
104 %define         _webappdir      %{_webapps}/%{_webapp}
105 %define         _sysconfdir     /etc/%{name}
106
107 %description
108 Eventum is a user-friendly and flexible issue tracking system that can
109 be used by a support department to track incoming technical support
110 requests, or by a software development team to quickly organize tasks
111 and bugs.
112
113 %description -l pl.UTF-8
114 Eventum to przyjazny dla użytkownika system śledzenia spraw, który
115 może być używany przez dział obsługi do śledzenia przychodzących żądań
116 obsługi technicznej albo przez zespół tworzący oprogramowanie do
117 szybkiej organizacji zadań i błędów.
118
119 %package setup
120 Summary:        Eventum setup package
121 Summary(pl.UTF-8):      Pakiet do wstępnej konfiguracji Eventum
122 Group:          Applications/WWW
123 Requires:       %{name} = %{version}-%{release}
124
125 %description setup
126 Install this package to configure initial Eventum installation. You
127 should uninstall this package when you're done, as it considered
128 insecure to keep the setup files in place.
129
130 %description setup -l pl.UTF-8
131 Ten pakiet należy zainstalować w celu wstępnej konfiguracji Eventum po
132 pierwszej instalacji. Potem należy go odinstalować, jako że
133 pozostawienie plików instalacyjnych mogłoby być niebezpieczne.
134
135 %package doc
136 Summary:        Eventum documentation and Wiki
137 Group:          Documentation
138
139 %description doc
140 Eventum documentation and copy of Wiki.
141
142 %package mail-queue
143 Summary:        Eventum mail queue process
144 Summary(pl.UTF-8):      Przetwarzanie kolejki poczty Eventum
145 Group:          Applications/WWW
146 Requires:       %{name} = %{version}-%{release}
147 Requires:       crondaemon
148
149 %description mail-queue
150 Beginning with the first release of Eventum, emails are not directly
151 sent out from the various scripts, but rather added to a mail queue
152 table that is processed by a cron job. If an email cannot be sent, it
153 will be marked as such in the mail queue log, and the cron job script
154 will re-try to send it again the next time it runs.
155
156 This package contains the cron job.
157
158 %description mail-queue -l pl.UTF-8
159 Od pierwszego wydania Eventum poczta nie jest wysyłana bezpośrednio z
160 różnych skryptów, lecz dodawana do kolejki przetwarzanej z crona.
161 Jeśli poczta nie może być wysłana, będzie odpowiednio oznaczona w logu
162 kolejki poczty, a skrypt z crona będzie próbował wysłać ją ponownie
163 następnym razem.
164
165 Ten pakiet zawiera zadanie dla crona.
166
167 %package mail-download
168 Summary:        Eventum email download
169 Summary(pl.UTF-8):      Ściąganie poczty Eventum
170 Group:          Applications/WWW
171 Requires:       %{name} = %{version}-%{release}
172 Requires:       crondaemon
173
174 %description mail-download
175 In order for Eventum's email integration feature to work, you need to
176 setup a cron job to run the script every so often.
177
178 This package contains the cron job.
179
180 %description mail-download -l pl.UTF-8
181 Aby integracja poczty elektronicznej w Eventum działała, trzeba
182 ustawić zadanie crona, aby uruchamiał odpowiedni skrypt wystarczająco
183 często.
184
185 Ten pakiet zawiera zadanie dla crona.
186
187 %package reminder
188 Summary:        Eventum Reminder System
189 Summary(pl.UTF-8):      System przypominania dla Eventum
190 Group:          Applications/WWW
191 Requires:       %{name} = %{version}-%{release}
192 Requires:       crondaemon
193
194 %description reminder
195 The reminder system was designed with the objective as serving as a
196 safe net for issues that need attention. Depending on what
197 configuration you create, you may have several reminders (or alerts)
198 be sent out whenever an issue needs attention, for whatever parameter
199 you may deem necessary.
200
201 This package contains the cron job.
202
203 %description reminder -l pl.UTF-8
204 System przypominania został zaprojektowany tak, aby służył jako
205 bezpieczna sieć dla spraw wymagających uwagi. W zależności od
206 konfiguracji można ustawić różne przypominajki (lub alarmy) wysyłane
207 przy każdej sprawie wymagającej uwagi lub przy parametrze, który można
208 uważać za potrzebny.
209
210 Ten pakiet zawiera zadanie dla crona.
211
212 %package monitor
213 Summary:        Eventum Heartbeat Monitor
214 Summary(pl.UTF-8):      Monitor życia dla Eventum
215 Group:          Applications/WWW
216 Requires:       %{name} = %{version}-%{release}
217 Requires:       crondaemon
218 Requires:       php(posix)
219
220 %description monitor
221 The heartbeat monitor is a feature designed for the administrator that
222 wants to be alerted whenever a common problem in Eventum is detected,
223 like the database server not being available anymore, or maybe when
224 the recommended permissions for certain configuration files are
225 changed.
226
227 Please note that before running the heartbeat monitor, you may need to
228 customize some of the checks to be appropriate for your own system,
229 particularly the permission and file checks on
230 Monitor::checkConfiguration().
231
232 This package contains the cron job.
233
234 %description monitor -l pl.UTF-8
235 Monitor życia to funkcjonalność zaprojektowana dla administratora
236 chcącego być alarmowanym przy każdym wykryciu popularnego problemu z
237 Eventum, jak nie działanie serwera bazy danych albo zmiana uprawnień
238 do plików konfiguracyjnych.
239
240 Należy zauważyć, że przed uruchomieniem tego monitora może być
241 konieczne dostosowanie niektórych testów do systemu, w szczególności
242 testów uprawnień i plików w Monitor::checkConfiguration().
243
244 Ten pakiet zawiera zadanie dla crona.
245
246 %package router-postfix
247 Summary:        Eventum Mail Routing - Postfix
248 Summary(pl.UTF-8):      Przekazywanie poczty Eventum - Postfix
249 Group:          Applications/Mail
250 Requires:       %{name} = %{version}-%{release}
251 Requires:       postfix
252 Provides:       eventum(router)
253 Obsoletes:      eventum(router)
254
255 %description router-postfix
256 This package provides way of routing notes and emails back to Eventum
257 via Postfix.
258
259 The Postfix configuration instructions you can find from
260 <https://github.com/eventum/eventum/wiki/System-Admin:-Setting-up-email-routing-with-postfix>
261
262 %description router-postfix -l pl.UTF-8
263 Ten pakiet udostępnia metodę przekazywania notatek i listów do Eventum
264 przez Postfiksa.
265
266 Opis konfiguracji Postfiksa można znaleźć pod adresem
267 <https://github.com/eventum/eventum/wiki/System-Admin:-Setting-up-email-routing-with-postfix>
268
269 %package irc
270 Summary:        Eventum IRC Notification Bot
271 Summary(pl.UTF-8):      IRC-owy bot powiadamiający dla Eventum
272 Group:          Applications/WWW
273 Requires(post,preun):   /sbin/chkconfig
274 Requires:       %{name} = %{version}-%{release}
275 Requires:       php(pcntl)
276 Requires:       php(sockets)
277 Requires:       php-pear-Net_SmartIRC >= 1.1.9
278 Requires:       rc-scripts >= 0.4.0.18
279
280 %description irc
281 The IRC notification bot is a nice feature for remote teams that want
282 to handle issues and want to have a quick and easy way to get simple
283 notifications. Right now the bot notifies of the following actions:
284 - New Issues
285 - Blocked emails
286 - Issues that got their assignment list changed
287
288 NOTE: You will need to manually edit the bot.php script to set your
289 appropriate preferences, like IRC server and channel that the bot
290 should join.
291
292 %description irc -l pl.UTF-8
293 IRC-owy bot powiadamiający to miła funkcjonalność dla zdalnych
294 zespołów chcących obsługiwać sprawy i mieć szybki i łatwy sposób na
295 uzyskiwanie prostych powiadomień. Aktualnie bot powiadamia o
296 następujących zdarzeniach:
297 - nowych sprawach
298 - zablokowanych listach
299 - sprawach, dla których zmieniła się lista powiązań
300
301 UWAGA: w celu wprowadzenia własnych ustawień, takich jak serwer IRC i
302 kanał używany przez bota, trzeba ręcznie zmodyfikować skrypt bot.php .
303
304 %package cli
305 Summary:        Eventum command-line interface
306 Summary(pl.UTF-8):      Interfejs linii poleceń dla Eventum
307 Group:          Applications/WWW
308 Requires:       php(core) >= %{php_min_version}
309 Requires:       php(phar)
310
311 %description cli
312 The Eventum command-line interface allows you to access most of the
313 features of the web interface straight from your command shell.
314
315 %description cli -l pl.UTF-8
316 Interfejs linii poleceń Eventum pozwala na dostęp do większości
317 funkcji interfejsu WWW prosto z linii poleceń powłoki.
318
319 %package sphinx
320 Summary:        Eventum Sphinx Search
321 Group:          Applications/WWW
322 Requires:       %{name} = %{version}-%{release}
323 Requires:       crondaemon
324 Requires:       sphinx
325
326 %description sphinx
327 Sphinx search integration for Eventum.
328
329 This package contains the cron job.
330
331 %prep
332 %setup -q -n %{name}-%{version}%{?githash:-%{subver}-g%{githash}}
333
334 mv docs/examples .
335
336 # bug fixes / features
337 %{?with_order:%patch2 -p1}
338 #%patch3 -p0
339 #%patch4 -p1
340
341 %{?with_order:cp -p %{SOURCE16} htdocs/images}
342
343 #%patch200 -p1
344
345 # produce default sphinx config
346 # must be run before paths.patch
347 %if 0
348 cat <<'EOF' > config/config.php
349 <?php
350 define('APP_SQL_DBTYPE', 'mysql');
351 define('APP_SQL_DBHOST', 'localhost:/var/lib/mysql/mysql.sock');
352 define('APP_SQL_DBPORT', 3306);
353 define('APP_SQL_DBNAME', 'eventum');
354 define('APP_SQL_DBUSER', 'mysql');
355 define('APP_SQL_DBPASS', '');
356 define('APP_TABLE_PREFIX', 'eventum_');
357 EOF
358 php config/sphinx.conf.php > config/sphinx.conf
359 rm config/config.php
360 %endif
361
362 # packaging
363 %patch100 -p1
364 %patch107 -p1
365 %patch108 -p1
366
367 rm htdocs/.htaccess.dist
368
369 mv config/irc_config{.dist.php,.php}
370 rm config/config.dist.php
371
372 # cleanup vendor. keep only needed libraries.
373 # (the rest are packaged with system packages)
374 mv vendor vendor.dist
375 vendor() {
376         local path dir
377         for path; do
378                 dir=$(dirname $path)
379                 test -d vendor/$dir || mkdir -p vendor/$dir
380                 mv vendor.dist/$path vendor/$path
381         done
382 }
383 vendor autoload.php
384 vendor composer/autoload_{classmap,files,namespaces,real,psr4}.php
385 vendor composer/ClassLoader.php
386 vendor ircmaxell/{random-lib,security-lib}
387 vendor defuse/php-encryption
388 vendor willdurand/email-reply-parser
389 vendor theorchard/monolog-cascade
390 vendor malkusch/lock
391 vendor phpxmlrpc/phpxmlrpc
392 vendor robmorgan/phinx
393 vendor mnapoli/silly
394 vendor psr/container
395 vendor phlib/flysystem-pdo
396 vendor league/flysystem
397 vendor php-di/invoker
398 vendor container-interop/container-interop
399 vendor symfony/config
400 vendor symfony/console
401 vendor symfony/debug
402 vendor symfony/event-dispatcher
403 vendor symfony/filesystem
404 vendor symfony/http-foundation
405 vendor symfony/options-resolver
406 vendor symfony/serializer
407 vendor symfony/yaml
408 vendor symfony/ldap
409 vendor paragonie/random_compat
410 vendor symfony/polyfill-php70
411
412 # remove backups from patching as we use globs to package files to buildroot
413 find '(' -name '*~' -o -name '*.orig' ')' | xargs -r rm -v
414
415 %build
416 %{__make} -C localization
417
418 %install
419 rm -rf $RPM_BUILD_ROOT
420 install -d \
421         $RPM_BUILD_ROOT{%{_webappdir}/{custom_field,templates,workflow},%{_sysconfdir},%{_bindir},%{_sbindir},%{_libdir}} \
422         $RPM_BUILD_ROOT/etc/{rc.d/init.d,cron.d,logrotate.d,sysconfig} \
423         $RPM_BUILD_ROOT/var/{run,cache,lib}/%{name} \
424         $RPM_BUILD_ROOT/var/log/{archive/,}%{name} \
425         $RPM_BUILD_ROOT/var/lib/%{name}/{routed_{emails,drafts,notes},storage} \
426         $RPM_BUILD_ROOT%{systemdtmpfilesdir}
427
428 %{__make} install-eventum install-cli install-localization \
429         sysconfdir=%{_webappdir} \
430         localedir=%{_localedir} \
431         DESTDIR=$RPM_BUILD_ROOT
432
433 ln -s %{_webappdir} $RPM_BUILD_ROOT%{_appdir}/config
434
435 cp -a vendor $RPM_BUILD_ROOT%{_appdir}
436
437 # unsupported locale
438 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/ht
439
440 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
441 cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
442
443 %{?with_order:cp -a htdocs/ajax $RPM_BUILD_ROOT%{_appdir}/htdocs}
444
445 touch $RPM_BUILD_ROOT%{_webappdir}/htpasswd
446 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_webappdir}/apache.conf
447 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_webappdir}/httpd.conf
448 cp -p %{SOURCE15} $RPM_BUILD_ROOT%{_webappdir}/lighttpd.conf
449
450 install -d $RPM_BUILD_ROOT/etc/sphinx
451 #cp -p config/sphinx.conf $RPM_BUILD_ROOT/etc/sphinx/%{name}.conf
452 cp -p config/sphinx.conf.php $RPM_BUILD_ROOT%{_webappdir}
453
454 cp -p %{SOURCE2} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-queue
455 cp -p %{SOURCE3} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-download
456 cp -p %{SOURCE4} $RPM_BUILD_ROOT/etc/cron.d/%{name}-reminder
457 cp -p %{SOURCE5} $RPM_BUILD_ROOT/etc/cron.d/%{name}-monitor
458 cp -p %{SOURCE10} $RPM_BUILD_ROOT/etc/cron.d/%{name}-sphinx
459
460 install -p %{SOURCE8} $RPM_BUILD_ROOT/etc/rc.d/init.d/eventum-irc
461 cp -p %{SOURCE9} $RPM_BUILD_ROOT/etc/sysconfig/eventum-irc
462
463 cp -p %{SOURCE14} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
464
465 # postfix router
466 install -p %{SOURCE13} $RPM_BUILD_ROOT%{_libdir}/router-postfix
467
468 cp -p %{SOURCE17} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/%{name}.conf
469
470 %find_lang %{name}
471
472 %clean
473 rm -rf $RPM_BUILD_ROOT
474
475 %pre
476 %groupadd -g 146 %{name}
477 %useradd -u 146 -d /var/lib/%{name} -g %{name} -c "Eventum User" %{name}
478 %addusertogroup http %{name}
479
480 %post
481 # create empty ghost files
482 # these permissions ensure the logs are write only
483 for a in \
484         errors.log login_attempts.log \
485         eventum.log \
486         auth.log cli.log \
487         irc_bot_error.log irc_bot_smartirc.log \
488 ; do
489         test -f /var/log/%{name}/$a && continue
490         install -m 0620 -o root -g http /dev/null /var/log/%{name}/$a
491 done
492
493 # run database update if configured
494 test -s %{_webappdir}/config.php && \
495 %{_appdir}/bin/upgrade.php || :
496
497 # nuke Smarty templates cache after upgrade
498 rm -f /var/cache/eventum/*.php
499
500 # Restart webserver on upgrade to get .mo translations reloaded.
501 # actually php engines "php-fcgi" and "php-fpm" needed only, apache is restarted anyway via webapp trigger.
502 %php_webserver_restart
503
504 %preun
505 if [ "$1" = "0" ]; then
506         # nuke cache
507         rm -f /var/cache/eventum/*.php 2>/dev/null || :
508 fi
509
510 %postun
511 if [ "$1" = "0" ]; then
512         %userremove %{name}
513         %groupremove %{name}
514 fi
515
516 %post setup
517 chmod 660 %{_webappdir}/{config,private_key,secret_key}.php
518 chown root:http %{_webappdir}/{config,private_key,secret_key}.php
519
520 %postun setup
521 if [ "$1" = "0" ] && [ -f %{_webappdir}/config.php ]; then
522         chmod 640 %{_webappdir}/{config,private_key,secret_key}.php
523         chown root:http %{_webappdir}/{config,private_key,secret_key}.php
524 fi
525
526 %post irc
527 /sbin/chkconfig --add eventum-irc
528 %service eventum-irc restart "Eventum IRC Bot"
529
530 %preun irc
531 if [ "$1" = 0 ]; then
532         %service eventum-irc stop
533         /sbin/chkconfig --del eventum-irc
534 fi
535
536 %triggerin -- apache1 < 1.3.37-3, apache1-base
537 %webapp_register apache %{_webapp}
538
539 %triggerun -- apache1 < 1.3.37-3, apache1-base
540 %webapp_unregister apache %{_webapp}
541
542 %triggerin -- apache < 2.2.0, apache-base
543 %webapp_register httpd %{_webapp}
544
545 %triggerun -- apache < 2.2.0, apache-base
546 %webapp_unregister httpd %{_webapp}
547
548 %triggerin -- lighttpd
549 %webapp_register lighttpd %{_webapp}
550
551 %triggerun -- lighttpd
552 %webapp_unregister lighttpd %{_webapp}
553
554 %triggerpostun -- %{name} < 3.0.0-0.2
555 for f in /etc/cron.d/eventum-*; do
556         # crontabs moved to bin
557         %{__sed} -i -e '
558                 s,/usr/share/eventum/crons/process_mail_queue.php,%{_appdir}/bin/process_mail_queue.php,
559                 s,/usr/share/eventum/crons/download_emails.php,%{_appdir}/bin/download_emails.php,
560                 s,/usr/share/eventum/crons/check_reminders.php,%{_appdir}/bin/check_reminders.php,
561                 s,/usr/share/eventum/crons/monitor.php,%{_appdir}/bin/monitor.php,
562         ' $f
563 done
564
565 %files -f %{name}.lang
566 %defattr(644,root,root,755)
567 %attr(751,root,root) %dir %{_webappdir}
568 %attr(751,root,http) %dir %{_webappdir}/crm
569 %attr(751,root,http) %dir %{_webappdir}/custom_field
570 %attr(751,root,http) %dir %{_webappdir}/partner
571 %attr(751,root,http) %dir %{_webappdir}/templates
572 %attr(751,root,http) %dir %{_webappdir}/workflow
573 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/apache.conf
574 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/httpd.conf
575 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/lighttpd.conf
576 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/config.php
577 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/private_key.php
578 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/secret_key.php
579 %attr(660,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/setup.php
580 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/htpasswd
581
582 %dir %attr(731,root,http) /var/log/%{name}
583 %attr(620,root,http) %ghost /var/log/%{name}/*
584 %dir %attr(750,root,root) /var/log/archive/%{name}
585 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/%{name}
586
587 %dir %{_appdir}
588 %{_appdir}/config
589
590 %dir %{_appdir}/bin
591 %attr(755,root,root) %{_appdir}/bin/extension.php
592 %attr(755,root,root) %{_appdir}/bin/ldapsync.php
593 %attr(755,root,root) %{_appdir}/bin/process_all_emails.php
594 %attr(755,root,root) %{_appdir}/bin/upgrade.php
595
596 %{_appdir}/autoload.php
597 %{_appdir}/globals.php
598 %{_appdir}/init.php
599 %{_appdir}/phinx.php
600 %dir %{_appdir}/htdocs
601 %{_appdir}/htdocs/*.php
602 %{_appdir}/htdocs/*.ico
603 %{_appdir}/htdocs/ajax
604 %{_appdir}/htdocs/css
605 %{_appdir}/htdocs/customer
606 %{_appdir}/htdocs/images
607 %{_appdir}/htdocs/js
608 %{_appdir}/htdocs/manage
609 %{_appdir}/htdocs/reports
610 %{_appdir}/htdocs/rpc
611 %{_appdir}/htdocs/components
612 %{_appdir}/templates
613
614 %dir %{_appdir}/db
615 %dir %{_appdir}/db/migrations
616 %{_appdir}/db/migrations/*.php
617
618 %{_appdir}/res
619 %{_appdir}/src
620 %{_appdir}/vendor
621 %dir %{_appdir}/lib
622 %{_appdir}/lib/eventum
623 %exclude %{_appdir}/src/Console/Command/MailDownloadCommand.php
624 %exclude %{_appdir}/src/Console/Command/MailQueueProcessCommand.php
625 %exclude %{_appdir}/src/Console/Command/MailQueueTruncateCommand.php
626 %exclude %{_appdir}/src/Console/Command/MonitorCommand.php
627 %exclude %{_appdir}/src/Console/Command/ReminderCheckCommand.php
628
629 %dir %{_libdir}
630
631 %{systemdtmpfilesdir}/%{name}.conf
632
633 %dir /var/lib/%{name}
634 %dir %attr(730,root,http) /var/run/%{name}
635 %dir %attr(730,root,http) /var/cache/%{name}
636
637 # saved mail copies
638 %attr(770,root,http) %dir /var/lib/%{name}/routed_emails
639 %attr(770,root,http) %dir /var/lib/%{name}/routed_drafts
640 %attr(770,root,http) %dir /var/lib/%{name}/routed_notes
641 # attachment storage
642 %attr(770,root,http) %dir /var/lib/%{name}/storage
643
644 %files setup
645 %defattr(644,root,root,755)
646 %{_appdir}/htdocs/setup
647
648 %files doc
649 %defattr(644,root,root,755)
650 %doc docs/*
651 %{_examplesdir}/%{name}-%{version}
652
653 %files mail-queue
654 %defattr(644,root,root,755)
655 %{_appdir}/src/Console/Command/MailQueueProcessCommand.php
656 %{_appdir}/src/Console/Command/MailQueueTruncateCommand.php
657 %attr(755,root,root) %{_appdir}/bin/process_mail_queue.php
658 %attr(755,root,root) %{_appdir}/bin/truncate_mail_queue.php
659 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-queue
660
661 %files mail-download
662 %defattr(644,root,root,755)
663 %{_appdir}/src/Console/Command/MailDownloadCommand.php
664 %attr(755,root,root) %{_appdir}/bin/download_emails.php
665 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-download
666
667 %files reminder
668 %defattr(644,root,root,755)
669 %{_appdir}/src/Console/Command/ReminderCheckCommand.php
670 %attr(755,root,root) %{_appdir}/bin/check_reminders.php
671 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-reminder
672
673 %files monitor
674 %defattr(644,root,root,755)
675 %{_appdir}/src/Console/Command/MonitorCommand.php
676 %attr(755,root,root) %{_appdir}/bin/monitor.php
677 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-monitor
678
679 %files router-postfix
680 %defattr(644,root,root,755)
681 %attr(755,root,root) %{_libdir}/router-postfix
682
683 %files irc
684 %defattr(644,root,root,755)
685 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/irc_config.php
686 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/eventum-irc
687 %attr(755,root,root) %{_appdir}/bin/irc-bot.php
688 %attr(754,root,root) /etc/rc.d/init.d/%{name}-irc
689
690 %files cli
691 %defattr(644,root,root,755)
692 %doc cli/eventumrc
693 %attr(755,root,root) %{_bindir}/%{name}
694
695 %files sphinx
696 %defattr(644,root,root,755)
697 %{_webappdir}/sphinx.conf.php
698 #%attr(750,root,http) %config(noreplace) %verify(not md5 mtime size) /etc/sphinx/%{name}.conf
699 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-sphinx
This page took 0.08682 seconds and 3 git commands to generate.