]> git.pld-linux.org Git - packages/eventum.git/blob - eventum.spec
up to 3.0.8-54-g2771cf2
[packages/eventum.git] / eventum.spec
1 #
2 # Conditional build:
3 %bcond_with     order   # with experimental order patch
4
5 %define         rel             1.3
6 %define         subver  54
7 %define         githash 2771cf2
8 %define         php_min_version 5.3.7
9 %include        /usr/lib/rpm/macros.php
10 Summary:        Eventum Issue / Bug tracking system
11 Summary(pl.UTF-8):      Eventum - system śledzenia spraw/błędów
12 Name:           eventum
13 Version:        3.0.8
14 Release:        %{?subver:1.%{subver}.%{?githash:g%{githash}.}}%{rel}
15 License:        GPL v2+
16 Group:          Applications/WWW
17 #Source0:       https://github.com/eventum/eventum/releases/download/v%{version}/%{name}-%{version}.tar.gz
18 Source0:        %{name}-%{version}-%{subver}-g%{githash}.tar.gz
19 # Source0-md5:  ca8932c1d68bdde29fddd89982db2c94
20 Source1:        %{name}-apache.conf
21 Source2:        %{name}-mail-queue.cron
22 Source3:        %{name}-mail-download.cron
23 Source4:        %{name}-reminder.cron
24 Source5:        %{name}-monitor.cron
25 Source6:        %{name}-cvs.php
26 Source8:        %{name}-irc.init
27 Source9:        %{name}-irc.sysconfig
28 Source10:       sphinx.crontab
29 Source13:       %{name}-router-postfix.sh
30 Source14:       %{name}.logrotate
31 Source15:       %{name}-lighttpd.conf
32 Source16:       http://www.isocra.com/images/updown2.gif
33 # Source16-md5: deb6eeb2552ba757d3a949ed10c4107d
34 Source17:       %{name}.tmpfiles
35 Patch2:         %{name}-order.patch
36 #Patch3:                group-users.patch
37 #Patch4:                https://github.com/glensc/eventum/compare/cf_escape.patch
38 # packaging patches that probably never go upstream
39 Patch100:       %{name}-paths.patch
40 Patch101:       %{name}-cvs-config.patch
41 Patch107:       %{name}-gettext.patch
42 Patch108:       autoload.patch
43 # some tests
44 Patch200:       %{name}-fixed-nav.patch
45 URL:            http://eventum.mysql.org/
46 BuildRequires:  /usr/bin/php
47 BuildRequires:  gettext-devel
48 BuildRequires:  php(core) >= %{php_min_version}
49 BuildRequires:  rpm-php-pearprov >= 4.0.2-98
50 BuildRequires:  rpmbuild(macros) >= 1.654
51 BuildRequires:  sed >= 4.0
52 Requires(postun):       /usr/sbin/groupdel
53 Requires(postun):       /usr/sbin/userdel
54 Requires(pre):  /bin/id
55 Requires(pre):  /usr/bin/getgid
56 Requires(pre):  /usr/sbin/groupadd
57 Requires(pre):  /usr/sbin/useradd
58 Requires:       fonts-TTF-RedHat-liberation
59 Requires:       php(core) >= %{php_min_version}
60 Requires:       php(filter)
61 Requires:       php(iconv)
62 Requires:       php(imap)
63 Requires:       php(json)
64 Requires:       php(mbstring)
65 Requires:       php(mysqli)
66 Requires:       php(pcre)
67 Requires:       php(session)
68 Requires:       php-Smarty >= 3.1
69 Requires:       php-Smarty-plugin-gettext
70 Requires:       php-ZendFramework-Config >= 2.4
71 Requires:       php-monolog >= 1.17.2
72 Requires:       php-pear-DB
73 Requires:       php-pear-Mail
74 Requires:       php-pear-Mail_Mime
75 Requires:       php-pear-Mail_mimeDecode
76 Requires:       php-pear-Math_Stats
77 Requires:       php-pear-Net_DIME
78 Requires:       php-pear-Net_SMTP
79 Requires:       php-pear-Net_Socket
80 Requires:       php-pear-Net_URL
81 Requires:       php-pear-Net_UserAgent_Detect
82 Requires:       php-pear-PEAR-core
83 Requires:       php-pear-Text_Diff
84 Requires:       php-pear-XML_RPC
85 Requires:       php-psr-Log >= 1.0.0-2
86 Requires:       php-symfony2-HttpFoundation >= 2.7.7
87 Requires:       phplot >= 5.8.0
88 Requires:       webapps
89 Requires:       webserver(access)
90 Requires:       webserver(alias)
91 Requires:       webserver(indexfile)
92 Requires:       webserver(php) >= 4.2.0
93 Suggests:       localedb
94 Suggests:       php-pear-Net_LDAP2
95 Suggests:       webserver(setenv)
96 Provides:       group(eventum)
97 Provides:       user(eventum)
98 Obsoletes:      eventum-base < 3.0.3-1.305
99 Obsoletes:      eventum-route-drafts < 3.0.8-1.1
100 Obsoletes:      eventum-route-emails < 3.0.8-1.1
101 Obsoletes:      eventum-route-notes < 3.0.8-1.1
102 Conflicts:      logrotate < 3.8.0
103 BuildArch:      noarch
104 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
105
106 %define         _noautoreq_pear ../init.php ../../init.php init.php /usr/share/eventum/init.php /etc/webapps/.* %{_appdir}/.* .*Smarty.class.php Services/JSON.php class.date_helper.php sphinxapi.php Net/LDAP2.* Auth/SASL.* Util.php smarty_internal.*
107
108 # exclude optional php dependencies
109 %define         _noautophp      php-gnupg php-hash php-pecl-http php-tk
110
111 %define         _noautoreq      %{_noautophp}
112
113 %define         _libdir         %{_prefix}/lib/%{name}
114 %define         _appdir         %{_datadir}/%{name}
115 %define         _smartydir      %{php_data_dir}/Smarty
116 %define         _webapps        /etc/webapps
117 %define         _webapp         %{name}
118 %define         _webappdir      %{_webapps}/%{_webapp}
119 %define         _sysconfdir     /etc/%{name}
120
121 %description
122 Eventum is a user-friendly and flexible issue tracking system that can
123 be used by a support department to track incoming technical support
124 requests, or by a software development team to quickly organize tasks
125 and bugs. Eventum is used by the MySQL AB Technical Support team, and
126 has allowed us to dramatically improve our response times.
127
128 %description -l pl.UTF-8
129 Eventum to przyjazny dla użytkownika system śledzenia spraw, który
130 może być używany przez dział obsługi do śledzenia przychodzących żądań
131 obsługi technicznej albo przez zespół tworzący oprogramowanie do
132 szybkiej organizacji zadań i błędów. Eventum jest używany przez zespół
133 Technical Support MySQL AB i umożliwił im znacząco poprawić czasy
134 reakcji.
135
136 %package setup
137 Summary:        Eventum setup package
138 Summary(pl.UTF-8):      Pakiet do wstępnej konfiguracji Eventum
139 Group:          Applications/WWW
140 Requires:       %{name} = %{version}-%{release}
141
142 %description setup
143 Install this package to configure initial Eventum installation. You
144 should uninstall this package when you're done, as it considered
145 insecure to keep the setup files in place.
146
147 %description setup -l pl.UTF-8
148 Ten pakiet należy zainstalować w celu wstępnej konfiguracji Eventum po
149 pierwszej instalacji. Potem należy go odinstalować, jako że
150 pozostawienie plików instalacyjnych mogłoby być niebezpieczne.
151
152 %package doc
153 Summary:        Eventum documentation and Wiki
154 Group:          Documentation
155
156 %description doc
157 Eventum documentation and copy of Wiki.
158
159 %package mail-queue
160 Summary:        Eventum mail queue process
161 Summary(pl.UTF-8):      Przetwarzanie kolejki poczty Eventum
162 Group:          Applications/WWW
163 Requires:       %{name} = %{version}-%{release}
164 Requires:       crondaemon
165
166 %description mail-queue
167 Beginning with the first release of Eventum, emails are not directly
168 sent out from the various scripts, but rather added to a mail queue
169 table that is processed by a cron job. If an email cannot be sent, it
170 will be marked as such in the mail queue log, and the cron job script
171 will re-try to send it again the next time it runs.
172
173 This package contains the cron job.
174
175 %description mail-queue -l pl.UTF-8
176 Od pierwszego wydania Eventum poczta nie jest wysyłana bezpośrednio z
177 różnych skryptów, lecz dodawana do kolejki przetwarzanej z crona.
178 Jeśli poczta nie może być wysłana, będzie odpowiednio oznaczona w logu
179 kolejki poczty, a skrypt z crona będzie próbował wysłać ją ponownie
180 następnym razem.
181
182 Ten pakiet zawiera zadanie dla crona.
183
184 %package mail-download
185 Summary:        Eventum email download
186 Summary(pl.UTF-8):      Ściąganie poczty Eventum
187 Group:          Applications/WWW
188 Requires:       %{name} = %{version}-%{release}
189 Requires:       crondaemon
190
191 %description mail-download
192 In order for Eventum's email integration feature to work, you need to
193 setup a cron job to run the script every so often.
194
195 This package contains the cron job.
196
197 %description mail-download -l pl.UTF-8
198 Aby integracja poczty elektronicznej w Eventum działała, trzeba
199 ustawić zadanie crona, aby uruchamiał odpowiedni skrypt wystarczająco
200 często.
201
202 Ten pakiet zawiera zadanie dla crona.
203
204 %package reminder
205 Summary:        Eventum Reminder System
206 Summary(pl.UTF-8):      System przypominania dla Eventum
207 Group:          Applications/WWW
208 Requires:       %{name} = %{version}-%{release}
209 Requires:       crondaemon
210
211 %description reminder
212 The reminder system was designed with the objective as serving as a
213 safe net for issues that need attention. Depending on what
214 configuration you create, you may have several reminders (or alerts)
215 be sent out whenever an issue needs attention, for whatever parameter
216 you may deem necessary.
217
218 This package contains the cron job.
219
220 %description reminder -l pl.UTF-8
221 System przypominania został zaprojektowany tak, aby służył jako
222 bezpieczna sieć dla spraw wymagających uwagi. W zależności od
223 konfiguracji można ustawić różne przypominajki (lub alarmy) wysyłane
224 przy każdej sprawie wymagającej uwagi lub przy parametrze, który można
225 uważać za potrzebny.
226
227 Ten pakiet zawiera zadanie dla crona.
228
229 %package monitor
230 Summary:        Eventum Heartbeat Monitor
231 Summary(pl.UTF-8):      Monitor życia dla Eventum
232 Group:          Applications/WWW
233 Requires:       %{name} = %{version}-%{release}
234 Requires:       crondaemon
235 Requires:       php(posix)
236
237 %description monitor
238 The heartbeat monitor is a feature designed for the administrator that
239 wants to be alerted whenever a common problem in Eventum is detected,
240 like the database server not being available anymore, or maybe when
241 the recommended permissions for certain configuration files are
242 changed.
243
244 Please note that before running the heartbeat monitor, you may need to
245 customize some of the checks to be appropriate for your own system,
246 particularly the permission and file checks on
247 Monitor::checkConfiguration().
248
249 This package contains the cron job.
250
251 %description monitor -l pl.UTF-8
252 Monitor życia to funkcjonalność zaprojektowana dla administratora
253 chcącego być alarmowanym przy każdym wykryciu popularnego problemu z
254 Eventum, jak nie działanie serwera bazy danych albo zmiana uprawnień
255 do plików konfiguracyjnych.
256
257 Należy zauważyć, że przed uruchomieniem tego monitora może być
258 konieczne dostosowanie niektórych testów do systemu, w szczególności
259 testów uprawnień i plików w Monitor::checkConfiguration().
260
261 Ten pakiet zawiera zadanie dla crona.
262
263 %package router-postfix
264 Summary:        Eventum Mail Routing - Postfix
265 Summary(pl.UTF-8):      Przekazywanie poczty Eventum - Postfix
266 Group:          Applications/Mail
267 Requires:       %{name} = %{version}-%{release}
268 Requires:       postfix
269 Provides:       eventum(router)
270 Obsoletes:      eventum(router)
271
272 %description router-postfix
273 This package provides way of routing notes and emails back to Eventum
274 via Postfix.
275
276 The Postfix configuration instructions you can find from
277 <http://eventum.mysql.org/wiki/index.php/Setting_up_email_routing_with_postfix>.
278
279 %description router-postfix -l pl.UTF-8
280 Ten pakiet udostępnia metodę przekazywania notatek i listów do Eventum
281 przez Postfiksa.
282
283 Opis konfiguracji Postfiksa można znaleźć pod adresem
284 <http://eventum.mysql.org/wiki/index.php/Setting_up_email_routing_with_postfix>.
285
286 %package irc
287 Summary:        Eventum IRC Notification Bot
288 Summary(pl.UTF-8):      IRC-owy bot powiadamiający dla Eventum
289 Group:          Applications/WWW
290 Requires(post,preun):   /sbin/chkconfig
291 Requires:       %{name} = %{version}-%{release}
292 Requires:       php(pcntl)
293 Requires:       php(sockets)
294 Requires:       php-pear-Net_SmartIRC >= 1.1.9
295 Requires:       rc-scripts >= 0.4.0.18
296
297 %description irc
298 The IRC notification bot is a nice feature for remote teams that want
299 to handle issues and want to have a quick and easy way to get simple
300 notifications. Right now the bot notifies of the following actions:
301 - New Issues
302 - Blocked emails
303 - Issues that got their assignment list changed
304
305 NOTE: You will need to manually edit the bot.php script to set your
306 appropriate preferences, like IRC server and channel that the bot
307 should join.
308
309 %description irc -l pl.UTF-8
310 IRC-owy bot powiadamiający to miła funkcjonalność dla zdalnych
311 zespołów chcących obsługiwać sprawy i mieć szybki i łatwy sposób na
312 uzyskiwanie prostych powiadomień. Aktualnie bot powiadamia o
313 następujących zdarzeniach:
314 - nowych sprawach
315 - zablokowanych listach
316 - sprawach, dla których zmieniła się lista powiązań
317
318 UWAGA: w celu wprowadzenia własnych ustawień, takich jak serwer IRC i
319 kanał używany przez bota, trzeba ręcznie zmodyfikować skrypt bot.php .
320
321 %package cli
322 Summary:        Eventum command-line interface
323 Summary(pl.UTF-8):      Interfejs linii poleceń dla Eventum
324 Group:          Applications/WWW
325 Requires:       php(core) >= %{php_min_version}
326 Requires:       php(phar)
327 Requires:       php-pear-XML_RPC
328
329 %description cli
330 The Eventum command-line interface allows you to access most of the
331 features of the web interface straight from your command shell.
332
333 %description cli -l pl.UTF-8
334 Interfejs linii poleceń Eventum pozwala na dostęp do większości
335 funkcji interfejsu WWW prosto z linii poleceń powłoki.
336
337 %package scm
338 Summary:        Eventum SCM integration
339 Summary(pl.UTF-8):      Integracja SCM dla Eventum
340 Group:          Applications/WWW
341 Requires:       php(core) >= %{php_min_version}
342 Requires:       php(json)
343 Requires:       php(pcre)
344 Requires:       php(spl)
345 Suggests:       cvs
346 Suggests:       git-core
347 Suggests:       php(openssl)
348 Suggests:       subversion
349
350 %description scm
351 This feature allows your software development teams to integrate your
352 Source Control Management system with your Issue Tracking System.
353
354 The integration is implemented in such a way that it will be forward
355 compatible with pretty much any SCM system, such as CVS.
356
357 For installation see
358 </eventum/help.php?topic=scm_integration_installation>.
359
360 %description scm -l pl.UTF-8
361 Ten pakiet pozwala zespołom programistów na integrację systemu
362 zarządzania źródłami (SCM - Source Control Management) z systemem
363 śledzenia spraw.
364
365 Integracja jest zaimplementowana tak, aby być kompatybilna w przód z
366 prawie każdym systemem SCM, jak np. CVS.
367
368 Szczegóły na temat instalacji można przeczytać pod
369 </eventum/help.php?topic=scm_integration_installation>.
370
371 %package sphinx
372 Summary:        Eventum Sphinx Search
373 Group:          Applications/WWW
374 Requires:       %{name} = %{version}-%{release}
375 Requires:       crondaemon
376 Requires:       sphinx
377
378 %description sphinx
379 Sphinx search integration for Eventum.
380
381 This package contains the cron job.
382
383 %prep
384 %setup -q -n %{name}-%{version}%{?githash:-%{subver}-g%{githash}}
385
386 mv docs/examples .
387
388 # bug fixes / features
389 %{?with_order:%patch2 -p1}
390 #%patch3 -p0
391 #%patch4 -p1
392
393 %{?with_order:cp -p %{SOURCE16} htdocs/images}
394
395 #%patch200 -p1
396
397 # produce default sphinx config
398 # must be run before paths.patch
399 %if 0
400 cat <<'EOF' > config/config.php
401 <?php
402 define('APP_SQL_DBTYPE', 'mysql');
403 define('APP_SQL_DBHOST', 'localhost:/var/lib/mysql/mysql.sock');
404 define('APP_SQL_DBPORT', 3306);
405 define('APP_SQL_DBNAME', 'eventum');
406 define('APP_SQL_DBUSER', 'mysql');
407 define('APP_SQL_DBPASS', '');
408 define('APP_TABLE_PREFIX', 'eventum_');
409 EOF
410 php config/sphinx.conf.php > config/sphinx.conf
411 rm config/config.php
412 %endif
413
414 # packaging
415 %patch100 -p1
416 %patch101 -p1
417 %patch107 -p1
418 %patch108 -p1
419
420 rm htdocs/.htaccess.dist
421 # deprecated in favour of process_all_emails.php
422 rm bin/route_*.php
423
424 # cleanup vendor. keep only needed libraries.
425 # (the rest are packaged with system packages)
426 mv vendor vendor.dist
427 vendor() {
428         local path dir
429         for path; do
430                 dir=$(dirname $path)
431                 test -d vendor/$dir || mkdir -p vendor/$dir
432                 mv vendor.dist/$path vendor/$path
433         done
434 }
435 vendor autoload.php
436 vendor composer/autoload_{classmap,files,namespaces,real,psr4}.php
437 vendor composer/ClassLoader.php
438 vendor ircmaxell/{password-compat,random-lib,security-lib}
439
440 # remove backups from patching as we use globs to package files to buildroot
441 find '(' -name '*~' -o -name '*.orig' ')' | xargs -r rm -v
442
443 %build
444 %{__make} -C localization
445
446 %install
447 rm -rf $RPM_BUILD_ROOT
448 install -d \
449         $RPM_BUILD_ROOT{%{_webappdir}/{custom_field,templates,workflow},%{_sysconfdir},%{_bindir},%{_sbindir},%{_libdir}} \
450         $RPM_BUILD_ROOT/etc/{rc.d/init.d,cron.d,logrotate.d,sysconfig} \
451         $RPM_BUILD_ROOT/var/{run,cache,lib}/%{name} \
452         $RPM_BUILD_ROOT/var/log/{archive/,}%{name} \
453         $RPM_BUILD_ROOT/var/lib/%{name}/routed_{emails,drafts,notes} \
454         $RPM_BUILD_ROOT%{systemdtmpfilesdir}
455
456 %{__make} install-eventum install-cli install-scm install-localization \
457         sysconfdir=%{_webappdir} \
458         localedir=%{_localedir} \
459         DESTDIR=$RPM_BUILD_ROOT
460
461 ln -s %{_webappdir} $RPM_BUILD_ROOT%{_appdir}/config
462
463 cp -a vendor $RPM_BUILD_ROOT%{_appdir}
464
465 # unsupported locale
466 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/ht
467
468 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
469 cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
470
471 %{?with_order:cp -a htdocs/ajax $RPM_BUILD_ROOT%{_appdir}/htdocs}
472
473 touch $RPM_BUILD_ROOT%{_webappdir}/htpasswd
474 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_webappdir}/apache.conf
475 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_webappdir}/httpd.conf
476 cp -p %{SOURCE15} $RPM_BUILD_ROOT%{_webappdir}/lighttpd.conf
477
478 install -d $RPM_BUILD_ROOT/etc/sphinx
479 #cp -p config/sphinx.conf $RPM_BUILD_ROOT/etc/sphinx/%{name}.conf
480 cp -p config/sphinx.conf.php $RPM_BUILD_ROOT%{_webappdir}
481
482 cp -p %{SOURCE2} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-queue
483 cp -p %{SOURCE3} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-download
484 cp -p %{SOURCE4} $RPM_BUILD_ROOT/etc/cron.d/%{name}-reminder
485 cp -p %{SOURCE5} $RPM_BUILD_ROOT/etc/cron.d/%{name}-monitor
486 cp -p %{SOURCE10} $RPM_BUILD_ROOT/etc/cron.d/%{name}-sphinx
487
488 cp -p config/irc_config.dist.php $RPM_BUILD_ROOT%{_webappdir}/irc_config.php
489
490 install -p %{SOURCE8} $RPM_BUILD_ROOT/etc/rc.d/init.d/eventum-irc
491 cp -p %{SOURCE9} $RPM_BUILD_ROOT/etc/sysconfig/eventum-irc
492
493 cp -p %{SOURCE14} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
494
495 # postfix router
496 install -p %{SOURCE13} $RPM_BUILD_ROOT%{_libdir}/router-postfix
497
498 cp -p %{SOURCE17} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/%{name}.conf
499
500 %find_lang %{name}
501
502 # scm
503 cp -p %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}/scm.php
504
505 %clean
506 rm -rf $RPM_BUILD_ROOT
507
508 %pre
509 %groupadd -g 146 %{name}
510 %useradd -u 146 -d /var/lib/%{name} -g %{name} -c "Eventum User" %{name}
511 %addusertogroup http %{name}
512
513 %post
514 # create empty ghost files
515 # these permissions ensure the logs are write only
516 for a in \
517         errors.log login_attempts.log \
518         eventum.log \
519         cli.log \
520         irc_bot_error.log irc_bot_smartirc.log \
521 ; do
522         test -f /var/log/%{name}/$a && continue
523         install -m 0620 -o root -g http /dev/null /var/log/%{name}/$a
524 done
525
526 # run database update if configured
527 test -s %{_webappdir}/config.php && \
528 %{_appdir}/bin/upgrade.php || :
529
530 # nuke Smarty templates cache after upgrade
531 rm -f /var/cache/eventum/*.php
532
533 # Restart webserver on upgrade to get .mo translations reloaded.
534 # actually php engines "php-fcgi" and "php-fpm" needed only, apache is restarted anyway via webapp trigger.
535 %php_webserver_restart
536
537 %preun
538 if [ "$1" = "0" ]; then
539         # nuke cache
540         rm -f /var/cache/eventum/*.php 2>/dev/null || :
541 fi
542
543 %postun
544 if [ "$1" = "0" ]; then
545         %userremove %{name}
546         %groupremove %{name}
547 fi
548
549 %post setup
550 chmod 660 %{_webappdir}/{config,private_key}.php
551 chown root:http %{_webappdir}/{config,private_key}.php
552
553 %postun setup
554 if [ "$1" = "0" ] && [ -f %{_webappdir}/config.php ]; then
555         chmod 640 %{_webappdir}/{config,private_key}.php
556         chown root:http %{_webappdir}/{config,private_key}.php
557 fi
558
559 %post irc
560 /sbin/chkconfig --add eventum-irc
561 %service eventum-irc restart "Eventum IRC Bot"
562
563 %preun irc
564 if [ "$1" = 0 ]; then
565         %service eventum-irc stop
566         /sbin/chkconfig --del eventum-irc
567 fi
568
569 %triggerin -- apache1 < 1.3.37-3, apache1-base
570 %webapp_register apache %{_webapp}
571
572 %triggerun -- apache1 < 1.3.37-3, apache1-base
573 %webapp_unregister apache %{_webapp}
574
575 %triggerin -- apache < 2.2.0, apache-base
576 %webapp_register httpd %{_webapp}
577
578 %triggerun -- apache < 2.2.0, apache-base
579 %webapp_unregister httpd %{_webapp}
580
581 %triggerin -- lighttpd
582 %webapp_register lighttpd %{_webapp}
583
584 %triggerun -- lighttpd
585 %webapp_unregister lighttpd %{_webapp}
586
587 %triggerpostun -- %{name} < 3.0.0-0.2
588 for f in /etc/cron.d/eventum-*; do
589         # crontabs moved to bin
590         %{__sed} -i -e '
591                 s,/usr/share/eventum/crons/process_mail_queue.php,%{_appdir}/bin/process_mail_queue.php,
592                 s,/usr/share/eventum/crons/download_emails.php,%{_appdir}/bin/download_emails.php,
593                 s,/usr/share/eventum/crons/check_reminders.php,%{_appdir}/bin/check_reminders.php,
594                 s,/usr/share/eventum/crons/monitor.php,%{_appdir}/bin/monitor.php,
595         ' $f
596 done
597
598 %files -f %{name}.lang
599 %defattr(644,root,root,755)
600 %attr(751,root,root) %dir %{_webappdir}
601 %attr(751,root,root) %dir %{_webappdir}/custom_field
602 %attr(751,root,root) %dir %{_webappdir}/templates
603 %attr(751,root,root) %dir %{_webappdir}/workflow
604 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/apache.conf
605 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/httpd.conf
606 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/lighttpd.conf
607 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/config.php
608 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/private_key.php
609 %attr(660,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/setup.php
610 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/htpasswd
611
612 %dir %attr(711,root,http) /var/log/%{name}
613 %attr(620,root,http) %ghost /var/log/%{name}/*
614 %dir %attr(750,root,root) /var/log/archive/%{name}
615 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/%{name}
616
617 %dir %{_appdir}
618 %{_appdir}/config
619
620 %dir %{_appdir}/bin
621 %attr(755,root,root) %{_appdir}/bin/process_all_emails.php
622 %attr(755,root,root) %{_appdir}/bin/upgrade.php
623
624 %{_appdir}/autoload.php
625 %{_appdir}/init.php
626 %dir %{_appdir}/htdocs
627 %{_appdir}/htdocs/*.php
628 %{_appdir}/htdocs/*.ico
629 %{_appdir}/htdocs/ajax
630 %{_appdir}/htdocs/css
631 %{_appdir}/htdocs/customer
632 %{_appdir}/htdocs/images
633 %{_appdir}/htdocs/js
634 %{_appdir}/htdocs/manage
635 %{_appdir}/htdocs/reports
636 %{_appdir}/htdocs/rpc
637 %{_appdir}/htdocs/components
638 %{_appdir}/templates
639
640 %dir %{_appdir}/upgrade
641 %{_appdir}/upgrade/flush_compiled_templates.php
642 %{_appdir}/upgrade/*.sql
643 %attr(755,root,root) %{_appdir}/upgrade/ldap_import.php
644 %attr(755,root,root) %{_appdir}/upgrade/ldap_update_users.php
645 %attr(755,root,root) %{_appdir}/upgrade/scm_trac_import.php
646 %{_appdir}/upgrade/patches
647
648 %{_appdir}/vendor
649 %{_appdir}/src
650 %dir %{_appdir}/lib
651 %{_appdir}/lib/eventum
652 %exclude %{_appdir}/lib/eventum/class.monitor.php
653
654 %dir %{_libdir}
655
656 %{systemdtmpfilesdir}/%{name}.conf
657
658 %dir /var/lib/%{name}
659 %dir %attr(730,root,http) /var/run/%{name}
660 %dir %attr(730,root,http) /var/cache/%{name}
661
662 # saved mail copies
663 %attr(770,root,http) %dir /var/lib/%{name}/routed_emails
664 %attr(770,root,http) %dir /var/lib/%{name}/routed_drafts
665 %attr(770,root,http) %dir /var/lib/%{name}/routed_notes
666
667 %files setup
668 %defattr(644,root,root,755)
669 %{_appdir}/htdocs/setup
670
671 %files doc
672 %defattr(644,root,root,755)
673 %doc docs/*
674 %{_examplesdir}/%{name}-%{version}
675
676 %files mail-queue
677 %defattr(644,root,root,755)
678 %attr(755,root,root) %{_appdir}/bin/process_mail_queue.php
679 %attr(755,root,root) %{_appdir}/bin/truncate_mail_queue.php
680 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-queue
681
682 %files mail-download
683 %defattr(644,root,root,755)
684 %attr(755,root,root) %{_appdir}/bin/download_emails.php
685 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-download
686
687 %files reminder
688 %defattr(644,root,root,755)
689 %attr(755,root,root) %{_appdir}/bin/check_reminders.php
690 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-reminder
691
692 %files monitor
693 %defattr(644,root,root,755)
694 %{_appdir}/lib/eventum/class.monitor.php
695 %attr(755,root,root) %{_appdir}/bin/monitor.php
696 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-monitor
697
698 %files router-postfix
699 %defattr(644,root,root,755)
700 %attr(755,root,root) %{_libdir}/router-postfix
701
702 %files irc
703 %defattr(644,root,root,755)
704 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/irc_config.php
705 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/eventum-irc
706 %attr(755,root,root) %{_appdir}/bin/irc-bot.php
707 %attr(754,root,root) /etc/rc.d/init.d/%{name}-irc
708
709 %files cli
710 %defattr(644,root,root,755)
711 %doc cli/eventumrc
712 %attr(755,root,root) %{_bindir}/%{name}
713
714 %files scm
715 %defattr(644,root,root,755)
716 %attr(751,root,root) %dir %{_sysconfdir}
717 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/scm.php
718 %attr(755,root,root) %{_sbindir}/eventum-cvs-hook
719 %attr(755,root,root) %{_sbindir}/eventum-git-hook
720 %attr(755,root,root) %{_sbindir}/eventum-svn-hook
721 %attr(755,root,root) %{_sbindir}/helpers.php
722
723 %files sphinx
724 %defattr(644,root,root,755)
725 %{_webappdir}/sphinx.conf.php
726 #%attr(750,root,http) %config(noreplace) %verify(not md5 mtime size) /etc/sphinx/%{name}.conf
727 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-sphinx
This page took 0.091925 seconds and 3 git commands to generate.