]> git.pld-linux.org Git - packages/eventum.git/blob - eventum.spec
- snapshot building support
[packages/eventum.git] / eventum.spec
1 # TODO
2 # - php5 is not tested, but not placing hard conflict on it, as it prevents php4 & php coinstallation
3 # - discard bundled packages (from INSTALL):
4 #  - JpGraph 1.5.3 (last GPL version)
5 #  - Smarty 2.3.0 (http://smarty.php.net)
6 #  - PEAR packages
7 #  - dTree 2.0.5 (http://www.destroydrop.com/javascript/tree/)
8 #  - dynCalendar.js (http://www.phpguru.org/dyncalendar.html)
9 #  - overLIB 3.5.1 (http://www.bosrup.com/web/overlib/)
10 #  - A few other small javascript libraries
11 # - Mail Queue Process, cron or separate package (misc/process_mail_queue.php)
12 # - Email Download (misc/download_emails.php)
13 # - Reminder System (misc/check_reminders.php)
14 # - Heartbeat Monitor (misc/monitor.php)
15 # - Email Routing Script (misc/route_emails.php)
16 # - Note Routing Script (misc/route_notes.php)
17 # - IRC Notification Bot (misc/irc/bot.php)
18 # - Command-line Interface (misc/cli/eventum)
19
20 # snapshot: DATE
21 #define _snap 20050114
22
23 %if 0%{?_snap}
24 %define _source http://downloads.mysql.com/snapshots/%{name}/%{name}-nightly-%{_snap}.tar.gz
25 %else
26 %define _source http://mysql.wildyou.net/Downloads/%{name}/%{name}-%{version}.tar.gz
27 %endif
28
29 %define _rel 1.9
30
31 Summary:        Eventum Issue / Bug Tracking System
32 Name:           eventum
33 Version:        1.4
34 Release:        %{?_snap:0.%{_snap}.}%{_rel}
35 License:        GPL
36 Group:          Applications/WWW
37 Source0:        %{_source}
38 # Source0-md5:  361c1355e46a6bbfa54e420964ec92cf
39 Patch0:         %{name}-clock-status.patch
40 URL:            http://dev.mysql.com/downloads/other/eventum/index.html
41 BuildRequires:  sed >= 4.0
42 Requires:       php >= 4.1.0
43 Requires:       php-pcre
44 Requires:       php-mysql
45 Requires:       php-gd
46 Requires:       php-imap
47 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
48
49 %define         _appdir %{_datadir}/%{name}
50
51 %description
52 Eventum is a user-friendly and flexible issue tracking system that can
53 be used by a support department to track incoming technical support
54 requests, or by a software development team to quickly organize tasks
55 and bugs. Eventum is used by the MySQL AB Technical Support team, and
56 has allowed us to dramatically improve our response times.
57
58 %prep
59 %setup -q %{?_snap:-n %{name}-%{_snap}}
60 %patch0 -p1
61
62 %build
63
64 %install
65 rm -rf $RPM_BUILD_ROOT
66
67 install -d $RPM_BUILD_ROOT%{_appdir}/{locks,templates_c}
68
69 # TODO: php4
70 sed -i -e 's,/usr/local/bin/php,/usr/bin/php,' misc/cli/eventum
71
72 cp -a . $RPM_BUILD_ROOT%{_appdir}
73
74 > $RPM_BUILD_ROOT%{_appdir}/setup.conf.php
75
76 # in doc
77 rm -f $RPM_BUILD_ROOT%{_appdir}/{COPYING,ChangeLog,FAQ,INSTALL,README,UPGRADE}
78 rm -rf $RPM_BUILD_ROOT%{_appdir}/misc/upgrade
79
80 %clean
81 rm -rf $RPM_BUILD_ROOT
82
83 %files
84 %defattr(644,root,root,755)
85 %doc ChangeLog FAQ INSTALL README UPGRADE misc/upgrade
86 %dir %{_appdir}
87 %attr(640,http,root) %config(noreplace) %{_appdir}/config.inc.php
88 %attr(640,http,root) %config(noreplace) %{_appdir}/setup.conf.php
89 %{_appdir}/*[!cf].php
90
91 %{_appdir}/css
92 %{_appdir}/customer
93 %{_appdir}/docs
94 %{_appdir}/images
95 %{_appdir}/js
96 %{_appdir}/manage
97 %{_appdir}/misc
98 %{_appdir}/reports
99 %{_appdir}/rpc
100 %{_appdir}/setup
101 %{_appdir}/templates
102
103 %dir %attr(755,http,root) %{_appdir}/locks
104
105 %dir %{_appdir}/include
106 %{_appdir}/include/customer
107 %{_appdir}/include/jpgraph
108 %{_appdir}/include/pear
109 %{_appdir}/include/Smarty
110 %{_appdir}/include/workflow
111 %{_appdir}/include/class.*
112 %{_appdir}/include/db_access.php
113 %{_appdir}/include/jsrsServer.inc.php
114 %attr(640,http,root) %{_appdir}/include/private_key.php
115
116 %dir %attr(755,http,root) %{_appdir}/logs
117 %attr(640,http,root) %{_appdir}/logs/*
118
119 %dir %attr(750,http,root) %{_appdir}/templates_c
This page took 0.082966 seconds and 3 git commands to generate.