]> git.pld-linux.org Git - packages/eventum.git/blob - eventum.spec
php-pear-Mail no longer used
[packages/eventum.git] / eventum.spec
1 #
2 # Conditional build:
3 %bcond_with     order   # with experimental order patch
4
5 %define         rel             0.3
6 %define         subver  346
7 %define         githash 8b147f6c
8 %define         php_min_version 5.5.0
9 %include        /usr/lib/rpm/macros.php
10 Summary:        Eventum Issue / Bug tracking system
11 Summary(pl.UTF-8):      Eventum - system śledzenia spraw/błędów
12 Name:           eventum
13 Version:        3.1.10
14 Release:        %{?subver:1.%{subver}.%{?githash:g%{githash}.}}%{rel}
15 License:        GPL v2+
16 Group:          Applications/WWW
17 #Source0:       https://github.com/eventum/eventum/releases/download/v%{version}/%{name}-%{version}.tar.gz
18 Source0:        https://github.com/eventum/eventum/releases/download/snapshot/%{name}-%{version}-%{subver}-g%{githash}.tar.gz
19 # Source0-md5:  e161cee555ffb0ff6ad9994efeaa10cc
20 Source1:        %{name}-apache.conf
21 Source2:        %{name}-mail-queue.cron
22 Source3:        %{name}-mail-download.cron
23 Source4:        %{name}-reminder.cron
24 Source5:        %{name}-monitor.cron
25 Source8:        %{name}-irc.init
26 Source9:        %{name}-irc.sysconfig
27 Source10:       sphinx.crontab
28 Source13:       %{name}-router-postfix.sh
29 Source14:       %{name}.logrotate
30 Source15:       %{name}-lighttpd.conf
31 Source16:       http://www.isocra.com/images/updown2.gif
32 # Source16-md5: deb6eeb2552ba757d3a949ed10c4107d
33 Source17:       %{name}.tmpfiles
34 Patch2:         %{name}-order.patch
35 #Patch3:                group-users.patch
36 #Patch4:                https://github.com/glensc/eventum/compare/cf_escape.patch
37 # packaging patches that probably never go upstream
38 Patch100:       %{name}-paths.patch
39 Patch107:       %{name}-gettext.patch
40 Patch108:       autoload.patch
41 # some tests
42 Patch200:       %{name}-fixed-nav.patch
43 URL:            https://wiki.github.com/eventum/eventum/
44 BuildRequires:  gettext-tools
45 BuildRequires:  rpm-php-pearprov >= 4.0.2-98
46 BuildRequires:  rpmbuild(macros) >= 1.654
47 BuildRequires:  sed >= 4.0
48 Requires(postun):       /usr/sbin/groupdel
49 Requires(postun):       /usr/sbin/userdel
50 Requires(pre):  /bin/id
51 Requires(pre):  /usr/bin/getgid
52 Requires(pre):  /usr/sbin/groupadd
53 Requires(pre):  /usr/sbin/useradd
54 Requires:       fonts-TTF-RedHat-liberation
55 Requires:       php(core) >= %{php_min_version}
56 Requires:       php(filter)
57 Requires:       php(iconv)
58 Requires:       php(imap)
59 Requires:       php(json)
60 Requires:       php(mbstring)
61 Requires:       php(pcre)
62 Requires:       php(pdo_mysql)
63 Requires:       php(session)
64 Requires:       php-Smarty >= 3.1
65 Requires:       php-Smarty-plugin-gettext
66 Requires:       php-ZendFramework-Config >= 2.4
67 Requires:       php-ZendFramework-Loader >= 2.4
68 Requires:       php-ZendFramework-Mail >= 2.4.9-2
69 Requires:       php-ZendFramework-Mime >= 2.4
70 Requires:       php-ZendFramework-ServiceManager >= 2.4
71 Requires:       php-ZendFramework-Validator >= 2.4
72 Requires:       php-monolog >= 1.17.2
73 Requires:       php-pear-Mail_Mime
74 Requires:       php-pear-Mail_mimeDecode
75 Requires:       php-pear-Math_Stats
76 Requires:       php-pear-Net_SMTP
77 Requires:       php-pear-Net_Socket
78 Requires:       php-pear-Net_URL
79 Requires:       php-pear-PEAR-core
80 Requires:       php-pear-Text_Diff
81 Requires:       php-psr-Log >= 1.0.0-2
82 Requires:       php-symfony2-Config >= 2.7.7
83 Requires:       php-symfony2-Console >= 2.7.7
84 Requires:       php-symfony2-Filesystem >= 2.7.7
85 Requires:       php-symfony2-HttpFoundation >= 2.7.7
86 Requires:       php-symfony2-OptionsResolver >= 2.7.7
87 Requires:       php-symfony2-Serializer >= 2.7.7
88 Requires:       php-symfony2-Yaml >= 2.7.7
89 Requires:       phplot >= 5.8.0
90 Requires:       webapps
91 Requires:       webserver(access)
92 Requires:       webserver(alias)
93 Requires:       webserver(indexfile)
94 Requires:       webserver(php) >= 4.2.0
95 Suggests:       localedb
96 Suggests:       php(mcrypt)
97 Suggests:       php(openssl)
98 Suggests:       php-pear-Net_LDAP2
99 Suggests:       php-pear-Net_POP3
100 Suggests:       webserver(setenv)
101 Provides:       group(eventum)
102 Provides:       user(eventum)
103 Obsoletes:      eventum-base < 3.0.3-1.305
104 Obsoletes:      eventum-route-drafts < 3.0.8-1.1
105 Obsoletes:      eventum-route-emails < 3.0.8-1.1
106 Obsoletes:      eventum-route-notes < 3.0.8-1.1
107 Conflicts:      logrotate < 3.8.0
108 BuildArch:      noarch
109 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
110
111 %define         _noautoreq_pear ../init.php ../../init.php init.php /usr/share/eventum/init.php /etc/webapps/.* %{_appdir}/.* .*Smarty.class.php Services/JSON.php class.date_helper.php sphinxapi.php Net/LDAP2.* Auth/SASL.* Util.php smarty_internal.*
112
113 # exclude optional php dependencies
114 %define         _noautophp      php-gnupg php-hash php-pecl-http php-tk
115
116 %define         _noautoreq      %{_noautophp}
117
118 %define         _libdir         %{_prefix}/lib/%{name}
119 %define         _appdir         %{_datadir}/%{name}
120 %define         _smartydir      %{php_data_dir}/Smarty
121 %define         _webapps        /etc/webapps
122 %define         _webapp         %{name}
123 %define         _webappdir      %{_webapps}/%{_webapp}
124 %define         _sysconfdir     /etc/%{name}
125
126 %description
127 Eventum is a user-friendly and flexible issue tracking system that can
128 be used by a support department to track incoming technical support
129 requests, or by a software development team to quickly organize tasks
130 and bugs.
131
132 %description -l pl.UTF-8
133 Eventum to przyjazny dla użytkownika system śledzenia spraw, który
134 może być używany przez dział obsługi do śledzenia przychodzących żądań
135 obsługi technicznej albo przez zespół tworzący oprogramowanie do
136 szybkiej organizacji zadań i błędów.
137
138 %package setup
139 Summary:        Eventum setup package
140 Summary(pl.UTF-8):      Pakiet do wstępnej konfiguracji Eventum
141 Group:          Applications/WWW
142 Requires:       %{name} = %{version}-%{release}
143
144 %description setup
145 Install this package to configure initial Eventum installation. You
146 should uninstall this package when you're done, as it considered
147 insecure to keep the setup files in place.
148
149 %description setup -l pl.UTF-8
150 Ten pakiet należy zainstalować w celu wstępnej konfiguracji Eventum po
151 pierwszej instalacji. Potem należy go odinstalować, jako że
152 pozostawienie plików instalacyjnych mogłoby być niebezpieczne.
153
154 %package doc
155 Summary:        Eventum documentation and Wiki
156 Group:          Documentation
157
158 %description doc
159 Eventum documentation and copy of Wiki.
160
161 %package mail-queue
162 Summary:        Eventum mail queue process
163 Summary(pl.UTF-8):      Przetwarzanie kolejki poczty Eventum
164 Group:          Applications/WWW
165 Requires:       %{name} = %{version}-%{release}
166 Requires:       crondaemon
167
168 %description mail-queue
169 Beginning with the first release of Eventum, emails are not directly
170 sent out from the various scripts, but rather added to a mail queue
171 table that is processed by a cron job. If an email cannot be sent, it
172 will be marked as such in the mail queue log, and the cron job script
173 will re-try to send it again the next time it runs.
174
175 This package contains the cron job.
176
177 %description mail-queue -l pl.UTF-8
178 Od pierwszego wydania Eventum poczta nie jest wysyłana bezpośrednio z
179 różnych skryptów, lecz dodawana do kolejki przetwarzanej z crona.
180 Jeśli poczta nie może być wysłana, będzie odpowiednio oznaczona w logu
181 kolejki poczty, a skrypt z crona będzie próbował wysłać ją ponownie
182 następnym razem.
183
184 Ten pakiet zawiera zadanie dla crona.
185
186 %package mail-download
187 Summary:        Eventum email download
188 Summary(pl.UTF-8):      Ściąganie poczty Eventum
189 Group:          Applications/WWW
190 Requires:       %{name} = %{version}-%{release}
191 Requires:       crondaemon
192
193 %description mail-download
194 In order for Eventum's email integration feature to work, you need to
195 setup a cron job to run the script every so often.
196
197 This package contains the cron job.
198
199 %description mail-download -l pl.UTF-8
200 Aby integracja poczty elektronicznej w Eventum działała, trzeba
201 ustawić zadanie crona, aby uruchamiał odpowiedni skrypt wystarczająco
202 często.
203
204 Ten pakiet zawiera zadanie dla crona.
205
206 %package reminder
207 Summary:        Eventum Reminder System
208 Summary(pl.UTF-8):      System przypominania dla Eventum
209 Group:          Applications/WWW
210 Requires:       %{name} = %{version}-%{release}
211 Requires:       crondaemon
212
213 %description reminder
214 The reminder system was designed with the objective as serving as a
215 safe net for issues that need attention. Depending on what
216 configuration you create, you may have several reminders (or alerts)
217 be sent out whenever an issue needs attention, for whatever parameter
218 you may deem necessary.
219
220 This package contains the cron job.
221
222 %description reminder -l pl.UTF-8
223 System przypominania został zaprojektowany tak, aby służył jako
224 bezpieczna sieć dla spraw wymagających uwagi. W zależności od
225 konfiguracji można ustawić różne przypominajki (lub alarmy) wysyłane
226 przy każdej sprawie wymagającej uwagi lub przy parametrze, który można
227 uważać za potrzebny.
228
229 Ten pakiet zawiera zadanie dla crona.
230
231 %package monitor
232 Summary:        Eventum Heartbeat Monitor
233 Summary(pl.UTF-8):      Monitor życia dla Eventum
234 Group:          Applications/WWW
235 Requires:       %{name} = %{version}-%{release}
236 Requires:       crondaemon
237 Requires:       php(posix)
238
239 %description monitor
240 The heartbeat monitor is a feature designed for the administrator that
241 wants to be alerted whenever a common problem in Eventum is detected,
242 like the database server not being available anymore, or maybe when
243 the recommended permissions for certain configuration files are
244 changed.
245
246 Please note that before running the heartbeat monitor, you may need to
247 customize some of the checks to be appropriate for your own system,
248 particularly the permission and file checks on
249 Monitor::checkConfiguration().
250
251 This package contains the cron job.
252
253 %description monitor -l pl.UTF-8
254 Monitor życia to funkcjonalność zaprojektowana dla administratora
255 chcącego być alarmowanym przy każdym wykryciu popularnego problemu z
256 Eventum, jak nie działanie serwera bazy danych albo zmiana uprawnień
257 do plików konfiguracyjnych.
258
259 Należy zauważyć, że przed uruchomieniem tego monitora może być
260 konieczne dostosowanie niektórych testów do systemu, w szczególności
261 testów uprawnień i plików w Monitor::checkConfiguration().
262
263 Ten pakiet zawiera zadanie dla crona.
264
265 %package router-postfix
266 Summary:        Eventum Mail Routing - Postfix
267 Summary(pl.UTF-8):      Przekazywanie poczty Eventum - Postfix
268 Group:          Applications/Mail
269 Requires:       %{name} = %{version}-%{release}
270 Requires:       postfix
271 Provides:       eventum(router)
272 Obsoletes:      eventum(router)
273
274 %description router-postfix
275 This package provides way of routing notes and emails back to Eventum
276 via Postfix.
277
278 The Postfix configuration instructions you can find from
279 <https://github.com/eventum/eventum/wiki/System-Admin:-Setting-up-email-routing-with-postfix>
280
281 %description router-postfix -l pl.UTF-8
282 Ten pakiet udostępnia metodę przekazywania notatek i listów do Eventum
283 przez Postfiksa.
284
285 Opis konfiguracji Postfiksa można znaleźć pod adresem
286 <https://github.com/eventum/eventum/wiki/System-Admin:-Setting-up-email-routing-with-postfix>
287
288 %package irc
289 Summary:        Eventum IRC Notification Bot
290 Summary(pl.UTF-8):      IRC-owy bot powiadamiający dla Eventum
291 Group:          Applications/WWW
292 Requires(post,preun):   /sbin/chkconfig
293 Requires:       %{name} = %{version}-%{release}
294 Requires:       php(pcntl)
295 Requires:       php(sockets)
296 Requires:       php-pear-Net_SmartIRC >= 1.1.9
297 Requires:       rc-scripts >= 0.4.0.18
298
299 %description irc
300 The IRC notification bot is a nice feature for remote teams that want
301 to handle issues and want to have a quick and easy way to get simple
302 notifications. Right now the bot notifies of the following actions:
303 - New Issues
304 - Blocked emails
305 - Issues that got their assignment list changed
306
307 NOTE: You will need to manually edit the bot.php script to set your
308 appropriate preferences, like IRC server and channel that the bot
309 should join.
310
311 %description irc -l pl.UTF-8
312 IRC-owy bot powiadamiający to miła funkcjonalność dla zdalnych
313 zespołów chcących obsługiwać sprawy i mieć szybki i łatwy sposób na
314 uzyskiwanie prostych powiadomień. Aktualnie bot powiadamia o
315 następujących zdarzeniach:
316 - nowych sprawach
317 - zablokowanych listach
318 - sprawach, dla których zmieniła się lista powiązań
319
320 UWAGA: w celu wprowadzenia własnych ustawień, takich jak serwer IRC i
321 kanał używany przez bota, trzeba ręcznie zmodyfikować skrypt bot.php .
322
323 %package cli
324 Summary:        Eventum command-line interface
325 Summary(pl.UTF-8):      Interfejs linii poleceń dla Eventum
326 Group:          Applications/WWW
327 Requires:       php(core) >= %{php_min_version}
328 Requires:       php(phar)
329
330 %description cli
331 The Eventum command-line interface allows you to access most of the
332 features of the web interface straight from your command shell.
333
334 %description cli -l pl.UTF-8
335 Interfejs linii poleceń Eventum pozwala na dostęp do większości
336 funkcji interfejsu WWW prosto z linii poleceń powłoki.
337
338 %package sphinx
339 Summary:        Eventum Sphinx Search
340 Group:          Applications/WWW
341 Requires:       %{name} = %{version}-%{release}
342 Requires:       crondaemon
343 Requires:       sphinx
344
345 %description sphinx
346 Sphinx search integration for Eventum.
347
348 This package contains the cron job.
349
350 %prep
351 %setup -q -n %{name}-%{version}%{?githash:-%{subver}-g%{githash}}
352
353 mv docs/examples .
354
355 # bug fixes / features
356 %{?with_order:%patch2 -p1}
357 #%patch3 -p0
358 #%patch4 -p1
359
360 %{?with_order:cp -p %{SOURCE16} htdocs/images}
361
362 #%patch200 -p1
363
364 # produce default sphinx config
365 # must be run before paths.patch
366 %if 0
367 cat <<'EOF' > config/config.php
368 <?php
369 define('APP_SQL_DBTYPE', 'mysql');
370 define('APP_SQL_DBHOST', 'localhost:/var/lib/mysql/mysql.sock');
371 define('APP_SQL_DBPORT', 3306);
372 define('APP_SQL_DBNAME', 'eventum');
373 define('APP_SQL_DBUSER', 'mysql');
374 define('APP_SQL_DBPASS', '');
375 define('APP_TABLE_PREFIX', 'eventum_');
376 EOF
377 php config/sphinx.conf.php > config/sphinx.conf
378 rm config/config.php
379 %endif
380
381 # packaging
382 %patch100 -p1
383 %patch107 -p1
384 %patch108 -p1
385
386 rm htdocs/.htaccess.dist
387
388 mv config/irc_config{.dist.php,.php}
389 rm config/config.dist.php
390
391 # cleanup vendor. keep only needed libraries.
392 # (the rest are packaged with system packages)
393 mv vendor vendor.dist
394 vendor() {
395         local path dir
396         for path; do
397                 dir=$(dirname $path)
398                 test -d vendor/$dir || mkdir -p vendor/$dir
399                 mv vendor.dist/$path vendor/$path
400         done
401 }
402 vendor autoload.php
403 vendor composer/autoload_{classmap,files,namespaces,real,psr4}.php
404 vendor composer/ClassLoader.php
405 vendor ircmaxell/{random-lib,security-lib}
406 vendor defuse/php-encryption
407 vendor willdurand/email-reply-parser
408 vendor theorchard/monolog-cascade
409 vendor malkusch/lock
410 vendor phpxmlrpc/phpxmlrpc
411 vendor robmorgan/phinx
412
413 # remove backups from patching as we use globs to package files to buildroot
414 find '(' -name '*~' -o -name '*.orig' ')' | xargs -r rm -v
415
416 %build
417 %{__make} -C localization
418
419 %install
420 rm -rf $RPM_BUILD_ROOT
421 install -d \
422         $RPM_BUILD_ROOT{%{_webappdir}/{custom_field,templates,workflow},%{_sysconfdir},%{_bindir},%{_sbindir},%{_libdir}} \
423         $RPM_BUILD_ROOT/etc/{rc.d/init.d,cron.d,logrotate.d,sysconfig} \
424         $RPM_BUILD_ROOT/var/{run,cache,lib}/%{name} \
425         $RPM_BUILD_ROOT/var/log/{archive/,}%{name} \
426         $RPM_BUILD_ROOT/var/lib/%{name}/routed_{emails,drafts,notes} \
427         $RPM_BUILD_ROOT%{systemdtmpfilesdir}
428
429 %{__make} install-eventum install-cli install-localization \
430         sysconfdir=%{_webappdir} \
431         localedir=%{_localedir} \
432         DESTDIR=$RPM_BUILD_ROOT
433
434 ln -s %{_webappdir} $RPM_BUILD_ROOT%{_appdir}/config
435
436 cp -a vendor $RPM_BUILD_ROOT%{_appdir}
437
438 # unsupported locale
439 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/ht
440
441 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
442 cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
443
444 %{?with_order:cp -a htdocs/ajax $RPM_BUILD_ROOT%{_appdir}/htdocs}
445
446 touch $RPM_BUILD_ROOT%{_webappdir}/htpasswd
447 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_webappdir}/apache.conf
448 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_webappdir}/httpd.conf
449 cp -p %{SOURCE15} $RPM_BUILD_ROOT%{_webappdir}/lighttpd.conf
450
451 install -d $RPM_BUILD_ROOT/etc/sphinx
452 #cp -p config/sphinx.conf $RPM_BUILD_ROOT/etc/sphinx/%{name}.conf
453 cp -p config/sphinx.conf.php $RPM_BUILD_ROOT%{_webappdir}
454
455 cp -p %{SOURCE2} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-queue
456 cp -p %{SOURCE3} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-download
457 cp -p %{SOURCE4} $RPM_BUILD_ROOT/etc/cron.d/%{name}-reminder
458 cp -p %{SOURCE5} $RPM_BUILD_ROOT/etc/cron.d/%{name}-monitor
459 cp -p %{SOURCE10} $RPM_BUILD_ROOT/etc/cron.d/%{name}-sphinx
460
461 install -p %{SOURCE8} $RPM_BUILD_ROOT/etc/rc.d/init.d/eventum-irc
462 cp -p %{SOURCE9} $RPM_BUILD_ROOT/etc/sysconfig/eventum-irc
463
464 cp -p %{SOURCE14} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
465
466 # postfix router
467 install -p %{SOURCE13} $RPM_BUILD_ROOT%{_libdir}/router-postfix
468
469 cp -p %{SOURCE17} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/%{name}.conf
470
471 %find_lang %{name}
472
473 %clean
474 rm -rf $RPM_BUILD_ROOT
475
476 %pre
477 %groupadd -g 146 %{name}
478 %useradd -u 146 -d /var/lib/%{name} -g %{name} -c "Eventum User" %{name}
479 %addusertogroup http %{name}
480
481 %post
482 # create empty ghost files
483 # these permissions ensure the logs are write only
484 for a in \
485         errors.log login_attempts.log \
486         eventum.log \
487         auth.log cli.log \
488         irc_bot_error.log irc_bot_smartirc.log \
489 ; do
490         test -f /var/log/%{name}/$a && continue
491         install -m 0620 -o root -g http /dev/null /var/log/%{name}/$a
492 done
493
494 # run database update if configured
495 test -s %{_webappdir}/config.php && \
496 %{_appdir}/bin/upgrade.php || :
497
498 # nuke Smarty templates cache after upgrade
499 rm -f /var/cache/eventum/*.php
500
501 # Restart webserver on upgrade to get .mo translations reloaded.
502 # actually php engines "php-fcgi" and "php-fpm" needed only, apache is restarted anyway via webapp trigger.
503 %php_webserver_restart
504
505 %preun
506 if [ "$1" = "0" ]; then
507         # nuke cache
508         rm -f /var/cache/eventum/*.php 2>/dev/null || :
509 fi
510
511 %postun
512 if [ "$1" = "0" ]; then
513         %userremove %{name}
514         %groupremove %{name}
515 fi
516
517 %post setup
518 chmod 660 %{_webappdir}/{config,private_key,secret_key}.php
519 chown root:http %{_webappdir}/{config,private_key,secret_key}.php
520
521 %postun setup
522 if [ "$1" = "0" ] && [ -f %{_webappdir}/config.php ]; then
523         chmod 640 %{_webappdir}/{config,private_key,secret_key}.php
524         chown root:http %{_webappdir}/{config,private_key,secret_key}.php
525 fi
526
527 %post irc
528 /sbin/chkconfig --add eventum-irc
529 %service eventum-irc restart "Eventum IRC Bot"
530
531 %preun irc
532 if [ "$1" = 0 ]; then
533         %service eventum-irc stop
534         /sbin/chkconfig --del eventum-irc
535 fi
536
537 %triggerin -- apache1 < 1.3.37-3, apache1-base
538 %webapp_register apache %{_webapp}
539
540 %triggerun -- apache1 < 1.3.37-3, apache1-base
541 %webapp_unregister apache %{_webapp}
542
543 %triggerin -- apache < 2.2.0, apache-base
544 %webapp_register httpd %{_webapp}
545
546 %triggerun -- apache < 2.2.0, apache-base
547 %webapp_unregister httpd %{_webapp}
548
549 %triggerin -- lighttpd
550 %webapp_register lighttpd %{_webapp}
551
552 %triggerun -- lighttpd
553 %webapp_unregister lighttpd %{_webapp}
554
555 %triggerpostun -- %{name} < 3.0.0-0.2
556 for f in /etc/cron.d/eventum-*; do
557         # crontabs moved to bin
558         %{__sed} -i -e '
559                 s,/usr/share/eventum/crons/process_mail_queue.php,%{_appdir}/bin/process_mail_queue.php,
560                 s,/usr/share/eventum/crons/download_emails.php,%{_appdir}/bin/download_emails.php,
561                 s,/usr/share/eventum/crons/check_reminders.php,%{_appdir}/bin/check_reminders.php,
562                 s,/usr/share/eventum/crons/monitor.php,%{_appdir}/bin/monitor.php,
563         ' $f
564 done
565
566 %files -f %{name}.lang
567 %defattr(644,root,root,755)
568 %attr(751,root,root) %dir %{_webappdir}
569 %attr(751,root,http) %dir %{_webappdir}/crm
570 %attr(751,root,http) %dir %{_webappdir}/custom_field
571 %attr(751,root,http) %dir %{_webappdir}/partner
572 %attr(751,root,http) %dir %{_webappdir}/templates
573 %attr(751,root,http) %dir %{_webappdir}/workflow
574 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/apache.conf
575 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/httpd.conf
576 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/lighttpd.conf
577 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/config.php
578 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/private_key.php
579 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/secret_key.php
580 %attr(660,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/setup.php
581 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/htpasswd
582
583 %dir %attr(731,root,http) /var/log/%{name}
584 %attr(620,root,http) %ghost /var/log/%{name}/*
585 %dir %attr(750,root,root) /var/log/archive/%{name}
586 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/%{name}
587
588 %dir %{_appdir}
589 %{_appdir}/config
590
591 %dir %{_appdir}/bin
592 %attr(755,root,root) %{_appdir}/bin/process_all_emails.php
593 %attr(755,root,root) %{_appdir}/bin/upgrade.php
594
595 %{_appdir}/autoload.php
596 %{_appdir}/globals.php
597 %{_appdir}/init.php
598 %{_appdir}/phinx.php
599 %dir %{_appdir}/htdocs
600 %{_appdir}/htdocs/*.php
601 %{_appdir}/htdocs/*.ico
602 %{_appdir}/htdocs/ajax
603 %{_appdir}/htdocs/css
604 %{_appdir}/htdocs/customer
605 %{_appdir}/htdocs/images
606 %{_appdir}/htdocs/js
607 %{_appdir}/htdocs/manage
608 %{_appdir}/htdocs/reports
609 %{_appdir}/htdocs/rpc
610 %{_appdir}/htdocs/components
611 %{_appdir}/templates
612
613 %dir %{_appdir}/upgrade
614 %{_appdir}/upgrade/*.sql
615 %{_appdir}/upgrade/patches
616 %dir %{_appdir}/db
617 %dir %{_appdir}/db/migrations
618 %{_appdir}/db/migrations/*.php
619
620 %{_appdir}/res
621 %{_appdir}/src
622 %{_appdir}/vendor
623 %dir %{_appdir}/lib
624 %{_appdir}/lib/eventum
625 %exclude %{_appdir}/lib/eventum/class.monitor.php
626
627 %dir %{_libdir}
628
629 %{systemdtmpfilesdir}/%{name}.conf
630
631 %dir /var/lib/%{name}
632 %dir %attr(730,root,http) /var/run/%{name}
633 %dir %attr(730,root,http) /var/cache/%{name}
634
635 # saved mail copies
636 %attr(770,root,http) %dir /var/lib/%{name}/routed_emails
637 %attr(770,root,http) %dir /var/lib/%{name}/routed_drafts
638 %attr(770,root,http) %dir /var/lib/%{name}/routed_notes
639
640 %files setup
641 %defattr(644,root,root,755)
642 %{_appdir}/htdocs/setup
643
644 %files doc
645 %defattr(644,root,root,755)
646 %doc docs/*
647 %{_examplesdir}/%{name}-%{version}
648
649 %files mail-queue
650 %defattr(644,root,root,755)
651 %attr(755,root,root) %{_appdir}/bin/process_mail_queue.php
652 %attr(755,root,root) %{_appdir}/bin/truncate_mail_queue.php
653 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-queue
654
655 %files mail-download
656 %defattr(644,root,root,755)
657 %attr(755,root,root) %{_appdir}/bin/download_emails.php
658 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-download
659
660 %files reminder
661 %defattr(644,root,root,755)
662 %attr(755,root,root) %{_appdir}/bin/check_reminders.php
663 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-reminder
664
665 %files monitor
666 %defattr(644,root,root,755)
667 %{_appdir}/lib/eventum/class.monitor.php
668 %attr(755,root,root) %{_appdir}/bin/monitor.php
669 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-monitor
670
671 %files router-postfix
672 %defattr(644,root,root,755)
673 %attr(755,root,root) %{_libdir}/router-postfix
674
675 %files irc
676 %defattr(644,root,root,755)
677 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/irc_config.php
678 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/eventum-irc
679 %attr(755,root,root) %{_appdir}/bin/irc-bot.php
680 %attr(754,root,root) /etc/rc.d/init.d/%{name}-irc
681
682 %files cli
683 %defattr(644,root,root,755)
684 %doc cli/eventumrc
685 %attr(755,root,root) %{_bindir}/%{name}
686
687 %files sphinx
688 %defattr(644,root,root,755)
689 %{_webappdir}/sphinx.conf.php
690 #%attr(750,root,http) %config(noreplace) %verify(not md5 mtime size) /etc/sphinx/%{name}.conf
691 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-sphinx
This page took 0.105207 seconds and 3 git commands to generate.