]> git.pld-linux.org Git - packages/eventum.git/blob - eventum.spec
- added tmpfiles config for systemd
[packages/eventum.git] / eventum.spec
1 # TODO
2 # - discard bundled packages (from INSTALL):
3 #  - JpGraph 1.5.3 (last GPL version)
4 #  - dTree 2.0.5 (http://www.destroydrop.com/javascript/tree/)
5 #  - dynCalendar.js (http://www.phpguru.org/dyncalendar.html)
6 #  - overLIB 3.5.1 (http://www.bosrup.com/web/overlib/)
7 #  - A few other small javascript libraries
8 #
9 # Conditional build:
10 %bcond_without  order   # with experimental order patch
11
12 %define         php_min_version 5.1.2
13 %define         subver  4434
14 %define         rel             2.3
15 %include        /usr/lib/rpm/macros.php
16 Summary:        Eventum Issue / Bug tracking system
17 Summary(pl.UTF-8):      Eventum - system śledzenia spraw/błędów
18 Name:           eventum
19 Version:        2.3.1
20 #Release:       %{rel}
21 Release:        %{rel}.bzr%{subver}
22 License:        GPL
23 Group:          Applications/WWW
24 #Source0:       http://launchpad.net/eventum/trunk/%{version}/+download/%{name}-%{version}.tar.gz
25 Source0:        %{name}-%{version}-dev-r%{subver}.tar.gz
26 # Source0-md5:  356e710384618aea1e6f3426a41dbc23
27 Source1:        %{name}-apache.conf
28 Source2:        %{name}-mail-queue.cron
29 Source3:        %{name}-mail-download.cron
30 Source4:        %{name}-reminder.cron
31 Source5:        %{name}-monitor.cron
32 Source6:        %{name}-cvs.php
33 Source7:        %{name}-irc.php
34 Source8:        %{name}-irc.init
35 Source9:        %{name}-irc.sysconfig
36 Source10:       sphinx.crontab
37 Source13:       %{name}-router-postfix.sh
38 Source14:       %{name}.logrotate
39 Source15:       %{name}-lighttpd.conf
40 Source16:       http://www.isocra.com/images/updown2.gif
41 # Source16-md5: deb6eeb2552ba757d3a949ed10c4107d
42 Source17:       %{name}.tmpfiles
43 Patch0:         %{name}-lf.patch
44 Patch2:         %{name}-order.patch
45 Patch3:         group-users.patch
46 # packaging patches that probably never go upstream
47 Patch100:       %{name}-paths.patch
48 Patch101:       %{name}-cvs-config.patch
49 Patch105:       %{name}-bot-reconnect.patch
50 Patch107:       %{name}-gettext.patch
51 # some tests
52 Patch200:       %{name}-fixed-nav.patch
53 URL:            http://eventum.mysql.org/
54 BuildRequires:  gettext-devel
55 BuildRequires:  rpm-php-pearprov >= 4.0.2-98
56 BuildRequires:  rpmbuild(macros) >= 1.461
57 BuildRequires:  sed >= 4.0
58 Requires:       %{name}-base = %{version}-%{release}
59 Requires:       Smarty >= 2.6.10-4
60 Requires:       php-common >= 4:%{php_min_version}
61 Requires:       php-filter
62 Requires:       php-gd
63 Requires:       php-iconv
64 Requires:       php-imap
65 Requires:       php-json
66 Requires:       php-mbstring
67 Requires:       php-mysql
68 Requires:       php-pcre
69 Requires:       php-pear-DB
70 Requires:       php-pear-Date
71 Requires:       php-pear-Mail
72 Requires:       php-pear-Mail_Mime
73 Requires:       php-pear-Mail_mimeDecode
74 Requires:       php-pear-Math_Stats
75 Requires:       php-pear-Net_DIME
76 Requires:       php-pear-Net_SMTP
77 Requires:       php-pear-Net_Socket
78 Requires:       php-pear-Net_URL
79 Requires:       php-pear-Net_UserAgent_Detect
80 Requires:       php-pear-PEAR-core
81 Requires:       php-pear-Text_Diff
82 Requires:       php-pear-XML_RPC
83 Requires:       php-session
84 Requires:       smarty-gettext
85 Requires:       webapps
86 Requires:       webserver(access)
87 Requires:       webserver(alias)
88 Requires:       webserver(indexfile)
89 Requires:       webserver(php) >= 4.2.0
90 Suggests:       localedb
91 Conflicts:      logrotate < 3.7-4
92 BuildArch:      noarch
93 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
94
95 %define         _noautopear     pear(../init.php) pear(init.php) pear(/usr/share/eventum/init.php) pear(/etc/webapps/.*) pear(%{_appdir}/.*) pear(jpgraph_dir.php) pear(.*Smarty.class.php) pear(Services/JSON.php) pear(class.date_helper.php) pear(sphinxapi.php)
96
97 # exclude optional php dependencies
98 %define         _noautophp      php-gnupg php-hash php-pecl-http php-tk
99
100 %define         _noautoreq      %{_noautophp} %{_noautopear}
101
102 %define         _libdir         %{_prefix}/lib/%{name}
103 %define         _appdir         %{_datadir}/%{name}
104 %define         _smartydir      %{php_data_dir}/Smarty
105 %define         _webapps        /etc/webapps
106 %define         _webapp         %{name}
107 %define         _webappdir      %{_webapps}/%{_webapp}
108 %define         _sysconfdir     /etc/%{name}
109
110 %description
111 Eventum is a user-friendly and flexible issue tracking system that can
112 be used by a support department to track incoming technical support
113 requests, or by a software development team to quickly organize tasks
114 and bugs. Eventum is used by the MySQL AB Technical Support team, and
115 has allowed us to dramatically improve our response times.
116
117 %description -l pl.UTF-8
118 Eventum to przyjazny dla użytkownika system śledzenia spraw, który
119 może być używany przez dział obsługi do śledzenia przychodzących żądań
120 obsługi technicznej albo przez zespół tworzący oprogramowanie do
121 szybkiej organizacji zadań i błędów. Eventum jest używany przez zespół
122 Technical Support MySQL AB i umożliwił im znacząco poprawić czasy
123 reakcji.
124
125 %package base
126 Summary:        Eventum base package
127 Summary(pl.UTF-8):      Podstawowy pakiet Eventum
128 Group:          Applications/WWW
129 Requires(postun):       /usr/sbin/groupdel
130 Requires(postun):       /usr/sbin/userdel
131 Requires(pre):  /bin/id
132 Requires(pre):  /usr/bin/getgid
133 Requires(pre):  /usr/sbin/groupadd
134 Requires(pre):  /usr/sbin/useradd
135 Provides:       group(eventum)
136 Provides:       user(eventum)
137
138 %description base
139 This package contains base directory structure for Eventum.
140
141 %description base -l pl.UTF-8
142 Ten pakiet zawiera podstawową strukturę katalogów dla Eventum.
143
144 %package setup
145 Summary:        Eventum setup package
146 Summary(pl.UTF-8):      Pakiet do wstępnej konfiguracji Eventum
147 Group:          Applications/WWW
148 Requires:       %{name} = %{version}-%{release}
149
150 %description setup
151 Install this package to configure initial Eventum installation. You
152 should uninstall this package when you're done, as it considered
153 insecure to keep the setup files in place.
154
155 %description setup -l pl.UTF-8
156 Ten pakiet należy zainstalować w celu wstępnej konfiguracji Eventum po
157 pierwszej instalacji. Potem należy go odinstalować, jako że
158 pozostawienie plików instalacyjnych mogłoby być niebezpieczne.
159
160 %package mail-queue
161 Summary:        Eventum mail queue process
162 Summary(pl.UTF-8):      Przetwarzanie kolejki poczty Eventum
163 Group:          Applications/WWW
164 Requires:       %{name} = %{version}-%{release}
165 Requires:       crondaemon
166
167 %description mail-queue
168 Beginning with the first release of Eventum, emails are not directly
169 sent out from the various scripts, but rather added to a mail queue
170 table that is processed by a cron job. If an email cannot be sent, it
171 will be marked as such in the mail queue log, and the cron job script
172 will re-try to send it again the next time it runs.
173
174 This package contains the cron job.
175
176 %description mail-queue -l pl.UTF-8
177 Od pierwszego wydania Eventum poczta nie jest wysyłana bezpośrednio z
178 różnych skryptów, lecz dodawana do kolejki przetwarzanej z crona.
179 Jeśli poczta nie może być wysłana, będzie odpowiednio oznaczona w logu
180 kolejki poczty, a skrypt z crona będzie próbował wysłać ją ponownie
181 następnym razem.
182
183 Ten pakiet zawiera zadanie dla crona.
184
185 %package mail-download
186 Summary:        Eventum email download
187 Summary(pl.UTF-8):      Ściąganie poczty Eventum
188 Group:          Applications/WWW
189 Requires:       %{name} = %{version}-%{release}
190 Requires:       crondaemon
191
192 %description mail-download
193 In order for Eventum's email integration feature to work, you need to
194 setup a cron job to run the script every so often.
195
196 This package contains the cron job.
197
198 %description mail-download -l pl.UTF-8
199 Aby integracja poczty elektronicznej w Eventum działała, trzeba
200 ustawić zadanie crona, aby uruchamiał odpowiedni skrypt wystarczająco
201 często.
202
203 Ten pakiet zawiera zadanie dla crona.
204
205 %package reminder
206 Summary:        Eventum Reminder System
207 Summary(pl.UTF-8):      System przypominania dla Eventum
208 Group:          Applications/WWW
209 Requires:       %{name} = %{version}-%{release}
210 Requires:       crondaemon
211
212 %description reminder
213 The reminder system was designed with the objective as serving as a
214 safe net for issues that need attention. Depending on what
215 configuration you create, you may have several reminders (or alerts)
216 be sent out whenever an issue needs attention, for whatever parameter
217 you may deem necessary.
218
219 This package contains the cron job.
220
221 %description reminder -l pl.UTF-8
222 System przypominania został zaprojektowany tak, aby służył jako
223 bezpieczna sieć dla spraw wymagających uwagi. W zależności od
224 konfiguracji można ustawić różne przypominajki (lub alarmy) wysyłane
225 przy każdej sprawie wymagającej uwagi lub przy parametrze, który można
226 uważać za potrzebny.
227
228 Ten pakiet zawiera zadanie dla crona.
229
230 %package monitor
231 Summary:        Eventum Heartbeat Monitor
232 Summary(pl.UTF-8):      Monitor życia dla Eventum
233 Group:          Applications/WWW
234 Requires:       %{name} = %{version}-%{release}
235 Requires:       crondaemon
236 Requires:       php-posix
237
238 %description monitor
239 The heartbeat monitor is a feature designed for the administrator that
240 wants to be alerted whenever a common problem in Eventum is detected,
241 like the database server not being available anymore, or maybe when
242 the recommended permissions for certain configuration files are
243 changed.
244
245 Please note that before running the heartbeat monitor, you may need to
246 customize some of the checks to be appropriate for your own system,
247 particularly the permission and file checks on
248 Monitor::checkConfiguration().
249
250 This package contains the cron job.
251
252 %description monitor -l pl.UTF-8
253 Monitor życia to funkcjonalność zaprojektowana dla administratora
254 chcącego być alarmowanym przy każdym wykryciu popularnego problemu z
255 Eventum, jak nie działanie serwera bazy danych albo zmiana uprawnień
256 do plików konfiguracyjnych.
257
258 Należy zauważyć, że przed uruchomieniem tego monitora może być
259 konieczne dostosowanie niektórych testów do systemu, w szczególności
260 testów uprawnień i plików w Monitor::checkConfiguration().
261
262 Ten pakiet zawiera zadanie dla crona.
263
264 %package route-drafts
265 Summary:        Eventum Draft Routing
266 Summary(pl.UTF-8):      Przekazywanie szkiców dla Eventum
267 Group:          Applications/WWW
268 Requires:       %{name} = %{version}-%{release}
269 Requires:       eventum(router)
270
271 %description route-drafts
272 The draft routing feature is used to automatically associate a thread
273 of drafts into an Eventum issue. By setting up Postfix to deliver
274 emails sent to a specific address (usually draft-<number>@<domain>) to
275 the above script, users are able to send drafts written in their mail
276 client to be stored in Eventum. These drafts will NOT broadcasted to
277 the notification list.
278
279 %description route-drafts -l pl.UTF-8
280 Przekazywanie szkiców służy do automatycznego wiązania wątku szkiców z
281 problemem w Eventum. Ustawiając Postfiksa, aby dostarczał pocztę
282 wysłaną na podany adres (zwykle draft-<liczba>@<domena>) do tego
283 skryptu umożliwia się użytkownikom wysyłanie szkiców napisanych w ich
284 kliencie pocztowym do zapisania w Eventum. Szkice te NIE będą wysyłane
285 na listę powiadomień.
286
287 %package route-emails
288 Summary:        Eventum Email Routing
289 Summary(pl.UTF-8):      Przekazywanie poczty dla Eventum
290 Group:          Applications/WWW
291 Requires:       %{name} = %{version}-%{release}
292 Requires:       eventum(router)
293
294 %description route-emails
295 The email routing feature is used to automatically associate a thread
296 of emails into an Eventum issue. By setting up Postfix to deliver
297 emails sent to a specific address (usually issue-<number>@<domain>) to
298 the above script, users are able to use their email clients to reply
299 to emails coming from Eventum, and those replies will be automatically
300 associated with the issue and broadcasted to the entire notification
301 list.
302
303 %description route-emails -l pl.UTF-8
304 Funkcjonalność przekazywania poczty służy do automatycznego wiązania
305 wątku listów ze sprawą w Eventum. Po ustawieniu czy nawet Postfiksa,
306 aby dostarczał listy wysyłane na pewien adres (zwykle
307 issue-<numer>@<domena>) na powyższy skrypt, użytkownicy będą mogli
308 używać klientów pocztowych do odpowiadania na listy przychodzące z
309 Eventum, a odpowiedzi te będą automatycznie wiązane ze sprawą i
310 rozprowadzane do całej listy ogłoszeniowej.
311
312 %package route-notes
313 Summary:        Eventum Note Routing
314 Summary(pl.UTF-8):      Przekazywanie notatek dla Eventum
315 Group:          Applications/WWW
316 Requires:       %{name} = %{version}-%{release}
317 Requires:       eventum(router)
318
319 %description route-notes
320 The note routing feature is used to automatically associate a thread
321 of notes into an Eventum issue. By setting up Postfix to deliver
322 emails sent to a specific address (usually note-<number>@<domain>) to
323 the above script, users are able to use their email clients to reply
324 to internal notes coming from Eventum, and those replies will be
325 automatically associated with the issue and broadcasted to the
326 notification list staff members.
327
328 %description route-notes -l pl.UTF-8
329 Funkcjonalność przekazywania notatek służy do automatycznego wiązania
330 wątku notatek ze sprawą w Eventum. Po ustawieniu Postfiksa, aby
331 dostarczał listy wysyłane na pewien adres (zwykle
332 note-<numer>@<domena>) na powyższy skrypt, użytkownicy będą mogli
333 używać klientów pocztowych do odpowiadania na wewnętrzne notatki
334 pochodzące od Eventu, a odpowiedzi te będą automatycznie wiązane ze
335 sprawą i rozprowadzane do członków personelu listy ogłoszeniowej.
336
337 %package router-postfix
338 Summary:        Eventum Mail Routing - Postfix
339 Summary(pl.UTF-8):      Przekazywanie poczty Eventum - Postfix
340 Group:          Applications/Mail
341 Requires:       %{name} = %{version}-%{release}
342 Requires:       postfix
343 Provides:       eventum(router)
344 Obsoletes:      eventum(router)
345
346 %description router-postfix
347 This package provides way of routing notes and emails back to Eventum
348 via Postfix.
349
350 The Postfix configuration instructions you can find from
351 <http://eventum.mysql.org/wiki/index.php/Setting_up_email_routing_with_postfix>.
352
353 %description router-postfix -l pl.UTF-8
354 Ten pakiet udostępnia metodę przekazywania notatek i listów do Eventum
355 przez Postfiksa.
356
357 Opis konfiguracji Postfiksa można znaleźć pod adresem
358 <http://eventum.mysql.org/wiki/index.php/Setting_up_email_routing_with_postfix>.
359
360 %package irc
361 Summary:        Eventum IRC Notification Bot
362 Summary(pl.UTF-8):      IRC-owy bot powiadamiający dla Eventum
363 Group:          Applications/WWW
364 Requires(post,preun):   /sbin/chkconfig
365 Requires:       %{name} = %{version}-%{release}
366 Requires:       php-sockets
367 Requires:       php-pear-Net_SmartIRC
368 Requires:       rc-scripts >= 0.4.0.18
369
370 %description irc
371 The IRC notification bot is a nice feature for remote teams that want
372 to handle issues and want to have a quick and easy way to get simple
373 notifications. Right now the bot notifies of the following actions:
374 - New Issues
375 - Blocked emails
376 - Issues that got their assignment list changed
377
378 NOTE: You will need to manually edit the bot.php script to set your
379 appropriate preferences, like IRC server and channel that the bot
380 should join.
381
382 %description irc -l pl.UTF-8
383 IRC-owy bot powiadamiający to miła funkcjonalność dla zdalnych
384 zespołów chcących obsługiwać sprawy i mieć szybki i łatwy sposób na
385 uzyskiwanie prostych powiadomień. Aktualnie bot powiadamia o
386 następujących zdarzeniach:
387 - nowych sprawach
388 - zablokowanych listach
389 - sprawach, dla których zmieniła się lista powiązań
390
391 UWAGA: w celu wprowadzenia własnych ustawień, takich jak serwer IRC i
392 kanał używany przez bota, trzeba ręcznie zmodyfikować skrypt bot.php .
393
394 %package cli
395 Summary:        Eventum command-line interface
396 Summary(pl.UTF-8):      Interfejs linii poleceń dla Eventum
397 Group:          Applications/WWW
398 Requires:       %{name}-base = %{version}-%{release}
399 Requires:       php-cli
400 Requires:       php-common >= 4:%{php_min_version}
401 Requires:       php-pear-XML_RPC
402
403 %description cli
404 The Eventum command-line interface allows you to access most of the
405 features of the web interface straight from your command shell.
406
407 %description cli -l pl.UTF-8
408 Interfejs linii poleceń Eventum pozwala na dostęp do większości
409 funkcji interfejsu WWW prosto z linii poleceń powłoki.
410
411 %package scm
412 Summary:        Eventum SCM integration
413 Summary(pl.UTF-8):      Integracja SCM dla Eventum
414 Group:          Applications/WWW
415 Requires:       %{name}-base = %{version}-%{release}
416 Requires:       php-cli
417 Requires:       php-common >= 4:%{php_min_version}
418 Requires:       php-pcre
419
420 %description scm
421 This feature allows your software development teams to integrate your
422 Source Control Management system with your Issue Tracking System.
423
424 The integration is implemented in such a way that it will be forward
425 compatible with pretty much any SCM system, such as CVS.
426
427 For installation see
428 </eventum/help.php?topic=scm_integration_installation>.
429
430 %description scm -l pl.UTF-8
431 Ten pakiet pozwala zespołom programistów na integrację systemu
432 zarządzania źródłami (SCM - Source Control Management) z systemem
433 śledzenia spraw.
434
435 Integracja jest zaimplementowana tak, aby być kompatybilna w przód z
436 prawie każdym systemem SCM, jak np. CVS.
437
438 Szczegóły na temat instalacji można przeczytać pod
439 </eventum/help.php?topic=scm_integration_installation>.
440
441 %package sphinx
442 Summary:        Eventum Sphinx Search
443 Group:          Applications/WWW
444 Requires:       %{name} = %{version}-%{release}
445 Requires:       crondaemon
446 Requires:       sphinx
447
448 %description sphinx
449 Sphinx search integration for Eventum.
450
451 This package contains the cron job.
452
453 %prep
454 %setup -q
455
456 # GPL v2
457 rm docs/COPYING
458
459 rm -r upgrade/*v1.[123]* # too old to support in PLD Linux
460 rm -r upgrade/v{1.,2.0,2.1_}* # no longer supported in PLD Linux
461 rm upgrade/flush_compiled_templates.php
462 rm -r upgrade/{*/,}index.html # not needed in PLD Linux
463
464 # bug fixes / features
465 %patch0 -p1
466 %{?with_order:%patch2 -p1}
467 %patch3 -p0
468
469 cp -p %{SOURCE16} htdocs/images
470
471 #%patch200 -p1
472
473 # produce default sphinx config
474 # must be run before paths.patch
475 cat <<'EOF' > config/config.php
476 <?php
477 define('APP_SQL_DBTYPE', 'mysql');
478 define('APP_SQL_DBHOST', 'localhost:/var/lib/mysql/mysql.sock');
479 define('APP_SQL_DBPORT', 3306);
480 define('APP_SQL_DBNAME', 'eventum');
481 define('APP_SQL_DBUSER', 'mysql');
482 define('APP_SQL_DBPASS', '');
483 define('APP_TABLE_PREFIX', 'eventum_');
484 EOF
485 php config/sphinx.conf.php > config/sphinx.conf
486 rm -f config/config.php
487
488 # packaging
489 %patch100 -p1
490 %patch101 -p1
491 %patch105 -p1
492 %patch107 -p1
493
494 %{__sed} -i -e "
495 s;define('CONFIG_PATH'.*');define('CONFIG_PATH', '%{_webappdir}');
496 " upgrade/{*/,}*.php
497
498 # remove backups from patching as we use globs to package files to buildroot
499 find '(' -name '*~' -o -name '*.orig' ')' | xargs -r rm -v
500
501 %build
502 %{__make} -C localization
503
504 %install
505 rm -rf $RPM_BUILD_ROOT
506 install -d \
507         $RPM_BUILD_ROOT{%{_webappdir},%{_sysconfdir},%{_bindir},%{_sbindir},%{_libdir}} \
508         $RPM_BUILD_ROOT/etc/{rc.d/init.d,cron.d,logrotate.d,sysconfig} \
509         $RPM_BUILD_ROOT/var/{run,cache,lib}/%{name} \
510         $RPM_BUILD_ROOT/var/log/{archive/,}%{name} \
511         $RPM_BUILD_ROOT/var/lib/%{name}/routed_{emails,drafts,notes} \
512         $RPM_BUILD_ROOT%{_appdir}/{include,htdocs/misc,upgrade} \
513         $RPM_BUILD_ROOT/usr/lib/tmpfiles.d
514
515 %{__make} install-eventum install-cli install-irc install-scm install-jpgraph install-localization \
516         sysconfdir=%{_webappdir} \
517         DESTDIR=$RPM_BUILD_ROOT
518
519 %{?with_order:cp -a htdocs/ajax $RPM_BUILD_ROOT%{_appdir}/htdocs}
520
521 touch $RPM_BUILD_ROOT%{_webappdir}/htpasswd
522 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_webappdir}/apache.conf
523 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_webappdir}/httpd.conf
524 cp -p %{SOURCE15} $RPM_BUILD_ROOT%{_webappdir}/lighttpd.conf
525
526 install -d $RPM_BUILD_ROOT/etc/sphinx
527 cp -p config/sphinx.conf $RPM_BUILD_ROOT/etc/sphinx/%{name}.conf
528 cp -p config/sphinx.conf.php $RPM_BUILD_ROOT%{_webappdir}
529
530 cp -p %{SOURCE2} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-queue
531 cp -p %{SOURCE3} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-download
532 cp -p %{SOURCE4} $RPM_BUILD_ROOT/etc/cron.d/%{name}-reminder
533 cp -p %{SOURCE5} $RPM_BUILD_ROOT/etc/cron.d/%{name}-monitor
534 cp -p %{SOURCE10} $RPM_BUILD_ROOT/etc/cron.d/%{name}-sphinx
535
536 cp -p %{SOURCE7} $RPM_BUILD_ROOT%{_webappdir}/irc_config.php
537
538 install -p %{SOURCE8} $RPM_BUILD_ROOT/etc/rc.d/init.d/eventum-irc
539 cp -p %{SOURCE9} $RPM_BUILD_ROOT/etc/sysconfig/eventum-irc
540
541 cp -p %{SOURCE14} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
542
543 # postfix router
544 install -p %{SOURCE13} $RPM_BUILD_ROOT%{_libdir}/router-postfix
545
546 install %{SOURCE17} $RPM_BUILD_ROOT/usr/lib/tmpfiles.d/%{name}.conf
547
548 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/locale/ht
549
550 %find_lang %{name}
551
552 # scm
553 install -p %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}/scm.php
554
555 # old compat
556 ln -s %{_sbindir}/eventum-cvs-hook $RPM_BUILD_ROOT%{_libdir}/process_cvs_commits
557 ln -s %{_sbindir}/eventum-svn-hook $RPM_BUILD_ROOT%{_libdir}/process_svn_commits
558
559 # skip pear for cli
560 rm -rf $RPM_BUILD_ROOT%{_datadir}/%{name}/cli
561 cp -a cli/lib/eventum $RPM_BUILD_ROOT%{_datadir}/%{name}/cli
562
563 %clean
564 rm -rf $RPM_BUILD_ROOT
565
566 %pre
567 %addusertogroup http %{name}
568
569 %post
570 # greate empty ghost files
571 for a in cli.log errors.log irc_bot.log login_attempts.log; do
572         if [ ! -f /var/log/%{name}/$a ]; then
573                 install -m 0620 -o root -g eventum /dev/null /var/log/%{name}/$a
574         fi
575 done
576
577 # database update
578 %{_appdir}/upgrade/update-database.php || :
579
580 # nuke Smarty templates cache after upgrade
581 rm -f /var/cache/eventum/*.php
582
583 # Restart webserver on upgrade to get .mo translations reloaded.
584 # actually php engines "php-fcgi" and "php-fpm" needed only, apache is restarted anyway via webapp trigger.
585 %php_webserver_restart
586
587 %preun
588 if [ "$1" = "0" ]; then
589         # nuke cache
590         rm -f /var/cache/eventum/*.php 2>/dev/null || :
591 fi
592
593 %pre base
594 %groupadd -P %{name}-base -g 146 %{name}
595 %useradd -P %{name}-base -u 146 -d /var/lib/%{name} -g %{name} -c "Eventum User" %{name}
596
597 %postun base
598 if [ "$1" = "0" ]; then
599         %userremove %{name}
600         %groupremove %{name}
601 fi
602
603 %post setup
604 chmod 660 %{_webappdir}/{config,private_key}.php
605 chown root:http %{_webappdir}/{config,private_key}.php
606
607 %postun setup
608 if [ "$1" = "0" ]; then
609         chmod 640 %{_webappdir}/{config,private_key}.php
610         chown root:http %{_webappdir}/{config,private_key}.php
611 fi
612
613 %post irc
614 /sbin/chkconfig --add eventum-irc
615 %service eventum-irc restart "Eventum IRC Bot"
616
617 %preun irc
618 if [ "$1" = 0 ]; then
619         %service eventum-irc stop
620         /sbin/chkconfig --del eventum-irc
621 fi
622
623 %triggerin -- apache1 < 1.3.37-3, apache1-base
624 %webapp_register apache %{_webapp}
625
626 %triggerun -- apache1 < 1.3.37-3, apache1-base
627 %webapp_unregister apache %{_webapp}
628
629 %triggerin -- apache < 2.2.0, apache-base
630 %webapp_register httpd %{_webapp}
631
632 %triggerun -- apache < 2.2.0, apache-base
633 %webapp_unregister httpd %{_webapp}
634
635 %triggerin -- lighttpd
636 %webapp_register lighttpd %{_webapp}
637
638 %triggerun -- lighttpd
639 %webapp_unregister lighttpd %{_webapp}
640
641 %triggerpostun -- %{name} < 2.2-2.57
642 # switching eventum->http user
643 chgrp http %{_webappdir}/config.php
644 chgrp http %{_webappdir}/private_key.php
645 chgrp http %{_webappdir}/setup.php
646 chgrp http /var/log/%{name}/*
647 # update crontab user
648 for a in /etc/cron.d/eventum-*; do
649         [ -f "$a" ] || continue
650         awk '!/#/ && NR > 6 && $6 =="eventum" {sub("eventum", "http", $6)}{print}'  $a > $a.rpmtmp && cat $a.rpmtmp > $a
651         rm -f $a.rpmtmp
652
653         # crontabs moved to crons subdir
654         %{__sed} -i -e '
655                 s,/usr/share/eventum/process_mail_queue.php,/usr/share/eventum/crons/process_mail_queue.php,
656                 s,/usr/share/eventum/download_emails.php,/usr/share/eventum/crons/download_emails.php,
657                 s,/usr/share/eventum/check_reminders.php,/usr/share/eventum/crons/check_reminders.php,
658                 s,/usr/share/eventum/monitor.php,/usr/share/eventum/crons/monitor.php,
659         ' $a
660 done
661
662 %files -f %{name}.lang
663 %defattr(644,root,root,755)
664 %doc docs/* htdocs/setup/schema.sql
665 %attr(751,root,root) %dir %{_webappdir}
666 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/apache.conf
667 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/httpd.conf
668 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/lighttpd.conf
669 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/config.php
670 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/private_key.php
671 %attr(660,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/setup.php
672 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/htpasswd
673
674 %dir %attr(731,root,http) /var/log/%{name}
675 %attr(620,root,http) %ghost /var/log/%{name}/*
676 %dir %attr(750,root,root) /var/log/archive/%{name}
677 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/%{name}
678
679 %dir %{_appdir}/crons
680 %{_appdir}/init.php
681 %dir %{_appdir}/htdocs
682 %{_appdir}/htdocs/*.php
683 %{_appdir}/htdocs/*.ico
684 %{_appdir}/htdocs/css
685 %{_appdir}/htdocs/customer
686 %{_appdir}/htdocs/images
687 %{_appdir}/htdocs/js
688 %{_appdir}/htdocs/manage
689 %{_appdir}/htdocs/reports
690 %{_appdir}/htdocs/rpc
691 %{_appdir}/htdocs/misc
692 %if %{with order}
693 %{_appdir}/htdocs/ajax
694 %endif
695 %{_appdir}/templates
696
697 %dir %{_appdir}/upgrade
698 %{_appdir}/upgrade/init.php
699 %attr(755,root,root) %{_appdir}/upgrade/update-database.php
700 %dir %{_appdir}/upgrade/v*
701 %attr(755,root,root) %{_appdir}/upgrade/v*/*.php
702 %{_appdir}/upgrade/patches
703
704 %dir %{_appdir}/lib
705 %{_appdir}/lib/eventum
706 %{_appdir}/lib/jpgraph
707 %exclude %{_appdir}/lib/eventum/class.monitor.php
708 /usr/lib/tmpfiles.d/%{name}.conf
709 %dir %attr(730,root,http) /var/run/%{name}
710 %dir %attr(730,root,http) /var/cache/%{name}
711
712 %files base
713 %defattr(644,root,root,755)
714 %attr(751,root,root) %dir %{_sysconfdir}
715 %dir %{_libdir}
716 %dir %{_appdir}
717 %dir /var/lib/%{name}
718 # saved mail copies
719 %attr(770,root,http) %dir /var/lib/%{name}/routed_emails
720 %attr(770,root,http) %dir /var/lib/%{name}/routed_drafts
721 %attr(770,root,http) %dir /var/lib/%{name}/routed_notes
722
723 %files setup
724 %defattr(644,root,root,755)
725 %{_appdir}/htdocs/setup
726
727 %files mail-queue
728 %defattr(644,root,root,755)
729 %attr(755,root,root) %{_appdir}/crons/process_mail_queue.php
730 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-queue
731
732 %files mail-download
733 %defattr(644,root,root,755)
734 %attr(755,root,root) %{_appdir}/crons/download_emails.php
735 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-download
736
737 %files reminder
738 %defattr(644,root,root,755)
739 %attr(755,root,root) %{_appdir}/crons/check_reminders.php
740 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-reminder
741
742 %files monitor
743 %defattr(644,root,root,755)
744 %{_appdir}/lib/eventum/class.monitor.php
745 %attr(755,root,root) %{_appdir}/crons/monitor.php
746 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-monitor
747
748 %files route-drafts
749 %defattr(644,root,root,755)
750 %attr(755,root,root) %{_appdir}/route_drafts.php
751
752 %files route-emails
753 %defattr(644,root,root,755)
754 %attr(755,root,root) %{_appdir}/route_emails.php
755
756 %files route-notes
757 %defattr(644,root,root,755)
758 %attr(755,root,root) %{_appdir}/route_notes.php
759
760 %files router-postfix
761 %defattr(644,root,root,755)
762 %attr(755,root,root) %{_libdir}/router-postfix
763
764 %files irc
765 %defattr(644,root,root,755)
766 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/irc_config.php
767 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/eventum-irc
768 %attr(755,root,root) %{_sbindir}/%{name}-irc-bot
769 %attr(754,root,root) /etc/rc.d/init.d/%{name}-irc
770
771 %files cli
772 %defattr(644,root,root,755)
773 %doc cli/eventumrc
774 %attr(755,root,root) %{_bindir}/%{name}
775 %{_appdir}/cli
776
777 %files scm
778 %defattr(644,root,root,755)
779 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/scm.php
780 %attr(755,root,root) %{_libdir}/process_cvs_commits
781 %attr(755,root,root) %{_libdir}/process_svn_commits
782 %attr(755,root,root) %{_sbindir}/eventum-cvs-hook
783 %attr(755,root,root) %{_sbindir}/eventum-svn-hook
784
785 %files sphinx
786 %defattr(644,root,root,755)
787 %{_webappdir}/sphinx.conf.php
788 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) /etc/sphinx/%{name}.conf
789 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-sphinx
This page took 0.136714 seconds and 3 git commands to generate.