]> git.pld-linux.org Git - packages/eventum.git/blob - eventum.spec
- more trigger fixes
[packages/eventum.git] / eventum.spec
1 # TODO
2 # - discard bundled packages (from INSTALL):
3 #  - JpGraph 1.5.3 (last GPL version)
4 #  - dTree 2.0.5 (http://www.destroydrop.com/javascript/tree/)
5 #  - dynCalendar.js (http://www.phpguru.org/dyncalendar.html)
6 #  - overLIB 3.5.1 (http://www.bosrup.com/web/overlib/)
7 #  - A few other small javascript libraries
8 #
9 # Conditional build:
10 %bcond_without  order   # with experimental order patch
11
12 #define snap    20060921
13 %define rev             r4097
14 %define rel             2.67
15 #define _rc             RC3
16
17 %define         php_min_version 5.1.2
18 %include        /usr/lib/rpm/macros.php
19 Summary:        Eventum Issue / Bug tracking system
20 Summary(pl.UTF-8):      Eventum - system śledzenia spraw/błędów
21 Name:           eventum
22 Version:        2.2
23 Release:        %{?_rc:%{_rc}.}%{rel}%{?snap:.%{snap}}%{?rev:.%{rev}}
24 License:        GPL
25 Group:          Applications/WWW
26 #Source0:       http://downloads.mysql.com/snapshots/eventum/%{name}-nightly-%{snap}.tar.gz
27 #Source0:       http://eventum.mysql.org/downloads/eventum-2.0.RC3.tar.gz
28 #Source0:       http://mysql.easynet.be/Downloads/eventum/%{name}-%{version}.tar.gz
29 # bzr branch lp:eventum eventum && cd eventum && make dist
30 Source0:        %{name}-%{version}-dev-%{rev}.tar.gz
31 # Source0-md5:  906d09b73296888f5ce383ea0c7a045c
32 Source1:        %{name}-apache.conf
33 Source2:        %{name}-mail-queue.cron
34 Source3:        %{name}-mail-download.cron
35 Source4:        %{name}-reminder.cron
36 Source5:        %{name}-monitor.cron
37 Source6:        %{name}-cvs.php
38 Source7:        %{name}-irc.php
39 Source8:        %{name}-irc.init
40 Source9:        %{name}-irc.sysconfig
41 Source13:       %{name}-router-postfix.sh
42 Source14:       %{name}.logrotate
43 Source15:       %{name}-lighttpd.conf
44 Source16:       http://www.isocra.com/images/updown2.gif
45 # Source16-md5: deb6eeb2552ba757d3a949ed10c4107d
46 Patch0:         %{name}-lf.patch
47 Patch2:         %{name}-order.patch
48 # packaging patches that probably never go upstream
49 Patch100:       %{name}-paths.patch
50 Patch101:       %{name}-cvs-config.patch
51 Patch105:       %{name}-bot-reconnect.patch
52 Patch107:       %{name}-gettext.patch
53 # some tests
54 Patch200:       %{name}-fixed-nav.patch
55 URL:            http://eventum.mysql.org/
56 BuildRequires:  gettext-devel
57 BuildRequires:  rpm-php-pearprov >= 4.0.2-98
58 BuildRequires:  rpmbuild(macros) >= 1.461
59 BuildRequires:  sed >= 4.0
60 Requires:       %{name}-base = %{version}-%{release}
61 Requires:       Smarty >= 2.6.10-4
62 Requires:       php-common >= 4:%{php_min_version}
63 Requires:       php-gd
64 Requires:       php-iconv
65 Requires:       php-imap
66 Requires:       php-mbstring
67 Requires:       php-mysql
68 Requires:       php-pcre
69 Requires:       php-pear-DB
70 Requires:       php-pear-Date
71 Requires:       php-pear-Mail
72 Requires:       php-pear-Mail_Mime
73 Requires:       php-pear-Mail_mimeDecode
74 Requires:       php-pear-Math_Stats
75 Requires:       php-pear-Net_DIME
76 Requires:       php-pear-Net_SMTP
77 Requires:       php-pear-Net_Socket
78 Requires:       php-pear-Net_URL
79 Requires:       php-pear-Net_UserAgent_Detect
80 Requires:       php-pear-PEAR-core
81 Requires:       php-pear-Text_Diff
82 Requires:       php-pear-XML_RPC
83 Requires:       php-session
84 Requires:       smarty-gettext
85 Requires:       webapps
86 Requires:       webserver(access)
87 Requires:       webserver(alias)
88 Requires:       webserver(indexfile)
89 Requires:       webserver(php) >= 4.2.0
90 Suggests:       localedb
91 Conflicts:      logrotate < 3.7-4
92 BuildArch:      noarch
93 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
94
95 %define         _noautopear     'pear(../init.php)' 'pear(init.php)' 'pear(/etc/webapps/.*)' 'pear(%{_appdir}/.*)' 'pear(jpgraph_dir.php)' 'pear(.*Smarty.class.php)' 'pear(Services/JSON.php)'
96
97 # exclude optional php dependencies
98 %define         _noautophp      'php-gnupg' 'php-hash' 'php-pecl-http' 'php-json' 'php-tk'
99
100 %define         _noautoreq      %{_noautophp} %{_noautopear}
101
102 %define         _libdir         %{_prefix}/lib/%{name}
103 %define         _appdir         %{_datadir}/%{name}
104 %define         _smartydir      %{php_data_dir}/Smarty
105 %define         _webapps        /etc/webapps
106 %define         _webapp         %{name}
107 %define         _webappdir      %{_webapps}/%{_webapp}
108 %define         _sysconfdir     /etc/%{name}
109
110 %description
111 Eventum is a user-friendly and flexible issue tracking system that can
112 be used by a support department to track incoming technical support
113 requests, or by a software development team to quickly organize tasks
114 and bugs. Eventum is used by the MySQL AB Technical Support team, and
115 has allowed us to dramatically improve our response times.
116
117 %description -l pl.UTF-8
118 Eventum to przyjazny dla użytkownika system śledzenia spraw, który
119 może być używany przez dział obsługi do śledzenia przychodzących żądań
120 obsługi technicznej albo przez zespół tworzący oprogramowanie do
121 szybkiej organizacji zadań i błędów. Eventum jest używany przez zespół
122 Technical Support MySQL AB i umożliwił im znacząco poprawić czasy
123 reakcji.
124
125 %package base
126 Summary:        Eventum base package
127 Summary(pl.UTF-8):      Podstawowy pakiet Eventum
128 Group:          Applications/WWW
129 Requires(postun):       /usr/sbin/groupdel
130 Requires(postun):       /usr/sbin/userdel
131 Requires(pre):  /bin/id
132 Requires(pre):  /usr/bin/getgid
133 Requires(pre):  /usr/sbin/groupadd
134 Requires(pre):  /usr/sbin/useradd
135 Provides:       group(eventum)
136 Provides:       user(eventum)
137
138 %description base
139 This package contains base directory structure for Eventum.
140
141 %description base -l pl.UTF-8
142 Ten pakiet zawiera podstawową strukturę katalogów dla Eventum.
143
144 %package setup
145 Summary:        Eventum setup package
146 Summary(pl.UTF-8):      Pakiet do wstępnej konfiguracji Eventum
147 Group:          Applications/WWW
148 Requires:       %{name} = %{version}-%{release}
149
150 %description setup
151 Install this package to configure initial Eventum installation. You
152 should uninstall this package when you're done, as it considered
153 insecure to keep the setup files in place.
154
155 %description setup -l pl.UTF-8
156 Ten pakiet należy zainstalować w celu wstępnej konfiguracji Eventum po
157 pierwszej instalacji. Potem należy go odinstalować, jako że
158 pozostawienie plików instalacyjnych mogłoby być niebezpieczne.
159
160 %package mail-queue
161 Summary:        Eventum mail queue process
162 Summary(pl.UTF-8):      Przetwarzanie kolejki poczty Eventum
163 Group:          Applications/WWW
164 Requires:       %{name} = %{version}-%{release}
165 Requires:       crondaemon
166
167 %description mail-queue
168 Beginning with the first release of Eventum, emails are not directly
169 sent out from the various scripts, but rather added to a mail queue
170 table that is processed by a cron job. If an email cannot be sent, it
171 will be marked as such in the mail queue log, and the cron job script
172 will re-try to send it again the next time it runs.
173
174 This package contains the cron job.
175
176 %description mail-queue -l pl.UTF-8
177 Od pierwszego wydania Eventum poczta nie jest wysyłana bezpośrednio z
178 różnych skryptów, lecz dodawana do kolejki przetwarzanej z crona.
179 Jeśli poczta nie może być wysłana, będzie odpowiednio oznaczona w logu
180 kolejki poczty, a skrypt z crona będzie próbował wysłać ją ponownie
181 następnym razem.
182
183 Ten pakiet zawiera zadanie dla crona.
184
185 %package mail-download
186 Summary:        Eventum email download
187 Summary(pl.UTF-8):      Ściąganie poczty Eventum
188 Group:          Applications/WWW
189 Requires:       %{name} = %{version}-%{release}
190 Requires:       crondaemon
191
192 %description mail-download
193 In order for Eventum's email integration feature to work, you need to
194 setup a cron job to run the script every so often.
195
196 This package contains the cron job.
197
198 %description mail-download -l pl.UTF-8
199 Aby integracja poczty elektronicznej w Eventum działała, trzeba
200 ustawić zadanie crona, aby uruchamiał odpowiedni skrypt wystarczająco
201 często.
202
203 Ten pakiet zawiera zadanie dla crona.
204
205 %package reminder
206 Summary:        Eventum Reminder System
207 Summary(pl.UTF-8):      System przypominania dla Eventum
208 Group:          Applications/WWW
209 Requires:       %{name} = %{version}-%{release}
210 Requires:       crondaemon
211
212 %description reminder
213 The reminder system was designed with the objective as serving as a
214 safe net for issues that need attention. Depending on what
215 configuration you create, you may have several reminders (or alerts)
216 be sent out whenever an issue needs attention, for whatever parameter
217 you may deem necessary.
218
219 This package contains the cron job.
220
221 %description reminder -l pl.UTF-8
222 System przypominania został zaprojektowany tak, aby służył jako
223 bezpieczna sieć dla spraw wymagających uwagi. W zależności od
224 konfiguracji można ustawić różne przypominajki (lub alarmy) wysyłane
225 przy każdej sprawie wymagającej uwagi lub przy parametrze, który można
226 uważać za potrzebny.
227
228 Ten pakiet zawiera zadanie dla crona.
229
230 %package monitor
231 Summary:        Eventum Heartbeat Monitor
232 Summary(pl.UTF-8):      Monitor życia dla Eventum
233 Group:          Applications/WWW
234 Requires:       %{name} = %{version}-%{release}
235 Requires:       crondaemon
236 Requires:       php(posix)
237
238 %description monitor
239 The heartbeat monitor is a feature designed for the administrator that
240 wants to be alerted whenever a common problem in Eventum is detected,
241 like the database server not being available anymore, or maybe when
242 the recommended permissions for certain configuration files are
243 changed.
244
245 Please note that before running the heartbeat monitor, you may need to
246 customize some of the checks to be appropriate for your own system,
247 particularly the permission and file checks on
248 Monitor::checkConfiguration().
249
250 This package contains the cron job.
251
252 %description monitor -l pl.UTF-8
253 Monitor życia to funkcjonalność zaprojektowana dla administratora
254 chcącego być alarmowanym przy każdym wykryciu popularnego problemu z
255 Eventum, jak nie działanie serwera bazy danych albo zmiana uprawnień
256 do plików konfiguracyjnych.
257
258 Należy zauważyć, że przed uruchomieniem tego monitora może być
259 konieczne dostosowanie niektórych testów do systemu, w szczególności
260 testów uprawnień i plików w Monitor::checkConfiguration().
261
262 Ten pakiet zawiera zadanie dla crona.
263
264 %package route-drafts
265 Summary:        Eventum Draft Routing
266 Summary(pl.UTF-8):      Przekazywanie szkiców dla Eventum
267 Group:          Applications/WWW
268 Requires:       %{name} = %{version}-%{release}
269 Requires:       eventum(router)
270
271 %description route-drafts
272 The draft routing feature is used to automatically associate a thread
273 of drafts into an Eventum issue. By setting up Postfix to deliver
274 emails sent to a specific address (usually draft-<number>@<domain>) to
275 the above script, users are able to send drafts written in their mail
276 client to be stored in Eventum. These drafts will NOT broadcasted to
277 the notification list.
278
279 %description route-drafts -l pl.UTF-8
280 Przekazywanie szkiców służy do automatycznego wiązania wątku szkiców z
281 problemem w Eventum. Ustawiając Postfiksa, aby dostarczał pocztę
282 wysłaną na podany adres (zwykle draft-<liczba>@<domena>) do tego
283 skryptu umożliwia się użytkownikom wysyłanie szkiców napisanych w ich
284 kliencie pocztowym do zapisania w Eventum. Szkice te NIE będą wysyłane
285 na listę powiadomień.
286
287 %package route-emails
288 Summary:        Eventum Email Routing
289 Summary(pl.UTF-8):      Przekazywanie poczty dla Eventum
290 Group:          Applications/WWW
291 Requires:       %{name} = %{version}-%{release}
292 Requires:       eventum(router)
293
294 %description route-emails
295 The email routing feature is used to automatically associate a thread
296 of emails into an Eventum issue. By setting up Postfix to deliver
297 emails sent to a specific address (usually issue-<number>@<domain>) to
298 the above script, users are able to use their email clients to reply
299 to emails coming from Eventum, and those replies will be automatically
300 associated with the issue and broadcasted to the entire notification
301 list.
302
303 %description route-emails -l pl.UTF-8
304 Funkcjonalność przekazywania poczty służy do automatycznego wiązania
305 wątku listów ze sprawą w Eventum. Po ustawieniu czy nawet Postfiksa,
306 aby dostarczał listy wysyłane na pewien adres (zwykle
307 issue-<numer>@<domena>) na powyższy skrypt, użytkownicy będą mogli
308 używać klientów pocztowych do odpowiadania na listy przychodzące z
309 Eventum, a odpowiedzi te będą automatycznie wiązane ze sprawą i
310 rozprowadzane do całej listy ogłoszeniowej.
311
312 %package route-notes
313 Summary:        Eventum Note Routing
314 Summary(pl.UTF-8):      Przekazywanie notatek dla Eventum
315 Group:          Applications/WWW
316 Requires:       %{name} = %{version}-%{release}
317 Requires:       eventum(router)
318
319 %description route-notes
320 The note routing feature is used to automatically associate a thread
321 of notes into an Eventum issue. By setting up Postfix to deliver
322 emails sent to a specific address (usually note-<number>@<domain>) to
323 the above script, users are able to use their email clients to reply
324 to internal notes coming from Eventum, and those replies will be
325 automatically associated with the issue and broadcasted to the
326 notification list staff members.
327
328 %description route-notes -l pl.UTF-8
329 Funkcjonalność przekazywania notatek służy do automatycznego wiązania
330 wątku notatek ze sprawą w Eventum. Po ustawieniu Postfiksa, aby
331 dostarczał listy wysyłane na pewien adres (zwykle
332 note-<numer>@<domena>) na powyższy skrypt, użytkownicy będą mogli
333 używać klientów pocztowych do odpowiadania na wewnętrzne notatki
334 pochodzące od Eventu, a odpowiedzi te będą automatycznie wiązane ze
335 sprawą i rozprowadzane do członków personelu listy ogłoszeniowej.
336
337 %package router-postfix
338 Summary:        Eventum Mail Routing - Postfix
339 Summary(pl.UTF-8):      Przekazywanie poczty Eventum - Postfix
340 Group:          Applications/Mail
341 Requires:       %{name} = %{version}-%{release}
342 Requires:       postfix
343 Provides:       eventum(router)
344 Obsoletes:      eventum(router)
345
346 %description router-postfix
347 This package provides way of routing notes and emails back to Eventum
348 via Postfix.
349
350 The Postfix configuration instructions you can find from
351 <http://eventum.mysql.org/wiki/index.php/Setting_up_email_routing_with_postfix>.
352
353 %description router-postfix -l pl.UTF-8
354 Ten pakiet udostępnia metodę przekazywania notatek i listów do Eventum
355 przez Postfiksa.
356
357 Opis konfiguracji Postfiksa można znaleźć pod adresem
358 <http://eventum.mysql.org/wiki/index.php/Setting_up_email_routing_with_postfix>.
359
360 %package irc
361 Summary:        Eventum IRC Notification Bot
362 Summary(pl.UTF-8):      IRC-owy bot powiadamiający dla Eventum
363 Group:          Applications/WWW
364 Requires(post,preun):   /sbin/chkconfig
365 Requires:       %{name} = %{version}-%{release}
366 Requires:       php(sockets)
367 Requires:       php-pear-Net_SmartIRC
368 Requires:       rc-scripts >= 0.4.0.18
369
370 %description irc
371 The IRC notification bot is a nice feature for remote teams that want
372 to handle issues and want to have a quick and easy way to get simple
373 notifications. Right now the bot notifies of the following actions:
374 - New Issues
375 - Blocked emails
376 - Issues that got their assignment list changed
377
378 NOTE: You will need to manually edit the bot.php script to set your
379 appropriate preferences, like IRC server and channel that the bot
380 should join.
381
382 %description irc -l pl.UTF-8
383 IRC-owy bot powiadamiający to miła funkcjonalność dla zdalnych
384 zespołów chcących obsługiwać sprawy i mieć szybki i łatwy sposób na
385 uzyskiwanie prostych powiadomień. Aktualnie bot powiadamia o
386 następujących zdarzeniach:
387 - nowych sprawach
388 - zablokowanych listach
389 - sprawach, dla których zmieniła się lista powiązań
390
391 UWAGA: w celu wprowadzenia własnych ustawień, takich jak serwer IRC i
392 kanał używany przez bota, trzeba ręcznie zmodyfikować skrypt bot.php .
393
394 %package cli
395 Summary:        Eventum command-line interface
396 Summary(pl.UTF-8):      Interfejs linii poleceń dla Eventum
397 Group:          Applications/WWW
398 Requires:       %{name}-base = %{version}-%{release}
399 Requires:       php-cli
400 Requires:       php-common >= 4:%{php_min_version}
401 Requires:       php-pear-XML_RPC
402
403 %description cli
404 The Eventum command-line interface allows you to access most of the
405 features of the web interface straight from your command shell.
406
407 %description cli -l pl.UTF-8
408 Interfejs linii poleceń Eventum pozwala na dostęp do większości
409 funkcji interfejsu WWW prosto z linii poleceń powłoki.
410
411 %package scm
412 Summary:        Eventum SCM integration
413 Summary(pl.UTF-8):      Integracja SCM dla Eventum
414 Group:          Applications/WWW
415 Requires:       %{name}-base = %{version}-%{release}
416 Requires:       php-cli
417 Requires:       php-common >= 4:%{php_min_version}
418 Requires:       php-pcre
419
420 %description scm
421 This feature allows your software development teams to integrate your
422 Source Control Management system with your Issue Tracking System.
423
424 The integration is implemented in such a way that it will be forward
425 compatible with pretty much any SCM system, such as CVS.
426
427 For installation see
428 </eventum/help.php?topic=scm_integration_installation>.
429
430 %description scm -l pl.UTF-8
431 Ten pakiet pozwala zespołom programistów na integrację systemu
432 zarządzania źródłami (SCM - Source Control Management) z systemem
433 śledzenia spraw.
434
435 Integracja jest zaimplementowana tak, aby być kompatybilna w przód z
436 prawie każdym systemem SCM, jak np. CVS.
437
438 Szczegóły na temat instalacji można przeczytać pod
439 </eventum/help.php?topic=scm_integration_installation>.
440
441 %prep
442 %setup -q
443
444 # GPL v2
445 rm docs/COPYING
446
447 rm -r upgrade/*v1.[123]* # too old to support in PLD Linux
448 rm -r upgrade/v{1.,2.0,2.1_}* # no longer supported in PLD Linux
449 rm upgrade/flush_compiled_templates.php
450 rm -r upgrade/{*/,}index.html # not needed in PLD Linux
451
452 # bug fixes / features
453 %patch0 -p1
454 %{?with_order:%patch2 -p1}
455
456 cp -a %{SOURCE16} htdocs/images
457
458 #%patch200 -p1
459
460 # packaging
461 %patch100 -p1
462 %patch101 -p1
463 %patch105 -p1
464 %patch107 -p1
465
466 %{__sed} -i -e "
467 s;define('CONFIG_PATH'.*');define('CONFIG_PATH', '%{_webappdir}');
468 " upgrade/{*/,}*.php
469
470 # remove backups from patching as we use globs to package files to buildroot
471 find '(' -name '*~' -o -name '*.orig' ')' | xargs -r rm -v
472
473 %build
474 %{__make} -C localization
475
476 %install
477 rm -rf $RPM_BUILD_ROOT
478 install -d \
479         $RPM_BUILD_ROOT{%{_webappdir},%{_sysconfdir},%{_bindir},%{_sbindir},%{_libdir}} \
480         $RPM_BUILD_ROOT/etc/{rc.d/init.d,cron.d,sysconfig} \
481         $RPM_BUILD_ROOT/var/{run,cache,lib}/%{name} \
482         $RPM_BUILD_ROOT/var/log/{archive/,}%{name} \
483         $RPM_BUILD_ROOT/var/lib/%{name}/routed_{emails,drafts,notes} \
484         $RPM_BUILD_ROOT%{_appdir}/{include,htdocs/misc,upgrade} \
485
486 %{__make} install-eventum install-cli install-irc install-scm install-jpgraph install-localization \
487         sysconfdir=%{_webappdir} \
488         DESTDIR=$RPM_BUILD_ROOT
489
490 %{?with_order:cp -a htdocs/ajax $RPM_BUILD_ROOT%{_appdir}/htdocs}
491
492 touch $RPM_BUILD_ROOT%{_webappdir}/htpasswd
493 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_webappdir}/apache.conf
494 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_webappdir}/httpd.conf
495 cp -a %{SOURCE15} $RPM_BUILD_ROOT%{_webappdir}/lighttpd.conf
496
497 cp -a %{SOURCE2} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-queue
498 cp -a %{SOURCE3} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-download
499 cp -a %{SOURCE4} $RPM_BUILD_ROOT/etc/cron.d/%{name}-reminder
500 cp -a %{SOURCE5} $RPM_BUILD_ROOT/etc/cron.d/%{name}-monitor
501
502 cp -a %{SOURCE7} $RPM_BUILD_ROOT%{_webappdir}/irc_config.php
503
504 cp -a %{SOURCE8} $RPM_BUILD_ROOT/etc/rc.d/init.d/eventum-irc
505 cp -a %{SOURCE9} $RPM_BUILD_ROOT/etc/sysconfig/eventum-irc
506
507 # postfix router
508 install %{SOURCE13} $RPM_BUILD_ROOT%{_libdir}/router-postfix
509
510 install -D %{SOURCE14} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
511
512 %find_lang %{name}
513
514 # scm
515 install %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}/scm.php
516
517 # old compat
518 ln -s %{_sbindir}/eventum-cvs-hook $RPM_BUILD_ROOT%{_libdir}/process_cvs_commits
519 ln -s %{_sbindir}/eventum-svn-hook $RPM_BUILD_ROOT%{_libdir}/process_svn_commits
520
521 # skip pear for cli
522 rm -rf $RPM_BUILD_ROOT%{_datadir}/%{name}/cli
523 cp -a cli/lib/eventum $RPM_BUILD_ROOT%{_datadir}/%{name}/cli
524
525 %clean
526 rm -rf $RPM_BUILD_ROOT
527
528 %pre
529 %addusertogroup http %{name}
530
531 %post
532 # check if the package is configured.
533 if grep -q "Header('Location: setup/')" %{_webappdir}/config.php; then
534 if [ -f %{_appdir}/htdocs/setup/index.php ]; then
535 %banner %{name} -e <<EOF
536
537 You haven't yet configured Eventum!
538 Please open in browser <http://localhost/eventum/>
539 If you need access from elsewhere, you need to edit
540 %{_webappdir}/apache.conf and restart apache.
541
542 IMPORTANT: When You have configured Eventum, please uninstall the
543 setup package, so that %{name}-setup is able to secure your Eventum
544 installation.
545
546 EOF
547 #' vim syntax hack
548 else
549 %banner %{name} -e <<EOF
550
551 You haven't yet configured Eventum!
552
553 To setup eventum, please install %{name}-setup and open in browser
554 <http://localhost/eventum/>.
555 If you need access from elsewhere, you need to edit
556 %{_webappdir}/*.conf depending on webserver and restart the webserver.
557
558 IMPORTANT: When You have configured Eventum, please uninstall the
559 setup package, so that %{name}-setup is able to secure your Eventum
560 installation.
561
562 EOF
563 #' vim syntax hack
564 fi
565
566 elif grep -q 'DEFAULTPRIVATEKEY' %{_webappdir}/private_key.php; then
567 %banner %{name} -e <<EOF
568
569 You have default private key installed!
570
571 Install %{name}-setup and open up http://yourserver/eventum/setup/
572 -- that will help you setup initial config.
573
574 when have configured Eventum, please uninstall the setup package,
575 so that %{name}-setup is able to secure your Eventum installation.
576
577 EOF
578         elif [ -d %{_appdir}/setup ]; then
579 %banner %{name} -e <<EOF
580
581 If you have have configured Eventum, please uninstall the setup package,
582 so that %{name}-setup is able to secure your Eventum installation.
583
584 EOF
585 fi
586
587 # greate empty ghost files
588 for a in cli.log errors.log irc_bot.log login_attempts.log; do
589         if [ ! -f /var/log/%{name}/$a ]; then
590                 install -m620 -oroot -geventum /dev/null /var/log/%{name}/$a
591         fi
592 done
593
594 # database update
595 %{_appdir}/upgrade/update-database.php || :
596
597 # nuke Smarty templates cache after upgrade
598 rm -f /var/cache/eventum/*.php
599
600 # Restart webserver on upgrade to get .mo translations reloaded.
601 # actually php engines "php-fcgi" and "php-fpm" needed only, apache is restarted anyway via webapp trigger.
602 %php_webserver_restart
603
604 %preun
605 if [ "$1" = "0" ]; then
606         # nuke cache
607         rm -f /var/cache/eventum/*.php 2>/dev/null || :
608 fi
609
610 %pre base
611 %groupadd -P %{name}-base -g 146 %{name}
612 %useradd -P %{name}-base -u 146 -d /var/lib/%{name} -g %{name} -c "Eventum User" %{name}
613
614 %postun base
615 if [ "$1" = "0" ]; then
616         %userremove %{name}
617         %groupremove %{name}
618 fi
619
620 %post setup
621 chmod 660 %{_webappdir}/{config,private_key}.php
622 chown root:eventum %{_webappdir}/{config,private_key}.php
623
624 %postun setup
625 if [ "$1" = "0" ]; then
626         chmod 640 %{_webappdir}/{config,private_key}.php
627         chown root:eventum %{_webappdir}/{config,private_key}.php
628 fi
629
630 %post irc
631 /sbin/chkconfig --add eventum-irc
632 %service eventum-irc restart "Eventum IRC Bot"
633
634 %preun irc
635 if [ "$1" = 0 ]; then
636         %service eventum-irc stop
637         /sbin/chkconfig --del eventum-irc
638 fi
639
640 %triggerin -- apache1 < 1.3.37-3, apache1-base
641 %webapp_register apache %{_webapp}
642
643 %triggerun -- apache1 < 1.3.37-3, apache1-base
644 %webapp_unregister apache %{_webapp}
645
646 %triggerin -- apache < 2.2.0, apache-base
647 %webapp_register httpd %{_webapp}
648
649 %triggerun -- apache < 2.2.0, apache-base
650 %webapp_unregister httpd %{_webapp}
651
652 %triggerin -- lighttpd
653 %webapp_register lighttpd %{_webapp}
654
655 %triggerun -- lighttpd
656 %webapp_unregister lighttpd %{_webapp}
657
658 %triggerpostun -- %{name} < 2.2-2.57
659 # switching eventum->http user
660 chgrp http %{_webappdir}/config.php
661 chgrp http %{_webappdir}/private_key.php
662 chgrp http %{_webappdir}/setup.php
663 chgrp http /var/log/%{name}/*
664 # update crontab user
665 for a in /etc/cron.d/eventum-*; do
666         [ -f "$a" ] || continue
667         awk '!/#/ && NR > 6 && $6 =="eventum" {sub("eventum", "http", $6)}{print}'  $a > $a.rpmtmp && cat $a.rpmtmp > $a
668         rm -f $a.rpmtmp
669
670         # crontabs moved to crons subdir
671         %{__sed} -i -e '
672                 s,/usr/share/eventum/process_mail_queue.php,/usr/share/eventum/crons/process_mail_queue.php,
673                 s,/usr/share/eventum/download_emails.php,/usr/share/eventum/crons/download_emails.php,
674                 s,/usr/share/eventum/check_reminders.php,/usr/share/eventum/crons/check_reminders.php,
675                 s,/usr/share/eventum/monitor.php,/usr/share/eventum/crons/monitor.php,
676         ' $a
677 done
678
679 %files -f %{name}.lang
680 %defattr(644,root,root,755)
681 %doc docs/* htdocs/setup/schema.sql
682 %attr(751,root,root) %dir %{_webappdir}
683 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/apache.conf
684 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/httpd.conf
685 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/lighttpd.conf
686 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/config.php
687 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/private_key.php
688 %attr(660,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/setup.php
689 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/htpasswd
690
691 %dir %attr(731,root,http) /var/log/%{name}
692 %attr(620,root,http) %ghost /var/log/%{name}/*
693 %dir %attr(750,root,root) /var/log/archive/%{name}
694 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/%{name}
695
696 %dir %{_appdir}/crons
697 %{_appdir}/init.php
698 %dir %{_appdir}/htdocs
699 %{_appdir}/htdocs/*.php
700 %{_appdir}/htdocs/*.ico
701 %{_appdir}/htdocs/css
702 %{_appdir}/htdocs/customer
703 %{_appdir}/htdocs/images
704 %{_appdir}/htdocs/js
705 %{_appdir}/htdocs/manage
706 %{_appdir}/htdocs/reports
707 %{_appdir}/htdocs/rpc
708 %{_appdir}/htdocs/misc
709 %if %{with order}
710 %{_appdir}/htdocs/ajax
711 %endif
712 %{_appdir}/templates
713
714 %dir %{_appdir}/upgrade
715 %{_appdir}/upgrade/init.php
716 %attr(755,root,root) %{_appdir}/upgrade/update-database.php
717 %dir %{_appdir}/upgrade/v*
718 %attr(755,root,root) %{_appdir}/upgrade/v*/*.php
719 %{_appdir}/upgrade/patches
720
721 %dir %{_appdir}/lib
722 %{_appdir}/lib/eventum
723 %{_appdir}/lib/jpgraph
724 %exclude %{_appdir}/lib/eventum/class.monitor.php
725
726 %dir %attr(730,root,http) /var/run/%{name}
727 %dir %attr(730,root,http) /var/cache/%{name}
728
729 %files base
730 %defattr(644,root,root,755)
731 %attr(751,root,root) %dir %{_sysconfdir}
732 %dir %{_libdir}
733 %dir %{_appdir}
734 %dir /var/lib/%{name}
735 # saved mail copies
736 %attr(770,root,http) %dir /var/lib/%{name}/routed_emails
737 %attr(770,root,http) %dir /var/lib/%{name}/routed_drafts
738 %attr(770,root,http) %dir /var/lib/%{name}/routed_notes
739
740 %files setup
741 %defattr(644,root,root,755)
742 %{_appdir}/htdocs/setup
743
744 %files mail-queue
745 %defattr(644,root,root,755)
746 %attr(755,root,root) %{_appdir}/crons/process_mail_queue.php
747 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-queue
748
749 %files mail-download
750 %defattr(644,root,root,755)
751 %attr(755,root,root) %{_appdir}/crons/download_emails.php
752 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-download
753
754 %files reminder
755 %defattr(644,root,root,755)
756 %attr(755,root,root) %{_appdir}/crons/check_reminders.php
757 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-reminder
758
759 %files monitor
760 %defattr(644,root,root,755)
761 %{_appdir}/lib/eventum/class.monitor.php
762 %attr(755,root,root) %{_appdir}/crons/monitor.php
763 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-monitor
764
765 %files route-drafts
766 %defattr(644,root,root,755)
767 %attr(755,root,root) %{_appdir}/route_drafts.php
768
769 %files route-emails
770 %defattr(644,root,root,755)
771 %attr(755,root,root) %{_appdir}/route_emails.php
772
773 %files route-notes
774 %defattr(644,root,root,755)
775 %attr(755,root,root) %{_appdir}/route_notes.php
776
777 %files router-postfix
778 %defattr(644,root,root,755)
779 %attr(755,root,root) %{_libdir}/router-postfix
780
781 %files irc
782 %defattr(644,root,root,755)
783 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/irc_config.php
784 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/eventum-irc
785 %attr(755,root,root) %{_sbindir}/%{name}-irc-bot
786 %attr(754,root,root) /etc/rc.d/init.d/%{name}-irc
787
788 %files cli
789 %defattr(644,root,root,755)
790 %doc cli/eventumrc
791 %attr(755,root,root) %{_bindir}/%{name}
792 %{_appdir}/cli
793
794 %files scm
795 %defattr(644,root,root,755)
796 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/scm.php
797 %attr(755,root,root) %{_libdir}/process_cvs_commits
798 %attr(755,root,root) %{_libdir}/process_svn_commits
799 %attr(755,root,root) %{_sbindir}/eventum-cvs-hook
800 %attr(755,root,root) %{_sbindir}/eventum-svn-hook
This page took 0.231259 seconds and 3 git commands to generate.