]> git.pld-linux.org Git - packages/eventum.git/blob - eventum.spec
up to 3.1.9
[packages/eventum.git] / eventum.spec
1 #
2 # Conditional build:
3 %bcond_with     order   # with experimental order patch
4
5 %define         rel             1
6 #define         subver  51
7 #define         githash 61de085
8 %define         php_min_version 5.5.0
9 %include        /usr/lib/rpm/macros.php
10 Summary:        Eventum Issue / Bug tracking system
11 Summary(pl.UTF-8):      Eventum - system śledzenia spraw/błędów
12 Name:           eventum
13 Version:        3.1.9
14 Release:        %{?subver:1.%{subver}.%{?githash:g%{githash}.}}%{rel}
15 License:        GPL v2+
16 Group:          Applications/WWW
17 Source0:        https://github.com/eventum/eventum/releases/download/v%{version}/%{name}-%{version}.tar.gz
18 # Source0-md5:  7e62e9879b3dfd2a0e923c955f0eeee9
19 #Source0:       %{name}-%{version}-%{subver}-g%{githash}.tar.gz
20 Source1:        %{name}-apache.conf
21 Source2:        %{name}-mail-queue.cron
22 Source3:        %{name}-mail-download.cron
23 Source4:        %{name}-reminder.cron
24 Source5:        %{name}-monitor.cron
25 Source8:        %{name}-irc.init
26 Source9:        %{name}-irc.sysconfig
27 Source10:       sphinx.crontab
28 Source13:       %{name}-router-postfix.sh
29 Source14:       %{name}.logrotate
30 Source15:       %{name}-lighttpd.conf
31 Source16:       http://www.isocra.com/images/updown2.gif
32 # Source16-md5: deb6eeb2552ba757d3a949ed10c4107d
33 Source17:       %{name}.tmpfiles
34 Patch2:         %{name}-order.patch
35 #Patch3:                group-users.patch
36 #Patch4:                https://github.com/glensc/eventum/compare/cf_escape.patch
37 # packaging patches that probably never go upstream
38 Patch100:       %{name}-paths.patch
39 Patch107:       %{name}-gettext.patch
40 Patch108:       autoload.patch
41 # some tests
42 Patch200:       %{name}-fixed-nav.patch
43 URL:            https://wiki.github.com/eventum/eventum/
44 BuildRequires:  /usr/bin/php
45 BuildRequires:  gettext-tools
46 BuildRequires:  php(core) >= %{php_min_version}
47 BuildRequires:  rpm-php-pearprov >= 4.0.2-98
48 BuildRequires:  rpmbuild(macros) >= 1.654
49 BuildRequires:  sed >= 4.0
50 Requires(postun):       /usr/sbin/groupdel
51 Requires(postun):       /usr/sbin/userdel
52 Requires(pre):  /bin/id
53 Requires(pre):  /usr/bin/getgid
54 Requires(pre):  /usr/sbin/groupadd
55 Requires(pre):  /usr/sbin/useradd
56 Requires:       fonts-TTF-RedHat-liberation
57 Requires:       php(core) >= %{php_min_version}
58 Requires:       php(filter)
59 Requires:       php(iconv)
60 Requires:       php(imap)
61 Requires:       php(json)
62 Requires:       php(mbstring)
63 Requires:       php(pcre)
64 Requires:       php(pdo_mysql)
65 Requires:       php(session)
66 Requires:       php-Smarty >= 3.1
67 Requires:       php-Smarty-plugin-gettext
68 Requires:       php-ZendFramework-Config >= 2.4
69 Requires:       php-ZendFramework-Loader >= 2.4
70 Requires:       php-ZendFramework-Mail >= 2.4.9-2
71 Requires:       php-ZendFramework-Mime >= 2.4
72 Requires:       php-ZendFramework-Validator >= 2.4
73 Requires:       php-monolog >= 1.17.2
74 Requires:       php-pear-DB
75 Requires:       php-pear-Mail
76 Requires:       php-pear-Mail_Mime
77 Requires:       php-pear-Mail_mimeDecode
78 Requires:       php-pear-Math_Stats
79 Requires:       php-pear-Net_SMTP
80 Requires:       php-pear-Net_Socket
81 Requires:       php-pear-Net_URL
82 Requires:       php-pear-PEAR-core
83 Requires:       php-pear-Text_Diff
84 Requires:       php-pear-XML_RPC
85 Requires:       php-psr-Log >= 1.0.0-2
86 Requires:       php-symfony2-Config >= 2.7.7
87 Requires:       php-symfony2-Filesystem >= 2.7.7
88 Requires:       php-symfony2-HttpFoundation >= 2.7.7
89 Requires:       php-symfony2-OptionsResolver >= 2.7.7
90 Requires:       php-symfony2-Serializer >= 2.7.7
91 Requires:       php-symfony2-Yaml >= 2.7.7
92 Requires:       phplot >= 5.8.0
93 Requires:       webapps
94 Requires:       webserver(access)
95 Requires:       webserver(alias)
96 Requires:       webserver(indexfile)
97 Requires:       webserver(php) >= 4.2.0
98 Suggests:       localedb
99 Suggests:       php(mcrypt)
100 Suggests:       php(openssl)
101 Suggests:       php-pear-Net_LDAP2
102 Suggests:       php-pear-Net_POP3
103 Suggests:       webserver(setenv)
104 Provides:       group(eventum)
105 Provides:       user(eventum)
106 Obsoletes:      eventum-base < 3.0.3-1.305
107 Obsoletes:      eventum-route-drafts < 3.0.8-1.1
108 Obsoletes:      eventum-route-emails < 3.0.8-1.1
109 Obsoletes:      eventum-route-notes < 3.0.8-1.1
110 Conflicts:      logrotate < 3.8.0
111 BuildArch:      noarch
112 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
113
114 %define         _noautoreq_pear ../init.php ../../init.php init.php /usr/share/eventum/init.php /etc/webapps/.* %{_appdir}/.* .*Smarty.class.php Services/JSON.php class.date_helper.php sphinxapi.php Net/LDAP2.* Auth/SASL.* Util.php smarty_internal.*
115
116 # exclude optional php dependencies
117 %define         _noautophp      php-gnupg php-hash php-pecl-http php-tk
118
119 %define         _noautoreq      %{_noautophp}
120
121 %define         _libdir         %{_prefix}/lib/%{name}
122 %define         _appdir         %{_datadir}/%{name}
123 %define         _smartydir      %{php_data_dir}/Smarty
124 %define         _webapps        /etc/webapps
125 %define         _webapp         %{name}
126 %define         _webappdir      %{_webapps}/%{_webapp}
127 %define         _sysconfdir     /etc/%{name}
128
129 %description
130 Eventum is a user-friendly and flexible issue tracking system that can
131 be used by a support department to track incoming technical support
132 requests, or by a software development team to quickly organize tasks
133 and bugs.
134
135 %description -l pl.UTF-8
136 Eventum to przyjazny dla użytkownika system śledzenia spraw, który
137 może być używany przez dział obsługi do śledzenia przychodzących żądań
138 obsługi technicznej albo przez zespół tworzący oprogramowanie do
139 szybkiej organizacji zadań i błędów.
140
141 %package setup
142 Summary:        Eventum setup package
143 Summary(pl.UTF-8):      Pakiet do wstępnej konfiguracji Eventum
144 Group:          Applications/WWW
145 Requires:       %{name} = %{version}-%{release}
146
147 %description setup
148 Install this package to configure initial Eventum installation. You
149 should uninstall this package when you're done, as it considered
150 insecure to keep the setup files in place.
151
152 %description setup -l pl.UTF-8
153 Ten pakiet należy zainstalować w celu wstępnej konfiguracji Eventum po
154 pierwszej instalacji. Potem należy go odinstalować, jako że
155 pozostawienie plików instalacyjnych mogłoby być niebezpieczne.
156
157 %package doc
158 Summary:        Eventum documentation and Wiki
159 Group:          Documentation
160
161 %description doc
162 Eventum documentation and copy of Wiki.
163
164 %package mail-queue
165 Summary:        Eventum mail queue process
166 Summary(pl.UTF-8):      Przetwarzanie kolejki poczty Eventum
167 Group:          Applications/WWW
168 Requires:       %{name} = %{version}-%{release}
169 Requires:       crondaemon
170
171 %description mail-queue
172 Beginning with the first release of Eventum, emails are not directly
173 sent out from the various scripts, but rather added to a mail queue
174 table that is processed by a cron job. If an email cannot be sent, it
175 will be marked as such in the mail queue log, and the cron job script
176 will re-try to send it again the next time it runs.
177
178 This package contains the cron job.
179
180 %description mail-queue -l pl.UTF-8
181 Od pierwszego wydania Eventum poczta nie jest wysyłana bezpośrednio z
182 różnych skryptów, lecz dodawana do kolejki przetwarzanej z crona.
183 Jeśli poczta nie może być wysłana, będzie odpowiednio oznaczona w logu
184 kolejki poczty, a skrypt z crona będzie próbował wysłać ją ponownie
185 następnym razem.
186
187 Ten pakiet zawiera zadanie dla crona.
188
189 %package mail-download
190 Summary:        Eventum email download
191 Summary(pl.UTF-8):      Ściąganie poczty Eventum
192 Group:          Applications/WWW
193 Requires:       %{name} = %{version}-%{release}
194 Requires:       crondaemon
195
196 %description mail-download
197 In order for Eventum's email integration feature to work, you need to
198 setup a cron job to run the script every so often.
199
200 This package contains the cron job.
201
202 %description mail-download -l pl.UTF-8
203 Aby integracja poczty elektronicznej w Eventum działała, trzeba
204 ustawić zadanie crona, aby uruchamiał odpowiedni skrypt wystarczająco
205 często.
206
207 Ten pakiet zawiera zadanie dla crona.
208
209 %package reminder
210 Summary:        Eventum Reminder System
211 Summary(pl.UTF-8):      System przypominania dla Eventum
212 Group:          Applications/WWW
213 Requires:       %{name} = %{version}-%{release}
214 Requires:       crondaemon
215
216 %description reminder
217 The reminder system was designed with the objective as serving as a
218 safe net for issues that need attention. Depending on what
219 configuration you create, you may have several reminders (or alerts)
220 be sent out whenever an issue needs attention, for whatever parameter
221 you may deem necessary.
222
223 This package contains the cron job.
224
225 %description reminder -l pl.UTF-8
226 System przypominania został zaprojektowany tak, aby służył jako
227 bezpieczna sieć dla spraw wymagających uwagi. W zależności od
228 konfiguracji można ustawić różne przypominajki (lub alarmy) wysyłane
229 przy każdej sprawie wymagającej uwagi lub przy parametrze, który można
230 uważać za potrzebny.
231
232 Ten pakiet zawiera zadanie dla crona.
233
234 %package monitor
235 Summary:        Eventum Heartbeat Monitor
236 Summary(pl.UTF-8):      Monitor życia dla Eventum
237 Group:          Applications/WWW
238 Requires:       %{name} = %{version}-%{release}
239 Requires:       crondaemon
240 Requires:       php(posix)
241
242 %description monitor
243 The heartbeat monitor is a feature designed for the administrator that
244 wants to be alerted whenever a common problem in Eventum is detected,
245 like the database server not being available anymore, or maybe when
246 the recommended permissions for certain configuration files are
247 changed.
248
249 Please note that before running the heartbeat monitor, you may need to
250 customize some of the checks to be appropriate for your own system,
251 particularly the permission and file checks on
252 Monitor::checkConfiguration().
253
254 This package contains the cron job.
255
256 %description monitor -l pl.UTF-8
257 Monitor życia to funkcjonalność zaprojektowana dla administratora
258 chcącego być alarmowanym przy każdym wykryciu popularnego problemu z
259 Eventum, jak nie działanie serwera bazy danych albo zmiana uprawnień
260 do plików konfiguracyjnych.
261
262 Należy zauważyć, że przed uruchomieniem tego monitora może być
263 konieczne dostosowanie niektórych testów do systemu, w szczególności
264 testów uprawnień i plików w Monitor::checkConfiguration().
265
266 Ten pakiet zawiera zadanie dla crona.
267
268 %package router-postfix
269 Summary:        Eventum Mail Routing - Postfix
270 Summary(pl.UTF-8):      Przekazywanie poczty Eventum - Postfix
271 Group:          Applications/Mail
272 Requires:       %{name} = %{version}-%{release}
273 Requires:       postfix
274 Provides:       eventum(router)
275 Obsoletes:      eventum(router)
276
277 %description router-postfix
278 This package provides way of routing notes and emails back to Eventum
279 via Postfix.
280
281 The Postfix configuration instructions you can find from
282 <https://github.com/eventum/eventum/wiki/System-Admin:-Setting-up-email-routing-with-postfix>
283
284 %description router-postfix -l pl.UTF-8
285 Ten pakiet udostępnia metodę przekazywania notatek i listów do Eventum
286 przez Postfiksa.
287
288 Opis konfiguracji Postfiksa można znaleźć pod adresem
289 <https://github.com/eventum/eventum/wiki/System-Admin:-Setting-up-email-routing-with-postfix>
290
291 %package irc
292 Summary:        Eventum IRC Notification Bot
293 Summary(pl.UTF-8):      IRC-owy bot powiadamiający dla Eventum
294 Group:          Applications/WWW
295 Requires(post,preun):   /sbin/chkconfig
296 Requires:       %{name} = %{version}-%{release}
297 Requires:       php(pcntl)
298 Requires:       php(sockets)
299 Requires:       php-pear-Net_SmartIRC >= 1.1.9
300 Requires:       rc-scripts >= 0.4.0.18
301
302 %description irc
303 The IRC notification bot is a nice feature for remote teams that want
304 to handle issues and want to have a quick and easy way to get simple
305 notifications. Right now the bot notifies of the following actions:
306 - New Issues
307 - Blocked emails
308 - Issues that got their assignment list changed
309
310 NOTE: You will need to manually edit the bot.php script to set your
311 appropriate preferences, like IRC server and channel that the bot
312 should join.
313
314 %description irc -l pl.UTF-8
315 IRC-owy bot powiadamiający to miła funkcjonalność dla zdalnych
316 zespołów chcących obsługiwać sprawy i mieć szybki i łatwy sposób na
317 uzyskiwanie prostych powiadomień. Aktualnie bot powiadamia o
318 następujących zdarzeniach:
319 - nowych sprawach
320 - zablokowanych listach
321 - sprawach, dla których zmieniła się lista powiązań
322
323 UWAGA: w celu wprowadzenia własnych ustawień, takich jak serwer IRC i
324 kanał używany przez bota, trzeba ręcznie zmodyfikować skrypt bot.php .
325
326 %package cli
327 Summary:        Eventum command-line interface
328 Summary(pl.UTF-8):      Interfejs linii poleceń dla Eventum
329 Group:          Applications/WWW
330 Requires:       php(core) >= %{php_min_version}
331 Requires:       php(phar)
332 Requires:       php-pear-XML_RPC
333
334 %description cli
335 The Eventum command-line interface allows you to access most of the
336 features of the web interface straight from your command shell.
337
338 %description cli -l pl.UTF-8
339 Interfejs linii poleceń Eventum pozwala na dostęp do większości
340 funkcji interfejsu WWW prosto z linii poleceń powłoki.
341
342 %package sphinx
343 Summary:        Eventum Sphinx Search
344 Group:          Applications/WWW
345 Requires:       %{name} = %{version}-%{release}
346 Requires:       crondaemon
347 Requires:       sphinx
348
349 %description sphinx
350 Sphinx search integration for Eventum.
351
352 This package contains the cron job.
353
354 %prep
355 %setup -q -n %{name}-%{version}%{?githash:-%{subver}-g%{githash}}
356
357 mv docs/examples .
358
359 # bug fixes / features
360 %{?with_order:%patch2 -p1}
361 #%patch3 -p0
362 #%patch4 -p1
363
364 %{?with_order:cp -p %{SOURCE16} htdocs/images}
365
366 #%patch200 -p1
367
368 # produce default sphinx config
369 # must be run before paths.patch
370 %if 0
371 cat <<'EOF' > config/config.php
372 <?php
373 define('APP_SQL_DBTYPE', 'mysql');
374 define('APP_SQL_DBHOST', 'localhost:/var/lib/mysql/mysql.sock');
375 define('APP_SQL_DBPORT', 3306);
376 define('APP_SQL_DBNAME', 'eventum');
377 define('APP_SQL_DBUSER', 'mysql');
378 define('APP_SQL_DBPASS', '');
379 define('APP_TABLE_PREFIX', 'eventum_');
380 EOF
381 php config/sphinx.conf.php > config/sphinx.conf
382 rm config/config.php
383 %endif
384
385 # packaging
386 %patch100 -p1
387 %patch107 -p1
388 %patch108 -p1
389
390 rm htdocs/.htaccess.dist
391
392 mv config/irc_config{.dist.php,.php}
393 rm config/config.dist.php
394
395 # cleanup vendor. keep only needed libraries.
396 # (the rest are packaged with system packages)
397 mv vendor vendor.dist
398 vendor() {
399         local path dir
400         for path; do
401                 dir=$(dirname $path)
402                 test -d vendor/$dir || mkdir -p vendor/$dir
403                 mv vendor.dist/$path vendor/$path
404         done
405 }
406 vendor autoload.php
407 vendor composer/autoload_{classmap,files,namespaces,real,psr4}.php
408 vendor composer/ClassLoader.php
409 vendor ircmaxell/{random-lib,security-lib}
410 vendor defuse/php-encryption
411 vendor willdurand/email-reply-parser
412 vendor theorchard/monolog-cascade
413 vendor malkusch/lock
414 vendor phpxmlrpc/phpxmlrpc
415
416 # remove backups from patching as we use globs to package files to buildroot
417 find '(' -name '*~' -o -name '*.orig' ')' | xargs -r rm -v
418
419 %build
420 %{__make} -C localization
421
422 %install
423 rm -rf $RPM_BUILD_ROOT
424 install -d \
425         $RPM_BUILD_ROOT{%{_webappdir}/{custom_field,templates,workflow},%{_sysconfdir},%{_bindir},%{_sbindir},%{_libdir}} \
426         $RPM_BUILD_ROOT/etc/{rc.d/init.d,cron.d,logrotate.d,sysconfig} \
427         $RPM_BUILD_ROOT/var/{run,cache,lib}/%{name} \
428         $RPM_BUILD_ROOT/var/log/{archive/,}%{name} \
429         $RPM_BUILD_ROOT/var/lib/%{name}/routed_{emails,drafts,notes} \
430         $RPM_BUILD_ROOT%{systemdtmpfilesdir}
431
432 %{__make} install-eventum install-cli install-localization \
433         sysconfdir=%{_webappdir} \
434         localedir=%{_localedir} \
435         DESTDIR=$RPM_BUILD_ROOT
436
437 ln -s %{_webappdir} $RPM_BUILD_ROOT%{_appdir}/config
438
439 cp -a vendor $RPM_BUILD_ROOT%{_appdir}
440
441 # unsupported locale
442 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/ht
443
444 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
445 cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
446
447 %{?with_order:cp -a htdocs/ajax $RPM_BUILD_ROOT%{_appdir}/htdocs}
448
449 touch $RPM_BUILD_ROOT%{_webappdir}/htpasswd
450 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_webappdir}/apache.conf
451 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_webappdir}/httpd.conf
452 cp -p %{SOURCE15} $RPM_BUILD_ROOT%{_webappdir}/lighttpd.conf
453
454 install -d $RPM_BUILD_ROOT/etc/sphinx
455 #cp -p config/sphinx.conf $RPM_BUILD_ROOT/etc/sphinx/%{name}.conf
456 cp -p config/sphinx.conf.php $RPM_BUILD_ROOT%{_webappdir}
457
458 cp -p %{SOURCE2} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-queue
459 cp -p %{SOURCE3} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-download
460 cp -p %{SOURCE4} $RPM_BUILD_ROOT/etc/cron.d/%{name}-reminder
461 cp -p %{SOURCE5} $RPM_BUILD_ROOT/etc/cron.d/%{name}-monitor
462 cp -p %{SOURCE10} $RPM_BUILD_ROOT/etc/cron.d/%{name}-sphinx
463
464 install -p %{SOURCE8} $RPM_BUILD_ROOT/etc/rc.d/init.d/eventum-irc
465 cp -p %{SOURCE9} $RPM_BUILD_ROOT/etc/sysconfig/eventum-irc
466
467 cp -p %{SOURCE14} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
468
469 # postfix router
470 install -p %{SOURCE13} $RPM_BUILD_ROOT%{_libdir}/router-postfix
471
472 cp -p %{SOURCE17} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/%{name}.conf
473
474 %find_lang %{name}
475
476 %clean
477 rm -rf $RPM_BUILD_ROOT
478
479 %pre
480 %groupadd -g 146 %{name}
481 %useradd -u 146 -d /var/lib/%{name} -g %{name} -c "Eventum User" %{name}
482 %addusertogroup http %{name}
483
484 %post
485 # create empty ghost files
486 # these permissions ensure the logs are write only
487 for a in \
488         errors.log login_attempts.log \
489         eventum.log \
490         auth.log cli.log \
491         irc_bot_error.log irc_bot_smartirc.log \
492 ; do
493         test -f /var/log/%{name}/$a && continue
494         install -m 0620 -o root -g http /dev/null /var/log/%{name}/$a
495 done
496
497 # run database update if configured
498 test -s %{_webappdir}/config.php && \
499 %{_appdir}/bin/upgrade.php || :
500
501 # nuke Smarty templates cache after upgrade
502 rm -f /var/cache/eventum/*.php
503
504 # Restart webserver on upgrade to get .mo translations reloaded.
505 # actually php engines "php-fcgi" and "php-fpm" needed only, apache is restarted anyway via webapp trigger.
506 %php_webserver_restart
507
508 %preun
509 if [ "$1" = "0" ]; then
510         # nuke cache
511         rm -f /var/cache/eventum/*.php 2>/dev/null || :
512 fi
513
514 %postun
515 if [ "$1" = "0" ]; then
516         %userremove %{name}
517         %groupremove %{name}
518 fi
519
520 %post setup
521 chmod 660 %{_webappdir}/{config,private_key,secret_key}.php
522 chown root:http %{_webappdir}/{config,private_key,secret_key}.php
523
524 %postun setup
525 if [ "$1" = "0" ] && [ -f %{_webappdir}/config.php ]; then
526         chmod 640 %{_webappdir}/{config,private_key,secret_key}.php
527         chown root:http %{_webappdir}/{config,private_key,secret_key}.php
528 fi
529
530 %post irc
531 /sbin/chkconfig --add eventum-irc
532 %service eventum-irc restart "Eventum IRC Bot"
533
534 %preun irc
535 if [ "$1" = 0 ]; then
536         %service eventum-irc stop
537         /sbin/chkconfig --del eventum-irc
538 fi
539
540 %triggerin -- apache1 < 1.3.37-3, apache1-base
541 %webapp_register apache %{_webapp}
542
543 %triggerun -- apache1 < 1.3.37-3, apache1-base
544 %webapp_unregister apache %{_webapp}
545
546 %triggerin -- apache < 2.2.0, apache-base
547 %webapp_register httpd %{_webapp}
548
549 %triggerun -- apache < 2.2.0, apache-base
550 %webapp_unregister httpd %{_webapp}
551
552 %triggerin -- lighttpd
553 %webapp_register lighttpd %{_webapp}
554
555 %triggerun -- lighttpd
556 %webapp_unregister lighttpd %{_webapp}
557
558 %triggerpostun -- %{name} < 3.0.0-0.2
559 for f in /etc/cron.d/eventum-*; do
560         # crontabs moved to bin
561         %{__sed} -i -e '
562                 s,/usr/share/eventum/crons/process_mail_queue.php,%{_appdir}/bin/process_mail_queue.php,
563                 s,/usr/share/eventum/crons/download_emails.php,%{_appdir}/bin/download_emails.php,
564                 s,/usr/share/eventum/crons/check_reminders.php,%{_appdir}/bin/check_reminders.php,
565                 s,/usr/share/eventum/crons/monitor.php,%{_appdir}/bin/monitor.php,
566         ' $f
567 done
568
569 %files -f %{name}.lang
570 %defattr(644,root,root,755)
571 %attr(751,root,root) %dir %{_webappdir}
572 %attr(751,root,root) %dir %{_webappdir}/custom_field
573 %attr(751,root,root) %dir %{_webappdir}/templates
574 %attr(751,root,root) %dir %{_webappdir}/workflow
575 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/apache.conf
576 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/httpd.conf
577 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/lighttpd.conf
578 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/config.php
579 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/private_key.php
580 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/secret_key.php
581 %attr(660,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/setup.php
582 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/htpasswd
583
584 %dir %attr(711,root,http) /var/log/%{name}
585 %attr(620,root,http) %ghost /var/log/%{name}/*
586 %dir %attr(750,root,root) /var/log/archive/%{name}
587 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/%{name}
588
589 %dir %{_appdir}
590 %{_appdir}/config
591
592 %dir %{_appdir}/bin
593 %attr(755,root,root) %{_appdir}/bin/process_all_emails.php
594 %attr(755,root,root) %{_appdir}/bin/upgrade.php
595
596 %{_appdir}/autoload.php
597 %{_appdir}/init.php
598 %dir %{_appdir}/htdocs
599 %{_appdir}/htdocs/*.php
600 %{_appdir}/htdocs/*.ico
601 %{_appdir}/htdocs/ajax
602 %{_appdir}/htdocs/css
603 %{_appdir}/htdocs/customer
604 %{_appdir}/htdocs/images
605 %{_appdir}/htdocs/js
606 %{_appdir}/htdocs/manage
607 %{_appdir}/htdocs/reports
608 %{_appdir}/htdocs/rpc
609 %{_appdir}/htdocs/components
610 %{_appdir}/templates
611
612 %dir %{_appdir}/upgrade
613 %{_appdir}/upgrade/*.sql
614 %{_appdir}/upgrade/patches
615
616 %{_appdir}/res
617 %{_appdir}/src
618 %{_appdir}/vendor
619 %dir %{_appdir}/lib
620 %{_appdir}/lib/eventum
621 %exclude %{_appdir}/lib/eventum/class.monitor.php
622
623 %dir %{_libdir}
624
625 %{systemdtmpfilesdir}/%{name}.conf
626
627 %dir /var/lib/%{name}
628 %dir %attr(730,root,http) /var/run/%{name}
629 %dir %attr(730,root,http) /var/cache/%{name}
630
631 # saved mail copies
632 %attr(770,root,http) %dir /var/lib/%{name}/routed_emails
633 %attr(770,root,http) %dir /var/lib/%{name}/routed_drafts
634 %attr(770,root,http) %dir /var/lib/%{name}/routed_notes
635
636 %files setup
637 %defattr(644,root,root,755)
638 %{_appdir}/htdocs/setup
639
640 %files doc
641 %defattr(644,root,root,755)
642 %doc docs/*
643 %{_examplesdir}/%{name}-%{version}
644
645 %files mail-queue
646 %defattr(644,root,root,755)
647 %attr(755,root,root) %{_appdir}/bin/process_mail_queue.php
648 %attr(755,root,root) %{_appdir}/bin/truncate_mail_queue.php
649 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-queue
650
651 %files mail-download
652 %defattr(644,root,root,755)
653 %attr(755,root,root) %{_appdir}/bin/download_emails.php
654 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-download
655
656 %files reminder
657 %defattr(644,root,root,755)
658 %attr(755,root,root) %{_appdir}/bin/check_reminders.php
659 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-reminder
660
661 %files monitor
662 %defattr(644,root,root,755)
663 %{_appdir}/lib/eventum/class.monitor.php
664 %attr(755,root,root) %{_appdir}/bin/monitor.php
665 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-monitor
666
667 %files router-postfix
668 %defattr(644,root,root,755)
669 %attr(755,root,root) %{_libdir}/router-postfix
670
671 %files irc
672 %defattr(644,root,root,755)
673 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/irc_config.php
674 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/eventum-irc
675 %attr(755,root,root) %{_appdir}/bin/irc-bot.php
676 %attr(754,root,root) /etc/rc.d/init.d/%{name}-irc
677
678 %files cli
679 %defattr(644,root,root,755)
680 %doc cli/eventumrc
681 %attr(755,root,root) %{_bindir}/%{name}
682
683 %files sphinx
684 %defattr(644,root,root,755)
685 %{_webappdir}/sphinx.conf.php
686 #%attr(750,root,http) %config(noreplace) %verify(not md5 mtime size) /etc/sphinx/%{name}.conf
687 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-sphinx
This page took 0.127354 seconds and 3 git commands to generate.