]> git.pld-linux.org Git - packages/eventum.git/blob - eventum.spec
adapter
[packages/eventum.git] / eventum.spec
1 # TODO
2 # - discard bundled packages (from INSTALL):
3 #  - JpGraph 1.5.3 (last GPL version)
4 #  - dTree 2.0.5 (http://www.destroydrop.com/javascript/tree/)
5 #  - dynCalendar.js (http://www.phpguru.org/dyncalendar.html)
6 #  - overLIB 3.5.1 (http://www.bosrup.com/web/overlib/)
7 #  - A few other small javascript libraries
8 #
9 # Conditional build:
10 %bcond_without  order   # with experimental order patch
11
12 %define         php_min_version 5.1.2
13 %include        /usr/lib/rpm/macros.php
14 Summary:        Eventum Issue / Bug tracking system
15 Summary(pl.UTF-8):      Eventum - system śledzenia spraw/błędów
16 Name:           eventum
17 Version:        2.3.4
18 Release:        1
19 License:        GPL v2
20 Group:          Applications/WWW
21 Source0:        https://launchpad.net/eventum/trunk/%{version}/+download/%{name}-%{version}.tar.gz
22 # Source0-md5:  f64a6cd054356513f6ff701be765600e
23 Source1:        %{name}-apache.conf
24 Source2:        %{name}-mail-queue.cron
25 Source3:        %{name}-mail-download.cron
26 Source4:        %{name}-reminder.cron
27 Source5:        %{name}-monitor.cron
28 Source6:        %{name}-cvs.php
29 Source7:        %{name}-irc.php
30 Source8:        %{name}-irc.init
31 Source9:        %{name}-irc.sysconfig
32 Source10:       sphinx.crontab
33 Source13:       %{name}-router-postfix.sh
34 Source14:       %{name}.logrotate
35 Source15:       %{name}-lighttpd.conf
36 Source16:       http://www.isocra.com/images/updown2.gif
37 # Source16-md5: deb6eeb2552ba757d3a949ed10c4107d
38 Source17:       %{name}.tmpfiles
39 Patch0:         %{name}-lf.patch
40 Patch2:         %{name}-order.patch
41 Patch3:         group-users.patch
42 Patch4:         https://github.com/glensc/eventum/compare/cf_escape.patch
43 # Patch4-md5:   17688773ec035fb162b6a8ad2c7cfa76
44 # packaging patches that probably never go upstream
45 Patch100:       %{name}-paths.patch
46 Patch101:       %{name}-cvs-config.patch
47 Patch105:       %{name}-bot-reconnect.patch
48 Patch107:       %{name}-gettext.patch
49 # some tests
50 Patch200:       %{name}-fixed-nav.patch
51 URL:            http://eventum.mysql.org/
52 BuildRequires:  /usr/bin/php
53 BuildRequires:  gettext-devel
54 BuildRequires:  rpm-php-pearprov >= 4.0.2-98
55 BuildRequires:  rpmbuild(macros) >= 1.654
56 BuildRequires:  sed >= 4.0
57 Requires:       %{name}-base = %{version}-%{release}
58 Requires:       Smarty >= 2.6.10-4
59 Requires:       php(core) >= %{php_min_version}
60 Requires:       php(filter)
61 Requires:       php(gd)
62 Requires:       php(iconv)
63 Requires:       php(imap)
64 Requires:       php(json)
65 Requires:       php(mbstring)
66 Requires:       php(mysql)
67 Requires:       php(pcre)
68 Requires:       php(session)
69 Requires:       php-pear-DB
70 Requires:       php-pear-Date
71 Requires:       php-pear-Mail
72 Requires:       php-pear-Mail_Mime
73 Requires:       php-pear-Mail_mimeDecode
74 Requires:       php-pear-Math_Stats
75 Requires:       php-pear-Net_DIME
76 Requires:       php-pear-Net_SMTP
77 Requires:       php-pear-Net_Socket
78 Requires:       php-pear-Net_URL
79 Requires:       php-pear-Net_UserAgent_Detect
80 Requires:       php-pear-PEAR-core
81 Requires:       php-pear-Text_Diff
82 Requires:       php-pear-XML_RPC
83 Requires:       smarty-gettext
84 Requires:       webapps
85 Requires:       webserver(access)
86 Requires:       webserver(alias)
87 Requires:       webserver(indexfile)
88 Requires:       webserver(php) >= 4.2.0
89 Suggests:       localedb
90 Suggests:       php-pear-Net_LDAP2
91 Conflicts:      logrotate < 3.8.0
92 BuildArch:      noarch
93 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
94
95 %define         _noautoreq_pear ../init.php init.php /usr/share/eventum/init.php /etc/webapps/.* %{_appdir}/.* jpgraph_dir.php .*Smarty.class.php Services/JSON.php class.date_helper.php sphinxapi.php Net/LDAP2.php
96
97 # exclude optional php dependencies
98 %define         _noautophp      php-gnupg php-hash php-pecl-http php-tk
99
100 %define         _noautoreq      %{_noautophp}
101
102 %define         _libdir         %{_prefix}/lib/%{name}
103 %define         _appdir         %{_datadir}/%{name}
104 %define         _smartydir      %{php_data_dir}/Smarty
105 %define         _webapps        /etc/webapps
106 %define         _webapp         %{name}
107 %define         _webappdir      %{_webapps}/%{_webapp}
108 %define         _sysconfdir     /etc/%{name}
109
110 %description
111 Eventum is a user-friendly and flexible issue tracking system that can
112 be used by a support department to track incoming technical support
113 requests, or by a software development team to quickly organize tasks
114 and bugs. Eventum is used by the MySQL AB Technical Support team, and
115 has allowed us to dramatically improve our response times.
116
117 %description -l pl.UTF-8
118 Eventum to przyjazny dla użytkownika system śledzenia spraw, który
119 może być używany przez dział obsługi do śledzenia przychodzących żądań
120 obsługi technicznej albo przez zespół tworzący oprogramowanie do
121 szybkiej organizacji zadań i błędów. Eventum jest używany przez zespół
122 Technical Support MySQL AB i umożliwił im znacząco poprawić czasy
123 reakcji.
124
125 %package base
126 Summary:        Eventum base package
127 Summary(pl.UTF-8):      Podstawowy pakiet Eventum
128 Group:          Applications/WWW
129 Requires(postun):       /usr/sbin/groupdel
130 Requires(postun):       /usr/sbin/userdel
131 Requires(pre):  /bin/id
132 Requires(pre):  /usr/bin/getgid
133 Requires(pre):  /usr/sbin/groupadd
134 Requires(pre):  /usr/sbin/useradd
135 Provides:       group(eventum)
136 Provides:       user(eventum)
137
138 %description base
139 This package contains base directory structure for Eventum.
140
141 %description base -l pl.UTF-8
142 Ten pakiet zawiera podstawową strukturę katalogów dla Eventum.
143
144 %package setup
145 Summary:        Eventum setup package
146 Summary(pl.UTF-8):      Pakiet do wstępnej konfiguracji Eventum
147 Group:          Applications/WWW
148 Requires:       %{name} = %{version}-%{release}
149
150 %description setup
151 Install this package to configure initial Eventum installation. You
152 should uninstall this package when you're done, as it considered
153 insecure to keep the setup files in place.
154
155 %description setup -l pl.UTF-8
156 Ten pakiet należy zainstalować w celu wstępnej konfiguracji Eventum po
157 pierwszej instalacji. Potem należy go odinstalować, jako że
158 pozostawienie plików instalacyjnych mogłoby być niebezpieczne.
159
160 %package mail-queue
161 Summary:        Eventum mail queue process
162 Summary(pl.UTF-8):      Przetwarzanie kolejki poczty Eventum
163 Group:          Applications/WWW
164 Requires:       %{name} = %{version}-%{release}
165 Requires:       crondaemon
166
167 %description mail-queue
168 Beginning with the first release of Eventum, emails are not directly
169 sent out from the various scripts, but rather added to a mail queue
170 table that is processed by a cron job. If an email cannot be sent, it
171 will be marked as such in the mail queue log, and the cron job script
172 will re-try to send it again the next time it runs.
173
174 This package contains the cron job.
175
176 %description mail-queue -l pl.UTF-8
177 Od pierwszego wydania Eventum poczta nie jest wysyłana bezpośrednio z
178 różnych skryptów, lecz dodawana do kolejki przetwarzanej z crona.
179 Jeśli poczta nie może być wysłana, będzie odpowiednio oznaczona w logu
180 kolejki poczty, a skrypt z crona będzie próbował wysłać ją ponownie
181 następnym razem.
182
183 Ten pakiet zawiera zadanie dla crona.
184
185 %package mail-download
186 Summary:        Eventum email download
187 Summary(pl.UTF-8):      Ściąganie poczty Eventum
188 Group:          Applications/WWW
189 Requires:       %{name} = %{version}-%{release}
190 Requires:       crondaemon
191
192 %description mail-download
193 In order for Eventum's email integration feature to work, you need to
194 setup a cron job to run the script every so often.
195
196 This package contains the cron job.
197
198 %description mail-download -l pl.UTF-8
199 Aby integracja poczty elektronicznej w Eventum działała, trzeba
200 ustawić zadanie crona, aby uruchamiał odpowiedni skrypt wystarczająco
201 często.
202
203 Ten pakiet zawiera zadanie dla crona.
204
205 %package reminder
206 Summary:        Eventum Reminder System
207 Summary(pl.UTF-8):      System przypominania dla Eventum
208 Group:          Applications/WWW
209 Requires:       %{name} = %{version}-%{release}
210 Requires:       crondaemon
211
212 %description reminder
213 The reminder system was designed with the objective as serving as a
214 safe net for issues that need attention. Depending on what
215 configuration you create, you may have several reminders (or alerts)
216 be sent out whenever an issue needs attention, for whatever parameter
217 you may deem necessary.
218
219 This package contains the cron job.
220
221 %description reminder -l pl.UTF-8
222 System przypominania został zaprojektowany tak, aby służył jako
223 bezpieczna sieć dla spraw wymagających uwagi. W zależności od
224 konfiguracji można ustawić różne przypominajki (lub alarmy) wysyłane
225 przy każdej sprawie wymagającej uwagi lub przy parametrze, który można
226 uważać za potrzebny.
227
228 Ten pakiet zawiera zadanie dla crona.
229
230 %package monitor
231 Summary:        Eventum Heartbeat Monitor
232 Summary(pl.UTF-8):      Monitor życia dla Eventum
233 Group:          Applications/WWW
234 Requires:       %{name} = %{version}-%{release}
235 Requires:       crondaemon
236 Requires:       php(posix)
237
238 %description monitor
239 The heartbeat monitor is a feature designed for the administrator that
240 wants to be alerted whenever a common problem in Eventum is detected,
241 like the database server not being available anymore, or maybe when
242 the recommended permissions for certain configuration files are
243 changed.
244
245 Please note that before running the heartbeat monitor, you may need to
246 customize some of the checks to be appropriate for your own system,
247 particularly the permission and file checks on
248 Monitor::checkConfiguration().
249
250 This package contains the cron job.
251
252 %description monitor -l pl.UTF-8
253 Monitor życia to funkcjonalność zaprojektowana dla administratora
254 chcącego być alarmowanym przy każdym wykryciu popularnego problemu z
255 Eventum, jak nie działanie serwera bazy danych albo zmiana uprawnień
256 do plików konfiguracyjnych.
257
258 Należy zauważyć, że przed uruchomieniem tego monitora może być
259 konieczne dostosowanie niektórych testów do systemu, w szczególności
260 testów uprawnień i plików w Monitor::checkConfiguration().
261
262 Ten pakiet zawiera zadanie dla crona.
263
264 %package route-drafts
265 Summary:        Eventum Draft Routing
266 Summary(pl.UTF-8):      Przekazywanie szkiców dla Eventum
267 Group:          Applications/WWW
268 Requires:       %{name} = %{version}-%{release}
269 Requires:       eventum(router)
270
271 %description route-drafts
272 The draft routing feature is used to automatically associate a thread
273 of drafts into an Eventum issue. By setting up Postfix to deliver
274 emails sent to a specific address (usually draft-<number>@<domain>) to
275 the above script, users are able to send drafts written in their mail
276 client to be stored in Eventum. These drafts will NOT broadcasted to
277 the notification list.
278
279 %description route-drafts -l pl.UTF-8
280 Przekazywanie szkiców służy do automatycznego wiązania wątku szkiców z
281 problemem w Eventum. Ustawiając Postfiksa, aby dostarczał pocztę
282 wysłaną na podany adres (zwykle draft-<liczba>@<domena>) do tego
283 skryptu umożliwia się użytkownikom wysyłanie szkiców napisanych w ich
284 kliencie pocztowym do zapisania w Eventum. Szkice te NIE będą wysyłane
285 na listę powiadomień.
286
287 %package route-emails
288 Summary:        Eventum Email Routing
289 Summary(pl.UTF-8):      Przekazywanie poczty dla Eventum
290 Group:          Applications/WWW
291 Requires:       %{name} = %{version}-%{release}
292 Requires:       eventum(router)
293
294 %description route-emails
295 The email routing feature is used to automatically associate a thread
296 of emails into an Eventum issue. By setting up Postfix to deliver
297 emails sent to a specific address (usually issue-<number>@<domain>) to
298 the above script, users are able to use their email clients to reply
299 to emails coming from Eventum, and those replies will be automatically
300 associated with the issue and broadcasted to the entire notification
301 list.
302
303 %description route-emails -l pl.UTF-8
304 Funkcjonalność przekazywania poczty służy do automatycznego wiązania
305 wątku listów ze sprawą w Eventum. Po ustawieniu czy nawet Postfiksa,
306 aby dostarczał listy wysyłane na pewien adres (zwykle
307 issue-<numer>@<domena>) na powyższy skrypt, użytkownicy będą mogli
308 używać klientów pocztowych do odpowiadania na listy przychodzące z
309 Eventum, a odpowiedzi te będą automatycznie wiązane ze sprawą i
310 rozprowadzane do całej listy ogłoszeniowej.
311
312 %package route-notes
313 Summary:        Eventum Note Routing
314 Summary(pl.UTF-8):      Przekazywanie notatek dla Eventum
315 Group:          Applications/WWW
316 Requires:       %{name} = %{version}-%{release}
317 Requires:       eventum(router)
318
319 %description route-notes
320 The note routing feature is used to automatically associate a thread
321 of notes into an Eventum issue. By setting up Postfix to deliver
322 emails sent to a specific address (usually note-<number>@<domain>) to
323 the above script, users are able to use their email clients to reply
324 to internal notes coming from Eventum, and those replies will be
325 automatically associated with the issue and broadcasted to the
326 notification list staff members.
327
328 %description route-notes -l pl.UTF-8
329 Funkcjonalność przekazywania notatek służy do automatycznego wiązania
330 wątku notatek ze sprawą w Eventum. Po ustawieniu Postfiksa, aby
331 dostarczał listy wysyłane na pewien adres (zwykle
332 note-<numer>@<domena>) na powyższy skrypt, użytkownicy będą mogli
333 używać klientów pocztowych do odpowiadania na wewnętrzne notatki
334 pochodzące od Eventu, a odpowiedzi te będą automatycznie wiązane ze
335 sprawą i rozprowadzane do członków personelu listy ogłoszeniowej.
336
337 %package router-postfix
338 Summary:        Eventum Mail Routing - Postfix
339 Summary(pl.UTF-8):      Przekazywanie poczty Eventum - Postfix
340 Group:          Applications/Mail
341 Requires:       %{name} = %{version}-%{release}
342 Requires:       postfix
343 Provides:       eventum(router)
344 Obsoletes:      eventum(router)
345
346 %description router-postfix
347 This package provides way of routing notes and emails back to Eventum
348 via Postfix.
349
350 The Postfix configuration instructions you can find from
351 <http://eventum.mysql.org/wiki/index.php/Setting_up_email_routing_with_postfix>.
352
353 %description router-postfix -l pl.UTF-8
354 Ten pakiet udostępnia metodę przekazywania notatek i listów do Eventum
355 przez Postfiksa.
356
357 Opis konfiguracji Postfiksa można znaleźć pod adresem
358 <http://eventum.mysql.org/wiki/index.php/Setting_up_email_routing_with_postfix>.
359
360 %package irc
361 Summary:        Eventum IRC Notification Bot
362 Summary(pl.UTF-8):      IRC-owy bot powiadamiający dla Eventum
363 Group:          Applications/WWW
364 Requires(post,preun):   /sbin/chkconfig
365 Requires:       %{name} = %{version}-%{release}
366 Requires:       php(sockets)
367 Requires:       php-pear-Net_SmartIRC
368 Requires:       rc-scripts >= 0.4.0.18
369
370 %description irc
371 The IRC notification bot is a nice feature for remote teams that want
372 to handle issues and want to have a quick and easy way to get simple
373 notifications. Right now the bot notifies of the following actions:
374 - New Issues
375 - Blocked emails
376 - Issues that got their assignment list changed
377
378 NOTE: You will need to manually edit the bot.php script to set your
379 appropriate preferences, like IRC server and channel that the bot
380 should join.
381
382 %description irc -l pl.UTF-8
383 IRC-owy bot powiadamiający to miła funkcjonalność dla zdalnych
384 zespołów chcących obsługiwać sprawy i mieć szybki i łatwy sposób na
385 uzyskiwanie prostych powiadomień. Aktualnie bot powiadamia o
386 następujących zdarzeniach:
387 - nowych sprawach
388 - zablokowanych listach
389 - sprawach, dla których zmieniła się lista powiązań
390
391 UWAGA: w celu wprowadzenia własnych ustawień, takich jak serwer IRC i
392 kanał używany przez bota, trzeba ręcznie zmodyfikować skrypt bot.php .
393
394 %package cli
395 Summary:        Eventum command-line interface
396 Summary(pl.UTF-8):      Interfejs linii poleceń dla Eventum
397 Group:          Applications/WWW
398 Requires:       %{name}-base = %{version}-%{release}
399 Requires:       php(core) >= %{php_min_version}
400 Requires:       php-cli
401 Requires:       php-pear-XML_RPC
402
403 %description cli
404 The Eventum command-line interface allows you to access most of the
405 features of the web interface straight from your command shell.
406
407 %description cli -l pl.UTF-8
408 Interfejs linii poleceń Eventum pozwala na dostęp do większości
409 funkcji interfejsu WWW prosto z linii poleceń powłoki.
410
411 %package scm
412 Summary:        Eventum SCM integration
413 Summary(pl.UTF-8):      Integracja SCM dla Eventum
414 Group:          Applications/WWW
415 Requires:       %{name}-base = %{version}-%{release}
416 Requires:       php(core) >= %{php_min_version}
417 Requires:       php(pcre)
418 Requires:       php-cli
419
420 %description scm
421 This feature allows your software development teams to integrate your
422 Source Control Management system with your Issue Tracking System.
423
424 The integration is implemented in such a way that it will be forward
425 compatible with pretty much any SCM system, such as CVS.
426
427 For installation see
428 </eventum/help.php?topic=scm_integration_installation>.
429
430 %description scm -l pl.UTF-8
431 Ten pakiet pozwala zespołom programistów na integrację systemu
432 zarządzania źródłami (SCM - Source Control Management) z systemem
433 śledzenia spraw.
434
435 Integracja jest zaimplementowana tak, aby być kompatybilna w przód z
436 prawie każdym systemem SCM, jak np. CVS.
437
438 Szczegóły na temat instalacji można przeczytać pod
439 </eventum/help.php?topic=scm_integration_installation>.
440
441 %package sphinx
442 Summary:        Eventum Sphinx Search
443 Group:          Applications/WWW
444 Requires:       %{name} = %{version}-%{release}
445 Requires:       crondaemon
446 Requires:       sphinx
447
448 %description sphinx
449 Sphinx search integration for Eventum.
450
451 This package contains the cron job.
452
453 %prep
454 %setup -q
455
456 # GPL v2
457 rm docs/COPYING
458
459 rm -r upgrade/*v1.[123]* # too old to support in PLD Linux
460 rm -r upgrade/v{1.,2.0,2.1_}* # no longer supported in PLD Linux
461 rm upgrade/flush_compiled_templates.php
462 rm -r upgrade/{*/,}index.html # not needed in PLD Linux
463
464 # bug fixes / features
465 %patch0 -p1
466 %{?with_order:%patch2 -p1}
467 %patch3 -p0
468 %patch4 -p1
469
470 cp -p %{SOURCE16} htdocs/images
471
472 #%patch200 -p1
473
474 # produce default sphinx config
475 # must be run before paths.patch
476 cat <<'EOF' > config/config.php
477 <?php
478 define('APP_SQL_DBTYPE', 'mysql');
479 define('APP_SQL_DBHOST', 'localhost:/var/lib/mysql/mysql.sock');
480 define('APP_SQL_DBPORT', 3306);
481 define('APP_SQL_DBNAME', 'eventum');
482 define('APP_SQL_DBUSER', 'mysql');
483 define('APP_SQL_DBPASS', '');
484 define('APP_TABLE_PREFIX', 'eventum_');
485 EOF
486 php config/sphinx.conf.php > config/sphinx.conf
487 rm -f config/config.php
488
489 # packaging
490 %patch100 -p1
491 %patch101 -p1
492 %patch105 -p1
493 %patch107 -p1
494
495 %{__sed} -i -e "
496 s;define('CONFIG_PATH'.*');define('CONFIG_PATH', '%{_webappdir}');
497 " upgrade/{*/,}*.php
498
499 # remove backups from patching as we use globs to package files to buildroot
500 find '(' -name '*~' -o -name '*.orig' ')' | xargs -r rm -v
501
502 %build
503 %{__make} -C localization
504
505 %install
506 rm -rf $RPM_BUILD_ROOT
507 install -d \
508         $RPM_BUILD_ROOT{%{_webappdir},%{_sysconfdir},%{_bindir},%{_sbindir},%{_libdir}} \
509         $RPM_BUILD_ROOT/etc/{rc.d/init.d,cron.d,logrotate.d,sysconfig} \
510         $RPM_BUILD_ROOT/var/{run,cache,lib}/%{name} \
511         $RPM_BUILD_ROOT/var/log/{archive/,}%{name} \
512         $RPM_BUILD_ROOT/var/lib/%{name}/routed_{emails,drafts,notes} \
513         $RPM_BUILD_ROOT%{_appdir}/{include,htdocs/misc,upgrade} \
514         $RPM_BUILD_ROOT%{systemdtmpfilesdir}
515
516 %{__make} install-eventum install-cli install-irc install-scm install-jpgraph install-localization \
517         sysconfdir=%{_webappdir} \
518         DESTDIR=$RPM_BUILD_ROOT
519
520 %{?with_order:cp -a htdocs/ajax $RPM_BUILD_ROOT%{_appdir}/htdocs}
521
522 touch $RPM_BUILD_ROOT%{_webappdir}/htpasswd
523 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_webappdir}/apache.conf
524 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_webappdir}/httpd.conf
525 cp -p %{SOURCE15} $RPM_BUILD_ROOT%{_webappdir}/lighttpd.conf
526
527 install -d $RPM_BUILD_ROOT/etc/sphinx
528 cp -p config/sphinx.conf $RPM_BUILD_ROOT/etc/sphinx/%{name}.conf
529 cp -p config/sphinx.conf.php $RPM_BUILD_ROOT%{_webappdir}
530
531 cp -p %{SOURCE2} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-queue
532 cp -p %{SOURCE3} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-download
533 cp -p %{SOURCE4} $RPM_BUILD_ROOT/etc/cron.d/%{name}-reminder
534 cp -p %{SOURCE5} $RPM_BUILD_ROOT/etc/cron.d/%{name}-monitor
535 cp -p %{SOURCE10} $RPM_BUILD_ROOT/etc/cron.d/%{name}-sphinx
536
537 cp -p %{SOURCE7} $RPM_BUILD_ROOT%{_webappdir}/irc_config.php
538
539 install -p %{SOURCE8} $RPM_BUILD_ROOT/etc/rc.d/init.d/eventum-irc
540 cp -p %{SOURCE9} $RPM_BUILD_ROOT/etc/sysconfig/eventum-irc
541
542 cp -p %{SOURCE14} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
543
544 # postfix router
545 install -p %{SOURCE13} $RPM_BUILD_ROOT%{_libdir}/router-postfix
546
547 cp -p %{SOURCE17} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/%{name}.conf
548
549 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/ht
550
551 %find_lang %{name}
552
553 # scm
554 install -p %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}/scm.php
555
556 # old compat
557 ln -s %{_sbindir}/eventum-cvs-hook $RPM_BUILD_ROOT%{_libdir}/process_cvs_commits
558 ln -s %{_sbindir}/eventum-svn-hook $RPM_BUILD_ROOT%{_libdir}/process_svn_commits
559
560 # skip pear for cli
561 rm -rf $RPM_BUILD_ROOT%{_datadir}/%{name}/cli
562 cp -a cli/lib/eventum $RPM_BUILD_ROOT%{_datadir}/%{name}/cli
563
564 %clean
565 rm -rf $RPM_BUILD_ROOT
566
567 %pre
568 %addusertogroup http %{name}
569
570 %post
571 # greate empty ghost files
572 for a in cli.log errors.log irc_bot.log login_attempts.log; do
573         if [ ! -f /var/log/%{name}/$a ]; then
574                 install -m 0620 -o root -g eventum /dev/null /var/log/%{name}/$a
575         fi
576 done
577
578 # run database update if configured
579 test -s %{_webappdir}/config.php && \
580 %{_appdir}/upgrade/update-database.php || :
581
582 # nuke Smarty templates cache after upgrade
583 rm -f /var/cache/eventum/*.php
584
585 # Restart webserver on upgrade to get .mo translations reloaded.
586 # actually php engines "php-fcgi" and "php-fpm" needed only, apache is restarted anyway via webapp trigger.
587 %php_webserver_restart
588
589 %preun
590 if [ "$1" = "0" ]; then
591         # nuke cache
592         rm -f /var/cache/eventum/*.php 2>/dev/null || :
593 fi
594
595 %pre base
596 %groupadd -P %{name}-base -g 146 %{name}
597 %useradd -P %{name}-base -u 146 -d /var/lib/%{name} -g %{name} -c "Eventum User" %{name}
598
599 %postun base
600 if [ "$1" = "0" ]; then
601         %userremove %{name}
602         %groupremove %{name}
603 fi
604
605 %post setup
606 chmod 660 %{_webappdir}/{config,private_key}.php
607 chown root:http %{_webappdir}/{config,private_key}.php
608
609 %postun setup
610 if [ "$1" = "0" ] && [ -f %{_webappdir}/config.php ]; then
611         chmod 640 %{_webappdir}/{config,private_key}.php
612         chown root:http %{_webappdir}/{config,private_key}.php
613 fi
614
615 %post irc
616 /sbin/chkconfig --add eventum-irc
617 %service eventum-irc restart "Eventum IRC Bot"
618
619 %preun irc
620 if [ "$1" = 0 ]; then
621         %service eventum-irc stop
622         /sbin/chkconfig --del eventum-irc
623 fi
624
625 %triggerin -- apache1 < 1.3.37-3, apache1-base
626 %webapp_register apache %{_webapp}
627
628 %triggerun -- apache1 < 1.3.37-3, apache1-base
629 %webapp_unregister apache %{_webapp}
630
631 %triggerin -- apache < 2.2.0, apache-base
632 %webapp_register httpd %{_webapp}
633
634 %triggerun -- apache < 2.2.0, apache-base
635 %webapp_unregister httpd %{_webapp}
636
637 %triggerin -- lighttpd
638 %webapp_register lighttpd %{_webapp}
639
640 %triggerun -- lighttpd
641 %webapp_unregister lighttpd %{_webapp}
642
643 %triggerpostun -- %{name} < 2.2-2.57
644 # switching eventum->http user
645 chgrp http %{_webappdir}/config.php
646 chgrp http %{_webappdir}/private_key.php
647 chgrp http %{_webappdir}/setup.php
648 chgrp http /var/log/%{name}/*
649 # update crontab user
650 for a in /etc/cron.d/eventum-*; do
651         [ -f "$a" ] || continue
652         awk '!/#/ && NR > 6 && $6 =="eventum" {sub("eventum", "http", $6)}{print}'  $a > $a.rpmtmp && cat $a.rpmtmp > $a
653         rm -f $a.rpmtmp
654
655         # crontabs moved to crons subdir
656         %{__sed} -i -e '
657                 s,/usr/share/eventum/process_mail_queue.php,/usr/share/eventum/crons/process_mail_queue.php,
658                 s,/usr/share/eventum/download_emails.php,/usr/share/eventum/crons/download_emails.php,
659                 s,/usr/share/eventum/check_reminders.php,/usr/share/eventum/crons/check_reminders.php,
660                 s,/usr/share/eventum/monitor.php,/usr/share/eventum/crons/monitor.php,
661         ' $a
662 done
663
664 %files -f %{name}.lang
665 %defattr(644,root,root,755)
666 %doc docs/* htdocs/setup/schema.sql
667 %attr(751,root,root) %dir %{_webappdir}
668 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/apache.conf
669 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/httpd.conf
670 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/lighttpd.conf
671 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/config.php
672 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/private_key.php
673 %attr(660,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/setup.php
674 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/htpasswd
675
676 %dir %attr(731,root,http) /var/log/%{name}
677 %attr(620,root,http) %ghost /var/log/%{name}/*
678 %dir %attr(750,root,root) /var/log/archive/%{name}
679 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/%{name}
680
681 %dir %{_appdir}/crons
682 %{_appdir}/init.php
683 %dir %{_appdir}/htdocs
684 %{_appdir}/htdocs/*.php
685 %{_appdir}/htdocs/*.ico
686 %{_appdir}/htdocs/css
687 %{_appdir}/htdocs/customer
688 %{_appdir}/htdocs/images
689 %{_appdir}/htdocs/js
690 %{_appdir}/htdocs/manage
691 %{_appdir}/htdocs/reports
692 %{_appdir}/htdocs/rpc
693 %{_appdir}/htdocs/misc
694 %if %{with order}
695 %{_appdir}/htdocs/ajax
696 %endif
697 %{_appdir}/templates
698
699 %dir %{_appdir}/upgrade
700 %{_appdir}/upgrade/init.php
701 %attr(755,root,root) %{_appdir}/upgrade/update-database.php
702 %attr(755,root,root) %{_appdir}/upgrade/ldap_import.php
703 %dir %{_appdir}/upgrade/v*
704 %attr(755,root,root) %{_appdir}/upgrade/v*/*.php
705 %{_appdir}/upgrade/patches
706
707 %dir %{_appdir}/lib
708 %{_appdir}/lib/eventum
709 %{_appdir}/lib/jpgraph
710 %exclude %{_appdir}/lib/eventum/class.monitor.php
711 %{systemdtmpfilesdir}/%{name}.conf
712 %dir %attr(730,root,http) /var/run/%{name}
713 %dir %attr(730,root,http) /var/cache/%{name}
714
715 %files base
716 %defattr(644,root,root,755)
717 %attr(751,root,root) %dir %{_sysconfdir}
718 %dir %{_libdir}
719 %dir %{_appdir}
720 %dir /var/lib/%{name}
721 # saved mail copies
722 %attr(770,root,http) %dir /var/lib/%{name}/routed_emails
723 %attr(770,root,http) %dir /var/lib/%{name}/routed_drafts
724 %attr(770,root,http) %dir /var/lib/%{name}/routed_notes
725
726 %files setup
727 %defattr(644,root,root,755)
728 %{_appdir}/htdocs/setup
729
730 %files mail-queue
731 %defattr(644,root,root,755)
732 %attr(755,root,root) %{_appdir}/crons/process_mail_queue.php
733 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-queue
734
735 %files mail-download
736 %defattr(644,root,root,755)
737 %attr(755,root,root) %{_appdir}/crons/download_emails.php
738 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-download
739
740 %files reminder
741 %defattr(644,root,root,755)
742 %attr(755,root,root) %{_appdir}/crons/check_reminders.php
743 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-reminder
744
745 %files monitor
746 %defattr(644,root,root,755)
747 %{_appdir}/lib/eventum/class.monitor.php
748 %attr(755,root,root) %{_appdir}/crons/monitor.php
749 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-monitor
750
751 %files route-drafts
752 %defattr(644,root,root,755)
753 %attr(755,root,root) %{_appdir}/route_drafts.php
754
755 %files route-emails
756 %defattr(644,root,root,755)
757 %attr(755,root,root) %{_appdir}/route_emails.php
758
759 %files route-notes
760 %defattr(644,root,root,755)
761 %attr(755,root,root) %{_appdir}/route_notes.php
762
763 %files router-postfix
764 %defattr(644,root,root,755)
765 %attr(755,root,root) %{_libdir}/router-postfix
766
767 %files irc
768 %defattr(644,root,root,755)
769 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/irc_config.php
770 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/eventum-irc
771 %attr(755,root,root) %{_sbindir}/%{name}-irc-bot
772 %attr(754,root,root) /etc/rc.d/init.d/%{name}-irc
773
774 %files cli
775 %defattr(644,root,root,755)
776 %doc cli/eventumrc
777 %attr(755,root,root) %{_bindir}/%{name}
778 %{_appdir}/cli
779
780 %files scm
781 %defattr(644,root,root,755)
782 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/scm.php
783 %attr(755,root,root) %{_libdir}/process_cvs_commits
784 %attr(755,root,root) %{_libdir}/process_svn_commits
785 %attr(755,root,root) %{_sbindir}/eventum-cvs-hook
786 %attr(755,root,root) %{_sbindir}/eventum-svn-hook
787
788 %files sphinx
789 %defattr(644,root,root,755)
790 %{_webappdir}/sphinx.conf.php
791 %attr(750,root,http) %config(noreplace) %verify(not md5 mtime size) /etc/sphinx/%{name}.conf
792 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-sphinx
This page took 0.099978 seconds and 3 git commands to generate.