]> git.pld-linux.org Git - packages/eventum.git/blob - eventum.spec
zf2/sf2 deps
[packages/eventum.git] / eventum.spec
1 #
2 # Conditional build:
3 %bcond_with     order   # with experimental order patch
4
5 %define         rel             1.3
6 %define         subver  60
7 %define         githash 788184f
8 %define         php_min_version 5.3.7
9 %include        /usr/lib/rpm/macros.php
10 Summary:        Eventum Issue / Bug tracking system
11 Summary(pl.UTF-8):      Eventum - system śledzenia spraw/błędów
12 Name:           eventum
13 Version:        3.0.10
14 Release:        %{?subver:1.%{subver}.%{?githash:g%{githash}.}}%{rel}
15 License:        GPL v2+
16 Group:          Applications/WWW
17 #Source0:       https://github.com/eventum/eventum/releases/download/v%{version}/%{name}-%{version}.tar.gz
18 Source0:        %{name}-%{version}-%{subver}-g%{githash}.tar.gz
19 # Source0-md5:  23a1fc1e680a859fb872fbe6e521a5ab
20 Source1:        %{name}-apache.conf
21 Source2:        %{name}-mail-queue.cron
22 Source3:        %{name}-mail-download.cron
23 Source4:        %{name}-reminder.cron
24 Source5:        %{name}-monitor.cron
25 Source6:        %{name}-cvs.php
26 Source8:        %{name}-irc.init
27 Source9:        %{name}-irc.sysconfig
28 Source10:       sphinx.crontab
29 Source13:       %{name}-router-postfix.sh
30 Source14:       %{name}.logrotate
31 Source15:       %{name}-lighttpd.conf
32 Source16:       http://www.isocra.com/images/updown2.gif
33 # Source16-md5: deb6eeb2552ba757d3a949ed10c4107d
34 Source17:       %{name}.tmpfiles
35 Patch2:         %{name}-order.patch
36 #Patch3:                group-users.patch
37 #Patch4:                https://github.com/glensc/eventum/compare/cf_escape.patch
38 # packaging patches that probably never go upstream
39 Patch100:       %{name}-paths.patch
40 Patch101:       %{name}-cvs-config.patch
41 Patch107:       %{name}-gettext.patch
42 Patch108:       autoload.patch
43 # some tests
44 Patch200:       %{name}-fixed-nav.patch
45 URL:            http://eventum.mysql.org/
46 BuildRequires:  /usr/bin/php
47 BuildRequires:  gettext-tools
48 BuildRequires:  php(core) >= %{php_min_version}
49 BuildRequires:  rpm-php-pearprov >= 4.0.2-98
50 BuildRequires:  rpmbuild(macros) >= 1.654
51 BuildRequires:  sed >= 4.0
52 Requires(postun):       /usr/sbin/groupdel
53 Requires(postun):       /usr/sbin/userdel
54 Requires(pre):  /bin/id
55 Requires(pre):  /usr/bin/getgid
56 Requires(pre):  /usr/sbin/groupadd
57 Requires(pre):  /usr/sbin/useradd
58 Requires:       fonts-TTF-RedHat-liberation
59 Requires:       php(core) >= %{php_min_version}
60 Requires:       php(filter)
61 Requires:       php(iconv)
62 Requires:       php(imap)
63 Requires:       php(json)
64 Requires:       php(mbstring)
65 Requires:       php(mysqli)
66 Requires:       php(pcre)
67 Requires:       php(session)
68 Requires:       php-Smarty >= 3.1
69 Requires:       php-Smarty-plugin-gettext
70 Requires:       php-ZendFramework-Config >= 2.4
71 Requires:       php-ZendFramework-Loader >= 2.4
72 Requires:       php-ZendFramework-Mail >= 2.4.9-2
73 Requires:       php-ZendFramework-Mime >= 2.4
74 Requires:       php-ZendFramework-Validator >= 2.4
75 Requires:       php-monolog >= 1.17.2
76 Requires:       php-pear-DB
77 Requires:       php-pear-Mail
78 Requires:       php-pear-Mail_Mime
79 Requires:       php-pear-Mail_mimeDecode
80 Requires:       php-pear-Math_Stats
81 Requires:       php-pear-Net_SMTP
82 Requires:       php-pear-Net_Socket
83 Requires:       php-pear-Net_URL
84 Requires:       php-pear-PEAR-core
85 Requires:       php-pear-Text_Diff
86 Requires:       php-pear-XML_RPC
87 Requires:       php-psr-Log >= 1.0.0-2
88 Requires:       php-symfony2-Config >= 2.7.7
89 Requires:       php-symfony2-Filesystem >= 2.7.7
90 Requires:       php-symfony2-HttpFoundation >= 2.7.7
91 Requires:       php-symfony2-OptionsResolver >= 2.7.7
92 Requires:       php-symfony2-Serializer >= 2.7.7
93 Requires:       php-symfony2-Yaml >= 2.7.7
94 Requires:       phplot >= 5.8.0
95 Requires:       webapps
96 Requires:       webserver(access)
97 Requires:       webserver(alias)
98 Requires:       webserver(indexfile)
99 Requires:       webserver(php) >= 4.2.0
100 Suggests:       localedb
101 Suggests:       php(mcrypt)
102 Suggests:       php(openssl)
103 Suggests:       php-pear-Net_LDAP2
104 Suggests:       php-pear-Net_POP3
105 Suggests:       webserver(setenv)
106 Provides:       group(eventum)
107 Provides:       user(eventum)
108 Obsoletes:      eventum-base < 3.0.3-1.305
109 Obsoletes:      eventum-route-drafts < 3.0.8-1.1
110 Obsoletes:      eventum-route-emails < 3.0.8-1.1
111 Obsoletes:      eventum-route-notes < 3.0.8-1.1
112 Conflicts:      logrotate < 3.8.0
113 BuildArch:      noarch
114 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
115
116 %define         _noautoreq_pear ../init.php ../../init.php init.php /usr/share/eventum/init.php /etc/webapps/.* %{_appdir}/.* .*Smarty.class.php Services/JSON.php class.date_helper.php sphinxapi.php Net/LDAP2.* Auth/SASL.* Util.php smarty_internal.*
117
118 # exclude optional php dependencies
119 %define         _noautophp      php-gnupg php-hash php-pecl-http php-tk
120
121 %define         _noautoreq      %{_noautophp}
122
123 %define         _libdir         %{_prefix}/lib/%{name}
124 %define         _appdir         %{_datadir}/%{name}
125 %define         _smartydir      %{php_data_dir}/Smarty
126 %define         _webapps        /etc/webapps
127 %define         _webapp         %{name}
128 %define         _webappdir      %{_webapps}/%{_webapp}
129 %define         _sysconfdir     /etc/%{name}
130
131 %description
132 Eventum is a user-friendly and flexible issue tracking system that can
133 be used by a support department to track incoming technical support
134 requests, or by a software development team to quickly organize tasks
135 and bugs. Eventum is used by the MySQL AB Technical Support team, and
136 has allowed us to dramatically improve our response times.
137
138 %description -l pl.UTF-8
139 Eventum to przyjazny dla użytkownika system śledzenia spraw, który
140 może być używany przez dział obsługi do śledzenia przychodzących żądań
141 obsługi technicznej albo przez zespół tworzący oprogramowanie do
142 szybkiej organizacji zadań i błędów. Eventum jest używany przez zespół
143 Technical Support MySQL AB i umożliwił im znacząco poprawić czasy
144 reakcji.
145
146 %package setup
147 Summary:        Eventum setup package
148 Summary(pl.UTF-8):      Pakiet do wstępnej konfiguracji Eventum
149 Group:          Applications/WWW
150 Requires:       %{name} = %{version}-%{release}
151
152 %description setup
153 Install this package to configure initial Eventum installation. You
154 should uninstall this package when you're done, as it considered
155 insecure to keep the setup files in place.
156
157 %description setup -l pl.UTF-8
158 Ten pakiet należy zainstalować w celu wstępnej konfiguracji Eventum po
159 pierwszej instalacji. Potem należy go odinstalować, jako że
160 pozostawienie plików instalacyjnych mogłoby być niebezpieczne.
161
162 %package doc
163 Summary:        Eventum documentation and Wiki
164 Group:          Documentation
165
166 %description doc
167 Eventum documentation and copy of Wiki.
168
169 %package mail-queue
170 Summary:        Eventum mail queue process
171 Summary(pl.UTF-8):      Przetwarzanie kolejki poczty Eventum
172 Group:          Applications/WWW
173 Requires:       %{name} = %{version}-%{release}
174 Requires:       crondaemon
175
176 %description mail-queue
177 Beginning with the first release of Eventum, emails are not directly
178 sent out from the various scripts, but rather added to a mail queue
179 table that is processed by a cron job. If an email cannot be sent, it
180 will be marked as such in the mail queue log, and the cron job script
181 will re-try to send it again the next time it runs.
182
183 This package contains the cron job.
184
185 %description mail-queue -l pl.UTF-8
186 Od pierwszego wydania Eventum poczta nie jest wysyłana bezpośrednio z
187 różnych skryptów, lecz dodawana do kolejki przetwarzanej z crona.
188 Jeśli poczta nie może być wysłana, będzie odpowiednio oznaczona w logu
189 kolejki poczty, a skrypt z crona będzie próbował wysłać ją ponownie
190 następnym razem.
191
192 Ten pakiet zawiera zadanie dla crona.
193
194 %package mail-download
195 Summary:        Eventum email download
196 Summary(pl.UTF-8):      Ściąganie poczty Eventum
197 Group:          Applications/WWW
198 Requires:       %{name} = %{version}-%{release}
199 Requires:       crondaemon
200
201 %description mail-download
202 In order for Eventum's email integration feature to work, you need to
203 setup a cron job to run the script every so often.
204
205 This package contains the cron job.
206
207 %description mail-download -l pl.UTF-8
208 Aby integracja poczty elektronicznej w Eventum działała, trzeba
209 ustawić zadanie crona, aby uruchamiał odpowiedni skrypt wystarczająco
210 często.
211
212 Ten pakiet zawiera zadanie dla crona.
213
214 %package reminder
215 Summary:        Eventum Reminder System
216 Summary(pl.UTF-8):      System przypominania dla Eventum
217 Group:          Applications/WWW
218 Requires:       %{name} = %{version}-%{release}
219 Requires:       crondaemon
220
221 %description reminder
222 The reminder system was designed with the objective as serving as a
223 safe net for issues that need attention. Depending on what
224 configuration you create, you may have several reminders (or alerts)
225 be sent out whenever an issue needs attention, for whatever parameter
226 you may deem necessary.
227
228 This package contains the cron job.
229
230 %description reminder -l pl.UTF-8
231 System przypominania został zaprojektowany tak, aby służył jako
232 bezpieczna sieć dla spraw wymagających uwagi. W zależności od
233 konfiguracji można ustawić różne przypominajki (lub alarmy) wysyłane
234 przy każdej sprawie wymagającej uwagi lub przy parametrze, który można
235 uważać za potrzebny.
236
237 Ten pakiet zawiera zadanie dla crona.
238
239 %package monitor
240 Summary:        Eventum Heartbeat Monitor
241 Summary(pl.UTF-8):      Monitor życia dla Eventum
242 Group:          Applications/WWW
243 Requires:       %{name} = %{version}-%{release}
244 Requires:       crondaemon
245 Requires:       php(posix)
246
247 %description monitor
248 The heartbeat monitor is a feature designed for the administrator that
249 wants to be alerted whenever a common problem in Eventum is detected,
250 like the database server not being available anymore, or maybe when
251 the recommended permissions for certain configuration files are
252 changed.
253
254 Please note that before running the heartbeat monitor, you may need to
255 customize some of the checks to be appropriate for your own system,
256 particularly the permission and file checks on
257 Monitor::checkConfiguration().
258
259 This package contains the cron job.
260
261 %description monitor -l pl.UTF-8
262 Monitor życia to funkcjonalność zaprojektowana dla administratora
263 chcącego być alarmowanym przy każdym wykryciu popularnego problemu z
264 Eventum, jak nie działanie serwera bazy danych albo zmiana uprawnień
265 do plików konfiguracyjnych.
266
267 Należy zauważyć, że przed uruchomieniem tego monitora może być
268 konieczne dostosowanie niektórych testów do systemu, w szczególności
269 testów uprawnień i plików w Monitor::checkConfiguration().
270
271 Ten pakiet zawiera zadanie dla crona.
272
273 %package router-postfix
274 Summary:        Eventum Mail Routing - Postfix
275 Summary(pl.UTF-8):      Przekazywanie poczty Eventum - Postfix
276 Group:          Applications/Mail
277 Requires:       %{name} = %{version}-%{release}
278 Requires:       postfix
279 Provides:       eventum(router)
280 Obsoletes:      eventum(router)
281
282 %description router-postfix
283 This package provides way of routing notes and emails back to Eventum
284 via Postfix.
285
286 The Postfix configuration instructions you can find from
287 <http://eventum.mysql.org/wiki/index.php/Setting_up_email_routing_with_postfix>.
288
289 %description router-postfix -l pl.UTF-8
290 Ten pakiet udostępnia metodę przekazywania notatek i listów do Eventum
291 przez Postfiksa.
292
293 Opis konfiguracji Postfiksa można znaleźć pod adresem
294 <http://eventum.mysql.org/wiki/index.php/Setting_up_email_routing_with_postfix>.
295
296 %package irc
297 Summary:        Eventum IRC Notification Bot
298 Summary(pl.UTF-8):      IRC-owy bot powiadamiający dla Eventum
299 Group:          Applications/WWW
300 Requires(post,preun):   /sbin/chkconfig
301 Requires:       %{name} = %{version}-%{release}
302 Requires:       php(pcntl)
303 Requires:       php(sockets)
304 Requires:       php-pear-Net_SmartIRC >= 1.1.9
305 Requires:       rc-scripts >= 0.4.0.18
306
307 %description irc
308 The IRC notification bot is a nice feature for remote teams that want
309 to handle issues and want to have a quick and easy way to get simple
310 notifications. Right now the bot notifies of the following actions:
311 - New Issues
312 - Blocked emails
313 - Issues that got their assignment list changed
314
315 NOTE: You will need to manually edit the bot.php script to set your
316 appropriate preferences, like IRC server and channel that the bot
317 should join.
318
319 %description irc -l pl.UTF-8
320 IRC-owy bot powiadamiający to miła funkcjonalność dla zdalnych
321 zespołów chcących obsługiwać sprawy i mieć szybki i łatwy sposób na
322 uzyskiwanie prostych powiadomień. Aktualnie bot powiadamia o
323 następujących zdarzeniach:
324 - nowych sprawach
325 - zablokowanych listach
326 - sprawach, dla których zmieniła się lista powiązań
327
328 UWAGA: w celu wprowadzenia własnych ustawień, takich jak serwer IRC i
329 kanał używany przez bota, trzeba ręcznie zmodyfikować skrypt bot.php .
330
331 %package cli
332 Summary:        Eventum command-line interface
333 Summary(pl.UTF-8):      Interfejs linii poleceń dla Eventum
334 Group:          Applications/WWW
335 Requires:       php(core) >= %{php_min_version}
336 Requires:       php(phar)
337 Requires:       php-pear-XML_RPC
338
339 %description cli
340 The Eventum command-line interface allows you to access most of the
341 features of the web interface straight from your command shell.
342
343 %description cli -l pl.UTF-8
344 Interfejs linii poleceń Eventum pozwala na dostęp do większości
345 funkcji interfejsu WWW prosto z linii poleceń powłoki.
346
347 %package scm
348 Summary:        Eventum SCM integration
349 Summary(pl.UTF-8):      Integracja SCM dla Eventum
350 Group:          Applications/WWW
351 Requires:       php(core) >= %{php_min_version}
352 Requires:       php(json)
353 Requires:       php(pcre)
354 Requires:       php(spl)
355 Suggests:       cvs
356 Suggests:       git-core
357 Suggests:       php(openssl)
358 Suggests:       subversion
359
360 %description scm
361 This feature allows your software development teams to integrate your
362 Source Control Management system with your Issue Tracking System.
363
364 The integration is implemented in such a way that it will be forward
365 compatible with pretty much any SCM system, such as CVS.
366
367 For installation see
368 </eventum/help.php?topic=scm_integration_installation>.
369
370 %description scm -l pl.UTF-8
371 Ten pakiet pozwala zespołom programistów na integrację systemu
372 zarządzania źródłami (SCM - Source Control Management) z systemem
373 śledzenia spraw.
374
375 Integracja jest zaimplementowana tak, aby być kompatybilna w przód z
376 prawie każdym systemem SCM, jak np. CVS.
377
378 Szczegóły na temat instalacji można przeczytać pod
379 </eventum/help.php?topic=scm_integration_installation>.
380
381 %package sphinx
382 Summary:        Eventum Sphinx Search
383 Group:          Applications/WWW
384 Requires:       %{name} = %{version}-%{release}
385 Requires:       crondaemon
386 Requires:       sphinx
387
388 %description sphinx
389 Sphinx search integration for Eventum.
390
391 This package contains the cron job.
392
393 %prep
394 %setup -q -n %{name}-%{version}%{?githash:-%{subver}-g%{githash}}
395
396 mv docs/examples .
397
398 # bug fixes / features
399 %{?with_order:%patch2 -p1}
400 #%patch3 -p0
401 #%patch4 -p1
402
403 %{?with_order:cp -p %{SOURCE16} htdocs/images}
404
405 #%patch200 -p1
406
407 # produce default sphinx config
408 # must be run before paths.patch
409 %if 0
410 cat <<'EOF' > config/config.php
411 <?php
412 define('APP_SQL_DBTYPE', 'mysql');
413 define('APP_SQL_DBHOST', 'localhost:/var/lib/mysql/mysql.sock');
414 define('APP_SQL_DBPORT', 3306);
415 define('APP_SQL_DBNAME', 'eventum');
416 define('APP_SQL_DBUSER', 'mysql');
417 define('APP_SQL_DBPASS', '');
418 define('APP_TABLE_PREFIX', 'eventum_');
419 EOF
420 php config/sphinx.conf.php > config/sphinx.conf
421 rm config/config.php
422 %endif
423
424 # packaging
425 %patch100 -p1
426 %patch101 -p1
427 %patch107 -p1
428 %patch108 -p1
429
430 rm htdocs/.htaccess.dist
431 # deprecated in favour of process_all_emails.php
432 rm bin/route_*.php
433
434 # cleanup vendor. keep only needed libraries.
435 # (the rest are packaged with system packages)
436 mv vendor vendor.dist
437 vendor() {
438         local path dir
439         for path; do
440                 dir=$(dirname $path)
441                 test -d vendor/$dir || mkdir -p vendor/$dir
442                 mv vendor.dist/$path vendor/$path
443         done
444 }
445 vendor autoload.php
446 vendor composer/autoload_{classmap,files,namespaces,real,psr4}.php
447 vendor composer/ClassLoader.php
448 vendor ircmaxell/{password-compat,random-lib,security-lib}
449 vendor defuse/php-encryption
450 vendor ramsey/array_column
451 vendor willdurand/email-reply-parser
452 vendor symfony/polyfill-php55
453
454 # remove backups from patching as we use globs to package files to buildroot
455 find '(' -name '*~' -o -name '*.orig' ')' | xargs -r rm -v
456
457 %build
458 %{__make} -C localization
459
460 %install
461 rm -rf $RPM_BUILD_ROOT
462 install -d \
463         $RPM_BUILD_ROOT{%{_webappdir}/{custom_field,templates,workflow},%{_sysconfdir},%{_bindir},%{_sbindir},%{_libdir}} \
464         $RPM_BUILD_ROOT/etc/{rc.d/init.d,cron.d,logrotate.d,sysconfig} \
465         $RPM_BUILD_ROOT/var/{run,cache,lib}/%{name} \
466         $RPM_BUILD_ROOT/var/log/{archive/,}%{name} \
467         $RPM_BUILD_ROOT/var/lib/%{name}/routed_{emails,drafts,notes} \
468         $RPM_BUILD_ROOT%{systemdtmpfilesdir}
469
470 %{__make} install-eventum install-cli install-scm install-localization \
471         sysconfdir=%{_webappdir} \
472         localedir=%{_localedir} \
473         DESTDIR=$RPM_BUILD_ROOT
474
475 ln -s %{_webappdir} $RPM_BUILD_ROOT%{_appdir}/config
476
477 cp -a vendor $RPM_BUILD_ROOT%{_appdir}
478
479 # unsupported locale
480 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/ht
481
482 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
483 cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
484
485 %{?with_order:cp -a htdocs/ajax $RPM_BUILD_ROOT%{_appdir}/htdocs}
486
487 touch $RPM_BUILD_ROOT%{_webappdir}/htpasswd
488 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_webappdir}/apache.conf
489 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_webappdir}/httpd.conf
490 cp -p %{SOURCE15} $RPM_BUILD_ROOT%{_webappdir}/lighttpd.conf
491
492 install -d $RPM_BUILD_ROOT/etc/sphinx
493 #cp -p config/sphinx.conf $RPM_BUILD_ROOT/etc/sphinx/%{name}.conf
494 cp -p config/sphinx.conf.php $RPM_BUILD_ROOT%{_webappdir}
495
496 cp -p %{SOURCE2} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-queue
497 cp -p %{SOURCE3} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-download
498 cp -p %{SOURCE4} $RPM_BUILD_ROOT/etc/cron.d/%{name}-reminder
499 cp -p %{SOURCE5} $RPM_BUILD_ROOT/etc/cron.d/%{name}-monitor
500 cp -p %{SOURCE10} $RPM_BUILD_ROOT/etc/cron.d/%{name}-sphinx
501
502 cp -p config/irc_config.dist.php $RPM_BUILD_ROOT%{_webappdir}/irc_config.php
503
504 install -p %{SOURCE8} $RPM_BUILD_ROOT/etc/rc.d/init.d/eventum-irc
505 cp -p %{SOURCE9} $RPM_BUILD_ROOT/etc/sysconfig/eventum-irc
506
507 cp -p %{SOURCE14} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
508
509 # postfix router
510 install -p %{SOURCE13} $RPM_BUILD_ROOT%{_libdir}/router-postfix
511
512 cp -p %{SOURCE17} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/%{name}.conf
513
514 %find_lang %{name}
515
516 # scm
517 cp -p %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}/scm.php
518
519 %clean
520 rm -rf $RPM_BUILD_ROOT
521
522 %pre
523 %groupadd -g 146 %{name}
524 %useradd -u 146 -d /var/lib/%{name} -g %{name} -c "Eventum User" %{name}
525 %addusertogroup http %{name}
526
527 %post
528 # create empty ghost files
529 # these permissions ensure the logs are write only
530 for a in \
531         errors.log login_attempts.log \
532         eventum.log \
533         cli.log \
534         irc_bot_error.log irc_bot_smartirc.log \
535 ; do
536         test -f /var/log/%{name}/$a && continue
537         install -m 0620 -o root -g http /dev/null /var/log/%{name}/$a
538 done
539
540 # run database update if configured
541 test -s %{_webappdir}/config.php && \
542 %{_appdir}/bin/upgrade.php || :
543
544 # nuke Smarty templates cache after upgrade
545 rm -f /var/cache/eventum/*.php
546
547 # Restart webserver on upgrade to get .mo translations reloaded.
548 # actually php engines "php-fcgi" and "php-fpm" needed only, apache is restarted anyway via webapp trigger.
549 %php_webserver_restart
550
551 %preun
552 if [ "$1" = "0" ]; then
553         # nuke cache
554         rm -f /var/cache/eventum/*.php 2>/dev/null || :
555 fi
556
557 %postun
558 if [ "$1" = "0" ]; then
559         %userremove %{name}
560         %groupremove %{name}
561 fi
562
563 %post setup
564 chmod 660 %{_webappdir}/{config,private_key}.php
565 chown root:http %{_webappdir}/{config,private_key}.php
566
567 %postun setup
568 if [ "$1" = "0" ] && [ -f %{_webappdir}/config.php ]; then
569         chmod 640 %{_webappdir}/{config,private_key}.php
570         chown root:http %{_webappdir}/{config,private_key}.php
571 fi
572
573 %post irc
574 /sbin/chkconfig --add eventum-irc
575 %service eventum-irc restart "Eventum IRC Bot"
576
577 %preun irc
578 if [ "$1" = 0 ]; then
579         %service eventum-irc stop
580         /sbin/chkconfig --del eventum-irc
581 fi
582
583 %triggerin -- apache1 < 1.3.37-3, apache1-base
584 %webapp_register apache %{_webapp}
585
586 %triggerun -- apache1 < 1.3.37-3, apache1-base
587 %webapp_unregister apache %{_webapp}
588
589 %triggerin -- apache < 2.2.0, apache-base
590 %webapp_register httpd %{_webapp}
591
592 %triggerun -- apache < 2.2.0, apache-base
593 %webapp_unregister httpd %{_webapp}
594
595 %triggerin -- lighttpd
596 %webapp_register lighttpd %{_webapp}
597
598 %triggerun -- lighttpd
599 %webapp_unregister lighttpd %{_webapp}
600
601 %triggerpostun -- %{name} < 3.0.0-0.2
602 for f in /etc/cron.d/eventum-*; do
603         # crontabs moved to bin
604         %{__sed} -i -e '
605                 s,/usr/share/eventum/crons/process_mail_queue.php,%{_appdir}/bin/process_mail_queue.php,
606                 s,/usr/share/eventum/crons/download_emails.php,%{_appdir}/bin/download_emails.php,
607                 s,/usr/share/eventum/crons/check_reminders.php,%{_appdir}/bin/check_reminders.php,
608                 s,/usr/share/eventum/crons/monitor.php,%{_appdir}/bin/monitor.php,
609         ' $f
610 done
611
612 %files -f %{name}.lang
613 %defattr(644,root,root,755)
614 %attr(751,root,root) %dir %{_webappdir}
615 %attr(751,root,root) %dir %{_webappdir}/custom_field
616 %attr(751,root,root) %dir %{_webappdir}/templates
617 %attr(751,root,root) %dir %{_webappdir}/workflow
618 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/apache.conf
619 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/httpd.conf
620 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/lighttpd.conf
621 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/config.php
622 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/private_key.php
623 %attr(660,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/setup.php
624 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/htpasswd
625
626 %dir %attr(711,root,http) /var/log/%{name}
627 %attr(620,root,http) %ghost /var/log/%{name}/*
628 %dir %attr(750,root,root) /var/log/archive/%{name}
629 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/%{name}
630
631 %dir %{_appdir}
632 %{_appdir}/config
633
634 %dir %{_appdir}/bin
635 %attr(755,root,root) %{_appdir}/bin/process_all_emails.php
636 %attr(755,root,root) %{_appdir}/bin/upgrade.php
637
638 %{_appdir}/autoload.php
639 %{_appdir}/init.php
640 %dir %{_appdir}/htdocs
641 %{_appdir}/htdocs/*.php
642 %{_appdir}/htdocs/*.ico
643 %{_appdir}/htdocs/ajax
644 %{_appdir}/htdocs/css
645 %{_appdir}/htdocs/customer
646 %{_appdir}/htdocs/images
647 %{_appdir}/htdocs/js
648 %{_appdir}/htdocs/manage
649 %{_appdir}/htdocs/reports
650 %{_appdir}/htdocs/rpc
651 %{_appdir}/htdocs/components
652 %{_appdir}/templates
653
654 %dir %{_appdir}/upgrade
655 %{_appdir}/upgrade/*.sql
656 %{_appdir}/upgrade/patches
657
658 %{_appdir}/vendor
659 %{_appdir}/src
660 %dir %{_appdir}/lib
661 %{_appdir}/lib/eventum
662 %exclude %{_appdir}/lib/eventum/class.monitor.php
663
664 %dir %{_libdir}
665
666 %{systemdtmpfilesdir}/%{name}.conf
667
668 %dir /var/lib/%{name}
669 %dir %attr(730,root,http) /var/run/%{name}
670 %dir %attr(730,root,http) /var/cache/%{name}
671
672 # saved mail copies
673 %attr(770,root,http) %dir /var/lib/%{name}/routed_emails
674 %attr(770,root,http) %dir /var/lib/%{name}/routed_drafts
675 %attr(770,root,http) %dir /var/lib/%{name}/routed_notes
676
677 %files setup
678 %defattr(644,root,root,755)
679 %{_appdir}/htdocs/setup
680
681 %files doc
682 %defattr(644,root,root,755)
683 %doc docs/*
684 %{_examplesdir}/%{name}-%{version}
685
686 %files mail-queue
687 %defattr(644,root,root,755)
688 %attr(755,root,root) %{_appdir}/bin/process_mail_queue.php
689 %attr(755,root,root) %{_appdir}/bin/truncate_mail_queue.php
690 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-queue
691
692 %files mail-download
693 %defattr(644,root,root,755)
694 %attr(755,root,root) %{_appdir}/bin/download_emails.php
695 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-download
696
697 %files reminder
698 %defattr(644,root,root,755)
699 %attr(755,root,root) %{_appdir}/bin/check_reminders.php
700 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-reminder
701
702 %files monitor
703 %defattr(644,root,root,755)
704 %{_appdir}/lib/eventum/class.monitor.php
705 %attr(755,root,root) %{_appdir}/bin/monitor.php
706 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-monitor
707
708 %files router-postfix
709 %defattr(644,root,root,755)
710 %attr(755,root,root) %{_libdir}/router-postfix
711
712 %files irc
713 %defattr(644,root,root,755)
714 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/irc_config.php
715 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/eventum-irc
716 %attr(755,root,root) %{_appdir}/bin/irc-bot.php
717 %attr(754,root,root) /etc/rc.d/init.d/%{name}-irc
718
719 %files cli
720 %defattr(644,root,root,755)
721 %doc cli/eventumrc
722 %attr(755,root,root) %{_bindir}/%{name}
723
724 %files scm
725 %defattr(644,root,root,755)
726 %attr(751,root,root) %dir %{_sysconfdir}
727 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/scm.php
728 %attr(755,root,root) %{_sbindir}/eventum-cvs-hook
729 %attr(755,root,root) %{_sbindir}/eventum-git-hook
730 %attr(755,root,root) %{_sbindir}/eventum-svn-hook
731 %attr(755,root,root) %{_sbindir}/helpers.php
732
733 %files sphinx
734 %defattr(644,root,root,755)
735 %{_webappdir}/sphinx.conf.php
736 #%attr(750,root,http) %config(noreplace) %verify(not md5 mtime size) /etc/sphinx/%{name}.conf
737 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-sphinx
This page took 2.013126 seconds and 3 git commands to generate.