]> git.pld-linux.org Git - packages/evas.git/blob - evas.spec
- fixed %configure options
[packages/evas.git] / evas.spec
1 #
2 # Conditional build:
3 %bcond_without  mmx             # without MMX and MMX2
4 %bcond_without  sse             # without SSE
5 %bcond_without  altivec         # without altivec
6 #
7 %ifnarch i586 i686 athlon
8 %undefine       with_mmx
9 %endif
10 %ifnarch i686 athlon
11 %undefine       with_sse
12 %endif
13 %ifnarch ppc
14 %undefine       with_altivec
15 %endif
16 #
17 Summary:        Multi-platform Canvas Library
18 Summary(pl):    Wieloplatformowa biblioteka do rysowania
19 Name:           evas
20 Version:        0.9.9.020
21 Release:        1
22 License:        BSD
23 Group:          Libraries
24 Source0:        http://enlightenment.freedesktop.org/files/%{name}-%{version}.tar.gz
25 # Source0-md5:  8dce18134e2ca1922bab69387741f4e7
26 Patch0:         %{name}-missing_m4.patch
27 URL:            http://enlightenment.org/Libraries/Evas/
28 BuildRequires:  DirectFB-devel
29 BuildRequires:  OpenGL-devel
30 BuildRequires:  autoconf
31 BuildRequires:  automake
32 BuildRequires:  edb-devel
33 BuildRequires:  eet-devel
34 BuildRequires:  freetype-devel
35 BuildRequires:  libjpeg-devel
36 BuildRequires:  libpng-devel
37 BuildRequires:  libtool
38 BuildRequires:  pkgconfig
39 Requires:       %{name}-libs = %{version}-%{release}
40 Requires:       fonts-TTF-bitstream-vera
41 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
42
43 %description
44 Evas is a clean display canvas API for several target display systems
45 that can draw anti-aliased text, smooth super and sub-sampled scaled
46 images, alpha-blend objects much and more.
47
48 %description -l pl
49 Evas to czyste API "p³ótna obrazu" dla ró¿nych systemów wy¶wietlania,
50 bêd±ce w stanie rysowaæ tekst z antyaliasingiem, wyg³adzane, skalowane
51 obrazy, obiekty z alpha-blendingiem i inne elementy.
52
53 %package libs
54 Summary:        Evas library
55 Summary(pl):    Biblioteka evas
56 Group:          X11/Libraries
57
58 %description libs
59 Evas library.
60
61 %description libs -l pl
62 Biblioteka evas.
63
64 %package devel
65 Summary:        Evas header files
66 Summary(pl):    Pliki nag³ówkowe Evas
67 Group:          Development/Libraries
68 Requires:       %{name}-libs = %{version}-%{release}
69 Requires:       DirectFB-devel
70 Requires:       OpenGL-devel
71 Requires:       edb-devel
72 Requires:       eet-devel
73 Requires:       freetype-devel
74 Requires:       libjpeg-devel
75 Requires:       libpng-devel
76
77 %description devel
78 Header files for Evas.
79
80 %description devel -l pl
81 Pliki nag³ówkowe Evas.
82
83 %package static
84 Summary:        Static Evas library
85 Summary(pl):    Statyczna biblioteka Evas
86 Group:          Development/Libraries
87 Requires:       %{name}-devel = %{version}-%{release}
88
89 %description static
90 Static Evas library.
91
92 %description static -l pl
93 Statyczna biblioteka Evas.
94
95 %prep
96 %setup -q
97 %patch0 -p1
98
99 %build
100 %{__libtoolize}
101 %{__aclocal}
102 %{__autoconf}
103 %{__autoheader}
104 %{__automake}
105 %configure \
106         --enable-software-x11   \
107         --disable-software-xcb  \
108         --enable-directfb       \
109         --enable-fb             \
110         --enable-buffer         \
111         --disable-software-qtopia \
112         --enable-gl-x11         \
113         --enable-xrender-x11    \
114         --enable-image-loader-png       \
115         --enable-image-loader-jpeg      \
116         --enable-image-loader-eet       \
117         --enable-font-loader-eet        \
118         --enable-image-loader-edb       \
119 %if %{with mmx}
120         --enable-cpu-mmx        \
121 %else
122         --disable-cpu-mmx       \
123 %endif
124 %if %{with sse}
125         --enable-cpu-sse        \
126 %else
127         --disable-cpu-sse       \
128 %endif
129 %if %{with altivec}
130         --enable-cpu-altivec    \
131 %else
132         --disable-cpu-altivec   \
133 %endif
134         --enable-cpu-c          \
135         --disable-valgrind
136
137 %{__make}
138
139 %install
140 rm -rf $RPM_BUILD_ROOT
141
142 %{__make} install \
143         DESTDIR=$RPM_BUILD_ROOT
144
145 cd $RPM_BUILD_ROOT%{_datadir}/%{name}
146 VERA=$(ls Vera*.ttf)
147 for FONT in $VERA; do
148         rm -f $FONT
149         ln -s %{_fontsdir}/TTF/$FONT .
150 done
151
152 %clean
153 rm -rf $RPM_BUILD_ROOT
154
155 %post   libs -p /sbin/ldconfig
156 %postun libs -p /sbin/ldconfig
157
158 %files
159 %defattr(644,root,root,755)
160 %doc AUTHORS COPYING COPYING-PLAIN INSTALL README
161 %attr(755,root,root) %{_bindir}/evas_*
162 %{_datadir}/%{name}
163
164 %files libs
165 %defattr(644,root,root,755)
166 %attr(755,root,root) %{_libdir}/libevas.so.*.*.*
167
168 %files devel
169 %defattr(644,root,root,755)
170 %attr(755,root,root) %{_bindir}/evas-config
171 %attr(755,root,root) %{_libdir}/libevas.so
172 %{_libdir}/libevas.la
173 %{_pkgconfigdir}/evas.pc
174 %{_includedir}/Evas*
175
176 %files static
177 %defattr(644,root,root,755)
178 %{_libdir}/libevas.a
This page took 0.062737 seconds and 3 git commands to generate.