]> git.pld-linux.org Git - packages/euphoria.git/blob - euphoria.spec
- replace R: ruby-modules with %%ruby_mod_ver_requires_eq macro
[packages/euphoria.git] / euphoria.spec
1 Summary:        EFL media player written in Ruby
2 Summary(pl):    Odtwarzacz multimedialny oparty o EFL napisany Rubym
3 Name:           euphoria
4 Version:        0.8.0
5 %define _snap   20050717
6 Release:        0.%{_snap}.0.1
7 License:        BSD
8 Group:          X11/Applications
9 #Source0:       http://dl.sourceforge.net/enlightenment/%{name}-%{version}.tar.gz
10 Source0:        http://sparky.homelinux.org/snaps/enli/e17/apps/%{name}-%{_snap}.tar.gz
11 # Source0-md5:  479e7046b4cbd20305ec8009c27b6d65
12 URL:            http://enlightenment.org/
13 BuildRequires:  edje
14 BuildRequires:  rpmbuild(macros) >= 1.277
15 BuildRequires:  ruby-modules
16 BuildRequires:  rake
17 BuildRequires:  sed >= 4.0
18 Requires:       ruby-ecore
19 Requires:       ruby-edje
20 Requires:       ruby-esmart
21 Requires:       ruby-evas
22 %ruby_mod_ver_requires_eq
23 Requires:       xmms2-client-lib-ecore-ruby
24 Requires:       xmms2-client-lib-ruby
25 BuildArch:      noarch
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %define _rubylibdir     %(ruby -r rbconfig -e 'print Config::CONFIG["sitelibdir"]')
29
30 %description
31 EFL media player written in Ruby.
32
33 %description -l pl
34 Odtwarzacz multimedialny oparty o EFL napisany Rubym.
35
36 %prep
37 %setup -q -n %{name}
38 sed -i bin/euphoria \
39         -e '/DATA_DIR = /s@".*"@"%{_datadir}/%{name}"@'
40
41 %build
42 rake
43
44 %install
45 rm -rf $RPM_BUILD_ROOT
46 install -d $RPM_BUILD_ROOT%{_bindir}
47
48 DESTDIR=$RPM_BUILD_ROOT
49 PREFIX=%{_usr}
50 RUBYLIBDIR=%{_rubylibdir}
51 export DESTDIR PREFIX RUBYLIBDIR
52 rake install
53
54 %clean
55 rm -rf $RPM_BUILD_ROOT
56
57 %files
58 %defattr(644,root,root,755)
59 %doc AUTHORS ChangeLog COPYING README TODO
60 %attr(755,root,root) %{_bindir}/%{name}
61 %{_datadir}/%{name}
62 %{_rubylibdir}/%{name}
This page took 0.039741 seconds and 3 git commands to generate.