]> git.pld-linux.org Git - packages/etcd.git/blob - etcd.spec
- updated to 3.3.12
[packages/etcd.git] / etcd.spec
1 # git rev-parse --short v2.0.11
2 %define         githash 777151f
3 Summary:        A highly-available key value store for shared configuration
4 Name:           etcd
5 Version:        2.0.11
6 Release:        1
7 License:        Apache v2.0
8 Group:          Daemons
9 Source0:        https://github.com/coreos/etcd/archive/v%{version}/%{name}-%{version}.tar.gz
10 # Source0-md5:  e928ca4a227930ae17bcef5cdf5478da
11 Patch0:         nogit.patch
12 URL:            https://github.com/coreos/etcd/
13 BuildRequires:  golang >= 1.2.1-3
14 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16 # disable debug packages for go packages
17 %define         debug_package %{nil}
18
19 # this will fool adapter not to touch 'etcd'
20 %define         _sysconfdir     __bogus__value
21
22 %description
23 A highly-available key value store for shared configuration.
24
25 %prep
26 %setup -q
27 %patch0 -p1
28
29 %build
30 GIT_SHA=%{githash} \
31 sh -xe build
32
33 %install
34 rm -rf $RPM_BUILD_ROOT
35 install -d $RPM_BUILD_ROOT%{_bindir}
36 install -p bin/etcd $RPM_BUILD_ROOT%{_bindir}
37 install -p bin/etcdctl $RPM_BUILD_ROOT%{_bindir}
38
39 %clean
40 rm -rf $RPM_BUILD_ROOT
41
42 %files
43 %defattr(644,root,root,755)
44 %doc LICENSE README.md Documentation/internal-protocol-versioning.md
45 %attr(755,root,root) %{_bindir}/etcd
46 %attr(755,root,root) %{_bindir}/etcdctl
This page took 0.116392 seconds and 3 git commands to generate.