]> git.pld-linux.org Git - packages/erlang.git/commitdiff
Up to 25.1.2. master auto/th/erlang-25.1.2-1
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Mon, 31 Oct 2022 22:19:47 +0000 (23:19 +0100)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Mon, 31 Oct 2022 22:19:47 +0000 (23:19 +0100)
erlang-ac.patch
erlang-no-fop.patch
erlang.spec
x32.patch

index b2e8138ccb0f6634aed6631ba7eaa889b3a7317c..9744f446e91717f64a73370699e0f0b391b0ba80 100644 (file)
@@ -1,9 +1,10 @@
 --- otp-OTP-24.1.2/otp_build.orig      2021-10-04 17:12:13.000000000 +0200
 +++ otp-OTP-24.1.2/otp_build   2021-10-25 21:32:32.099541733 +0200
-@@ -197,20 +197,6 @@ do_update_configure ()
+@@ -197,21 +197,6 @@ do_update_configure ()
  {
      get_do_commit $1
-    
+-    export AUTOCONF_VERSION="$USE_AUTOCONF_VERSION"
 -    ac_ver_blob=`autoconf --version`
 -    if [ $? -ne 0 ]; then
 -      echo "ERROR: Failed to check autoconf version! You need to have autoconf of version $USE_AUTOCONF_VERSION in path." 1>&2
@@ -20,4 +21,5 @@
 -    
      out_files=
  
-     for dir in $aclocal_dirs; do
+     install_sh=`basename $install_sh_master`
+
index 960d69a1903f15bfd3e1b656e3b1ad263a6560cf..c6f0adbc8c013eabc6db7fb6ea3b0e87884dc1d7 100644 (file)
@@ -1,6 +1,6 @@
---- otp-OTP-21.3.8.6/erts/configure.in.orig    2019-07-11 17:18:55.000000000 +0200
-+++ otp-OTP-21.3.8.6/erts/configure.in 2019-09-09 17:44:05.368217526 +0200
-@@ -855,7 +855,8 @@
+--- otp-OTP-21.3.8.6/erts/configure.ac.orig    2019-07-11 17:18:55.000000000 +0200
++++ otp-OTP-21.3.8.6/erts/configure.ac 2019-09-09 17:44:05.368217526 +0200
+@@ -459,7 +459,8 @@ if test -z "$XSLTPROC"; then
    AC_MSG_WARN([No 'xsltproc' command found: the documentation cannot be built])
  fi
  
@@ -10,3 +10,4 @@
  if test -z "$FOP"; then
    FOP="$ERL_TOP/make/fakefop"
    echo "fop" >> doc/CONF_INFO
+
index afe70e2c2ac107b6e96f38ab65a76a98e01dcbdf..6a14f8e5603c2fcd9d64ff073f291b38e4fef87f 100644 (file)
 %bcond_without odbc            # without unixODBC support
 #
 
-%define                erts_version    12.1.2
+%define                erts_version    13.1.2
 
 Summary:       OpenSource Erlang/OTP
 Summary(pl.UTF-8):     Erlang/OTP z otwartymi źródłami
 Name:          erlang
-Version:       24.1.2
-Release:       2
+Version:       25.1.2
+Release:       1
 Epoch:         2
 %define                _version        %(echo %{version} | tr _ -)
 License:       APLv2
 Group:         Development/Languages
 Source0:       https://github.com/erlang/otp/archive/OTP-%{version}.tar.gz
-# Source0-md5: 103fb735f9510574c1bbbd12690c5b63
+# Source0-md5: ac654a239f8e9c3514b183c657bca4bf
 Source2:       epmd.service
 Source3:       epmd.socket
 Source4:       epmd@.service
@@ -33,7 +33,7 @@ Patch0:               %{name}-fPIC.patch
 Patch1:                x32.patch
 # disable pdf docs (require libxslt-progs and fop > 1.0, with -cache option)
 Patch2:                %{name}-no-fop.patch
-Patch3:                ssl.patch
+
 Patch4:                %{name}-ac.patch
 URL:           http://www.erlang.org/
 %{?with_java:BuildRequires:    /usr/bin/jar}
@@ -87,7 +87,7 @@ Dokumentacja do Erlanga.
 #%patch0 -p1
 %patch1 -p1
 %patch2 -p1
-%patch3 -p1
+
 %patch4 -p1
 
 %build
@@ -207,7 +207,6 @@ rm -rf $RPM_BUILD_ROOT
 %{_libdir}/%{name}/erts-%{erts_version}/src
 %{_libdir}/%{name}/erts-%{erts_version}/include
 %dir %{_libdir}/%{name}/erts-%{erts_version}/lib
-%{_libdir}/%{name}/erts-%{erts_version}/lib/liberts*.a
 %dir %{_libdir}/%{name}/erts-%{erts_version}/lib/internal
 %{_libdir}/%{name}/erts-%{erts_version}/lib/internal/liberts_internal*.a
 %{_libdir}/%{name}/erts-%{erts_version}/lib/internal/libethread.a
index 602a4e031f387881e4fad6a0fdecaa47f4cd84ff..38a5dd4902fc5025520629f5d70a1b7ec2753b4f 100644 (file)
--- a/x32.patch
+++ b/x32.patch
@@ -15,12 +15,12 @@ Last-Modified: Sun, 27 Dec 2015 12:39:07 +0300
      int have_cpuid;
      /*
       * If it is possible to toggle eflags bit 21,
-@@ -219,7 +219,7 @@
+@@ -217,7 +217,7 @@ ethr_x86_cpuid__(int *eax, int *ebx, int
        return;
      }
  #endif
 -#if ETHR_SIZEOF_PTR == 4 && defined(__PIC__) && __PIC__
 +#if ETHR_SIZEOF_PTR == 4 && (!defined(__x86_64__) || !(__x86_64__ && __ILP32__)) && defined(__PIC__) && __PIC__
      /*
-      * When position independet code is used in 32-bit mode, the B register
+      * When position independent code is used in 32-bit mode, the B register
       * is used for storage of global offset table address, and we may not
This page took 0.089988 seconds and 4 git commands to generate.