]> git.pld-linux.org Git - packages/erlang.git/commitdiff
- updated autotools rebuild for no-fop patch to actually work
authorJakub Bogusz <qboosh@pld-linux.org>
Tue, 26 Oct 2021 04:25:33 +0000 (06:25 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Tue, 26 Oct 2021 04:25:33 +0000 (06:25 +0200)
- added ac patch to allow autoconf > 2.69
- package erts lib files

erlang-ac.patch [new file with mode: 0644]
erlang.spec

diff --git a/erlang-ac.patch b/erlang-ac.patch
new file mode 100644 (file)
index 0000000..b2e8138
--- /dev/null
@@ -0,0 +1,23 @@
+--- otp-OTP-24.1.2/otp_build.orig      2021-10-04 17:12:13.000000000 +0200
++++ otp-OTP-24.1.2/otp_build   2021-10-25 21:32:32.099541733 +0200
+@@ -197,20 +197,6 @@ do_update_configure ()
+ {
+     get_do_commit $1
+    
+-    ac_ver_blob=`autoconf --version`
+-    if [ $? -ne 0 ]; then
+-      echo "ERROR: Failed to check autoconf version! You need to have autoconf of version $USE_AUTOCONF_VERSION in path." 1>&2
+-      exit 1
+-    fi
+-    ac_ver=`echo $ac_ver_blob | sed "s|[^0-9]*\([0-9][^ \t\n]*\).*|\1|"`
+-    case $ac_ver in
+-      $USE_AUTOCONF_VERSION)
+-          ;;
+-      *)
+-          echo "ERROR: autoconf of version $ac_ver found in path! You need to have autoconf of version $USE_AUTOCONF_VERSION in path." 1>&2
+-          exit 1;;
+-    esac
+-    
+     out_files=
+     for dir in $aclocal_dirs; do
index 073700e19d1ca408aa85c7a993a1935e30d68633..afe70e2c2ac107b6e96f38ab65a76a98e01dcbdf 100644 (file)
@@ -34,9 +34,10 @@ Patch1:              x32.patch
 # disable pdf docs (require libxslt-progs and fop > 1.0, with -cache option)
 Patch2:                %{name}-no-fop.patch
 Patch3:                ssl.patch
+Patch4:                %{name}-ac.patch
 URL:           http://www.erlang.org/
 %{?with_java:BuildRequires:    /usr/bin/jar}
-BuildRequires: autoconf
+BuildRequires: autoconf >= 2.69
 BuildRequires: automake
 BuildRequires: flex
 %{?with_java:BuildRequires:    jdk >= 1.2}
@@ -87,9 +88,10 @@ Dokumentacja do Erlanga.
 %patch1 -p1
 %patch2 -p1
 %patch3 -p1
+%patch4 -p1
 
 %build
-./otp_build autoconf
+./otp_build update_configure --no-commit
 
 %configure \
 %ifarch sparc
@@ -200,9 +202,15 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_libdir}/%{name}/bin/typer
 %{_libdir}/%{name}/bin/start*.*
 %dir %{_libdir}/%{name}/erts-%{erts_version}
+%{_libdir}/%{name}/erts-%{erts_version}/info
 %{_libdir}/%{name}/erts-%{erts_version}/man
 %{_libdir}/%{name}/erts-%{erts_version}/src
 %{_libdir}/%{name}/erts-%{erts_version}/include
+%dir %{_libdir}/%{name}/erts-%{erts_version}/lib
+%{_libdir}/%{name}/erts-%{erts_version}/lib/liberts*.a
+%dir %{_libdir}/%{name}/erts-%{erts_version}/lib/internal
+%{_libdir}/%{name}/erts-%{erts_version}/lib/internal/liberts_internal*.a
+%{_libdir}/%{name}/erts-%{erts_version}/lib/internal/libethread.a
 #%{_libdir}/%{name}/erts-%{erts_version}/*.ear
 %dir %{_libdir}/%{name}/erts-%{erts_version}/bin
 %attr(755,root,root) %{_libdir}/%{name}/erts-%{erts_version}/bin/beam*
This page took 0.052128 seconds and 4 git commands to generate.